tar-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377
  1. Summary: A GNU file archiving program.
  2. Summary(ja): GNU ファイルアーカイブプログラム
  3. Name: tar
  4. Version: 1.27.1
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. Group: Applications/Archiving
  8. Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
  9. Patch0: tar-1.13.18-manpage.patch
  10. Patch8: tar-1.20-loneZeroWarning.patch
  11. Patch10: tar-1.15.1-gcc4.patch
  12. #Fix extracting sparse files to a filesystem like vfat,
  13. #when ftruncate may fail to grow the size of a file.(#179507)
  14. Patch11: tar-1.15.1-vfatTruncate.patch
  15. #change inclusion defaults of tar to "--wildcards --anchored
  16. #--wildcards-match-slash" for compatibility reasons (#206841)
  17. Patch12: tar-1.17-wildcards.patch
  18. # Fix for bad cooperation of -C and -u options.
  19. # ~> #688567
  20. # ~> http://lists.gnu.org/archive/html/bug-tar/2012-02/msg00007.html
  21. # ~> still downstream
  22. Patch15: tar-1.26-update-with-change-directory.patch
  23. # adhoc but useful patch for z option accepts bzip2ed tarball.
  24. Patch100: tar-1.13.6-barterly.patch
  25. Patch110: tar-1.22-rtapelib-overflow.patch
  26. BuildRequires: autoconf texinfo gettext
  27. Requires(post,postun): install-info
  28. Buildroot: %{_tmppath}/%{name}-%{version}-root
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. The GNU tar program saves many files together in one archive and can
  33. restore individual files (or all of the files) from that archive. Tar
  34. can also be used to add supplemental files to an archive and to update
  35. or list files in the archive. Tar includes multivolume support,
  36. automatic archive compression/decompression, the ability to perform
  37. remote archives, and the ability to perform incremental and full
  38. backups.
  39. If you want to use tar for remote backups, you also need to install
  40. the rmt package.
  41. %description -l ja
  42. GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
  43. から個々のファイルを(または全てのファイルを)リストアしたりする。tar はまた
  44. 追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
  45. 使われる。
  46. tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
  47. アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
  48. 機能を含んでいる。
  49. もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
  50. もまたインストールする必要がある。
  51. %prep
  52. %setup -q
  53. %patch0 -p1 -b .manpage
  54. %patch8 -p1 -b .loneZeroWarning
  55. %patch11 -p1 -b .vfatTruncate
  56. %patch12 -p1 -b .wildcards
  57. %patch15 -p1 -b .update_and_changedir
  58. %patch100 -p1 -b .accept-bz2
  59. %patch110 -p1 -b .CVE-2010-0624
  60. %build
  61. autoreconf
  62. %configure --bindir=/bin --libexecdir=/sbin
  63. make LIBS=-lbsd %{?_smp_mflags}
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. make prefix=${RPM_BUILD_ROOT}%{_prefix} \
  67. localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
  68. bindir=${RPM_BUILD_ROOT}/bin \
  69. libexecdir=${RPM_BUILD_ROOT}/sbin \
  70. mandir=${RPM_BUILD_ROOT}%{_mandir} \
  71. infodir=${RPM_BUILD_ROOT}%{_infodir} \
  72. install
  73. ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
  74. ( cd $RPM_BUILD_ROOT
  75. for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
  76. do
  77. [ -d $dir ] || continue
  78. strip $dir/* || :
  79. done
  80. gzip -9nf .%{_infodir}/tar.info*
  81. rm -f .%{_infodir}/dir
  82. )
  83. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  84. install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
  85. rm -f ${RPM_BUILD_ROOT}/sbin/rmt
  86. %find_lang %name
  87. %post
  88. /sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
  89. %preun
  90. if [ $1 = 0 ]; then
  91. /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
  92. fi
  93. %clean
  94. rm -rf ${RPM_BUILD_ROOT}
  95. %files -f %{name}.lang
  96. %defattr(-,root,root)
  97. %doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
  98. /bin/tar
  99. /bin/gtar
  100. %{_mandir}/man1/tar.1*
  101. %{_infodir}/tar.info*
  102. %changelog
  103. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.27.1-1
  104. - new upstream release
  105. - remove Patch13 (tar-1.23-oldarchive.patch)
  106. - add Patch15 (tar-1.26-update-with-change-directory.patch) from Fedora
  107. * Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
  108. - new upstream release
  109. - added BuildRequires: gettext
  110. * Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
  111. - new upstream release
  112. - changed source archive type (gzip to bzip2)
  113. - modified Patch8 a little
  114. - added Patch11,12,13 from Fedora development
  115. - added BuildRequires: autoconf texinfo
  116. - run autoreconf on %%build
  117. * Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
  118. - add patch110 for fix CVE-2010-0624 (rmt) from fc11
  119. * Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
  120. - add missing documents
  121. * Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
  122. - spec in utf-8
  123. * Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
  124. - new upstream release
  125. - improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
  126. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
  127. - new upstream release
  128. - remove unneeded patches
  129. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
  130. - rebuilt for VineSeed
  131. * Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
  132. - add patch120 for fix CVE-2006-6097
  133. * Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
  134. - add patch110 for fix CVE-2006-0300
  135. * Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
  136. - new upstream release
  137. - fixed patch6 and patch7 for new upstream release
  138. - some patches are imported from fedora package. and fixed
  139. -- stop issuing lone zero block warnings(patch8)
  140. -- fixed testsuite(patch9)
  141. -- don't applyed(patch10)
  142. -- fixed offset had incorrect type(patch11)
  143. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
  144. - new upstream release
  145. - some patches are imported from fedora package.
  146. * Fri May 2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
  147. - rebuild with new toolchain
  148. - update BuildRequire (autoconf253 -> autoconf)
  149. * Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
  150. - add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
  151. * Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
  152. - Oops the spec was in Shift-JIS. Fixed.
  153. * Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
  154. - based on 1.3.25-8 from Rawhide and built for Vine Linux
  155. - the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
  156. - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
  157. - rebuild to remove rpmlib dependancy
  158. - Sat May 26 2001 <sagami@vinelinux.org>
  159. - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
  160. - added barterly patch
  161. * Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
  162. - Included security patch from errata release.
  163. * Mon Jul 1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
  164. - Fix argv NULL termination (#64869)
  165. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  166. - automated rebuild
  167. * Tue Apr 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
  168. - Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
  169. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  170. - automated rebuild
  171. * Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
  172. - Don't include hardlinks to sockets in a tar file (#54827)
  173. * Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
  174. - 1.13.25
  175. * Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
  176. - Update to 1.13.22, adapt patches
  177. * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
  178. - Fix #52084
  179. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
  180. - Fix build with current autoconf (stricter checking on AC_DEFINE)
  181. - Fix segfault when tarring directories without having read permissions
  182. (#40802)
  183. * Tue Mar 6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  184. - Don't depend on librt.
  185. * Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
  186. - langify
  187. * Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  188. - Fix up the man page (#28915)
  189. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  190. - 1.3.19, nukes -I and fixes up -N
  191. - Add -I back in as an alias to -j with a nice loud warning
  192. * Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  193. - 1.3.18
  194. - Update man page to reflect changes
  195. * Thu Oct 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  196. - Fix the "ignore failed read" option (Bug #8330)
  197. * Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  198. - fix hang on tar tvzf - <something.tar.gz, introduced by
  199. exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
  200. * Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  201. - really fix exit code (Bug #15448)
  202. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  203. - fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
  204. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  205. - automatic rebuild
  206. * Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  207. - FHSify
  208. * Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
  209. - fix for ia64
  210. * Wed Feb 9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  211. - Fix the exclude bug (#9201)
  212. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  213. - man pages are compressed
  214. - fix description
  215. - fix fnmatch build problems
  216. * Sun Jan 9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  217. - 1.13.17
  218. - remove dotbug patch (fixed in base)
  219. - update download URL
  220. * Fri Jan 7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  221. - Fix a severe bug (tar xf any_package_containing_. would delete the
  222. current directory)
  223. * Wed Jan 5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  224. - 1.3.16
  225. - unset LINGUAS before running configure
  226. * Tue Nov 9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  227. - 1.13.14
  228. - Update man page to know about -I / --bzip
  229. - Remove dependancy on rmt - tar can be used for anything local
  230. without it.
  231. * Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
  232. - upgrade to 1.13.11.
  233. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  234. - update to 1.13.9.
  235. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  236. - update to 1.13.6.
  237. - support -y --bzip2 options for bzip2 compression (#2415).
  238. * Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
  239. - update to 1.13.5.
  240. * Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
  241. - update to 1.13
  242. * Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
  243. - update to 1.12.64014.
  244. - pipe patch corrected for remote tars now merged in.
  245. * Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
  246. - update to tar-1.12.64013.
  247. - subtract (and reopen #2415) bzip2 support using -y.
  248. - move gtar to /bin.
  249. * Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
  250. - upgrade to tar-1.12.64011 to
  251. - add bzip2 support (#2415)
  252. - fix filename bug (#3479)
  253. * Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
  254. - fix suspended tar with compression over pipe produces error (#390).
  255. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  256. - auto rebuild in the new build environment (release 8)
  257. * Mon Mar 08 1999 Michael Maher <mike@redhat.com>
  258. - added patch for bad name cache.
  259. - FIXES BUG 320
  260. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  261. - Injected new description and group.
  262. * Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
  263. - bumped spec number for initial rh 6.0 build
  264. * Tue Aug 4 1998 Jeff Johnson <jbj@redhat.com>
  265. - add /usr/bin/gtar symlink (change #421)
  266. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  267. - Fiddle bindir/libexecdir to get RH install correct.
  268. - Don't include /sbin/rmt -- use the rmt from dump.
  269. - Turn on nls.
  270. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  271. - translations modified for de, fr, tr
  272. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  273. - updated from 1.11.8 to 1.12
  274. - various spec file cleanups
  275. - /sbin/install-info support
  276. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  277. - built against glibc
  278. * Thu May 29 1997 Michael Fulbright <msf@redhat.com>
  279. - Fixed to include rmt