w3m-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397
  1. %define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
  2. %define _docdir %{_defaultdocdir}
  3. #%define cvsdate 20060815
  4. Summary: A Pager with WWW capability
  5. Summary(ja): World Wide Web に対応したページャ
  6. Name: w3m
  7. Version: 0.5.3
  8. Release: 1%{?_dist_release}
  9. Group: Applications/Internet
  10. License: BSD
  11. URL: http://w3m.sourceforge.net/
  12. Source0: %{name}-%{version}.tar.gz
  13. Source1: w3m.sh
  14. Source2: w3m.csh
  15. Source10: w3m-term
  16. Source11: filter-requires-w3m.sh
  17. Requires: perl, openssl >= 0.9, gc >= 6.2
  18. Requires(post,preun): alternatives
  19. Provides: webclient, pager
  20. Obsoletes: w3m-m17n
  21. BuildRequires: openssl-devel >= 0.9
  22. BuildRequires: ncurses-devel
  23. BuildRequires: gc-devel >= 6.2
  24. BuildRequires: sed
  25. BuildRequires: gtk2-devel
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: shaolin
  30. # work around for [VineSeed-x86_64:00178]
  31. %define __find_requires %{SOURCE11}
  32. %description
  33. w3m is a pager with WWW capability. It IS a pager, but it can be
  34. used as a text-mode WWW browser. The features of w3m are as follows:
  35. - When reading HTML document, you can follow links and view images
  36. (using external image viewer).
  37. - It has 'internet message mode', which determines the type of document
  38. from header. If the Content-Type: field of the document is text/html,
  39. that document is displayed as HTML document.
  40. - You can change URL description like 'http://hogege.net' in plain text
  41. into link to that URL.
  42. %description -l ja
  43. w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
  44. です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
  45. ・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
  46. り,画像を見ることができる.
  47. ・Internet message 表示のためのモードがある.この時,Content-Type: が
  48. text/html の場合は,自動的に HTML の文書として表示する.また,自力で
  49. MIME header のデコードをする.
  50. ・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
  51. をたどることができる.
  52. %package img
  53. Summary: inline image extension support utilities for w3m
  54. Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
  55. Group: Applications/Internet
  56. Requires: %{name} = %{version}-%{release}
  57. %description img
  58. w3m-img provides some utilities to support inline
  59. images for w3m
  60. on terminal emulator in X Window System environments.
  61. %description -l ja img
  62. w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
  63. 表示するためのユーティリティです。
  64. %prep
  65. %setup -q
  66. find Bonus -type f | \
  67. xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
  68. %build
  69. %configure \
  70. --enable-japanese=E \
  71. --with-termlib=ncurses \
  72. --enable-image=x11 \
  73. --with-imagelib=gtk2 \
  74. --with-browser=gnome-open \
  75. --with-mailer=gnome-open \
  76. --with-editor=%{_sysbindir}/vi
  77. sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
  78. sed -i -e 's|\-lgpm||g' Makefile
  79. make %{?_smp_mflags}
  80. %install
  81. rm -rf %{buildroot}
  82. make install DESTDIR=%{buildroot}
  83. mkdir -p %{buildroot}/etc/profile.d
  84. cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
  85. cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
  86. mkdir -p %{buildroot}%{_bindir}
  87. cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
  88. chmod +x %{buildroot}%{_bindir}/w3m-term
  89. mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
  90. install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
  91. install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
  92. # dont include duplicated man pages and CVS directory in doc
  93. rm -f doc-jp/w3m.1 doc/w3m.1
  94. find . -type d -name "CVS" | xargs rm -rf
  95. # prepare system-wide preference file
  96. mkdir -p %{buildroot}%{_sysconfdir}/w3m
  97. # prepare applnk
  98. %define applnkdir /etc/X11/applnk/Internet
  99. mkdir -p %{buildroot}/%{applnkdir}
  100. cat > %{buildroot}/%{applnkdir}/%{name}.desktop <<EOF
  101. [Desktop Entry]
  102. Name=%{name}
  103. Type=Application
  104. Comment=A Pager with WWW capability
  105. Comment[ja]=WWW対応ページャ
  106. Exec=w3m-term
  107. Terminal=false
  108. EOF
  109. # eliminate executable bit in %doc
  110. find Bonus/ -type f -perm +111 | xargs -r chmod -x
  111. %clean
  112. rm -rf %{buildroot}
  113. %post
  114. %{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
  115. %preun
  116. if [ "$1" = "0" ]; then
  117. %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
  118. fi
  119. %files
  120. %defattr(-,root,root)
  121. %doc Bonus ChangeLog NEWS README doc doc-jp
  122. %attr(755,root,root) %config /etc/profile.d/*
  123. %config(missingok) %{applnkdir}/%{name}.desktop
  124. %dir %{_sysconfdir}/w3m
  125. %{_bindir}/w3m*
  126. %exclude %{_libexecdir}/w3m/w3mimgdisplay
  127. %{_libexecdir}/w3m/
  128. %{_datadir}/w3m/
  129. %{_datadir}/locale/*/LC_MESSAGES/*
  130. %{_mandir}/ja/man1/w3m.1*
  131. %{_mandir}/man1/w3m*
  132. %files img
  133. %{_libexecdir}/w3m/w3mimgdisplay
  134. %changelog
  135. * Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
  136. - new upstream release
  137. - drop unnecessary patches: upstream fixed
  138. - ambwidth patch (Patch10)
  139. - sudden crash patch (Patch11)
  140. - x86_64 patch (Patch100)
  141. * Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
  142. - rebuild with openssl-1.0.0c
  143. - add Patch100 (w3m-0.5.2-x86_64-vine.patch)
  144. * Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
  145. - add Patch10 to fix display utf8 ambiguous width characters
  146. (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
  147. - add Patch11 to fix sudden crash
  148. (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
  149. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
  150. - rebuilt with gcc-4.4.3-3 on ppc
  151. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
  152. - rebuilt with new toolchain
  153. * Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
  154. - spec in utf-8
  155. - remove Requires: indexhtml
  156. - set HTTP_HOME to http://vinelinux.org/
  157. - update w3m-term
  158. * Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
  159. - new upstream release
  160. - dropped Patch100 (merged into upstream)
  161. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
  162. - rebuilt with new toolchain and environment
  163. * Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
  164. - add Provides: pager
  165. - add Requires(post,preun): alternatives
  166. * Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
  167. - add update-alternatives: pager in %post and %preun scriptlet
  168. * Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  169. - 0.5.1.20060815-0vl2
  170. - rebuilt for VineSeed
  171. * Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  172. - 0.5.1.20060815-0vl1.1
  173. - add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
  174. * Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
  175. - update to cvs snapshot
  176. - use gtk2 for w3m-img instead of gdk-pixbuf
  177. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
  178. - use filter-requires-w3m.sh as find-requires (rpm's bug?)
  179. * Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
  180. - use %%{_docdir}/Vine/index.html as default homepage
  181. * Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
  182. - change default editor to %%{_sysbindir}/vi
  183. - use ncurses explicitly as termlib
  184. * Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
  185. - fix typo
  186. - add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
  187. * Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  188. - rebuild without gpm
  189. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  190. - new upstream release
  191. - Obsoletes: w3m-m17n
  192. * Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
  193. - add message catalogs to %%files
  194. * Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
  195. - new upstream release
  196. - fix w3mimgdisplay path in w3m-term
  197. * Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
  198. - new upstream release
  199. - split w3mimgdisplay to w3m-img subpackage.
  200. - Requires: gc >= 6.2
  201. * Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
  202. - new upstream release
  203. * Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
  204. - new upstream release
  205. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
  206. - new upstream release.
  207. w3m 0.3.2.2 - 2002-12-06
  208. * security fix: html_quote for img alt attributes
  209. * Fri Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
  210. - change default page path to /usr/doc/HTML.
  211. this should be changed to /usr/share/doc in next release.
  212. ( TODO: indexhtml package )
  213. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
  214. - new upstream release
  215. w3m 0.3.2.1 - 2002-11-27
  216. * security fix: html_quote for frame contents
  217. * backport from w3m 0.3.2+cvs
  218. - fix segmentation fault by large complex table.
  219. [w3m-dev 03371][w3m-dev 03438]
  220. * Wed Nov 6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
  221. - new upstream release
  222. w3m 0.3.2 - 2002-11-05
  223. * ~/.netrc: password for ftp
  224. * rc: display_lineinfo: display current line number
  225. * rc: passwd_file: passwd file for HTTP auth
  226. * func: MARK_WORD
  227. * rc: imgsize: obsoleted
  228. * w3m-img for framebuffer merged
  229. * Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
  230. - replace gc with an old version on alpha (Source20)
  231. * Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
  232. - upstream release
  233. - coped new configure options
  234. * Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
  235. - fixed configure option ([VineSeed:06372])
  236. - added openssl-devel version in {Build,}Requires
  237. * Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
  238. - updated in sync with upstream 0.3 release
  239. (now w3m-img patch is included in the upstream version)
  240. * Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
  241. - w3m-0.2.5 with 0.2.5+cvs-1.302
  242. * Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
  243. - eliminate executable bit in %doc
  244. - spec cleanup
  245. * Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
  246. - updated to current stable release
  247. * Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
  248. - updated to new upstream release
  249. - FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
  250. * Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
  251. - 0.2.1-0vl9
  252. - added sparc patch
  253. * Thu Aug 23 2001 <shom@vinelinux.org>
  254. - 0.2.1-0vl8: add w3m-term script
  255. * Mon Aug 06 2001 <sagami@vinelinux.org>
  256. - 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
  257. - update img patch to version 1.10 from 1.9
  258. * Mon Aug 6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
  259. - added img patch
  260. * Mon Jul 16 2001 <sagami@vinelinux.org>
  261. - 0.2.1-0vl5: spec file clean up
  262. - openssl-devel for BuildPrereq, not openssl
  263. - install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
  264. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  265. - 0.2.1-0vl4
  266. - rebuilt with openssl-0.9.6b
  267. * Sun Jun 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  268. - 0.2.1-0vl3
  269. - security fixes (http://www.lac.co.jp/security/snsadv/32.html)
  270. * Sat Jun 09 2001 <sagami@vinelinux.org>
  271. - 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
  272. - actually rebuilt with ncurses5 (i386)
  273. * Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
  274. - 0.2.1-0vl1
  275. * Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  276. - 0.1.10-0vl6
  277. - use better macros
  278. - rebuilt with ncurses5
  279. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  280. - w3m-0.1.10-0vl5
  281. - use applnk instead of wmconfig
  282. - use openssl
  283. * Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  284. - w3m-0.1.10-0vl4
  285. - fix typo in w3m.csh and w3m.wmconfig
  286. * Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
  287. - w3m-0.1.10-0vl3
  288. - provide default HTTP_HOME in /etc/profile.d
  289. * Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
  290. - Provides: webclient, Requires: indexhtml (capability of lynx)
  291. - added w3m.wmconfig
  292. - give them(who?) RPM_OPT_FLAGS(what?)
  293. - dont include duplicated man pages and CVS directory in doc
  294. * Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
  295. - 0.1.10-0vl1
  296. * Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
  297. - fix spec file
  298. * Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
  299. - updated from 0.1.4 to 0.1.6
  300. * Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
  301. - updated from 991203 to 0.1.4
  302. * Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
  303. - updated from 991028 to 991203
  304. * Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
  305. - updated from 990820 to 991028
  306. * Tue Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
  307. - updated from 990716 to 990820
  308. * Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
  309. - initial Release to VinePlus