xsp-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. %define mono_dir %(/usr/bin/monodir)
  2. Summary: Small Web Server Hosting ASP.NET
  3. Summary(ja): ASP.NET を提供する小さなウェブサーバ
  4. Name: xsp
  5. URL: http://go-mono.com/
  6. License: GNU General Public License (GPL)
  7. Group: Applications/Internet
  8. Version: 2.10.2
  9. Release: 1%{?_dist_release}
  10. Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. BuildRequires: mono-devel mono-web
  14. BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
  15. BuildRequires: pkgconfig
  16. # One of the test runs requires this
  17. BuildRequires: sqlite
  18. # This must be manually entered according to xsp's protocol version
  19. # Since this package is currently noarch, and mod_mono's name is different
  20. # on different distros, we can't use this... yet
  21. #Requires: mod_mono >= %{version}
  22. Distribution: Vine Linux
  23. Vendor: Project Vine
  24. Packager: owa
  25. %description
  26. The XSP server is a small Web server that hosts the Mono System.Web
  27. classes for running what is commonly known as ASP.NET.
  28. %prep
  29. %setup -q
  30. %build
  31. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  32. # Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
  33. ./configure \
  34. --prefix=%{_prefix} \
  35. --libexecdir=%{_prefix}/lib \
  36. --libdir=%{_prefix}/lib \
  37. --mandir=%{_prefix}/share/man \
  38. --infodir=%{_prefix}/share/info \
  39. --sysconfdir=%{_sysconfdir}
  40. make
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  44. make install DESTDIR=$RPM_BUILD_ROOT
  45. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
  46. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %files
  50. %defattr(-,root,root)
  51. %doc NEWS README
  52. %{_bindir}/*
  53. %{_prefix}/lib/xsp
  54. %{mono_dir}/gac/Mono.WebServer2
  55. %{mono_dir}/gac/fastcgi-mono-server2
  56. %{mono_dir}/gac/fastcgi-mono-server4
  57. %{mono_dir}/gac/mod-mono-server2
  58. %{mono_dir}/gac/mod-mono-server4
  59. %{mono_dir}/gac/xsp2
  60. %{mono_dir}/gac/xsp4
  61. %{mono_dir}/2.0/Mono.WebServer2.dll
  62. %{mono_dir}/2.0/fastcgi-mono-server2.exe
  63. %{mono_dir}/2.0/mod-mono-server2.exe
  64. %{mono_dir}/2.0/xsp2.exe
  65. %{mono_dir}/4.0/Mono.WebServer2.dll
  66. %{mono_dir}/4.0/fastcgi-mono-server4.exe
  67. %{mono_dir}/4.0/mod-mono-server4.exe
  68. %{mono_dir}/4.0/xsp4.exe
  69. %{_prefix}/lib/monodoc/sources/Mono.WebServer.*
  70. %{_prefix}/lib/monodoc/sources/Mono.FastCGI.*
  71. %{_datadir}/pkgconfig/*
  72. %{_mandir}/*/*
  73. %changelog
  74. * Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.2-1
  75. - updated xsp to 2.10.2
  76. * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-2
  77. - rebuilt with mono-2.10.1-3
  78. * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-1
  79. - updated xsp to 2.10
  80. * Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
  81. - updated xsp to 2.8.2
  82. * Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
  83. - updated xsp to 2.8.1
  84. * Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
  85. - updated xsp to 2.8
  86. - rebuilt with mono-2.8
  87. - dropt BR: mono-jscript
  88. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
  89. - rebuild with rpm-4.8.1 for pkg-config file
  90. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
  91. - updated xsp to 2.6.5
  92. * Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
  93. - updated xsp to 2.6.4
  94. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
  95. - updated xsp to 2.6.3
  96. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
  97. - updated to 2.6
  98. - rebuilt with new toolchain
  99. * Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
  100. - updated to 2.4.3
  101. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  102. - changed Group to Applications/Internet
  103. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
  104. - updated to 2.4
  105. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  106. - initial build for VineSeed
  107. - updated xsp to 2.0
  108. - added japanese summary
  109. - applied vine versioning policy
  110. - spec in utf-8
  111. * Tue Apr 22 2008 wberrier@suse.de
  112. - update to 1.9.1 (bugfix release)
  113. - Output date header (instead of asp.net doing it)
  114. * Tue Mar 25 2008 wberrier@suse.de
  115. - update to 1.9
  116. - minor test updates
  117. - BaseRequestBroker fix: Check if the request ID is valid inside
  118. the lock.
  119. * Mon Jan 14 2008 wberrier@suse.de
  120. - update to 1.2.6
  121. - FastCGI support
  122. * Thu Aug 30 2007 wberrier@suse.de
  123. - xsp_1.2.5_p5_final.patch: Fix for regression in the request
  124. broker
  125. * Fri Aug 17 2007 wberrier@suse.de
  126. - xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
  127. - bugs: 81699, 81906, 82379, 82057
  128. - fixes ability to handle large (GB) uploads (needed for iFolder)
  129. * Fri Aug 3 2007 wberrier@suse.de
  130. - Update to 1.2.5
  131. - More robust exception handling
  132. - Fixed permissions bits for non executable scripts
  133. - virtual host support
  134. - New Documentation for Mono.WebServer
  135. - Improved event handling
  136. * Tue Jun 5 2007 wberrier@novell.com
  137. - Remove unnecessary path defines (prefix, sysconfdir)
  138. - Update to 1.2.4
  139. - fix some race conditions and crashes
  140. - add tracing support
  141. * Fri Apr 13 2007 wberrier@novell.com
  142. - add %%debug_package so debug packages get created
  143. * Wed Apr 11 2007 wberrier@novell.com
  144. - Add mono dep/req for older distros
  145. * Thu Mar 1 2007 wberrier@suse.de
  146. - Update Update to 1.2.3
  147. - Bug fix #80230 (prevents possible nullref)
  148. - Support for response header encoding
  149. * Mon Jan 22 2007 ro@suse.de
  150. - drop requires for gnome-filesystem
  151. * Sat Dec 2 2006 wberrier@suse.de
  152. - Update to 1.2.1 (Fate #301111)
  153. - Bugfixes:
  154. - close the connection if there's an error reading the headers
  155. (including assembly loading exceptions due to a bad installation).
  156. - kill the warning that everyone is worried about.
  157. * Fri Oct 20 2006 wberrier@suse.de
  158. - Update to 1.1.18
  159. - 2.0 updates
  160. * Thu Oct 19 2006 wberrier@suse.de
  161. - Add mono-devel to fix bnc #213576 (missing provides)
  162. * Tue Sep 5 2006 wberrier@suse.de
  163. - Update to 1.1.17.1 bugfix release
  164. - Read from the stream, not the socket as the socket data is
  165. encrypted when using SSL.
  166. * Wed Aug 30 2006 wberrier@suse.de
  167. - Update to 1.1.17
  168. - Added support for X.509 client certificates
  169. - Update to handle newly created AppDomains
  170. * Mon Jul 31 2006 wberrier@suse.de
  171. - update to 1.1.16.1
  172. - better connection handling
  173. - fixes bugs: 77698,78034,78621
  174. * Tue Apr 25 2006 wberrier@suse.de
  175. - Security update (remove all the duplicated slashes
  176. and don't do an extra Replace on non-windows.) and minor fix for
  177. [#78034].
  178. * Wed Jan 25 2006 mls@suse.de
  179. - converted neededforbuild to BuildRequires
  180. * Fri Jan 6 2006 wberrier@suse.de
  181. - Update to 1.1.13, clean up deps
  182. * Thu Nov 10 2005 wberrier@suse.de
  183. - Update to 1.1.10, set libdir to lib/
  184. * Fri Oct 7 2005 wberrier@suse.de
  185. - Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
  186. libexec, so I disabled the patch)
  187. * Tue Jul 19 2005 sbrabec@suse.cz
  188. - Build as noarch (#81109).
  189. * Fri Jul 15 2005 sbrabec@suse.cz
  190. - Updated to version 1.0.9 (#96776).
  191. * Mon Feb 21 2005 clahey@suse.de
  192. - Updated to 1.0.6.
  193. * Sun Feb 6 2005 ro@suse.de
  194. - use /usr/lib/mono
  195. * Mon Dec 13 2004 clahey@suse.de
  196. - New package.