gnome-sharp2-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %define mono_dir %(/usr/bin/monodir)
  2. %define _name gnome-sharp
  3. Summary: .Net Language Bindings for Gnome
  4. Summary(ja): Mono 用 GNOME バインディング
  5. Name: gnome-sharp2
  6. Version: 2.24.1
  7. Release: 8%{?_dist_release}
  8. License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
  9. Group: Development/Libraries
  10. URL: http://gtk-sharp.sf.net
  11. Source: %{_name}-%{version}.tar.bz2
  12. Patch2: gnome-sharp-find_gtkhtml_ver.patch
  13. Patch3: gnome-sharp-2.24.1-TestXfer.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk-sharp2 gtk-sharp2-gapi
  16. BuildRequires: librsvg2-devel
  17. BuildRequires: mono-devel monodoc
  18. BuildRequires: vte-devel gtkhtml3-devel
  19. BuildRequires: libSM-devel
  20. BuildRequires: libgnomeui-devel
  21. %define env_options export MONO_SHARED_DIR=/tmp
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. This package contains Mono bindings for Gnome.
  26. %package -n gnome-sharp2-complete
  27. Group: Development/Libraries
  28. Summary: GTK+ and GNOME bindings for Mono (virtual package)
  29. Requires: art-sharp2 = %{version}-%{release}
  30. Requires: gconf-sharp2 = %{version}-%{release}
  31. Requires: gnome-sharp2 = %{version}-%{release}
  32. Requires: gnome-vfs-sharp2 = %{version}-%{release}
  33. #Requires: glib-sharp2 >= 2.10.3
  34. %description -n gnome-sharp2-complete
  35. Gtk# is a library that allows you to build fully native graphical GNOME
  36. applications using Mono. Gtk# is a binding to GTK+, the cross platform
  37. user interface toolkit used in GNOME. It includes bindings for Gtk,
  38. Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. (Virtual
  39. package which depends on all gtk-sharp2 subpackages)
  40. %package -n gnome-vfs-sharp2
  41. Summary: Mono bindings for gnomevfs
  42. Group: Development/Libraries
  43. Requires: gnome-vfs2
  44. %description -n gnome-vfs-sharp2
  45. This package contains Mono bindings gnomevfs.
  46. %package -n art-sharp2
  47. Summary: Mono bindings for libart
  48. Group: Development/Libraries
  49. Requires: libart_lgpl
  50. %description -n art-sharp2
  51. This package contains Mono bindings for libart.
  52. %package -n gconf-sharp2
  53. Summary: Mono bindings for gconf
  54. Group: Development/Libraries
  55. %description -n gconf-sharp2
  56. This package contains Mono bindings for gconf and gconf peditors.
  57. %prep
  58. %setup -q -n %{_name}-%{version}
  59. %patch3 -p1 -b .TestXfer
  60. autoreconf -f -i
  61. %build
  62. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  63. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  64. %configure \
  65. --libexecdir=%{_prefix}/lib \
  66. --enable-debug
  67. make
  68. %install
  69. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  70. %makeinstall
  71. ## remove unuse files
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
  73. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
  74. rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %files -n gnome-sharp2-complete
  78. %defattr(-, root, root)
  79. ## This is the 'base' package so we put the common dirs of all in this package
  80. # Otherwise, this package doesn't get created!
  81. %dir %{mono_dir}/gtk-sharp-2.0
  82. %dir %{_prefix}/lib/gtk-sharp-2.0
  83. %files -n gnome-sharp2
  84. %defattr(-,root,root)
  85. %{_libdir}/libgnomesharpglue-2.so
  86. %{_libdir}/pkgconfig/gnome-sharp-2.0.pc
  87. %{mono_dir}/gac/*gnome-sharp
  88. %{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
  89. %{_datadir}/gapi-2.0/gnome-api.xml
  90. %files -n gnome-vfs-sharp2
  91. %defattr(-,root,root)
  92. %{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
  93. %{mono_dir}/gac/*gnome-vfs-sharp
  94. %{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
  95. %{_datadir}/gapi-2.0/gnome-vfs-api.xml
  96. %files -n art-sharp2
  97. %defattr(-,root,root)
  98. %{_libdir}/pkgconfig/art-sharp-2.0.pc
  99. %{mono_dir}/gac/*art-sharp
  100. %{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
  101. %{_datadir}/gapi-2.0/art-api.xml
  102. %files -n gconf-sharp2
  103. %defattr(-, root, root)
  104. %{_bindir}/gconfsharp2-schemagen
  105. %{_libdir}/pkgconfig/gconf-sharp-2.0.pc
  106. %{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
  107. %{mono_dir}/gac/*gconf-sharp
  108. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
  109. # Other distros place these in gnome-sharp2??
  110. %{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
  111. %{mono_dir}/gac/*gconf-sharp-peditors
  112. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
  113. %changelog
  114. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-8
  115. - rebuild with VineSeed environment
  116. - add BuildRequires: libgnomeui-devel
  117. * Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-7
  118. - add BuildRequires: libSM-devel
  119. * Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
  120. - added gnome-sharp-2.24.1-TestXfer.patch
  121. - rebuilt with mono-2.8
  122. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
  123. - build with rpm-4.8.1-1 for pkg-config file
  124. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
  125. - rebuilt with new environment
  126. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
  127. - rebuilt with latest rpm to update mono-dependencies
  128. - dropt BR: libgnomedb-devel
  129. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
  130. - changed Group to Development/Libraries
  131. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
  132. - updated to 2.24.1
  133. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
  134. - initial build for VineSeed
  135. - updated gnome-sharp2 to 2.20.0
  136. - added japanese summary
  137. - applied vine versioning policy
  138. - spec in utf-8
  139. * Thu Apr 24 2008 wberrier@suse.de
  140. - Update to 2.12.1
  141. * Bugfix in GLib ref management for Gnome.Program crash in
  142. gnome-sharp
  143. * Thu Apr 3 2008 wberrier@novell.com
  144. - Can now build 2.16 and 2.20 from the same spec
  145. - Update to 2.20.0
  146. - Updated bindings to coincide with gtk# 2.12
  147. - Removed bindings: gtkhtml#, rsvg#, and vte#
  148. * Wed Mar 26 2008 wberrier@novell.com
  149. - Update to 2.16.1
  150. - Allow storage of empty lists in gconf
  151. - Bug fixes:
  152. - [GConf] Impossible to set empty list values (bnc#325516)
  153. - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
  154. * Tue Jul 3 2007 wberrier@suse.de
  155. - Initial package of gnome-sharp2 2.16.0
  156. - (Split from gtk-sharp 2.8.3)