ipmitool-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. Name: ipmitool
  2. Summary: Utility for IPMI control
  3. Summary(ja): IPMIコントロールユーティリティ
  4. Version: 1.8.11
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://ipmitool.sourceforge.net/
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  10. Source1: openipmi-ipmievd.sysconf
  11. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: openssl-devel readline-devel ncurses-devel
  13. Requires(post): chkconfig
  14. Requires(preun): chkconfig
  15. Obsoletes: OpenIPMI-tools < 2.0.14-3
  16. Provides: OpenIPMI-tools = 2.0.14-3
  17. Patch1: ipmitool-1.8.10-ipmievd-init.patch
  18. Patch2: ipmitool-1.8.10-ipmievd-condrestart.patch
  19. Patch3: ipmitool-1.8.11-ipmieved-pidfile.patch
  20. Patch4: ipmitool-1.8.11-dell-oem.patch
  21. Patch5: ipmitool-1.8.11-dell-setled.patch
  22. Patch6: ipmitool-1.8.10-k-option.patch
  23. Patch7: ipmitool-1.8.11-set-kg-key.patch
  24. Patch8: ipmitool-1.8.11-set-kg-key2.patch
  25. Patch9: ipmitool-1.8.11-sol-payload-size.patch
  26. Patch10: ipmitool-1.8.11-dell-setled-updates.patch
  27. Patch11: ipmitool-1.8.11-dell-big-endian.patch
  28. Patch12: ipmitool-1.8.11-sol-leak.patch
  29. %description
  30. This package contains a utility for interfacing with devices that support
  31. the Intelligent Platform Management Interface specification. IPMI is
  32. an open standard for machine health, inventory, and remote power control.
  33. This utility can communicate with IPMI-enabled devices through either a
  34. kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
  35. the IPMI specification. IPMIv2 adds support for encrypted LAN
  36. communications and remote Serial-over-LAN functionality.
  37. It provides commands for reading the Sensor Data Repository (SDR) and
  38. displaying sensor values, displaying the contents of the System Event
  39. Log (SEL), printing Field Replaceable Unit (FRU) information, reading and
  40. setting LAN configuration, and chassis power control.
  41. %prep
  42. %setup -q
  43. %patch1 -p1 -b .ipmievd-init
  44. %patch2 -p0 -b .condrestart
  45. %patch3 -p1 -b .ipmievd-pidfile
  46. %patch4 -p1 -b .delloem
  47. %patch5 -p1 -b .setled
  48. %patch6 -p1 -b .k-option
  49. %patch7 -p1 -b .set-kg
  50. %patch8 -p1 -b .set-kg2
  51. %patch9 -p1 -b .sol-payload-size
  52. %patch10 -p1 -b .setled-updates
  53. %patch11 -p1 -b .fixes
  54. %patch12 -p1 -b .sol-leak
  55. for f in AUTHORS ChangeLog; do
  56. iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
  57. mv ${f}.utf8 ${f}
  58. done
  59. %build
  60. # --disable-dependency-tracking speeds up the build
  61. # --enable-file-security adds some security checks
  62. # --disable-intf-free disables FreeIPMI support - we don't want to depend on
  63. # FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
  64. %configure --disable-dependency-tracking --enable-file-security --disable-intf-free
  65. make %{?_smp_mflags}
  66. %install
  67. rm -rf %{buildroot}
  68. make DESTDIR=%{buildroot} install
  69. install -Dpm 755 contrib/ipmievd.init.redhat %{buildroot}%{_initrddir}/ipmievd
  70. install -Dpm 644 %SOURCE1 %{buildroot}%{_sysconfdir}/sysconfig/ipmievd
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %post
  74. /sbin/chkconfig --add ipmievd
  75. %preun
  76. if [ $1 = 0 ]; then
  77. service ipmievd stop >/dev/null 2>&1
  78. /sbin/chkconfig --del ipmievd
  79. fi
  80. %postun
  81. if [ "$1" -ge "1" ]; then
  82. service ipmievd condrestart >/dev/null 2>&1 || :
  83. fi
  84. %files
  85. %defattr(-,root,root)
  86. %config(noreplace) %{_sysconfdir}/sysconfig/ipmievd
  87. %{_initrddir}/ipmievd
  88. %{_bindir}/*
  89. %{_sbindir}/*
  90. %{_mandir}/man*/*
  91. %doc %{_datadir}/doc/ipmitool
  92. %{_datadir}/ipmitool
  93. %changelog
  94. * Mon Jul 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.11-1
  95. - initial build for Vine Linux
  96. * Thu Aug 18 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-11
  97. - fixed delloem powermonitor on bigendian systems (#731718)
  98. - fixed memory leak in Serial-over-Lan module (#731977)
  99. * Wed Aug 10 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
  100. - added -Y option for ipmitool to hide Kg key from cmdline (#698647)
  101. - added 'channel setkg' command to set Kg encryption key on remote machine
  102. (#726390)
  103. * Thu Aug 4 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
  104. - updated 'delloem setled' command to indicate SES status and drive
  105. activities for a PCI-e SSD (#727314)
  106. * Mon Jul 25 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-9
  107. - rebuilt for RHEL 6.2 Fastrack
  108. * Thu Jul 14 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-8
  109. - fixed 'ipmi sol' sending wrong packets due to miscalculation of SOL
  110. payload size (#675975)
  111. * Mon Feb 7 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-7
  112. - added 'delloem' command for Dell-specific IPMI extensions (#631649, #63793)
  113. * Wed Jun 2 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-6
  114. - Changed ipmievd to use /var/run/ipmievd.pid file by default (#596809)
  115. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-5
  116. - Fixed exit code of ipmievd initscript with wrong arguments (#562186)
  117. * Fri Dec 11 2009 Dennis Gregorovic <dgregor@redhat.com> - 1.8.11-4.1
  118. - Rebuilt for RHEL 6
  119. * Mon Nov 2 2009 Jan Safranek <jsafrane@redhat.com> 1.8.11-4
  120. - fix ipmievd initscript 'condrestart' action (#532188)
  121. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.8.11-3
  122. - rebuilt with new openssl
  123. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.11-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  125. * Thu Feb 26 2009 Jan Safranek <jsafrane@redhat.com> 1.8.11-1
  126. - updated to new version
  127. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.10-4
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  129. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> 1.8.10-3
  130. - rebuild with new openssl
  131. * Tue Oct 14 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-2
  132. - fix issues found during package review:
  133. - clear Default-Start: line in the init script, the service should be
  134. disabled by default
  135. - added Obsoletes: OpenIPMI-tools
  136. - compile with --disable-dependency-tracking to speed things up
  137. - compile with --enable-file-security
  138. - compile with --disable-intf-free, don't depend on FreeIPMI libraries
  139. (FreeIPMI has its own ipmitool-like utility)
  140. * Mon Oct 13 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-1
  141. - package created, based on upstream .spec file