libproxy-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define gecko_version 1.9.1
  3. Summary: A library handling all the details of proxy configuration
  4. Name: libproxy
  5. Version: 0.2.3
  6. Release: 4%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://code.google.com/p/libproxy/
  10. Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
  11. Patch0: libproxy-0.2.3-dbus.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildRequires: python-devel
  14. #Virtual Provides - We need either mozjs or WebKit
  15. Requires: %{name}-pac >= %{version}
  16. #
  17. Requires: libproxy-python = %{version}-%{release}
  18. Requires: libproxy-bin = %{version}-%{release}
  19. # gnome
  20. BuildRequires: GConf2-devel
  21. # mozjs
  22. BuildRequires: gecko-devel >= %{gecko_version}
  23. # NetworkManager
  24. BuildRequires: NetworkManager-devel
  25. BuildRequires: dbus-devel
  26. # webkit (gtk)
  27. BuildRequires: WebKit-gtk-devel
  28. # kde
  29. BuildRequires: libXmu-devel
  30. BuildRequires: libX11-devel
  31. %description
  32. libproxy offers the following features:
  33. * extremely small core footprint (< 35K)
  34. * no external dependencies within libproxy core
  35. (libproxy plugins may have dependencies)
  36. * only 3 functions in the stable external API
  37. * dynamic adjustment to changing network topology
  38. * a standard way of dealing with proxy settings across all scenarios
  39. * a sublime sense of joy and accomplishment
  40. Non-default rpmbuild options:
  41. --with webkit: Enable WebKit-gtk support
  42. %package bin
  43. Summary: Binary to test %{name}
  44. Group: Applications/System
  45. Requires: %{name} = %{version}-%{release}
  46. %description bin
  47. The %{name}-bin package contains the proxy binary for %{name}
  48. %package python
  49. Summary: Binding for %{name} and python
  50. Group: System Environment/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description python
  53. The %{name}-python package contains the python binding for %{name}
  54. %package gnome
  55. Summary: Plugin for %{name} and gnome
  56. Group: System Environment/Libraries
  57. Requires: %{name} = %{version}-%{release}
  58. %description gnome
  59. The %{name}-gnome package contains the %{name} plugin for gnome.
  60. %package kde
  61. Summary: Plugin for %{name} and kde
  62. Group: System Environment/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. %description kde
  65. The %{name}-kde package contains the %{name} plugin for kde.
  66. %package mozjs
  67. Summary: Plugin for %{name} and mozjs
  68. Group: System Environment/Libraries
  69. Requires: %{name} = %{version}
  70. #Tweak this according to the current gecko-libs version
  71. Requires: gecko-libs >= %{gecko_version}
  72. Provides: %{name}-pac = %{version}-%{release}
  73. %description mozjs
  74. The %{name}-mozjs package contains the %{name} plugin for mozjs.
  75. %package webkit
  76. Summary: Plugin for %{name} and webkit
  77. Group: System Environment/Libraries
  78. Requires: %{name} = %{version}
  79. Provides: %{name}-pac = %{version}-%{release}
  80. %description webkit
  81. The %{name}-webkit package contains the %{name} plugin for
  82. webkit.
  83. %package devel
  84. Summary: Development files for %{name}
  85. Group: Development/Libraries
  86. Requires: %{name} = %{version}-%{release}
  87. Requires: pkgconfig
  88. %description devel
  89. The %{name}-devel package contains libraries and header files for
  90. developing applications that use %{name}.
  91. %prep
  92. %setup -q
  93. %patch0 -p1 -b .dbus
  94. touch -r configure.dbus configure
  95. touch -r configure.ac.dbus configure.ac
  96. %build
  97. %configure --includedir=%{_includedir}/libproxy --disable-static --with-python
  98. make %{?_smp_mflags}
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  102. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %post -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %files
  108. %defattr(-,root,root,-)
  109. %doc AUTHORS COPYING README
  110. %{_libdir}/*.so.*
  111. %dir %{_libdir}/%{name}
  112. %dir %{_libdir}/%{name}/%{version}
  113. %dir %{_libdir}/%{name}/%{version}/plugins
  114. %{_libdir}/%{name}/%{version}/plugins/envvar.so
  115. %{_libdir}/%{name}/%{version}/plugins/file.so
  116. %{_libdir}/%{name}/%{version}/plugins/networkmanager.so
  117. %files bin
  118. %defattr(-,root,root,-)
  119. %{_bindir}/proxy
  120. %files python
  121. %defattr(-,root,root,-)
  122. %{python_sitelib}/*
  123. %files gnome
  124. %defattr(-,root,root,-)
  125. %{_libdir}/%{name}/%{version}/plugins/gnome.so
  126. %files kde
  127. %defattr(-,root,root,-)
  128. %{_libdir}/%{name}/%{version}/plugins/kde.so
  129. %files mozjs
  130. %defattr(-,root,root,-)
  131. %{_libdir}/%{name}/%{version}/plugins/mozjs.so
  132. %files webkit
  133. %defattr(-,root,root,-)
  134. %{_libdir}/%{name}/%{version}/plugins/webkit.so
  135. %files devel
  136. %defattr(-,root,root,-)
  137. %{_includedir}/libproxy/
  138. %{_libdir}/*.so
  139. %{_libdir}/pkgconfig/libproxy-1.0.pc
  140. %changelog
  141. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  142. - rebuild with python-2.6
  143. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  144. - rebuild with gecko-1.9.1
  145. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  146. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  147. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  148. - initial build for Vine Linux
  149. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  150. - Rebuild for webkit
  151. - Raise requirement for xulrunner to 1.9.1
  152. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  154. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  155. - Merge NetworkManager module into the main libproxy package
  156. - Main Requires the -python and -bin subpackage
  157. (splitted for multilibs compliance).
  158. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  159. - Disable Gnome/KDE default support via builtin modules.
  160. (it needs to be integrated via Gconf2/neon instead).
  161. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  162. - Disable Obsoletes.
  163. - Requires ev instead of evr for optionnals sub-packages.
  164. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  165. - Use conditionals build.
  166. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  167. - Remove plugin- in the name of the packages
  168. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  169. - Move proxy.h to libproxy/proxy.h
  170. This will prevent it to be included in the default include path
  171. - Split main to libs and util and use libproxy to install all
  172. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  173. - Rename binding-python to python
  174. - Add Requires: gecko-libs >= %%{gecko_version}
  175. - Fix some descriptions
  176. - Add plugin-webkit package
  177. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  178. - Convert to Fedora spec
  179. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  180. - Updated to version 0.2.3
  181. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  182. - Extended spec file to build all available plugins
  183. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  184. - Initial spec file for Version 0.2.2