moonlight-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. %define mono_dir %{_prefix}/lib/mono
  2. %define monodoc_dir %{_prefix}/lib/monodoc
  3. %define moonlight_dir %{_prefix}/lib/moonlight
  4. %define pkgconfigdir %{_datadir}/pkgconfig
  5. %define included_mono 2.6
  6. Summary: An open source implementation of Silverlight
  7. Summary(ja): Silverlight のオープンソースによる実装
  8. Name: moonlight
  9. Version: 2.0
  10. Release: 3%{?_dist_release}
  11. Group: Applications/Multimedia
  12. License: LGPL v2.0 only ; MIT License (or similar) ; Ms-Pl
  13. URL: http://go-mono.com/moonlight/
  14. Source0: ftp://ftp.novell.com/pub/mono/sources/moon/2.0/moonlight-%{version}.tar.bz2
  15. Source1: ftp://ftp.novell.com/pub/mono/sources/moon/2.0/mono-%{included_mono}.tar.bz2
  16. Source2: ftp://ftp.novell.com/pub/mono/sources/moon/2.0/mono-basic-%{included_mono}.tar.bz2
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. #Patch0: missing-files.patch
  19. #BuildRequires: mono-devel >= 2.6
  20. #BuildRequires: monodoc
  21. BuildRequires: gtk-sharp2
  22. BuildRequires: rsvg2-sharp
  23. BuildRequires: wnck-sharp
  24. BuildRequires: gcc-c++
  25. BuildRequires: gtk2-devel
  26. BuildRequires: alsa-lib-devel
  27. BuildRequires: xulrunner-devel
  28. #BuildRequires: automake
  29. #BuildRequires: autoconf
  30. ExclusiveArch: %ix86 x86_64
  31. %description
  32. Moonlight is an open source implementation of Microsoft Silverlight for
  33. Unix systems.
  34. %description -l ja
  35. Moonlight は Unix 系システムのための,Microsoft Silverlight のオープン
  36. ソースな実装です.
  37. %package libs
  38. Summary: Moonlight libmoon
  39. Group: System Environment/Libraries
  40. License: LGPL v2.0 only
  41. %description libs
  42. Moonlight libmoon
  43. %package devel
  44. Summary: Moonlight libmoon C/C++ development files
  45. Group: Development/Libraries
  46. License: LGPL v2.0 only
  47. Requires: %{name}-libs == %{version}
  48. %description devel
  49. Development files for libmoon
  50. %package tools
  51. Summary: Moonlight tools
  52. Group: Development/Tools
  53. Requires: %{name}-libs == %{version}
  54. %description tools
  55. Moonlight tools (mopen, xamlg, xaml2html, mxap, respack, svg2xaml)
  56. %package plugin
  57. Summary: Moonlight browser plugin
  58. Group: Applications/Internet
  59. Requires: %{name}-libs == %{version}
  60. %description plugin
  61. Browser plugin for Novell Moonlight
  62. %package web-devel
  63. Summary: Development files for Moonlight Web
  64. Group: Development/Libraries
  65. License: MIT License (or similar) ; Ms-Pl
  66. Requires: %{name}-plugin == %{version}
  67. %description web-devel
  68. Development files for creating Moonlight web applications.
  69. %package desktop
  70. Summary: Mono bindings for Moonlight Desktop
  71. Group: Development/Libraries
  72. License: MIT License (or similar) ; Ms-Pl
  73. Requires: %{name}-libs == %{version}
  74. %description desktop
  75. Mono bindings for Novell Moonlight.
  76. %package desktop-devel
  77. Summary: Development files for Moonlight Desktop
  78. Group: Development/Libraries
  79. License: MIT License (or similar) ; Ms-Pl
  80. Requires: %{name}-libs == %{version}
  81. Requires: glib2-devel
  82. Requires: gtk-sharp2
  83. Requires: %{name}-desktop == %{version}
  84. Requires: %{name}-tools == %{version}
  85. %description desktop-devel
  86. Development files for Moonlight Desktop.
  87. %package sharp
  88. Summary: Moonlight sharp
  89. Group: Development/Libraries
  90. Requires: %{name}-libs == %{version}
  91. %description sharp
  92. Provides a gtk-sharp object that can be used to embed a moonlight surface in a desktop application.
  93. %prep
  94. %setup -q
  95. %setup -q -T -D -b 1 -n %{name}-%{version}
  96. %setup -q -T -D -b 2 -n %{name}-%{version}
  97. %build
  98. # The plugin requires a complete build of it's own mono
  99. pushd ../mono-%{included_mono}
  100. ./configure \
  101. --prefix=%{_builddir}/install \
  102. --with-mcs-docs=no \
  103. --with-ikvm-native=no \
  104. ;
  105. # mono is not strictly -j safe
  106. %{__make} EXTERNAL_MCS=false EXTERNAL_RUNTIME=false
  107. %{__make} install
  108. find %{_builddir}/install -name \*.la -delete
  109. popd
  110. # Configure against the junk install of mono
  111. export PATH=%{_builddir}/install/bin:${PATH}
  112. export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
  113. export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
  114. #autoreconf -f -i -Wnone
  115. %configure \
  116. --with-ffmpeg=no \
  117. --with-cairo=system \
  118. --with-mcspath=%{_builddir}/mono-%{included_mono}/mcs \
  119. --with-mono-basic-path=%{_builddir}/mono-basic-%{included_mono} \
  120. --with-ff3=yes \
  121. --with-testing=no \
  122. --with-performance=no \
  123. --with-examples=no \
  124. --with-debug=no \
  125. --with-sanity-checks=no \
  126. export MONO_GAC_PREFIX=%{_builddir}/install:%{_prefix}
  127. %{__make} %{?_smp_mflags}
  128. %install
  129. rm -rf $RPM_BUILD_ROOT
  130. export PATH=%{_builddir}/install/bin:${PATH}
  131. export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
  132. export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
  133. make install DESTDIR=${RPM_BUILD_ROOT} pkgconfigdir=%{pkgconfigdir}
  134. mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  135. ln -s %{_libdir}/moonlight/plugin/libmoonloader.so \
  136. $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/libmoonloader.so
  137. # remove unuse files
  138. rm -f $RPM_BUILD_ROOT%{_libdir}/libshocker.so
  139. find %{buildroot} -name \*.la -delete
  140. %post libs -p /sbin/ldconfig
  141. %postun libs -p /sbin/ldconfig
  142. %clean
  143. rm -rf $RPM_BUILD_ROOT
  144. %files libs
  145. %defattr(-, root, root)
  146. %doc AUTHORS COPYING ChangeLog README TODO NEWS
  147. %{_libdir}/libmoon.so.*
  148. %files devel
  149. %defattr(-, root, root)
  150. %{_libdir}/libmoon.so
  151. %files tools
  152. %defattr(-, root, root)
  153. %{_bindir}/mopen
  154. %{_bindir}/munxap
  155. %{_bindir}/mxap
  156. %{_bindir}/respack
  157. %{_bindir}/sockpol
  158. %{_bindir}/unrespack
  159. %{_bindir}/xaml2html
  160. %{_bindir}/xamlg
  161. %dir %{_libdir}/moonlight
  162. %{_libdir}/moonlight/mopen.exe*
  163. %{_libdir}/moonlight/munxap.exe
  164. %{_libdir}/moonlight/mxap.exe
  165. %{_libdir}/moonlight/respack.exe
  166. %{_libdir}/moonlight/xaml2html.exe
  167. %{_libdir}/moonlight/xamlg.exe
  168. %{_libdir}/moonlight/sockpol.exe
  169. %{_mandir}/man1/mopen.1.gz
  170. %{_mandir}/man1/mxap.1.gz
  171. %{_mandir}/man1/respack.1.gz
  172. %{_mandir}/man1/svg2xaml.1.gz
  173. %{_mandir}/man1/xamlg.1.gz
  174. %{_mandir}/man1/sockpol.1.gz
  175. %files plugin
  176. %defattr(-, root, root)
  177. %dir %{_libdir}/moonlight/plugin
  178. %{_libdir}/moonlight/plugin/Microsoft.VisualBasic.dll
  179. %{_libdir}/moonlight/plugin/System.Core.dll*
  180. %{_libdir}/moonlight/plugin/System.Net.dll*
  181. %{_libdir}/moonlight/plugin/System.Runtime.Serialization.dll*
  182. %{_libdir}/moonlight/plugin/System.ServiceModel.Web.dll*
  183. %{_libdir}/moonlight/plugin/System.ServiceModel.dll*
  184. %{_libdir}/moonlight/plugin/System.Windows.Browser.dll*
  185. %{_libdir}/moonlight/plugin/System.Windows.dll*
  186. %{_libdir}/moonlight/plugin/System.Xml.dll*
  187. %{_libdir}/moonlight/plugin/System.dll*
  188. %{_libdir}/moonlight/plugin/libmoonloader.so
  189. %{_libdir}/moonlight/plugin/libmoonplugin-ff3bridge.so
  190. %{_libdir}/moonlight/plugin/libmoonplugin.so
  191. %{_libdir}/moonlight/plugin/mscorlib.dll*
  192. %{_libdir}/mozilla/plugins/libmoonloader.so
  193. %files web-devel
  194. %defattr(-, root, root)
  195. %{_bindir}/smcs
  196. %dir %{moonlight_dir}/2.0-redist
  197. %{moonlight_dir}/2.0-redist/System.Windows.Controls.Data.dll*
  198. %{moonlight_dir}/2.0-redist/System.Windows.Controls.dll*
  199. %{moonlight_dir}/2.0-redist/System.Xml.Linq.dll*
  200. %dir %{moonlight_dir}/2.0
  201. %{moonlight_dir}/2.0/Microsoft.VisualBasic.dll*
  202. %{moonlight_dir}/2.0/Mono.CompilerServices.SymbolWriter.dll*
  203. %{moonlight_dir}/2.0/System.Core.dll*
  204. %{moonlight_dir}/2.0/System.Net.dll*
  205. %{moonlight_dir}/2.0/System.Runtime.Serialization.dll*
  206. %{moonlight_dir}/2.0/System.ServiceModel.Web.dll*
  207. %{moonlight_dir}/2.0/System.ServiceModel.dll*
  208. %{moonlight_dir}/2.0/System.Windows.Browser.dll*
  209. %{moonlight_dir}/2.0/System.Windows.dll*
  210. %{moonlight_dir}/2.0/System.Xml.dll*
  211. %{moonlight_dir}/2.0/System.dll*
  212. %{moonlight_dir}/2.0/mscorlib.dll*
  213. %{moonlight_dir}/2.0/respack.exe*
  214. %{moonlight_dir}/2.0/smcs.exe*
  215. %{moonlight_dir}/2.0/buildversion
  216. %{pkgconfigdir}/moonlight-web-2.0.pc
  217. %files desktop
  218. %defattr(-, root, root)
  219. %{mono_dir}/gac/Moon.Windows.Desktop
  220. %{mono_dir}/gac/Moonlight.Gtk
  221. %{mono_dir}/gac/System.Windows
  222. %{mono_dir}/gac/System.Windows.Browser
  223. %{mono_dir}/gac/System.Windows.Controls
  224. %{mono_dir}/gac/System.Windows.Controls.Data
  225. %files desktop-devel
  226. %defattr(-, root, root)
  227. %dir %{mono_dir}/moonlight
  228. %{mono_dir}/moonlight/Moon.Windows.Desktop.dll*
  229. %{mono_dir}/moonlight/System.Windows.Browser.dll*
  230. %{mono_dir}/moonlight/System.Windows.Controls.Data.dll*
  231. %{mono_dir}/moonlight/System.Windows.Controls.dll*
  232. %{mono_dir}/moonlight/System.Windows.dll*
  233. %{pkgconfigdir}/moonlight-desktop-2.0.pc
  234. # It may make sense in the future to have a moonlight-gtk package
  235. %{mono_dir}/moonlight/Moonlight.Gtk.dll*
  236. %{monodoc_dir}/sources/moonlight-gtk.source
  237. %{monodoc_dir}/sources/moonlight-gtk.tree
  238. %{monodoc_dir}/sources/moonlight-gtk.zip
  239. %{pkgconfigdir}/moonlight-gtk-2.0.pc
  240. %changelog
  241. * Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.0-3
  242. - export PATH, LD_LIBRARY_PATH, PKG_CONFIG_PATH, MONO_GAC_PREFIX
  243. * Sat Sep 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-2
  244. - fixed Group
  245. - added BR: wnck-sharp
  246. * Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  247. - updated moonlight to 2.0
  248. * Thu Jul 09 2009 Shu KONNO <owa@bg.wakwak.com> 1.0.1-1
  249. - updated moon to 1.0.1
  250. - dropt missing-files.patch (included in source)
  251. - built with latest rpm to update mono-dependencies
  252. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.1-2
  253. - changed plugin Group to Applications/Internet
  254. - changed other sub packages Group to Development/Libraries
  255. - added %%pkgconfigdir macro
  256. * Sat Sep 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
  257. - new upstream release
  258. - added missing-files.patch from suse
  259. - added --with-managed=desktop
  260. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 0.8-1
  261. - initial build for VineSeed
  262. - moonlight 0.8
  263. - vine versioning policy
  264. - spec in utf-8