libyaml-vl.spec 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. Summary: YAML 1.1 parser and emitter written in C
  2. Name: libyaml
  3. Version: 0.2.2
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: MIT
  9. URL: http://pyyaml.org/
  10. Source0: http://pyyaml.org/download/libyaml/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. %description
  13. YAML is a data serialization format designed for human readability and
  14. interaction with scripting languages. LibYAML is a YAML parser and
  15. emitter written in C.
  16. %package devel
  17. Summary: Development libraries and headers for developing LibYAML applications
  18. Group: Development/Libraries
  19. Requires: libyaml = %{version}-%{release}
  20. %description devel
  21. Development libraries and headers for developing LibYAML applications.
  22. %prep
  23. %setup -q -n %{name}-%{version}
  24. %build
  25. ./bootstrap
  26. %configure
  27. make %{?_smp_mflags}
  28. %install
  29. rm -rf %{buildroot}
  30. make DESTDIR=%{buildroot} INSTALL="install -p" install
  31. rm -f %{buildroot}%{_libdir}/*.{la,a}
  32. soname=$(readelf -d %{buildroot}%{_libdir}/libyaml.so | awk '$2 == "(SONAME)" {print $NF}' | tr -d '[]')
  33. rm -f %{buildroot}%{_libdir}/libyaml.so
  34. echo "INPUT($soname)" > %{buildroot}%{_libdir}/libyaml.so
  35. %check
  36. make check
  37. %clean
  38. rm -rf %{buildroot}
  39. %post -p /sbin/ldconfig
  40. %postun -p /sbin/ldconfig
  41. %files
  42. %defattr(-,root,root,-)
  43. %license LICENSE
  44. %doc README
  45. %{_libdir}/%{name}*.so.*
  46. %files devel
  47. %defattr(-,root,root,-)
  48. %doc doc/html
  49. %{_libdir}/%{name}*.so
  50. %{_libdir}/pkgconfig/yaml-0.1.pc
  51. %{_includedir}/yaml.h
  52. %changelog
  53. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.2-1
  54. - new upstream release.
  55. * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.1.6-2
  56. - moved libyaml to System Environment/Libraries Group
  57. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.6-1
  58. - update to 0.1.6
  59. * Mon Mar 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.4-1
  60. - new upstream release
  61. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.2-1
  62. - initial build for Vine Linux
  63. * Tue Mar 3 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-3
  64. - Remove static libraries
  65. * Thu Feb 26 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-2
  66. - Remove README and LICENSE from docs on -devel package
  67. - Remove -static package and merge contents into the -devel package
  68. * Wed Feb 25 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-1
  69. - Initial packaging for Fedora