cairo-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340
  1. Summary: Cairo - multi-platform 2D graphics library.
  2. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  3. Name: cairo
  4. Version: 1.10.0
  5. Release: 2%{?_dist_release}
  6. License: LGPL/MPL
  7. Group: System Environment/Libraries
  8. Source0: http://cairographics.org/releases/%{name}-%{version}.tar.gz
  9. # don't use serverside gradients, most drivers don't handle those and are
  10. # really slow, should workaround performances issues for ati, nouveau and nvidia
  11. # https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  12. Patch1: cairo-1.10.0-dont_use_server_side_gradients.patch
  13. URL: http://cairographics.org/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: pixman-devel
  17. BuildRequires: libpng-devel
  18. BuildRequires: freetype2-devel
  19. BuildRequires: fontconfig-devel
  20. BuildRequires: libX11-devel
  21. BuildRequires: libXrender-devel
  22. BuildRequires: gtk-doc
  23. BuildConflicts: XOrg-compat70-devel
  24. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  25. %description
  26. Cairo provides anti-aliased vector-based rendering for X. Paths
  27. consist of line segments and cubic splines and can be rendered at any
  28. width with various join and cap styles. All colors may be specified
  29. with optional translucence (opacity/alpha) and combined using the
  30. extended Porter/Duff compositing algebra as found in the X Render
  31. Extension.
  32. Cairo exports a stateful rendering API similar in spirit to the path
  33. construction, text, and painting operators of PostScript, (with the
  34. significant addition of translucence in the imaging model). When
  35. complete, the API is intended to support the complete imaging model of
  36. PDF 1.4.
  37. Cairo relies on the Xc library for backend rendering. Xc provides an
  38. abstract interface for rendering to multiple target types. As of this
  39. writing, Xc allows Cairo to target X drawables as well as generic
  40. image buffers. Future backends such as PostScript, PDF, and perhaps
  41. OpenGL are currently being planned.
  42. %package -n compat32-%{name}
  43. Summary: Cairo - multi-platform 2D graphics library.
  44. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  45. Group: System Environment/Libraries
  46. Requires: %{name} = %{version}
  47. %description -n compat32-%{name}
  48. Cairo provides anti-aliased vector-based rendering for X. Paths
  49. consist of line segments and cubic splines and can be rendered at any
  50. width with various join and cap styles. All colors may be specified
  51. with optional translucence (opacity/alpha) and combined using the
  52. extended Porter/Duff compositing algebra as found in the X Render
  53. Extension.
  54. Cairo exports a stateful rendering API similar in spirit to the path
  55. construction, text, and painting operators of PostScript, (with the
  56. significant addition of translucence in the imaging model). When
  57. complete, the API is intended to support the complete imaging model of
  58. PDF 1.4.
  59. Cairo relies on the Xc library for backend rendering. Xc provides an
  60. abstract interface for rendering to multiple target types. As of this
  61. writing, Xc allows Cairo to target X drawables as well as generic
  62. image buffers. Future backends such as PostScript, PDF, and perhaps
  63. OpenGL are currently being planned.
  64. %package devel
  65. Summary: Development files for Cairo library.
  66. Summary(ja): Cairo ライブラリの開発用ファイル
  67. Group: Development/Libraries
  68. Provides: lib%{name}-devel = %{version}-%{release}
  69. Requires: %{name} = %{version}
  70. Requires: libpng-devel
  71. Requires: freetype2-devel
  72. Requires: fontconfig-devel
  73. Requires: libX11-devel
  74. Requires: libXrender-devel
  75. Requires: pixman-devel
  76. %description devel
  77. Development files for Cairo library.
  78. %package tools
  79. Summary: Development tools for cairo
  80. Group: Development/Tools
  81. %description tools
  82. Cairo is a 2D graphics library designed to provide high-quality display
  83. and print output.
  84. This package contains tools for working with the cairo graphics library.
  85. * cairo-trace: Record cairo library calls for later playback
  86. %prep
  87. %setup -q
  88. %patch1 -p1 -b .dont-use-server-side-gradients
  89. %build
  90. %configure --enable-gtk-doc
  91. %ifarch x86_64
  92. cp libtool libtool.old
  93. ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
  94. sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
  95. > libtool
  96. rm libtool.old
  97. %endif
  98. make
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. %makeinstall
  102. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %post -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %post -n compat32-%{name} -p /sbin/ldconfig
  108. %postun -n compat32-%{name} -p /sbin/ldconfig
  109. %files
  110. %defattr(644,root,root,755)
  111. %doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
  112. %{_libdir}/lib*.so.*
  113. %files devel
  114. %defattr(644,root,root,755)
  115. %{_libdir}/lib*.so
  116. #{_libdir}/lib*.la
  117. %{_includedir}/*
  118. %{_libdir}/pkgconfig/*.pc
  119. %{_libdir}/lib*.a
  120. %{_datadir}/gtk-doc/html/cairo
  121. %files tools
  122. %defattr(-,root,root,-)
  123. %{_bindir}/cairo-trace
  124. %{_libdir}/cairo
  125. %if %{build_compat32}
  126. %files -n compat32-%{name}
  127. %defattr(644,root,root,755)
  128. %{_libdir}/lib*.so.*
  129. %endif
  130. %changelog
  131. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  132. - add patch1 from ubuntu to fix performance regressions
  133. - don't use serverside gradients, most drivers don't handle those and are
  134. really slow, should workaround performances issues for ati, nouveau and nvidia
  135. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  136. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  137. - new upstream release
  138. - add tools sub package
  139. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  140. - add BuildRequires: fontconfig-devel
  141. - add Requires: fontconfig-devel (devel package)
  142. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  143. - build with rpm-4.8.1-1 for pkg-config file
  144. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  145. - new upstream release
  146. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  147. - new upstream release
  148. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  149. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  150. - added BuildRequires: gtk-doc
  151. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  152. - new upstream release
  153. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  154. - new upstream release
  155. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  156. - new upstream release
  157. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  158. - new upstream release
  159. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  160. - new upstream release
  161. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  162. - add Requires: pixman-devel to -devel
  163. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  164. - rebuilt with xorg-x11 7.3
  165. - spec in UTF-8
  166. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  167. - new upstream release
  168. - removed lib*.la from devel package
  169. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  170. - used %%{?_dist_release}
  171. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  172. - new upstream release
  173. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  174. - new upstream release
  175. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  176. - new upstream release
  177. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  178. - new upstream release
  179. - remove BuildRequires: pango-devel, gtk2-devel
  180. (these are only needed for testing)
  181. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  182. - upstream release
  183. - Patch30 and Patch40 is skipped (not working correctly)
  184. but held in src.rpm
  185. - add BUGS, ROADMAP to %%doc
  186. - add BuildRequires: pango-devel, gtk2-devel
  187. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  188. - rebuild without XOrg-compat70-devel
  189. - add BuildConflicts: XOrg-compat70-devel
  190. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  191. - new upstream release
  192. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  193. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  194. - added Patch40 for 15bpp problem
  195. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  196. - added ad-hoc Patch30 for 16bpp problem
  197. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  198. - new upstream release
  199. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  200. - new upstream release
  201. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  202. - new upstream release
  203. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  204. - added compat32- package for x86_64 architecture support
  205. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  206. - added x86_64 architecture support
  207. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  208. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  209. - add X.Org 6.9.0 (6090000) to blacklist
  210. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  211. - new upstream release
  212. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  213. - update Patch10
  214. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  215. - add Patch10 to use embedded bitmap font if available.
  216. (controllable by "embeddedbitmap" in fontconfig)
  217. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  218. - rebuild with new fontconfig
  219. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  220. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  221. to devel package instead of BuildRequires (typo)
  222. - add Japanese summaries
  223. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  224. - new upstream release
  225. - remove libpixman dependency (which is now included in cairo)
  226. - obsoletes libpixman <= 0.1.6
  227. - add more BuildRequires
  228. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  229. - new upstream version
  230. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  231. - new upstream version
  232. - fixed License (http://cairographics.org/introduction)
  233. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  234. - new upstream version
  235. - include gtk-doc files
  236. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  237. - new upstream version
  238. - add Requires: libpixman
  239. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  240. - new upstream version (cairo-0.2.0)
  241. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  242. - rebuilt for VineLinux
  243. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  244. - 0.1.23
  245. - reenable libtoolize
  246. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  247. - fix devel provides
  248. - drop redundant buildrequires
  249. - requires new pixman
  250. - autoconf 2.5 macro
  251. - New release 0.1.22
  252. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  253. - build with X11
  254. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  255. - 0.1.17
  256. - provides cairo
  257. - drop patch, use --disable-xlib
  258. - buildrequires
  259. - don't run libtoolize
  260. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  261. - initial mandrake package