vala-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314
  1. %global api_ver 0.10
  2. Summary: A modern programming language for GNOME
  3. Summary: GNOME 用のモダンなプログラミング言語
  4. Name: vala
  5. Version: 0.10.1
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  9. License: LGPLv2+ and BSD
  10. URL: http://live.gnome.org/Vala
  11. Source0: http://download.gnome.org/sources/vala/0.10/vala-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
  14. Requires: gtk2-devel
  15. %description
  16. Vala is a new programming language that aims to bring modern programming
  17. language features to GNOME developers without imposing any additional
  18. runtime requirements and without using a different ABI compared to
  19. applications and libraries written in C.
  20. valac, the Vala compiler, is a self-hosting compiler that translates
  21. Vala source code into C source and header files. It uses the GObject
  22. type system to create classes and interfaces declared in the Vala source
  23. code. It's also planned to generate GIDL files when gobject-
  24. introspection is ready.
  25. The syntax of Vala is similar to C#, modified to better fit the GObject
  26. type system.
  27. %package devel
  28. Summary: Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: pkgconfig
  32. %description devel
  33. Vala is a new programming language that aims to bring modern programming
  34. language features to GNOME developers without imposing any additional
  35. runtime requirements and without using a different ABI compared to
  36. applications and libraries written in C.
  37. This package contains development files for %{name}. This is not necessary for
  38. using the %{name} compiler.
  39. %package tools
  40. Summary: Tools for creating projects and bindings for %{name}
  41. Group: Development/Languages
  42. License: LGPLv2+
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: gnome-common intltool libtool
  45. Provides: %{name}-vapigen = %{version}-%{release}
  46. Obsoletes: %{name}-vapigen < %{version}-%{release}
  47. %description tools
  48. Vala is a new programming language that aims to bring modern programming
  49. language features to GNOME developers without imposing any additional
  50. runtime requirements and without using a different ABI compared to
  51. applications and libraries written in C.
  52. This package contains tools to generate Vala projects, as well as API bindings
  53. from existing C libraries, allowing access from Vala programs.
  54. %package doc
  55. Summary: Documentation for %{name}
  56. Group: Documentation
  57. License: LGPLv2+
  58. BuildArch: noarch
  59. Requires: %{name} = %{version}-%{release}
  60. Requires: devhelp
  61. Provides: %{name}-docs = %{version}-%{release}
  62. Obsoletes: %{name}-docs < %{version}-%{release}
  63. %description doc
  64. Vala is a new programming language that aims to bring modern programming
  65. language features to GNOME developers without imposing any additional
  66. runtime requirements and without using a different ABI compared to
  67. applications and libraries written in C.
  68. This package contains documentation in a devhelp HTML book.
  69. %prep
  70. %setup -q
  71. %build
  72. %configure --enable-vapigen
  73. # Don't use rpath!
  74. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  75. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  76. make %{?_smp_mflags}
  77. # checks currently utilize installed Vala, not the one being compiled
  78. #%check
  79. #make check
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post -p /sbin/ldconfig
  87. %postun -p /sbin/ldconfig
  88. %files
  89. %defattr(-,root,root,-)
  90. %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
  91. %{_bindir}/vala
  92. %{_bindir}/valac
  93. %{_bindir}/vala-%{api_ver}
  94. %{_bindir}/valac-%{api_ver}
  95. %{_datadir}/vala-%{api_ver}
  96. %{_libdir}/libvala-%{api_ver}.so.*
  97. %{_mandir}/*/valac*
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %{_includedir}/vala-%{api_ver}
  101. %{_libdir}/libvala-%{api_ver}.so
  102. %{_libdir}/pkgconfig/vala-%{api_ver}.pc
  103. %{_datadir}/aclocal/vala.m4
  104. %files tools
  105. %defattr(-,root,root,-)
  106. %{_bindir}/vala-gen-introspect
  107. %{_bindir}/vapicheck
  108. %{_bindir}/vapigen
  109. %{_bindir}/vala-gen-introspect-%{api_ver}
  110. %{_bindir}/vapicheck-%{api_ver}
  111. %{_bindir}/vapigen-%{api_ver}
  112. %{_libdir}/vala-%{api_ver}
  113. %{_mandir}/*/*gen*
  114. %files doc
  115. %defattr(-,root,root,-)
  116. %{_datadir}/devhelp/books/vala-%{api_ver}
  117. %changelog
  118. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  119. - new upstream release
  120. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  121. - new upstream release
  122. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  123. - rebuilt with rpm-4.8.1 for pkg-config
  124. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  125. - new upstream release
  126. - made -doc subpackage noarch
  127. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  128. - new upstream release
  129. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  130. - new upstream release
  131. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  132. - new upstream release
  133. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  134. - new upstream release
  135. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  136. - new upstream release
  137. - change BuildRequires: gecko-libs -> xulrunner-devel
  138. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  139. - new upstream release
  140. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  141. - new upstream release
  142. * Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  143. - new upstream release
  144. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  145. - initial build for Vine Linux
  146. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  147. - Update to 0.7.5
  148. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  150. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  151. - Patch broken ModuleInit attribute (upstream bug 587444)
  152. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  153. - Update to 0.7.4
  154. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  155. - Update to 0.7.3
  156. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  157. - Update to 0.6.1
  158. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  159. - Update to 0.5.7
  160. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  161. - Update to 0.5.6
  162. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  163. - Update to 0.5.3
  164. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  165. - Fix bug in Emacs version detection
  166. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  167. - Use buildsystem variables to determine available Emacs version
  168. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  169. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  170. - Update to 0.5.2
  171. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  172. - Update to 0.5.1
  173. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  174. - Update to 0.3.5
  175. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  176. - Add vala-mode for editing Vala code in Emacs
  177. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  178. - Update to 0.3.4
  179. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  180. - Update to 0.3.3
  181. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  182. - Update to 0.3.2
  183. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  184. - Update to 0.2.0
  185. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  186. - Update to 0.1.7
  187. - -tool subpackage now requires gnome-common, intltool and libtoolize
  188. for out-of-the-box vala-gen-project support
  189. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  190. - Autorebuild for GCC 4.3
  191. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  192. - Update to 0.1.6
  193. - Revert vapi addition, needed declarations have been inlined (r846)
  194. - Rename -docs subpackage to -doc, to comply with guidelines
  195. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  196. - Manually add Gee vapi file to package (bz #428692)
  197. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  198. - Backport patch to autodetect location of automake shared files
  199. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  200. - Add build dependency on gtk2-devel
  201. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  202. - Enable project generator tool
  203. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  204. - Update to 0.1.5
  205. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  206. - Add build dependency on devhelp
  207. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  208. - Update to 0.1.4
  209. - Put newly-added documentation in its own subpackage (depends on devhelp)
  210. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  211. - vapigen subpackage: add missing Require: on perl-XML-Twig
  212. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  213. - Split -vapigen subpackage. It is functionally self-contained and the license
  214. is more restricted
  215. - Updated license declarations
  216. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  217. - Licensing and URL updates
  218. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  219. - Enable binding generation tools
  220. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  221. - Update to 0.1.3
  222. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  223. - Update to 0.0.8
  224. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  225. - Update to 0.0.7
  226. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  227. - Update to 0.0.6
  228. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  229. - Initial package