screen-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. Summary: A screen manager that supports multiple logins on one terminal.
  2. Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
  3. Name: screen
  4. Version: 4.8.0
  5. Release: 2%{?_dist_release}
  6. Group: accessories
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. Source0: https://ftp.gnu.org/gnu/screen/screen-%{version}.tar.gz
  11. Source1: screen.pam
  12. Patch1: screen-4.3.1-libs.patch
  13. Patch2: screen-4.3.1-screenrc.patch
  14. Patch3: screen-E3.patch
  15. Patch4: screen-4.3.1-suppress_remap.patch
  16. Patch5: screen-4.3.1-crypt.patch
  17. Patch6: screen-4.8.0-expand-d_xtermosc.patch
  18. # security
  19. Patch1000: 99_CVE-2021-26937.patch
  20. Requires: ncurses
  21. Requires(post,preun): /sbin/install-info
  22. BuildRequires: ncurses-devel, texinfo, perl
  23. BuildRequires: pam-devel
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. %description
  26. The screen utility allows you to have multiple logins on just one
  27. terminal. Screen is useful for users who telnet into a machine or
  28. are connected via a dumb terminal, but want to use more than just
  29. one login.
  30. Install the screen package if you need a screen manager that can
  31. support multiple logins on one terminal.
  32. %description -l ja
  33. 一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
  34. ユーティリティです。telnetで操作しているユーザやダムターミナルから
  35. 接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
  36. 便利なプログラムです。
  37. %debug_package
  38. %prep
  39. %setup -q
  40. %autosetup -p1
  41. %build
  42. autoreconf -vfi
  43. %configure \
  44. --enable-pam \
  45. --enable-locate \
  46. --enable-telnet \
  47. --enable-colors256 \
  48. --with-sys-screenrc=%{_sysconfdir}/screenrc
  49. # configure can figure out these values.
  50. #perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
  51. #perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
  52. perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
  53. perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
  54. perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
  55. rm -f doc/screen.info*
  56. # fails with %{?_smp_mflags}
  57. make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. mkdir -p $RPM_BUILD_ROOT/etc/skel
  61. perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
  62. %makeinstall DDESTDIR=$RPM_BUILD_ROOT
  63. ( cd $RPM_BUILD_ROOT
  64. # gzip -9nf .%{_infodir}/screen.info*
  65. # strip .%{_bindir}/screen-%{version}
  66. rm -f .%{_bindir}/screen.old .%{_bindir}/screen
  67. mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
  68. )
  69. install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
  70. install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
  71. # Better not forget to copy the pam file around
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
  73. install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/screen
  74. # Remove files from the buildroot which we don't want packaged
  75. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %post
  79. /sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  80. if [ -d /tmp/screens ]; then
  81. # we're not setuid root anymore
  82. chmod 777 /tmp/screens
  83. fi
  84. %preun
  85. if [ $1 = 0 ]; then
  86. /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  87. fi
  88. %files
  89. %defattr(-,root,root)
  90. %license COPYING
  91. %doc NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
  92. #%attr(755,root,root) %{_bindir}/screen
  93. %{_bindir}/screen
  94. %{_mandir}/man1/screen.*
  95. %{_infodir}/screen.info*
  96. %{_datadir}/screen
  97. %config(noreplace) %{_sysconfdir}/screenrc
  98. %config(noreplace) %{_sysconfdir}/pam.d/screen
  99. %config /etc/skel/.screenrc
  100. %changelog
  101. * Thu Feb 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.0-2
  102. - imported Patch1000 from debian.
  103. * Thu Feb 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.0-1
  104. - update to 4.8.0.
  105. - re-imported patches from rawhide.
  106. * Fri Apr 20 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.6.2-1
  107. - update to 4.6.2
  108. - change License
  109. - sync fc28 package
  110. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.3-4
  111. - rebuild with VineSeed environment
  112. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.3-3vl6
  113. - build on current VineSeed
  114. - add execvpe patch (Patch0) based upstream git
  115. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
  116. - spec in UTF-8
  117. - add Patch12 to build against glibc-2.8
  118. - fix typo (from --enable-color256 to --enable-colors256)
  119. thanks Minematsu Hiroki-san for pointing this out
  120. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
  121. - used %%{?_dist_release}
  122. * Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
  123. - rebuild for VineSeed
  124. * Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
  125. - rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
  126. * Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
  127. - add BuildRequires: texinfo, perl
  128. * Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
  129. - upstream release with security fix (build for Vine 4.0)
  130. * Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
  131. - use License instead of Copyright
  132. * Sat Jun 5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
  133. - new upstream release
  134. - add %%{_datadir}/screen in %%files
  135. - no replace configuration file: /etc/screenrc
  136. * Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
  137. - eliminate %%{_bindir} from %%files section
  138. * Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
  139. - update to 3.9.13
  140. - add FAQ instead of a symbolic link to FAQ
  141. - remove unnecessary patches
  142. * Thu Nov 1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
  143. - update to 3.9.10 (security update)
  144. * Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
  145. - update to 3.9.9
  146. - rebuild by current Seed
  147. - remove makeinfo patch, jbj patch
  148. * Sat Mar 10 2001 sagami@vinelinux.org
  149. - made minor spec fixes
  150. * Fri Mar 2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
  151. - update to 3.9.8
  152. - update 3.9.5-jbj.patch for 3.9.8
  153. - add hascrypt patch
  154. * Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  155. - 3.9.5-1vl3
  156. - built with gcc-2.95.3
  157. - partially used rpmmacros
  158. * Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  159. - 3.9.5-1vl2
  160. - fixed %files section to handle compressed man page
  161. * Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
  162. - updated to 3.9.5
  163. * Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  164. - 3.9.4-5vl1
  165. - merged missing patches from screen-3.9.4-3 on Red Hat 6.1
  166. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  167. - you know, we weren't just patching in Unix98 pty support for fun.
  168. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  169. - put screendir in ~
  170. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  171. - update to 3.9.4.
  172. * Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
  173. - force tty permissions/group
  174. * Sat Jun 5 1999 Dale Lovelace <dale@redhat.com>
  175. - permissions on /etc/skel/.screenrc to 644
  176. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  177. - take out warning of directory permissions so root can still use screen
  178. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  179. - take out warning of directory ownership so root can still use screen
  180. * Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
  181. - patched in utempter support, turned off setuid bit
  182. * Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
  183. - fixed unix98 pty support
  184. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  185. - auto rebuild in the new build environment (release 3)
  186. * Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
  187. - add patch for Unix98 pty support
  188. * Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
  189. - update to 3.7.6.
  190. * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
  191. - build root
  192. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  193. - translations modified for de, fr, tr
  194. * Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  195. - upgraded to 3.7.4
  196. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  197. - removed glibc 1.99 specific patch
  198. * Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
  199. - added install-info support
  200. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  201. - built against glibc