calibre-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: calibre
  3. Version: 0.8.50
  4. Release: 2%{?_dist_release}
  5. Summary: E-book converter and library management
  6. Group: Applications/Multimedia
  7. License: GPLv3
  8. URL: http://calibre-ebook.com/
  9. # SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. # Upstream packages some unfree fonts which we cannot redistribute.
  11. # While we're at it, also delete the liberation fonts which we already have.
  12. #
  13. # Download the upstream tarball and invoke this script while in the tarball's
  14. # directory:
  15. # ./generate-tarball.sh %{version}
  16. Source0: %{name}-%{version}-nofonts.tar.xz
  17. Source1: generate-tarball.sh
  18. Source2: calibre-mount-helper
  19. Patch0: %{name}-manpages.patch
  20. Patch1: %{name}-no-update.patch
  21. Patch2: calibre-0.8.21-poppler.patch
  22. Patch3: calibre-0.8.50-poppler-0.20.x.patch
  23. Patch10: calibre-0.8.41-python27.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  25. BuildRequires: python >= 2.7.1
  26. BuildRequires: python-devel >= 2.7.1
  27. BuildRequires: ImageMagick-devel >= 6.5.9
  28. BuildRequires: python-setuptools
  29. BuildRequires: qt4-devel >= 4.7.0
  30. BuildRequires: PyQt4-devel >= 4.8.2
  31. BuildRequires: poppler-qt4-devel >= 0.12
  32. BuildRequires: podofo-devel >= 0.8.2
  33. BuildRequires: desktop-file-utils
  34. BuildRequires: python-mechanize >= 0.1.1
  35. BuildRequires: python-lxml >= 2.2.1
  36. BuildRequires: python-cssutils >= 0.9.6
  37. BuildRequires: python-dateutil >= 1.4.1
  38. BuildRequires: python-imaging >= 1.1.6
  39. BuildRequires: xdg-utils >= 1.0.2
  40. BuildRequires: python-BeautifulSoup >= 3.0.5
  41. BuildRequires: xz
  42. BuildRequires: unzip
  43. BuildRequires: libwmf-devel >= 0.2.8
  44. BuildRequires: chmlib-devel >= 0.40
  45. BuildRequires: python-cssutils > 0.9.6
  46. BuildRequires: sqlite3-devel
  47. BuildRequires: libicu-devel >= 4.4
  48. Requires: PyQt4
  49. Requires: pyPdf
  50. Requires: python-cherrypy
  51. Requires: python-cssutils
  52. Requires: ImageMagick
  53. Requires: python-odf
  54. Requires: python-django-tagging
  55. Requires: python-lxml
  56. Requires: python-imaging
  57. Requires: python-mechanize
  58. Requires: python-dateutil
  59. Requires: python-genshi
  60. Requires: python-BeautifulSoup
  61. ## vine
  62. Requires: TrueType-liberation
  63. %description
  64. Calibre is meant to be a complete e-library solution. It includes library
  65. management, format conversion, news feeds to ebook conversion as well as
  66. e-book reader sync features.
  67. Calibre is primarily a ebook cataloging program. It manages your ebook
  68. collection for you. It is designed around the concept of the logical book,
  69. i.e. a single entry in the database that may correspond to ebooks in several
  70. formats. It also supports conversion to and from a dozen different ebook
  71. formats.
  72. Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
  73. RTF, TXT, PDF and LRS.
  74. %prep
  75. %setup -q -n %{name}
  76. # don't append calibre1 to the name of the manpages. No need to compress either
  77. # upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
  78. %patch0 -p1 -b .manpages
  79. # don't check for new upstream version (that's what packagers do)
  80. %patch1 -p1 -b .no-update
  81. # modify poppler checks
  82. %patch2 -p1 -b .poppler
  83. %patch3 -p1 -b .poppler.0.20
  84. # use python2.7
  85. %patch10 -p1 -b .vine
  86. # dos2unix newline conversion
  87. %{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
  88. # remove shebangs
  89. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
  90. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
  91. %{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
  92. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
  93. %{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
  94. %{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
  95. %{__sed} -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
  96. %{__chmod} -x src/calibre/*/*/*/*.py
  97. %{__chmod} -x src/calibre/*/*/*.py
  98. %{__chmod} -x src/calibre/*/*.py
  99. %{__chmod} -x src/calibre/*.py
  100. %build
  101. OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
  102. %install
  103. %__rm -rf %{buildroot}
  104. %__mkdir -p %{buildroot}%{_datadir}
  105. # create directories for xdg-utils
  106. %__mkdir_p %{buildroot}%{_datadir}/icons
  107. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
  108. %__mkdir_p %{buildroot}%{_datadir}/packages
  109. %__mkdir_p %{buildroot}%{_datadir}/mime
  110. %__mkdir_p %{buildroot}%{_datadir}/mime/packages
  111. %__mkdir_p %{buildroot}%{_datadir}/applications
  112. %__mkdir_p %{buildroot}%{_datadir}/desktop-directories
  113. # create directory for calibre environment module
  114. # the install script assumes it's there.
  115. %__mkdir_p %{buildroot}%{python_sitelib}
  116. XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
  117. XDG_UTILS_INSTALL_MODE="system" \
  118. LIBPATH="%{_libdir}" \
  119. python setup.py install --root=%{buildroot}%{_prefix} \
  120. --prefix=%{_prefix} \
  121. --libdir=%{_libdir} \
  122. --staging-libdir=%{buildroot}%{_libdir}
  123. # remove shebang from init_calibre.py here because
  124. # it just got spawned by the install script
  125. %{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
  126. # icons
  127. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  128. %__cp -p resources/images/library.png \
  129. %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
  130. %__cp -p resources/images/viewer.png \
  131. %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
  132. # every file is empty here
  133. find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
  134. # packages aren't allowed to register mimetypes like this
  135. %__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
  136. desktop-file-validate \
  137. %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
  138. desktop-file-validate \
  139. %{buildroot}%{_datadir}/applications/calibre-gui.desktop
  140. desktop-file-validate \
  141. %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
  142. %__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
  143. %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
  144. # mimetype icon for lrf
  145. %__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
  146. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
  147. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
  148. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
  149. %__cp -p resources/images/mimetypes/lrf.png \
  150. %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
  151. %__cp -p resources/images/viewer.png \
  152. %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
  153. # don't put bash completions in /usr/etc
  154. %__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
  155. # these are provided as separate packages
  156. %__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
  157. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
  158. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
  159. # link to system fonts after we have deleted (see Source0) the non-free ones
  160. # http://bugs.calibre-ebook.com/ticket/3832
  161. %__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
  162. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
  163. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
  164. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
  165. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
  166. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
  167. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
  168. # http://bugs.calibre-ebook.com/ticket/3770#comment:7
  169. # man pages
  170. %__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
  171. # delete locales, calibre stores them in a zip file now
  172. rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
  173. %{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
  174. %__install -m 755 %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
  175. %clean
  176. %{__rm} -rf %{buildroot}
  177. %post
  178. update-desktop-database &> /dev/null ||:
  179. update-mime-database %{_datadir}/mime &> /dev/null || :
  180. touch --no-create %{_datadir}/icons/hicolor || :
  181. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  182. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  183. fi
  184. %postun
  185. update-desktop-database &> /dev/null ||:
  186. update-mime-database %{_datadir}/mime &> /dev/null || :
  187. touch --no-create %{_datadir}/icons/hicolor || :
  188. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  189. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  190. fi
  191. %files
  192. %defattr(-,root,root,-)
  193. %doc COPYRIGHT LICENSE Changelog.yaml
  194. %{_bindir}/calibre
  195. %{_bindir}/calibre-complete
  196. %{_bindir}/calibre-customize
  197. %{_bindir}/calibre-debug
  198. %{_bindir}/calibre-parallel
  199. %{_bindir}/calibre-server
  200. %{_bindir}/calibre-smtp
  201. %{_bindir}/calibre-mount-helper
  202. %{_bindir}/calibredb
  203. %{_bindir}/ebook-convert
  204. %{_bindir}/ebook-device
  205. %{_bindir}/ebook-meta
  206. %{_bindir}/ebook-viewer
  207. %{_bindir}/epub-fix
  208. %{_bindir}/fetch-ebook-metadata
  209. %{_bindir}/lrf2lrs
  210. %{_bindir}/lrfviewer
  211. %{_bindir}/lrs2lrf
  212. %{_bindir}/markdown-calibre
  213. %{_bindir}/pdfmanipulate
  214. %{_bindir}/web2disk
  215. %config(noreplace) %{_sysconfdir}/bash_completion.d/
  216. %{_libdir}/%{name}
  217. %{_datadir}/%{name}
  218. %{_datadir}/pixmaps/*
  219. %{_datadir}/applications/*.desktop
  220. %{_datadir}/mime/packages/*
  221. %{_datadir}/icons/hicolor/scalable/mimetypes/*
  222. %{_datadir}/icons/hicolor/scalable/apps/*
  223. %{python_sitelib}/init_calibre.py*
  224. %{_mandir}/man1/*
  225. %changelog
  226. * Sun Aug 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.50-2
  227. - rebuild with ImageMagick-6.8.6.8
  228. - add Patch3 (calibre-0.8.50-poppler-0.20.x.patch)
  229. * Tue May 8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.50-1
  230. - new upstream release
  231. - BuildRequires: qt4-devel >= 4.8.0
  232. - BuildRequires: PyQt4-devel >= 4.9.1
  233. * Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
  234. - new upstream release
  235. * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
  236. - new upstream release
  237. * Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
  238. - rebuild with ImageMagick-6.7.5.10
  239. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
  240. - new upstream release
  241. * Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
  242. - new upstream release
  243. * Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
  244. - new upstream release
  245. * Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
  246. - new upstream release
  247. * Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
  248. - new upstream release
  249. * Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
  250. - new upstream release
  251. * Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
  252. - new upstream release
  253. * Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
  254. - new upstream release
  255. - added BuildRequires: libicu-devel
  256. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
  257. - new upstream release
  258. * Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
  259. - new upstream release
  260. * Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
  261. - new upstream release
  262. * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
  263. - Update to 0.7.24
  264. * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
  265. - Update to 0.7.23
  266. - Fix up mount helper with our own local script.
  267. - Change files to list binaries so missing ones can more easily be noted.
  268. * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
  269. - Update to 0.7.22
  270. * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
  271. - Update to 0.7.21
  272. * Wed Sep 29 2010 jkeating - 0.7.20-2
  273. - Rebuilt for gcc bug 634757
  274. * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
  275. - Update to 0.7.20
  276. * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
  277. - Rebuild for new ImageMagick
  278. * Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
  279. - new upstream release
  280. - Fix svg/png changes.
  281. * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
  282. - Fix svg/png changes.
  283. * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
  284. - Update to 0.7.18
  285. - Require > 0.9.6 cssutils
  286. * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
  287. - Update to 0.7.17
  288. * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
  289. - Update to 0.7.16
  290. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
  291. - initial build based on Fedora development
  292. * Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
  293. - Update to 0.7.15
  294. * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
  295. - rebuild (poppler)
  296. * Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
  297. - Update to 0.7.14
  298. * Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
  299. - Update to 0.7.13
  300. * Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
  301. - Update to 0.7.12
  302. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
  303. - Update to 0.7.11
  304. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
  305. - Rebuilt for python2.7
  306. * Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
  307. - Update to 0.7.10
  308. * Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
  309. - Update to 0.7.9
  310. * Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
  311. - Update to 0.7.8
  312. - build tar.xz instead of tar.bz2
  313. * Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
  314. - Update to 0.7.7
  315. * Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
  316. - Update to 0.7.6
  317. * Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
  318. - Update to 0.7.5
  319. * Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
  320. - Update to 0.7.4
  321. * Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
  322. - rebuilt with podofo 0.8.1
  323. * Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
  324. - Update to 0.7.1
  325. - Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
  326. * Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
  327. - Update to 0.7.0
  328. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
  329. - Update to 0.6.55
  330. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
  331. - Update to 0.6.54
  332. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
  333. - Update to 0.6.53
  334. * Wed May 5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
  335. - Rebuild against new poppler
  336. * Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
  337. - new upstream release 0.6.47
  338. - new chmlib requirement
  339. - create directory for calibre's environment module
  340. - use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
  341. - remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
  342. * Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
  343. - new upstream release 0.6.42
  344. - remove shebang from default_tweaks.py
  345. * Mon Feb 1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
  346. - new upstream release 0.6.37
  347. * Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
  348. - new upstream release 0.6.36
  349. - fixed a cssprofiles issue with loading the profiles
  350. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
  351. - added -cssprofiles patch to cvs
  352. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
  353. - remove python-cssutils 0.9.6 dependency
  354. * Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
  355. - new upstream release
  356. - fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
  357. - removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
  358. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
  359. - fix for package tagged without adding new patch to cvs
  360. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
  361. - new upstream release 0.6.32
  362. - project website has changed
  363. - added python-BeautifulSoup BuildRequire
  364. - new patch to fix full buildpath in binary files
  365. * Sun Dec 6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
  366. - New upstream version
  367. - Regenerated no-update patch because of code relocation
  368. * Wed Dec 2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
  369. - New upstream release
  370. * Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
  371. - New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
  372. * Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
  373. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
  374. - patch to stop checking for new upstream version
  375. * Sat Nov 7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
  376. - new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
  377. - added python-BeautifulSoup requirement
  378. * Wed Nov 4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
  379. - new upstream version:
  380. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
  381. - upstream now ships correct .desktop files
  382. - fixed missing dependency: PyQt4
  383. - fixed calibre-gui icon
  384. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
  385. - removed unfree fonts from source package
  386. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
  387. - readability enhancements
  388. - added python-genshi requires
  389. - removed libwmf require since ImageMagick provides libwmf-lite as a
  390. dependency and that's what we actually need
  391. * Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
  392. - new upstream version:
  393. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
  394. - delete fonts, calibre can find the system fonts
  395. - specify libdir as an install option, so calibre will link properly
  396. even on 64bit
  397. * Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
  398. - updated requires list
  399. - new upstream release
  400. - can override CFLAGS now
  401. - removed trac and genshi duplicates
  402. - use xdg env variables to do desktop integration in the buildroot
  403. - added xdg-utils buildrequire
  404. - install udev rules in /usr/lib even on 64bit and don't own the whole dir
  405. - removed wrongly used Version field from .desktop files
  406. * Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
  407. - mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
  408. - removed unneeded INSTALL file
  409. - marked bash completion file as config(noreplace) and take ownership of the dir
  410. * Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
  411. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
  412. - the install process changed significantly
  413. - locales were added
  414. * Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
  415. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
  416. - minor path fixes
  417. - rearranged files section
  418. * Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
  419. - handle desktop files
  420. - don't compress manpages and don't list them as duplicates
  421. - added lrfviewer icon
  422. * Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
  423. - Initial RPM release