minitube-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153
  1. # Qt4 version auto-detection -- inagaki
  2. %define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.1)
  3. %if "%{?_dist_release}" >= "vl7"
  4. %define qt4qmake %{_bindir}/qmake
  5. %else
  6. %define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
  7. %endif
  8. # Move original binary to libexec dir and replace it by wrapper script
  9. %define MINITUBE_BIN %{_libexecdir}/%{name}
  10. Summary: Native YouTube Client
  11. Summary(ja): YouTube 専用クライアント
  12. Name: minitube
  13. Version: 2.0
  14. Release: 1%{?_dist_release}
  15. Source0: http://flavio.tordini.org/files/minitube/minitube.tar.gz
  16. Source10: minitube.sh
  17. Source20: minitube-ja.desktop
  18. License: GPLv3+
  19. Group: Applications/Multimedia
  20. URL: http://flavio.tordini.org/minitube
  21. Requires: phonon-backend-gstreamer
  22. Requires(post): desktop-file-utils
  23. Requires(postun):desktop-file-utils
  24. BuildRequires: qt4-devel > 4.5
  25. BuildRequires: qt4-designer
  26. BuildRequires: phonon-devel
  27. BuildRequires: python-devel
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. Minitube is a native YouTube client. With it you can watch
  33. YouTube videos in a new way: you type a keyword, Minitube
  34. gives you an endless video stream. Minitube does not require
  35. the Flash Player.
  36. Minitube is not about cloning the original YouTube web interface,
  37. it aims to create a new TV-like experience.
  38. You should install following packages to play videos.
  39. - self-build-gstreamer-plugins-bad
  40. - self-build-gstreamer-plugins-ffmpeg
  41. %description -l ja
  42. Minitube は YouTube の新しい視聴方法を提案する、専用のクライ
  43. アントソフトウェアです。キーワードを入力すると、Minitube は
  44. 関連する動画をエンドレスで再生します。
  45. また Minitube を使うと Flash Player 無しでビデオが再生できます。
  46. Minitube は YouTube のウェブインターフェースのクローンでは無
  47. く、新たなテレビ風の視聴スタイルを目指しています。
  48. ビデオの再生には以下のパッケージが必要となります。併せてイン
  49. ストールしてください。
  50. - self-build-gstreamer-plugins-bad
  51. - self-build-gstreamer-plugins-ffmpeg
  52. %prep
  53. %setup -q -n %{name}
  54. %build
  55. %{qt4qmake} prefix=%{_prefix}
  56. %{__make} %{?_smp_mflags}
  57. %install
  58. %{__rm} -rf $RPM_BUILD_ROOT
  59. %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
  60. ## wrapper
  61. %{__mkdir_p} $RPM_BUILD_ROOT%{_libexecdir}
  62. %{__mv} $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{MINITUBE_BIN}
  63. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  64. # desktop file with japanese messages
  65. %{__install} -m 644 %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  66. %clean
  67. %{__rm} -rf $RPM_BUILD_ROOT
  68. %post
  69. update-desktop-database %{_datadir}/applications>& /dev/null ||:
  70. touch --no-create %{_datadir}/icons/hicolor
  71. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  72. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  73. fi
  74. %postun
  75. update-desktop-database %{_datadir}/applications>& /dev/null ||:
  76. touch --no-create %{_datadir}/icons/hicolor
  77. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  78. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  79. fi
  80. %files
  81. %defattr(-,root,root)
  82. %doc AUTHORS COPYING CHANGES INSTALL TODO
  83. %{MINITUBE_BIN}
  84. %{_bindir}/%{name}
  85. %{_datadir}/applications/%{name}.desktop
  86. %{_datadir}/icons/hicolor
  87. %{_datadir}/%{name}/locale
  88. %changelog
  89. * Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
  90. - new upstream release
  91. * Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
  92. - new upstream release
  93. * Wed Jul 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
  94. - new upstream release
  95. * Tue May 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-2
  96. - fix Source10 (remove gksu)
  97. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-1
  98. - new upstream release
  99. * Fri Jan 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
  100. - new upstream release
  101. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
  102. - new upstream release
  103. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-1
  104. - new upstream release
  105. * Wed May 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  106. - new upstream release
  107. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-1
  108. - new upstream release
  109. * Fri Jul 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.1-1
  110. - new upstream release
  111. * Sat May 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.0-1
  112. - initial build for Vine Linux
  113. - add minitube.desktop with japanese translation
  114. - add wrapper script to check necessary packages at runtime