v8-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. # For the 1.2 branch, we use 0s here
  3. # For 1.3+, we use the three digit versions
  4. %global somajor 2
  5. %global sominor 4
  6. %global sobuild 9
  7. %global sover %{somajor}.%{sominor}.%{sobuild}
  8. %define svnrevision 5631
  9. Name: v8
  10. Version: %{sover}
  11. Release: 1%{?svnrevision:.svn%svnrevision}%{?_dist_release}
  12. Summary: JavaScript Engine
  13. Summary(ja): JavaScript エンジン
  14. Group: System Environment/Libraries
  15. License: BSD
  16. URL: http://code.google.com/p/v8
  17. # U=http://v8.googlecode.com/svn/trunk/
  18. # R=$(svn log $U |awk '/^r[0-9]* / {r=$1} /2\.4\.8/ {print r; exit}')
  19. # svn export -$R $U v8-2.4.8
  20. # tar cjf v8-2.4.8.tar.bz2 v8-2.4.8
  21. Source0: %{name}-%{version}%{?svnrevision:.svn%svnrevision}.tar.bz2
  22. Source10: v8-snapshot.sh
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. ExclusiveArch: %{ix86} x86_64 arm
  25. BuildRequires: scons
  26. BuildRequires: readline-devel
  27. %description
  28. V8 is Google's open source JavaScript engine. V8 is written in C++ and is used
  29. in Google Chrome, the open source browser from Google. V8 implements ECMAScript
  30. as specified in ECMA-262, 3rd edition.
  31. #'
  32. %description -l ja
  33. V8 は Google のオープンソース JavaScript エンジンです。
  34. V8 で C++ 書かれており、Google 発のオープンソースブラウザである
  35. Google Chrome で使われています。
  36. V8 は ECMA-262 第 3 版で指定されている ECMAScript を満たしています。
  37. %package devel
  38. Group: Development/Libraries
  39. Summary: Development headers and libraries for v8
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Development headers, libraries and tools for v8.
  43. %prep
  44. %setup -q
  45. # -fno-strict-aliasing is needed with gcc 4.4 to get past some ugly code
  46. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -fPIC -fno-strict-aliasing -Wno-unused-parameter\'| %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  47. %__sed -i "s|'-O3',|$PARSED_OPT_FLAGS,|g" SConstruct
  48. %build
  49. %if %{?_dist_release} == "vl6"
  50. export GCC_VERSION="44"
  51. %endif
  52. scons library=shared snapshots=on %{_smp_mflags} \
  53. %ifarch x86_64
  54. arch=x64 \
  55. %endif
  56. visibility=default \
  57. env=CCFLAGS:"-fPIC"
  58. # When will people learn to create versioned shared libraries by default?
  59. # first, lets get rid of the old .so
  60. %__rm -rf libv8.so
  61. # Now, lets make it right.
  62. %ifarch arm
  63. g++ $RPM_OPT_FLAGS -fPIC -o libv8.so.%{sover} -shared -Wl,-soname,libv8.so.%{somajor} obj/release/*.os obj/release/arm/*.os
  64. %endif
  65. %ifarch %{ix86}
  66. g++ $RPM_OPT_FLAGS -fPIC -o libv8.so.%{sover} -shared -Wl,-soname,libv8.so.%{somajor} obj/release/*.os obj/release/ia32/*.os
  67. %endif
  68. %ifarch x86_64
  69. g++ $RPM_OPT_FLAGS -fPIC -o libv8.so.%{sover} -shared -Wl,-soname,libv8.so.%{somajor} obj/release/*.os obj/release/x64/*.os
  70. %endif
  71. # We need to do this so d8 can link against it.
  72. %__ln_s -f libv8.so.%{sover} libv8.so
  73. scons d8 %{_smp_mflags} \
  74. %ifarch x86_64
  75. arch=x64 \
  76. %endif
  77. library=shared snapshots=on console=readline visibility=default
  78. # Ahem
  79. %__rm -rf d8
  80. g++ $RPM_OPT_FLAGS -o d8 obj/release/d8-debug.os obj/release/d8-posix.os obj/release/d8-readline.os obj/release/d8.os obj/release/d8-js.os -lpthread -lreadline -lpthread -L. -lv8
  81. %install
  82. %__rm -rf %{buildroot}
  83. %__mkdir_p %{buildroot}%{_includedir}
  84. %__mkdir_p %{buildroot}%{_libdir}
  85. %__install -p include/*.h %{buildroot}%{_includedir}
  86. %__install -p libv8.so.%{sover} %{buildroot}%{_libdir}
  87. %__mkdir_p %{buildroot}%{_bindir}
  88. %__install -p -m0755 d8 %{buildroot}%{_bindir}
  89. %__install -d %{buildroot}%{python_sitelib}
  90. %__install -pm644 tools/js2c.py %{buildroot}%{python_sitelib}
  91. %__install -pm644 tools/jsmin.py %{buildroot}%{python_sitelib}
  92. cd %{buildroot}%{_libdir}
  93. %__ln_s -f libv8.so.%{sover} libv8.so
  94. %__ln_s -f libv8.so.%{sover} libv8.so.%{somajor}
  95. %__ln_s -f libv8.so.%{sover} libv8.so.%{somajor}.%{sominor}
  96. %__chmod -x %{buildroot}%{_includedir}/v8*.h
  97. %clean
  98. %__rm -rf %{buildroot}
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %files
  102. %defattr(-,root,root,-)
  103. %doc AUTHORS ChangeLog LICENSE
  104. %{_bindir}/d8
  105. %{_libdir}/*.so.*
  106. %files devel
  107. %defattr(-,root,root,-)
  108. %{_includedir}/*.h
  109. %{_libdir}/*.so
  110. %{python_sitelib}/*.py*
  111. %changelog
  112. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.4.9-1.svn5631
  113. - source 2.4.9 rev.5631
  114. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.4.8-1
  115. - initial build
  116. * Sat Sep 18 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.4.4-1
  117. - Newer version
  118. - Package based on 2.3.11-1.20100831svn5385 by Tom "spot" Callaway
  119. * Wed Sep 15 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.3.8-2
  120. - Package based on 2.3.11-1.20100831svn5385 by Tom "spot" Callaway