bind-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613
  1. %define _localstatedir /var
  2. %define pversion 9.6.ESV.R4.P1
  3. %define sversion 9.6-ESV-R4-P1
  4. %define bind_epoch 1
  5. %define bind_uid 25
  6. %define bind_gid 25
  7. Summary: A DNS (Domain Name System) server.
  8. Summary(ja): DNS (Domain Name System) サーバ
  9. Name: bind
  10. Version: %{pversion}
  11. Release: 1%{?_dist_release}
  12. License: distributable
  13. Group: System Environment/Daemons
  14. Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
  15. Source1: bind-manpages.tar.bz2
  16. Source2: named.sysconfig
  17. Source3: named.init
  18. Source4: named.logrotate
  19. Source5: keygen.c
  20. Url: http://www.isc.org/bind.html
  21. Patch1: bind-9.3.3rc2-rndckey.patch
  22. Buildroot: %{_tmppath}/%{name}-%{version}-root
  23. BuildPreReq: openssl-devel glibc-devel libtool
  24. BuildRequires: libxml2-devel libcap-devel
  25. PreReq: chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
  26. PreReq: bind-utils = %{bind_epoch}:%{version}-%{release}
  27. Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
  28. Conflicts: bind9 <= 9.2.1-0vl5, bind-current
  29. Obsoletes: bind9 <= 9.2.1-0vl5
  30. epoch: %{bind_epoch}
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. BIND (Berkeley Internet Name Domain) is an implementation of the DNS
  35. (Domain Name System) protocols. BIND includes a DNS server (named),
  36. which resolves host names to IP addresses, and a resolver library
  37. (routines for applications to use when interfacing with DNS). A DNS
  38. server allows clients to name resources or objects and share the
  39. information with other network machines. The named DNS server can be
  40. used on workstations as a caching name server, but is generally only
  41. needed on one machine for an entire network. Note that the
  42. configuration files for making BIND act as a simple caching nameserver
  43. are included in the caching-nameserver package.
  44. Install the bind package if you need a DNS server for your network. If
  45. you want bind to act a caching name server, you will also need to install
  46. the caching-nameserver package.
  47. %package libs
  48. Summary: Libraries used by various DNS packages
  49. Group: System Environment/Libraries
  50. Conflicts: bind-current-libs
  51. %description libs
  52. Contains libraries used by both the bind server package as well as the utils packages.
  53. %package utils
  54. Summary: Utilities for querying DNS name servers.
  55. Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
  56. Group: Applications/System
  57. Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
  58. Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
  59. Obsoletes: bind9-utils <= 9.2.1-0vl5
  60. %description utils
  61. Bind-utils contains a collection of utilities for querying DNS (Domain
  62. Name Service) name servers to find out information about Internet hosts.
  63. These tools will provide you with the IP addresses for given host names,
  64. as well as other information about registered domains and network
  65. addresses.
  66. You should install bind-utils if you need to get information from DNS name
  67. servers.
  68. %package devel
  69. Summary: Include files and libraries needed for bind DNS development.
  70. Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
  71. Group: Development/Libraries
  72. Requires: bind = %{bind_epoch}:%{version}-%{release}
  73. Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
  74. Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
  75. Obsoletes: bind9-devel <= 9.2.1-0vl5
  76. %description devel
  77. The bind-devel package contains all the include files and the
  78. library required for DNS (Domain Name Service) development for
  79. BIND versions 9.x.x.
  80. You should install bind-devel if you want to develop bind DNS
  81. applications. If you install bind-devel, you'll also need to install
  82. bind.
  83. #'
  84. %prep
  85. %setup -n bind-%{sversion} -q
  86. %patch1 -p1 -b .key
  87. %build
  88. libtoolize --copy --force
  89. aclocal
  90. autoconf
  91. %configure --with-libtool --with-openssl=/usr --enable-threads
  92. make %{?_smp_mflags}
  93. %install
  94. rm -rf $RPM_BUILD_ROOT
  95. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
  96. mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
  97. mkdir -p ${RPM_BUILD_ROOT}/var/named
  98. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
  99. mkdir -p ${RPM_BUILD_ROOT}/var/run/named
  100. make DESTDIR=$RPM_BUILD_ROOT install
  101. install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
  102. install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
  103. install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
  104. install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
  105. touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
  106. gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
  107. cd $RPM_BUILD_ROOT%{_mandir}
  108. tar xjf %{SOURCE1}
  109. # newer version is contained in source
  110. rm -f man5/named.conf.5.gz
  111. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  112. cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
  113. %pre
  114. if [ "$1" -eq 1 ]; then
  115. /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
  116. /usr/sbin/useradd -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
  117. fi;
  118. :;
  119. %post
  120. /sbin/ldconfig
  121. /sbin/chkconfig --add named
  122. if [ "$1" -eq 1 ]; then
  123. if [ ! -e /etc/rndc.key ]; then
  124. /usr/sbin/rndc-confgen -a > /dev/null 2>&1
  125. fi
  126. [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
  127. # rndc.key has to have correct perms and ownership, CVE-2007-6283
  128. [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
  129. [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
  130. # Check DNSSEC settings if this is a fresh install
  131. if [ -r /etc/sysconfig/dnssec ]; then
  132. . /etc/sysconfig/dnssec
  133. [ -x /usr/sbin/dnssec-configure ] && \
  134. dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
  135. /dev/null 2>&1
  136. fi;
  137. fi
  138. :;
  139. %preun
  140. if [ "$1" -eq 0 ]; then
  141. /sbin/service named stop >/dev/null 2>&1 || :
  142. /sbin/chkconfig --del named ||:
  143. fi
  144. exit 0
  145. %postun
  146. if [ "$1" -ge 1 ]; then
  147. %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
  148. fi
  149. /sbin/ldconfig
  150. %triggerpostun -- bind < 8.2.2_P5-15
  151. /sbin/chkconfig --add named
  152. /sbin/ldconfig
  153. %clean
  154. rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
  155. %post libs -p /sbin/ldconfig
  156. %postun libs -p /sbin/ldconfig
  157. %files
  158. %defattr(-,root,root)
  159. %doc CHANGES README
  160. %doc doc/arm doc/draft doc/rfc doc/misc
  161. %config(noreplace) %{_sysconfdir}/logrotate.d/named
  162. %config %{_sysconfdir}/rc.d/init.d/named
  163. %config(noreplace) %{_sysconfdir}/sysconfig/named
  164. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
  165. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
  166. %{_sbindir}/dnssec*
  167. %{_sbindir}/lwresd
  168. %{_sbindir}/named
  169. %{_sbindir}/named-bootconf
  170. %{_sbindir}/named-check*
  171. %{_sbindir}/named-compilezone
  172. %{_sbindir}/rndc*
  173. %{_sbindir}/dns-keygen
  174. #%{_libdir}/libbind9.so.*
  175. #%{_libdir}/libisccc.so.*
  176. #%{_libdir}/libisccfg.so.*
  177. %{_mandir}/man5/resolv.conf.5*
  178. %{_mandir}/man5/named.conf.5*
  179. %{_mandir}/man5/rndc.conf.5*
  180. %{_mandir}/man8/rndc.8*
  181. %{_mandir}/man8/named.8*
  182. %{_mandir}/man8/lwresd.8*
  183. %{_mandir}/man8/dnssec*.8*
  184. %{_mandir}/man8/named-checkconf.8*
  185. %{_mandir}/man8/named-checkzone.8*
  186. %{_mandir}/man8/named-compilezone.8*
  187. %{_mandir}/man8/rndc-confgen.8*
  188. %attr(-,named,named) %dir %{_var}/named
  189. %attr(-,named,named) %dir %{_var}/run/named
  190. %files libs
  191. %defattr(-,root,root)
  192. %{_libdir}/*.so.*
  193. %files utils
  194. %defattr(-,root,root)
  195. %{_bindir}/dig
  196. %{_bindir}/host
  197. %{_bindir}/nslookup
  198. %{_bindir}/nsupdate
  199. #%{_libdir}/libdns.so.*
  200. #%{_libdir}/libisc.so.*
  201. #%{_libdir}/liblwres.so.*
  202. %{_mandir}/man1/host.1*
  203. %{_mandir}/man1/nsupdate.1*
  204. %{_mandir}/man1/dig.1*
  205. %{_mandir}/man5/resolver.5*
  206. %{_mandir}/man1/nslookup.1*
  207. %{_mandir}/man8/nslookup.8*
  208. %files devel
  209. %defattr(-,root,root)
  210. %{_libdir}/*.so
  211. %{_libdir}/*.la
  212. %{_libdir}/*.a
  213. %{_includedir}/*
  214. %{_mandir}/man3/*
  215. %{_mandir}/man1/isc-config.sh.1*
  216. %{_bindir}/isc-config.sh
  217. %changelog
  218. * Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
  219. - new upstream release with security fix (CVE-2011-1910)
  220. * Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
  221. - new upstream release
  222. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
  223. - rebuild with openssl-1.0.0c
  224. * Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
  225. - rebuild package
  226. * Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
  227. - change spec filename bind9-vl -> bind-vl
  228. * Thu Oct 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
  229. - new upstream ESV release
  230. - add BR: libxml2-devel libcap-devel
  231. * Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
  232. - add Conflicts bind-current
  233. * Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
  234. - new upstream ESV release
  235. - add epoch 1 to upgrade from exist bind package
  236. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
  237. - add man1/isc-config.sh.1 into devel file list
  238. * Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
  239. - new upstream release with security fix (CVE-2009-4022, 2010-0097)
  240. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
  241. - new upstream release with security fix (CVE-2009-4022)
  242. * Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
  243. - new upstream release with security fix
  244. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
  245. - new upstream release
  246. - clean up %%post/%%pre scriptlet
  247. - create named user and group in %%pre
  248. - don't remove named user/group in %%preun
  249. - use rndc-confgen to create rndc.key
  250. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
  251. - new upstream release
  252. - drop patch0 and patch14, merged in upstream
  253. * Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
  254. - new upstream release with security fix
  255. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
  256. - new upstream release with security fix
  257. - new versioning policy
  258. * Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
  259. - new upstream release with security fix
  260. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
  261. - new upstream release
  262. - build with new openssl/toolchain
  263. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
  264. - new upstream release with security fix
  265. * Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
  266. - new upstream release
  267. * Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
  268. - add Prereq sed
  269. * Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
  270. - new upstream release for security fix (CVE-2006-4095,4096)
  271. * Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
  272. - separate -libs package
  273. - remove old named.conf.5.gz
  274. - newer version is contained in source
  275. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
  276. - add bsdcompat patch (Patch4)
  277. - add fix_h_errno patch from FC
  278. - h_errno not being accessed / set correctly in libbind
  279. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
  280. - new upstream release
  281. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
  282. - added PreReq to bind-utils (see: [VineSeed:09555])
  283. * Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
  284. - new upstream release
  285. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
  286. - fix /etc/init.d/named to use rndc
  287. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
  288. - rebuild to remove unneeded dependancy
  289. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
  290. - new upstream release
  291. * Tue Mar 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
  292. - new upstream release
  293. * Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
  294. - fix dependancies.
  295. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
  296. - add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
  297. - change package name to bind for VineSeed.
  298. - use more macros.
  299. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
  300. - fixed some macros
  301. - add conflicts: to bind-* in bind9-devel and bind9-utils
  302. - add provides: bind = %%{version}
  303. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
  304. - use %%configure macros
  305. * Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
  306. - fixed inconsistent dependency
  307. * Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
  308. - updated to 9.2.2rc1
  309. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
  310. - updated to bind9(9.2.1), test packages ;)
  311. -- based on Rawhide's bind-9.2.0-8
  312. -- changed name bind9
  313. -- added Conflicts: bind
  314. * Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
  315. - release 8.3.1 includes security fixes
  316. * Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
  317. - Upgraded to current stable release 8.3.0
  318. * Mon Oct 8 2001 <zn@mbf.nifty.com>
  319. - 8.2.5-0vl0: Upgraded to new upstream version.
  320. * Thu May 24 2001 <sagami@vinelinux.org>
  321. - 8.2.4-0vl1: eliminate CVS related files from %%doc
  322. * Thu May 17 2001 <sagami@vinelinux.org>
  323. - 8.2.4-0vl0
  324. * Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  325. - 8.2.3-1vl2
  326. - built on VineSeed
  327. * Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
  328. - add doc/old
  329. - build for Vine 2.1
  330. * Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  331. - 8.2.3, fixes several security problems
  332. * Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
  333. - static libraries may be used in shared objects. Build with -fPIC on ia64
  334. * Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  335. - 8.2.2-P7 (fixes Bug #20546)
  336. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  337. - condrestart fixes
  338. * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  339. - change the init script to take condrestart, not cond-restart
  340. - add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
  341. the %pre and %post scripts
  342. * Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  343. - Don't prereq /etc/init.d
  344. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  345. - move initscript back
  346. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  347. - automatic rebuild
  348. * Sun Jul 9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  349. - add "exit 0" for uninstall case
  350. * Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  351. - add prereq init.d and cleanup install section
  352. * Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  353. - fix the init script
  354. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  355. - make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
  356. * Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  357. - Fix up the initscript (Bug #13033)
  358. - Fix build with current glibc (Bug #12755)
  359. - /etc/rc.d/init.d -> /etc/init.d
  360. - use %%{_mandir} rather than /usr/share/man
  361. * Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
  362. - fix conflict with man-pages
  363. - remove compatibilty chkconfig links
  364. - initscript munging
  365. * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  366. - modify logrotate setup to use PID file
  367. - temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
  368. - actually bump the release this time
  369. * Sun Jun 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  370. - FHS compliance
  371. * Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  372. - clean up restart patch
  373. * Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  374. - provide /var/named (fix for bugs #9847, #10205)
  375. - preserve args when restarted via ndc(8) (bug #10227)
  376. - make resolv.conf(5) a link to resolver(5) (bug #10245)
  377. - fix SYSTYPE bug in all makefiles
  378. - move creation of named user from %%post into %%pre
  379. * Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  380. - Fix TTL (patch from ISC, Bug #9820)
  381. * Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  382. - fix typo in spec (it's %post, without a leading blank) introduced in -6
  383. - change SYSTYPE to linux
  384. * Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
  385. - pick a standard < 100 uid/gid for named
  386. * Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
  387. - Pass named a '-u named' parameter by default, and add/remove user.
  388. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  389. - fix host mx bug (Bug #9021)
  390. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  391. - rebuild to fix dependencies
  392. - man pages are compressed
  393. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  394. - It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
  395. * Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  396. - Fix up location of named-bootconf.pl and make it executable
  397. (Bug #8028)
  398. - bind-devel requires bind
  399. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  400. - update to 8.2.2-P5
  401. * Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
  402. - update to 8.2.2-P3
  403. * Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
  404. - add patch to stop a cache only server from complaining about lame servers
  405. on every request.
  406. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  407. - use real stop and start in named.init for restart, not ndc restart, it has
  408. problems when named has changed during a package update... (# 4890)
  409. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  410. - chkconfig --del in %preun, not %postun
  411. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  412. - initscript munging
  413. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  414. - fix installed chkconfig links to match init file
  415. * Sat Jul 3 1999 Jeff Johnson <jbj@redhat.com>
  416. - conflict with new (in man-1.24) man pages (#3876,#3877).
  417. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  418. - fix named.logrotate (wrong %SOURCE)
  419. * Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
  420. - update to 8.2.1.
  421. - add named.logrotate (#3571).
  422. - hack around egcs-1.1.2 -m486 bug (#3413, #3485).
  423. - vet file list.
  424. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  425. - don't run by default
  426. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  427. - nslookup fixes (#2463).
  428. - missing files (#3152).
  429. * Sat May 1 1999 Stepan Kasal <kasal@math.cas.cz>
  430. - nslookup patched:
  431. to count numRecords properly
  432. to fix subsequent calls to ls -d
  433. to parse "view" and "finger" commands properly
  434. the view hack updated for bind-8 (using sed)
  435. * Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
  436. - add ISC patch
  437. - add quick hack to make host not crash
  438. - add more docs
  439. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  440. - add probing information in the init file to keep linuxconf happy
  441. - dont strip libbind
  442. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  443. - auto rebuild in the new build environment (release 3)
  444. * Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
  445. - removed 'done' output at named shutdown.
  446. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  447. - version 8.2
  448. * Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
  449. - patch to use the __FDS_BITS macro
  450. - build for glibc 2.1
  451. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  452. - change named.restart to /usr/sbin/ndc restart
  453. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  454. - install man pages correctly.
  455. - change K10named to K45named.
  456. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  457. - don't start if /etc/named.conf doesn't exist.
  458. * Sat Aug 8 1998 Jeff Johnson <jbj@redhat.com>
  459. - autmagically create /etc/named.conf from /etc/named.boot in %post
  460. - remove echo in %post
  461. * Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
  462. - merge in 5.1 mods
  463. * Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
  464. - Several essential modifications to build and install correctly.
  465. - Modified 'ndc' to avoid deprecated use of '-'
  466. * Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
  467. - Used buildroot
  468. - patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
  469. on Redhat 5.0 instead of <nlist.h>