ninja-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. Name: ninja
  2. Version: 1.7.1
  3. Release: 1%{?_dist_release}
  4. Summary: A small build system with a focus on speed
  5. Summary(ja): スピードを重視した小さなビルドシステム
  6. License: ASL 2.0
  7. URL: http://martine.github.com/ninja/
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Source0: https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
  11. Source1: ninja.vim
  12. BuildRequires: asciidoc
  13. BuildRequires: gtest-devel
  14. BuildRequires: python-devel
  15. BuildRequires: re2c >= 0.11.3
  16. %description
  17. Ninja is a small build system with a focus on speed. It differs from other
  18. build systems in two major respects: it is designed to have its input files
  19. generated by a higher-level build system, and it is designed to run builds as
  20. fast as possible.
  21. %prep
  22. %setup -qn ninja-%{version}
  23. %build
  24. CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
  25. %{__python} configure.py --bootstrap --verbose
  26. ./ninja -v manual
  27. ./ninja -v ninja_test
  28. %install
  29. # TODO: Install ninja_syntax.py?
  30. mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
  31. install -pm755 ninja %{buildroot}%{_bindir}/ninja
  32. ln -sf ninja %{buildroot}%{_bindir}/ninja-build
  33. install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
  34. install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
  35. install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
  36. install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  37. install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
  38. %check
  39. # workaround possible too low default limits
  40. ulimit -n 4096 && ulimit -u 4096
  41. ./ninja_test
  42. %files
  43. %doc COPYING HACKING.md README doc/manual.html
  44. %{_bindir}/ninja
  45. %{_bindir}/ninja-build
  46. %{_datadir}/bash-completion/completions/ninja-bash-completion
  47. %{_datadir}/emacs/site-lisp/ninja-mode.el
  48. %{_datadir}/vim/vimfiles/syntax/ninja.vim
  49. %{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  50. # zsh does not have a -filesystem package
  51. %{_datadir}/zsh/
  52. %changelog
  53. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  54. - updated to 1.7.1.
  55. * Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
  56. - update to 1.6.0
  57. - remove R: vim, emacsen
  58. (TODO: vim or el should be splitted to subpackage)
  59. - add ninja-build symlink to compatible with other rpm distros.
  60. * Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  61. - initial build for Vine Linux
  62. * Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
  63. - Update to 1.4.0
  64. * Sun Nov 3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
  65. - Use special %%doc to install all docs (#994005).
  66. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  68. * Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
  69. - workaround possible too low limits for number of processes and open files,
  70. fixes build on ppc/ppc64 and s390(x)
  71. * Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
  72. - Update to 1.3.4
  73. - Run test suite
  74. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  76. * Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
  77. - Update to 1.0.0
  78. * Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
  79. - Update to new snapshot
  80. * Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
  81. - Preserve timestamps on install
  82. - Install as ninja-build to avoid conflicts with the ninja IRC package
  83. - Update snapshot
  84. * Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
  85. - Add an ftdetect file for ninja
  86. - Fix zsh-stuff directory ownership
  87. * Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
  88. - Add a Group tag
  89. * Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
  90. - Update to new snapshot
  91. * Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
  92. - Initial package