libldb-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define talloc_version 2.1.0
  2. %define tdb_version 1.2.12
  3. %define tevent_version 0.9.19
  4. Name: libldb
  5. Version: 1.1.16
  6. Release: 1%{?_dist_release}
  7. Group: Development/Libraries
  8. Summary: A schema-less, ldap like, API and database
  9. Requires: libtalloc >= %{talloc_version}
  10. Requires: libtdb >= %{tdb_version}
  11. Requires: libtevent >= %{tevent_version}
  12. License: LGPLv3+
  13. URL: http://ldb.samba.org/
  14. Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
  15. BuildRequires: libtalloc-devel >= %{talloc_version}
  16. BuildRequires: libtdb-devel >= %{tdb_version}
  17. BuildRequires: libtevent-devel >= %{tevent_version}
  18. BuildRequires: popt-devel
  19. BuildRequires: autoconf
  20. BuildRequires: libxslt
  21. BuildRequires: docbook-style-xsl
  22. BuildRequires: python-devel
  23. BuildRequires: python-tdb
  24. BuildRequires: pytalloc-devel
  25. BuildRequires: python-tevent
  26. BuildRequires: doxygen
  27. Provides: bundled(libreplace)
  28. Provides: bundled(libtdb_compat)
  29. Provides: bundled(libccan)
  30. # Patches
  31. Patch1001: FED01-fix-tevent-check.patch
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: tomop
  35. %description
  36. An extensible library that implements an LDAP like API to access remote LDAP
  37. servers, or use local tdb databases.
  38. %package -n ldb-tools
  39. Group: Development/Libraries
  40. Summary: Tools to manage LDB files
  41. Requires: libldb = %{version}-%{release}
  42. %description -n ldb-tools
  43. Tools to manage LDB files
  44. %package devel
  45. Group: Development/Libraries
  46. Summary: Developer tools for the LDB library
  47. Requires: libldb = %{version}-%{release}
  48. Requires: libtdb-devel >= %{tdb_version}
  49. Requires: libtalloc-devel >= %{talloc_version}
  50. Requires: libtevent-devel >= %{tevent_version}
  51. Requires: pkgconfig
  52. %description devel
  53. Header files needed to develop programs that link against the LDB library.
  54. %package -n pyldb
  55. Group: Development/Libraries
  56. Summary: Python bindings for the LDB library
  57. Requires: libldb = %{version}-%{release}
  58. Requires: python-tdb >= %{tdb_version}
  59. %description -n pyldb
  60. Python bindings for the LDB library
  61. %package -n pyldb-devel
  62. Group: Development/Libraries
  63. Summary: Development files for the Python bindings for the LDB library
  64. Requires: pyldb = %{version}-%{release}
  65. %description -n pyldb-devel
  66. Development files for the Python bindings for the LDB library
  67. %prep
  68. %setup -q -n ldb-%{version}
  69. %patch1001 -p1
  70. %build
  71. # tdb_compat and ccan have no upstream releases to link against yet and their
  72. # API is in flux. It is unsafe to make them public and shared at this time.
  73. %configure --disable-rpath \
  74. --disable-rpath-install \
  75. --bundled-libraries=NONE \
  76. --builtin-libraries=tdb_compat,ccan,replace \
  77. --with-modulesdir=%{_libdir}/ldb/modules \
  78. --with-privatelibdir=%{_libdir}/ldb
  79. make V=1 %{?_smp_mflags}
  80. doxygen Doxyfile
  81. %install
  82. make install DESTDIR=%{buildroot}
  83. rm -f %{buildroot}%{_libdir}/libldb.a
  84. # Remove _tevent.so (it's managed by python-tevent)
  85. #rm -f %{buildroot}/%{python_sitearch}/_tevent.so
  86. # Shared libraries need to be marked executable for
  87. # rpmbuild to strip them and include them in debuginfo
  88. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  89. # Install API docs
  90. cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
  91. %clean
  92. rm -rf %{buildroot}
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files
  96. %defattr(-,root,root,-)
  97. %dir %{_libdir}/ldb
  98. %{_libdir}/libldb.so.*
  99. %dir %{_libdir}/ldb/modules
  100. %dir %{_libdir}/ldb/modules/ldb
  101. %{_libdir}/ldb/libldb-cmdline.so
  102. %{_libdir}/ldb/modules/ldb/*.so
  103. %files -n ldb-tools
  104. %defattr(-,root,root,-)
  105. %{_bindir}/ldbadd
  106. %{_bindir}/ldbdel
  107. %{_bindir}/ldbedit
  108. %{_bindir}/ldbmodify
  109. %{_bindir}/ldbrename
  110. %{_bindir}/ldbsearch
  111. %{_mandir}/man1/ldbadd.1.*
  112. %{_mandir}/man1/ldbdel.1.*
  113. %{_mandir}/man1/ldbedit.1.*
  114. %{_mandir}/man1/ldbmodify.1.*
  115. %{_mandir}/man1/ldbrename.1.*
  116. %{_mandir}/man1/ldbsearch.1.*
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_includedir}/ldb_module.h
  120. %{_includedir}/ldb_handlers.h
  121. %{_includedir}/ldb_errors.h
  122. %{_includedir}/ldb_version.h
  123. %{_includedir}/ldb.h
  124. %{_libdir}/libldb.so
  125. %{_libdir}/pkgconfig/ldb.pc
  126. %{_mandir}/man3/ldb*.gz
  127. %files -n pyldb
  128. %defattr(-,root,root,-)
  129. %{python_sitearch}/ldb.so
  130. %{_libdir}/libpyldb-util.so.1*
  131. %files -n pyldb-devel
  132. %defattr(-,root,root,-)
  133. %{_includedir}/pyldb.h
  134. %{_libdir}/libpyldb-util.so
  135. %{_libdir}/pkgconfig/pyldb-util.pc
  136. %{_mandir}/man*/Py*.gz
  137. %post -n pyldb
  138. /sbin/ldconfig
  139. %postun -n pyldb
  140. /sbin/ldconfig
  141. %changelog
  142. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
  143. - new upstream release.
  144. * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
  145. - new upstream release.
  146. * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
  147. - moved libldb-cmdline.so to main package.
  148. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
  149. - fixed dependency.
  150. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
  151. - new upstream release.
  152. - initial build for Vine Linux.
  153. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  155. * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
  156. - New upstream release
  157. - Add ldb_module_error() routine
  158. - Fedora: work around unreliable configure check for pytevent
  159. - Drop patch to ignore --disable-silent-rules (included in tarball)
  160. * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
  161. - Add patch to ignore --disable-silent-rules
  162. * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
  163. - Add explicit mention of the bundled libreplace
  164. - https://fedorahosted.org/fpc/ticket/120
  165. - Add explicit mention of bundled libtdb_compat and libccan
  166. - https://fedorahosted.org/fpc/ticket/119
  167. * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
  168. - Build and install API documentation
  169. - Build tdb_compat and ccan statically. They have no upstream releases to
  170. link against yet and their API is in flux. It is unsafe to make them
  171. public and shared at this time.
  172. * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
  173. - New upstream release
  174. - Required for building newer samba4 packages
  175. * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
  176. - Update to 1.1.0
  177. (dependency for samba4 alpha16 snapshot)
  178. * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
  179. - Update to 1.0.2
  180. (dependency for samba4 alpha15 snapshot)
  181. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
  182. - Disable rpath
  183. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
  184. - New upstream release 1.0.0
  185. - SOname bump to account for module loading changes
  186. - Rename libldb-tools to ldb-tools to make upgrades easier
  187. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  189. * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
  190. - Fixes from package review
  191. - Change Requires: on tools subpackage to be the exact version/release
  192. - Remove unnecessary BuildRoot directive
  193. * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
  194. - Update to 0.9.22 (first independent release of libldb upstream)