texlive-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. # * texmf/web2c/texmf.cnf
  4. # use BUILD
  5. # * texmf/xdvi
  6. # use BUILD
  7. # * depend libX*
  8. # inimf
  9. # mf
  10. # pdfclose
  11. # pdfopen
  12. # pxdvi-motif
  13. # xdvi-motif
  14. %global _use_internal_dependency_generator 0
  15. %global __find_provides %{SOURCE99}
  16. %global __find_requires %{nil}
  17. %global texlivesrcver 20130823
  18. Summary: The TeX text formatting system
  19. Summary(ja): TeX 文書整形システム
  20. Name: texlive
  21. Version: 2013
  22. Release: 1%{?_dist_release}
  23. License: distributable
  24. Group: Applications/Publishing
  25. URL: http://www.tug.org/texlive/
  26. ## original TeX Live source
  27. #Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  28. ## snapshot
  29. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  30. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  31. Source: %{name}-source-%{texlivesrcver}.tar.xz
  32. ## tlptexlive: pmetapost
  33. Source1: http://www.preining.info/software/build-tlptexlive-20130815.zip
  34. Source2: http://www.tug.org/texlive/updmap-kanji.html
  35. ## our updmap{,-hdr}.cfg from collection-basic 20130823
  36. # NOTE:
  37. # * texmf.cnf: we use the conf file texmf.cnf generated from Source0
  38. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  39. Source7: updmap.cfg.texlive-%{texlivesrcver}
  40. ## desktop files
  41. # Source10: pxdvi.desktop
  42. Source11: texdoctk.desktop
  43. # ## pxdvi from tlptexlive 2012
  44. # Source50: texlive-source-xdvik-20130106.tar.xz
  45. # Source51: http://www.preining.info/software/build-tlptexlive-20130106.zip
  46. ## find library sonames for libkpathsea and libptexenc
  47. Source99: find-provides-texlive.sh
  48. ## etc...
  49. #Source100: texlive.cron
  50. ######
  51. # TeX patches
  52. ######
  53. ## vine
  54. Patch0: reautoconf-parallel.diff
  55. Patch1: texlive-%{texlivesrcver}-vine.patch
  56. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  57. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  58. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  59. ## security
  60. Requires: coreutils
  61. Requires: ed mktemp
  62. Requires: tmpwatch
  63. Requires: zlib
  64. Requires: libpng
  65. Requires: gd
  66. Requires: ncurses
  67. Requires: libjpeg
  68. Requires: t1lib
  69. Requires: freetype2
  70. Requires: openMotif
  71. Requires: poppler >= 0.20
  72. Requires: openssl
  73. Requires: libpaper
  74. Requires: fontconfig
  75. Requires: perl-Tk perl-Tk-TableMatrix
  76. Requires: nkf
  77. Requires: ghostscript >= 8.71
  78. Requires: libkpathsea = %{version}-%{release}
  79. Requires: libptexenc = %{version}-%{release}
  80. Requires: fontconfig >= 2.6.0-2
  81. Requires(post,postun): fontconfig >= 2.6.0-2
  82. Requires(post): ed mktemp
  83. Requires(post): vutils >= 7.1
  84. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  85. BuildRequires: xz
  86. BuildRequires: unzip
  87. BuildRequires: bison flex
  88. BuildRequires: bzip2-devel
  89. BuildRequires: zlib-devel
  90. BuildRequires: libpng-devel
  91. BuildRequires: gd-devel
  92. BuildRequires: ncurses-devel
  93. BuildRequires: libjpeg-devel
  94. BuildRequires: t1lib-devel
  95. BuildRequires: XOrg-devel
  96. BuildRequires: freetype2-devel >= 2.1.10
  97. BuildRequires: autoconf >= 2.68
  98. BuildRequires: openMotif-devel
  99. BuildRequires: poppler-devel >= 0.20
  100. BuildRequires: openssl-devel
  101. BuildRequires: libpaper-devel
  102. BuildRequires: fontconfig-devel
  103. BuildRequires: nkf
  104. BuildRequires: texlive-vtlpkg = %{version}
  105. Buildroot: %{_tmppath}/%{name}-%{version}-root
  106. Vendor: Project Vine
  107. Distribution: Vine Linux
  108. Packager: munepi
  109. %description
  110. The TeX Live software distribution offers a complete TeX system for a
  111. variety of Unix, Macintosh, Windows and other platforms. It
  112. encompasses programs for editing, typesetting, previewing and printing
  113. of TeX documents in many different languages, and a large collection
  114. of TeX macros and font libraries.
  115. The distribution includes extensive general documentation about TeX,
  116. as well as the documentation for the included software packages.
  117. %description -l ja
  118. TeX Live ソフトウェアディストリビューションは、
  119. さまざまな Unix, Macintosh, Windows、および
  120. 他のプラットホームに対して完全な TeX システムを提供します。
  121. 多くの異なった言語を含む TeX ドキュメントの
  122. 編集、組版、閲覧、印刷するためのプログラム、
  123. そして、TeX マクロやフォントライブラリの大きなコレクションを
  124. 同梱しています。
  125. このディストリビューションは
  126. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  127. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  128. %package doc
  129. Summary: TeX Live: Documentation files of %{name}
  130. Group: Applications/Publishing
  131. Requires: %{name} = %{version}-%{release}
  132. BuildArch: noarch
  133. %description doc
  134. This package contains documentation files of %{name}.
  135. %package -n libkpathsea
  136. Summary: path search library for the TeX Live
  137. Summary(ja): TeX Live 用パス検索ライブラリ
  138. Group: System Environment/Libraries
  139. %description -n libkpathsea
  140. This package includes runtime part of the Kpathsea library.
  141. %package -n libkpathsea-devel
  142. Summary: path search libary and header files for the TeX Live
  143. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  144. Group: Development/Libraries
  145. Requires: libkpathsea = %{version}-%{release}
  146. %description -n libkpathsea-devel
  147. This package includes static library and header files of the Kpathsea library.
  148. %package -n libptexenc
  149. Summary: Kanji code convert library for Japanese pTeX
  150. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  151. Group: System Environment/Libraries
  152. Requires: libkpathsea = %{version}-%{release}
  153. %description -n libptexenc
  154. This package includes runtime part of the ptexenc library.
  155. %package -n libptexenc-devel
  156. Summary: Kanji code convert library and header files for Japanese pTeX
  157. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  158. Group: Development/Libraries
  159. Requires: libptexenc = %{version}-%{release}
  160. %description -n libptexenc-devel
  161. This package includes header files of the ptexenc library.
  162. %prep
  163. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  164. #%setup -q -n %{name}-%{texlivesrcver}-source
  165. %setup -q -n %{name}-source-%{texlivesrcver} -a 1
  166. %patch0 -p0 -b .parallel
  167. %patch1 -p1 -b .vine
  168. %patch2 -p1 -b .vine
  169. %patch3 -p1 -b .vine
  170. ## Applying tlptexlive that provides pxdvi(k) and pmpost
  171. echo "applying patches"
  172. cat "$(pwd)/build-tlptexlive-20130815/patches/series" | while read p r ; do
  173. echo $p | grep '^#' >/dev/null || \
  174. patch -p1 $r < "$(pwd)/build-tlptexlive-20130815/patches/$p" || exit 1
  175. done
  176. # ## pxdvi from tlptexlive 2012
  177. # echo "creating pxdvi folder"
  178. # [ -d texk/pxdvik ] && exit 1
  179. # %__cp -pR texlive-source-20130106/texk/xdvik texk/pxdvik
  180. # echo "applying patches"
  181. # cat "$(pwd)/build-tlptexlive-20130106/patches/series" | \
  182. # grep -v -e freetype-modules -e pmpost -e reautoconf | while read p r ; do
  183. # echo $p | grep '^#' >/dev/null || \
  184. # patch -p1 $r < "$(pwd)/build-tlptexlive-20130106/patches/$p" || exit 1
  185. # done
  186. #
  187. # # customize pxdvik for Vine Linux
  188. # %patch10 -p1 -b .vine
  189. ## Avoid pollution from internal libraries.
  190. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
  191. # ./reautoconf || exit 1
  192. %build
  193. set -x
  194. unset TEXINPUTS || :
  195. unset HOME || :
  196. export CFLAGS="$RPM_OPT_FLAGS" \
  197. CXXFLAGS="$RPM_OPT_FLAGS" \
  198. LANG=C
  199. PREFIX=$(pwd)/work
  200. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  201. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  202. TL_CONFIGURE_ARGS=" \
  203. --disable-multiplatform \
  204. --disable-native-texlive-build \
  205. --with-banner-add=\"/Vine Linux\" \
  206. --enable-shared --disable-static \
  207. --enable-compiler-warnings=max \
  208. --without-cxx-runtime-hack \
  209. \
  210. --enable-web2c \
  211. --enable-web-progs --enable-dvipdfmx --enable-mendexk \
  212. --enable-makejvf --enable-pxdvik --enable-dvipsk \
  213. --enable-tetex --enable-texlive \
  214. \
  215. --with-system-xpdf \
  216. --with-system-gd \
  217. --with-system-t1lib \
  218. --with-system-libpng \
  219. --with-system-zlib \
  220. --with-system-freetype2 \
  221. --with-system-pixman \
  222. --with-system-poppler \
  223. --with-system-cairo \
  224. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  225. --with-pic \
  226. \
  227. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  228. --disable-dvi2tty \
  229. --disable-t1utils --disable-psutils --disable-detex \
  230. --disable-dvipng --disable-lcdf-typetools \
  231. "
  232. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  233. TL_MAKE=%__make ./Build || exit 1
  234. %install
  235. ## prepare %%install session
  236. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  237. ## copy inst directory to /usr
  238. %__mkdir_p %{buildroot}
  239. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  240. %ifarch x86_64
  241. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  242. %endif
  243. ## make some fundamental texmf trees
  244. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  245. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  246. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  247. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  248. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  249. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  250. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  251. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  252. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  253. The directory %{_tl_texmfdist} is the TeX Live distribution wide TEXMF.
  254. You should not do any changes in this directory.
  255. EOF
  256. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  257. The directory %{_tl_texmfdist} is the distribution wide TEXMF.
  258. You should not use this directory to manage any other packages because
  259. we Project Vine use this directory to manage non-CTAN packages and
  260. enhancement packages.
  261. EOF
  262. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  263. The directory %{_tl_texmflocal} is the system wide TEXMF.
  264. If you are a privileged user of this system,
  265. you can use this directory to manage your local packages.
  266. EOF
  267. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  268. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  269. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  270. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  271. ## our map files for dvipdfmx
  272. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  273. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  274. for x in ptex uptex otf otf-up; do
  275. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  276. done
  277. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  278. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  279. done
  280. ## desktop things
  281. %__mkdir_p %{buildroot}%{_datadir}/applications
  282. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  283. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  284. # for created fonts
  285. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  286. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  287. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  288. ## set executable bit for the library
  289. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  290. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  291. # configure ConTeXt
  292. for x in context ctxtools luatools texexec texmfstart; do
  293. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  294. done
  295. # touch ghosts
  296. touch %{buildroot}%{_tl_texmfvine}/ls-R
  297. touch %{buildroot}%{_tl_texmfdist}/ls-R
  298. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  299. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  300. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  301. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  302. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  303. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  304. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  305. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  306. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  307. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  308. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  309. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  310. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  311. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  312. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  313. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  314. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  315. ## remove unpackaging files
  316. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  317. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  318. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  319. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  320. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  321. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  322. %__rm -f %{buildroot}%{_infodir}/*
  323. ## use external packages
  324. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  325. ### Files list
  326. find %{buildroot} -type f -or -type l | \
  327. %__sed -e "s|%{buildroot}||g" | \
  328. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  329. %__grep -v "%{_includedir}" | \
  330. %__grep -v "%{_libdir}" | \
  331. %__grep -v "%{_infodir}" | \
  332. %__sed -e "s|.*ls-R$|%ghost &|" \
  333. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  334. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  335. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  336. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  337. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  338. -e "s|.*\.cnf$|%config(noreplace) &|" \
  339. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  340. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  341. -e "s|^.*/updmap/$|%config &|" \
  342. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  343. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  344. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  345. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  346. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  347. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  348. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  349. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  350. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  351. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  352. -e "s|%{_mandir}/.*|&*|" \
  353. > %{_builddir}/filelist.full
  354. find %{buildroot}%{_tl_texmfvine}* -type d | \
  355. %__sed -e "s|^%{buildroot}|%dir |" \
  356. -e "s|$|/|" >> %{_builddir}/filelist.full
  357. ## subpackages
  358. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  359. cat %{_builddir}/filelist.doc \
  360. %{_builddir}/filelist.full | \
  361. sort | uniq -u > %{_builddir}/filelist.tmp
  362. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  363. %clean
  364. %__rm -rf %{buildroot}
  365. %pretrans
  366. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012
  367. [ $? -eq 1 ] && exit 0
  368. _trans_time=$(date +%Y%m%d)
  369. echo "Running some transitional processes on your TeX system ... "
  370. x=(
  371. #/var/lib/texmf
  372. #/etc/texmf
  373. /usr/share/texmf-local
  374. /usr/share/texmf-var
  375. /usr/share/texmf-config
  376. )
  377. for dir in ${x[@]}; do
  378. _trans_dir=${dir}.${_trans_time}.rpmorig
  379. [ -d ${_trans_dir}.old ] && \
  380. echo -n " " && \
  381. echo "Found ${_trans_dir}.old: " && \
  382. echo -n " " && \
  383. %__rm -rvf ${_trans_dir}.old
  384. [ -d ${_trans_dir} ] && \
  385. echo -n " " && \
  386. echo "Found ${_trans_dir}: " && \
  387. echo -n " " && \
  388. %__mv -v ${_trans_dir} ${_trans_dir}.old
  389. [ -d ${dir} ] && \
  390. echo -n " " && \
  391. echo "Found ${dir}: " && \
  392. echo -n " " && \
  393. %__mv -v ${dir} ${_trans_dir}
  394. done
  395. echo "done."
  396. %postun
  397. if [ "$1" = 0 ]; then
  398. %__rm -rf %{_tl_vartexfonts}
  399. fi
  400. exit 0
  401. %post
  402. %_tl_touch_run texhash
  403. %_tl_touch_run updmap
  404. %_tl_touch_run mtxrun
  405. %_tl_touch_run fmtutil
  406. exit 0
  407. %posttrans
  408. %__mkdir_p %{_tl_vartexfonts}
  409. %__chmod 1777 %{_tl_vartexfonts}
  410. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  411. ( %{_tl_exec_upddeffont} ) ||:
  412. %{_tl_exec_texhash}
  413. %{_tl_exec_mtxrun}
  414. %{_tl_exec_updmap}
  415. %{_tl_exec_fmtutil}
  416. exit 0
  417. %post -n libkpathsea
  418. /sbin/ldconfig
  419. # for x in kpathsea tds web2c; do
  420. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  421. # done
  422. # %preun -n libkpathsea
  423. # if [ "$1" = 0 ]; then
  424. # for x in kpathsea tds web2c; do
  425. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  426. # done
  427. # fi
  428. %postun -n libkpathsea
  429. /sbin/ldconfig
  430. %post -n libptexenc
  431. /sbin/ldconfig
  432. %postun -n libptexenc
  433. /sbin/ldconfig
  434. %triggerin -- ghostscript
  435. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  436. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  437. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  438. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  439. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  440. fi
  441. %_tl_touch_run texhash
  442. exit 0
  443. %files -f %{_builddir}/filelist.full
  444. %defattr(-,root,root)
  445. %dir %{_tl_aliasttfdir}
  446. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  447. # %config %{_sysconfdir}/cron.daily/texlive.cron
  448. %files doc -f %{_builddir}/filelist.doc
  449. %defattr(-,root,root)
  450. %files -n libkpathsea
  451. %defattr(-,root,root)
  452. %{_libdir}/libkpathsea.so.*
  453. # %{_infodir}/kpathsea.info*
  454. %files -n libkpathsea-devel
  455. %defattr(-,root,root)
  456. %{_libdir}/libkpathsea.so
  457. %dir %{_includedir}/kpathsea
  458. %{_includedir}/kpathsea/*
  459. %files -n libptexenc
  460. %defattr(-,root,root)
  461. %{_libdir}/libptexenc.so.*
  462. %files -n libptexenc-devel
  463. %defattr(-,root,root)
  464. %{_libdir}/libptexenc.so
  465. %dir %{_includedir}/ptexenc
  466. %{_includedir}/ptexenc/*
  467. %changelog
  468. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  469. - upgrade to TeX Live 2013
  470. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  471. - dropped Requires: jvf
  472. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  473. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  474. - fixed duplicated lw35 for updmap.pl
  475. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  476. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  477. - touch the map files generated by updmap-sys
  478. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  479. - fixed Source7: updmap.cfg.texlive-20120701
  480. (upto /etc/texmf/web2c/updmap.cfg)
  481. - fixex %%triggerin -- ghostscript
  482. - replaced %%exec_texhash with %%touch_run texhash
  483. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  484. - TeX Live 2012 + tlptexlive 20121107
  485. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  486. - drop BR: poppler-devel temporaly
  487. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  488. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  489. - build with poppler-0.18.4
  490. - remove tlmgr
  491. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  492. - updated to tl11supp-120120
  493. - run %%{exec_fmtutil} at %%post when upgrading
  494. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  495. - updated to tl11supp-111214
  496. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  497. - added BuildRequires: texlive-common
  498. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  499. - check japanese.ldf
  500. - updated tl11supp-111120-vine.patch
  501. - added the following options to $$TL_CONFIGURE_ARGS:
  502. --disable-detex
  503. --disable-dvipng
  504. --disable-lcdf-typetools
  505. - remove some files of asymptote
  506. - remove a man file of latexmk
  507. - remove man files of lcdf-typetools
  508. - remove man files of dvipng
  509. - remove a man file of detex
  510. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  511. - added find-provides-texlive.sh and set it to %%__find_provides
  512. - use to find library sonames for libkpathsea and libptexenc
  513. - added cmex.enc (%%{SOURCE110})
  514. - do not install cmex.enc in our TDS, yet
  515. - removed some unused directories in texmf/fonts/map
  516. - removed man files of lcdf-typetools
  517. - moved texdoc{,tk} and its related files to texlive-doc
  518. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  519. - TeX Live 2011 + tl11supp-111120
  520. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  521. - make the directory VARTEXFONTS (%%posttrans)
  522. - dropped %%triggerpostun -- texlive < 2009-17vl6
  523. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  524. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  525. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  526. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  527. - added %%pre to avoid conflictions of texmf-{config,var}
  528. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  529. - dropped Requires: texlive-common
  530. - added perl-Tk-TableMatrix
  531. - supported texdoctk
  532. - removed broken symbolic links in /usr/bin
  533. - for each these symbolic links, the package of its real file/path
  534. should be its owner.
  535. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  536. - added %%triggerpostun -- texlive < 2009-17vl6
  537. - make the directory VARTEXFONTS
  538. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  539. - fixed %%dir VARTEXFONTS around in %%files
  540. - dropped BuildRequires: t1utils
  541. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  542. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  543. - changed VARTEXFONTS to /var/lib/texmf/fonts
  544. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  545. - fixed updmap.cfg
  546. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  547. - dropped Requires: texlive-macros
  548. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  549. - updated ptexlive-20100711-pxdvik-vine.patch
  550. and added texlive-20091107-xdvik-vine.patch
  551. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  552. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  553. - supported Vine Linux 5
  554. - for vl5, changed a requirement of Japanese VF package
  555. - added Requires: texlive-jvf = 2009 (vl5)
  556. - dropped dependencies of Provides:/Obsoletes: tags
  557. - merged these dependencies in texlive-common-vl.spec
  558. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  559. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  560. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  561. - applied some security patches from Debian
  562. - texlive-2009-CVE-2010-0827.patch
  563. - texlive-2009-CVE-2010-1440.patch
  564. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  565. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  566. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  567. - fixed some dependencies
  568. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  569. - added BuildArch: noarch in %%package doc
  570. - removed some comment-out sentences
  571. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  572. - separeted texmf-dist to texlive-common package
  573. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  574. - unpacked texlive-20091107-source.tar.xz
  575. - babel is available now
  576. - applied eptex-100420 and some patches:
  577. - eptex-100420-vine.patch
  578. - eptex-100420-patch1.diff
  579. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  580. - updated ptexlive-20100711
  581. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  582. - customized updmap.cfg to correspond installed fonts
  583. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  584. - fixed insttexfont()
  585. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  586. - added jvf of MORISAWA basic 5 fonts
  587. - added cm-super, mathdesign in fntlst
  588. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  589. - define insttexfont() in %%install
  590. - copy almost compatible tetex-3.0
  591. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  592. - ptexlive-20090322 + TeXLive 2009
  593. - added BuildRequires: openssl-devel
  594. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  595. - ptexlive-20091009 + TeXLive 2008