at-spi2-core-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318
  1. %bcond_with firstbuild
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. # Meson settings
  5. %global _vpath_srcdir .
  6. %global _vpath_builddir %{_target_platform}
  7. %global __global_cflags %{optflags}
  8. %global __global_cxxflags %{optflags}
  9. %global __global_fflags %{optflags} -I%_fmoddir
  10. %global __global_fcflags %{optflags} -I%_fmoddir
  11. %global __global_ldflags -Wl,-z,relro %{_hardened_ldflags}
  12. %global _hardened_ldflags ""
  13. %global __meson_wrap_mode default
  14. Name: at-spi2-core
  15. Version: 2.27.1
  16. Release: 1%{?_dist_release}
  17. Summary: Protocol definitions and daemon for D-Bus at-spi
  18. Group: System Environment/Libraries
  19. License: LGPLv2+
  20. URL: http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
  21. Source0: http://download.gnome.org/sources/at-spi2-core/2.27/%{name}-%{version}.tar.xz
  22. BuildRequires: meson
  23. BuildRequires: dbus-devel
  24. BuildRequires: dbus-glib-devel
  25. BuildRequires: glib2-devel
  26. %{!?with_firstbuild:BuildRequires: gobject-introspection-devel}
  27. BuildRequires: libXtst-devel
  28. BuildRequires: libXevie-devel
  29. BuildRequires: libXext-devel
  30. BuildRequires: libXi-devel
  31. BuildRequires: libSM-devel
  32. BuildRequires: autoconf automake libtool
  33. BuildRequires: intltool
  34. BuildRequires: gtk-doc
  35. %{!?with_firstbuild:BuildRequires: at-spi2-core-devel}
  36. Requires: dbus
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. Packager: Takemikaduchi
  40. %description
  41. at-spi allows assistive technologies to access GTK-based
  42. applications. Essentially it exposes the internals of applications for
  43. automation, so tools such as screen readers, magnifiers, or even
  44. scripting interfaces can query and interact with GUI controls.
  45. This version of at-spi is a major break from previous versions.
  46. It has been completely rewritten to use D-Bus rather than
  47. ORBIT / CORBA for its transport protocol.
  48. %package devel
  49. Summary: Development files and headers for at-spi2-core
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description devel
  53. The at-spi2-core-devel package includes the header files and
  54. API documentation for libatspi.
  55. # compat32
  56. %package -n compat32-%{name}
  57. Summary: Protocol definitions and daemon for D-Bus at-spi
  58. Group: System Environment/Libraries
  59. Requires: %{name} = %{version}-%{release}
  60. %description -n compat32-%{name}
  61. at-spi allows assistive technologies to access GTK-based
  62. applications. Essentially it exposes the internals of applications for
  63. automation, so tools such as screen readers, magnifiers, or even
  64. scripting interfaces can query and interact with GUI controls.
  65. This version of at-spi is a major break from previous versions.
  66. It has been completely rewritten to use D-Bus rather than
  67. ORBIT / CORBA for its transport protocol.
  68. %package -n compat32-%{name}-devel
  69. Summary: Development files and headers for at-spi2-core
  70. Group: Development/Libraries
  71. Requires: compat32-%{name} = %{version}-%{release}
  72. Requires: %{name}-devel = %{version}-%{release}
  73. %description -n compat32-%{name}-devel
  74. The at-spi2-core-devel package includes the header files and
  75. API documentation for libatspi.
  76. %prep
  77. %setup -q
  78. %meson -Denable_docs=true
  79. %meson_build
  80. %install
  81. %meson_install
  82. %{find_lang} %{name}
  83. rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %post -n compat32-%{name} -p /sbin/ldconfig
  87. %postun -n compat32-%{name} -p /sbin/ldconfig
  88. %files -f %{name}.lang
  89. %doc COPYING AUTHORS README
  90. %{_libexecdir}/at-spi2-registryd
  91. %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
  92. %{_libdir}/libatspi.so.*
  93. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Atspi-2.0.typelib}
  94. %{_libexecdir}/at-spi-bus-launcher
  95. %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
  96. %{_datadir}/dbus-1/services/org.a11y.Bus.service
  97. %{_datadir}/defaults/at-spi2/accessibility.conf
  98. %files devel
  99. %{_libdir}/libatspi.so
  100. %{_datadir}/gtk-doc/html/libatspi
  101. %{!?with_firstbuild:%{_datadir}/gir-1.0/Atspi-2.0.gir}
  102. %{_includedir}/at-spi-2.0
  103. %{_libdir}/pkgconfig/atspi-2.pc
  104. # compat32
  105. %if %{build_compat32}
  106. %files -n compat32-%{name}
  107. %defattr(-,root,root,-)
  108. %{_libdir}/libatspi.so.*
  109. %files -n compat32-%{name}-devel
  110. %defattr(-,root,root,-)
  111. %{_libdir}/libatspi.so
  112. %endif
  113. %changelog
  114. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.27.1-1
  115. - new upstream release.
  116. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.20.2-1
  117. - new upstream release
  118. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.3-1
  119. - new upstream release
  120. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.1-1
  121. - new upstream release
  122. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-1
  123. - new upstream release
  124. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.1-1
  125. - new upstream release
  126. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.0-1
  127. - new upstream release
  128. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.0-1
  129. - new upstream release
  130. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.2-1
  131. - new upstream release
  132. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-1
  133. - new upstream release
  134. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  135. - new upstream release
  136. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  137. - new upstream release
  138. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  139. - new upstream release
  140. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  141. - new upstream release
  142. * Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-2
  143. - create compat32 sub packages
  144. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
  145. - new upstream release
  146. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-1
  147. - new upstream release
  148. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.1-1
  149. - new upstream release
  150. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.2-1
  151. - new upstream release
  152. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-1
  153. - new upstream release
  154. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
  155. - new upstream release
  156. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.92-1
  157. - initial build for Vine Linux
  158. * Tue Sep 6 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.91-1
  159. - Update to 2.1.91
  160. * Mon Jul 25 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
  161. - Update to 2.1.4
  162. * Thu Jun 16 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.2-1
  163. - Update to 2.1.2
  164. * Wed May 11 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.1-1
  165. - Update to 2.1.1
  166. * Tue Apr 26 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.1-1
  167. - Update to 2.0.1
  168. * Mon Apr 4 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
  169. - Update to 2.0.0
  170. * Fri Apr 1 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.93-2
  171. - Fix 30 second wait during login (#691995)
  172. * Fri Mar 25 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.93-1
  173. - Update to 1.91.93
  174. * Mon Mar 21 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.92-1
  175. - Update to 2.91.92
  176. * Wed Mar 9 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.91-2
  177. - Fix a crash on logout
  178. * Mon Mar 7 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.91-1
  179. - Update to 1.91.91
  180. * Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.90-1
  181. - Update to 1.91.90
  182. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.91.6.1-2
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  184. * Wed Feb 2 2011 Christopher Aillon <caillon@redhat.com> - 1.91.6.1-1
  185. - Update to 1.91.6.1
  186. * Tue Feb 1 2011 Christopher Aillon <caillon@redhat.com> - 1.91.6-1
  187. - Update to 1.91.6
  188. * Fri Jan 21 2011 Christopher Aillon <caillon@redhat.com> - 1.91.5-2
  189. - Add gobject-introspection support
  190. * Mon Jan 10 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.5-1
  191. - Update to 1.91.5
  192. * Thu Nov 11 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.2-1
  193. - Update 1.91.2
  194. * Mon Oct 4 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.0-1
  195. - Update to 1.91.0
  196. * Wed Sep 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  197. - Update to 0.4.0
  198. * Tue Aug 31 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
  199. - Update to 0.3.91
  200. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
  201. - Update to 0.3.90
  202. * Tue Jun 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  203. - Update to 0.3.4
  204. * Tue Jun 8 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
  205. - Update to 0.3.3
  206. * Tue Jun 1 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  207. - Don't relocate the dbus a11y stack
  208. * Fri May 28 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  209. - Update to 0.3.2
  210. * Sat May 15 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.1-1
  211. - Update to 0.3.1
  212. * Tue Mar 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.8-1
  213. - Update to 0.1.8
  214. * Sat Feb 20 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
  215. - Update to 0.1.7
  216. * Wed Feb 10 2010 Tomas Bzatek <tbzatek@redhat.com> - 0.1.6-1
  217. - Update to 0.1.6
  218. * Wed Jan 20 2010 Matthias Clasen <mlasen@redhat.com> - 0.1.5-2
  219. - Specify the right location for the dbus daemon
  220. * Sat Jan 16 2010 Matthias Clasen <mlasen@redhat.com> - 0.1.5-1
  221. - Update to 0.1.5
  222. * Tue Dec 22 2009 Matthias Clasen <mlasen@redhat.com> - 0.1.4-1
  223. - Update to 0.1.4
  224. * Fri Dec 4 2009 Matthias Clasen <mlasen@redhat.com> - 0.1.3-1
  225. - Initial packaging