audit-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %{!?__python3: %global __python3 /usr/bin/python3}
  4. %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print (get_python_lib())")}
  5. %{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  6. %define sca_version 0.4.10
  7. %define sca_release 4
  8. Summary: User space tools for 2.6 kernel auditing
  9. Name: audit
  10. Version: 2.7.7
  11. Release: 1%{?_dist_release}
  12. License: GPLv2+
  13. Group: System Environment/Daemons
  14. URL: http://people.redhat.com/sgrubb/audit/
  15. Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  16. #Patch10: audit-1.7.18-pthread.patch
  17. #Patch11: audit-1.7.18-krb5.patch
  18. #Patch12: audit-1.7.18-libaudit.patch
  19. Distribution: Vine Linux
  20. Vendor: Project Vine
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: gettext intltool libtool swig
  23. BuildRequires: python-devel python3-devel
  24. BuildRequires: openldap-devel
  25. BuildRequires: tcp_wrappers
  26. BuildRequires: krb5-devel
  27. BuildRequires: kernel-headers >= 2.6.18
  28. BuildRequires: libcap-ng-devel
  29. BuildRequires: automake >= 1.9
  30. BuildRequires: autoconf >= 2.59
  31. Requires: %{name}-libs = %{version}-%{release}
  32. Requires: chkconfig
  33. Requires(pre): coreutils
  34. %description
  35. The audit package contains the user space utilities for
  36. storing and searching the audit records generate by
  37. the audit subsystem in the Linux 2.6 kernel.
  38. %package libs
  39. Summary: Dynamic library for libaudit
  40. License: LGPLv2+
  41. Group: Development/Libraries
  42. %description libs
  43. The audit-libs package contains the dynamic libraries needed for
  44. applications to use the audit framework.
  45. %package libs-devel
  46. Summary: Header files and static library for libaudit
  47. License: LGPLv2+
  48. Group: Development/Libraries
  49. Requires: %{name}-libs = %{version}-%{release}
  50. Requires: kernel-headers >= 2.6.18
  51. %description libs-devel
  52. The audit-libs-devel package contains the static libraries and header
  53. files needed for developing applications that need to use the audit
  54. framework libraries.
  55. %package libs-python
  56. Summary: Python2 bindings for libaudit
  57. License: LGPLv2+
  58. Group: Development/Libraries
  59. Requires: %{name}-libs = %{version}-%{release}
  60. %description libs-python
  61. The audit-libs-python package contains the bindings so that libaudit
  62. and libauparse can be used by python2.
  63. %package libs-python3
  64. Summary: Python3 bindings for libaudit
  65. License: LGPLv2+
  66. Group: Development/Libraries
  67. Requires: %{name}-libs = %{version}-%{release}
  68. %description libs-python3
  69. The audit-libs-python3 package contains the bindings so that libaudit
  70. and libauparse can be used by python3.
  71. %package -n audispd-plugins
  72. Summary: Plugins for the audit event dispatcher
  73. License: GPLv2+
  74. Group: System Environment/Daemons
  75. Requires: %{name} = %{version}-%{release}
  76. Requires: %{name}-libs = %{version}-%{release}
  77. Requires: openldap
  78. %description -n audispd-plugins
  79. The audispd-plugins package provides plugins for the real-time
  80. interface to the audit system, audispd. These plugins can do things
  81. like relay events to remote machines or analyze events for suspicious
  82. behavior.
  83. %package -n compat32-%{name}-libs
  84. Summary: Dynamic library for libaudit
  85. License: LGPLv2+
  86. Group: Development/Libraries
  87. %description -n compat32-%{name}-libs
  88. The audit-libs package contains the dynamic libraries needed for
  89. applications to use the audit framework.
  90. %prep
  91. %setup -q
  92. #%patch10 -p1
  93. #%patch11 -p1
  94. #%patch12 -p1
  95. %build
  96. %configure --sbindir=/sbin --libdir=/%{_lib} \
  97. --with-python=yes --with-python3=yes \
  98. --with-libcap-ng=yes --with-libwrap --enable-gssapi-krb5=yes
  99. make CFLAGS="%{optflags}" %{?_smp_mflags}
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d,audit/rules.d}}
  103. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  104. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  105. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  106. mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
  107. make DESTDIR=$RPM_BUILD_ROOT install
  108. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  109. # This winds up in the wrong place when libtool is involved
  110. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  111. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  112. curdir=`pwd`
  113. cd $RPM_BUILD_ROOT/%{_libdir}
  114. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  115. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  116. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  117. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  118. cd $curdir
  119. # Remove these items so they don't get picked up.
  120. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  121. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  122. find $RPM_BUILD_ROOT -name '*.la' -delete
  123. find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
  124. # Move the pkgconfig file
  125. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  126. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  127. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  128. touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
  129. #% check
  130. #make check
  131. %clean
  132. rm -rf $RPM_BUILD_ROOT
  133. rm -rf zos-remote-policy
  134. %post libs -p /sbin/ldconfig
  135. %post
  136. /sbin/chkconfig --add auditd
  137. # This is to migrate users from audit-1.0.x installations
  138. if [ -f /etc/auditd.conf ]; then
  139. mv /etc/auditd.conf /etc/audit/auditd.conf
  140. fi
  141. if [ -f /etc/audit.rules ]; then
  142. mv /etc/audit.rules /etc/audit/audit.rules
  143. fi
  144. # This is to enable the dispatcher option which was commented out
  145. if [ -f /etc/audit/auditd.conf ]; then
  146. grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
  147. if [ $? -eq 1 ] ; then
  148. tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
  149. if [ -n $tmp ]; then
  150. sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
  151. cat $tmp > /etc/audit/auditd.conf
  152. rm -f $tmp
  153. fi
  154. fi
  155. fi
  156. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  157. %preun
  158. if [ $1 -eq 0 ]; then
  159. /sbin/service auditd stop > /dev/null 2>&1
  160. /sbin/chkconfig --del auditd
  161. fi
  162. %postun libs -p /sbin/ldconfig
  163. %postun
  164. if [ $1 -ge 1 ]; then
  165. /sbin/service auditd condrestart > /dev/null 2>&1 || :
  166. fi
  167. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  168. %files libs
  169. %defattr(-,root,root)
  170. %{!?_licensedir:%global license %%doc}
  171. %license COPYING.LIB
  172. /%{_lib}/libaudit.*
  173. /%{_lib}/libauparse.*
  174. %config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  175. %{_mandir}/man5/libaudit.conf.5.gz
  176. %files libs-devel
  177. %defattr(-,root,root)
  178. %{!?_licensedir:%global license %%doc}
  179. %license COPYING.LIB
  180. %doc contrib/skeleton.c contrib/plugin
  181. %{_libdir}/libaudit.a
  182. %{_libdir}/libauparse.a
  183. %{_libdir}/libaudit.so
  184. %{_libdir}/libauparse.so
  185. %{_includedir}/libaudit.h
  186. %{_includedir}/auparse.h
  187. %{_includedir}/auparse-defs.h
  188. %{_datadir}/aclocal/audit.m4
  189. %{_libdir}/pkgconfig/audit.pc
  190. %{_libdir}/pkgconfig/auparse.pc
  191. %{_mandir}/man3/*
  192. %files libs-python
  193. %defattr(-,root,root)
  194. %attr(755,root,root) %{python_sitearch}/_audit.so
  195. %attr(755,root,root) %{python_sitearch}/auparse.so
  196. %{python_sitearch}/audit.py*
  197. %files libs-python3
  198. %defattr(-,root,root,-)
  199. %attr(755,root,root) %{python3_sitearch}/*
  200. %files
  201. %defattr(-,root,root,-)
  202. %doc README ChangeLog rules init.d/auditd.cron
  203. %{!?_licensedir:%global license %%doc}
  204. %license COPYING
  205. %attr(644,root,root) %{_mandir}/man8/audispd.8.gz
  206. %attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
  207. %attr(644,root,root) %{_mandir}/man8/auditd.8.gz
  208. %attr(644,root,root) %{_mandir}/man8/aureport.8.gz
  209. %attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
  210. %attr(644,root,root) %{_mandir}/man8/autrace.8.gz
  211. %attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
  212. %attr(644,root,root) %{_mandir}/man8/aulast.8.gz
  213. %attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
  214. %attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
  215. %attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
  216. %attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
  217. %attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
  218. %attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
  219. %attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
  220. %attr(750,root,root) /sbin/auditctl
  221. %attr(750,root,root) /sbin/auditd
  222. %attr(755,root,root) /sbin/ausearch
  223. %attr(755,root,root) /sbin/aureport
  224. %attr(750,root,root) /sbin/autrace
  225. %attr(750,root,root) /sbin/audispd
  226. %attr(750,root,root) /sbin/augenrules
  227. %attr(750,root,root) %{_bindir}/aulastlog
  228. %attr(750,root,root) %{_bindir}/aulast
  229. %attr(755,root,root) %{_bindir}/ausyscall
  230. %attr(755,root,root) %{_bindir}/auvirt
  231. %attr(755,root,root) /etc/rc.d/init.d/auditd
  232. %attr(750,root,root) %dir %{_var}/log/audit
  233. %attr(750,root,root) %dir /etc/audit
  234. %attr(750,root,root) %dir /etc/audit/rules.d
  235. %attr(750,root,root) %dir /etc/audisp
  236. %attr(750,root,root) %dir /etc/audisp/plugins.d
  237. %config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
  238. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
  239. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  240. %config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
  241. %config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
  242. %config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
  243. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
  244. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
  245. %files -n audispd-plugins
  246. %defattr(-,root,root,-)
  247. %attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
  248. %attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
  249. %attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
  250. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
  251. %config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
  252. %attr(750,root,root) /sbin/audispd-zos-remote
  253. %config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
  254. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
  255. %attr(750,root,root) /sbin/audisp-remote
  256. %attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
  257. %attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
  258. %if %{build_compat32}
  259. %files -n compat32-%{name}-libs
  260. %{!?_licensedir:%global license %%doc}
  261. %license COPYING.LIB
  262. %defattr(-,root,root)
  263. %attr(755,root,root) /%{_lib}/libaudit.*
  264. %attr(755,root,root) /%{_lib}/libauparse.*
  265. %endif
  266. %changelog
  267. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
  268. - new upstream release.
  269. - dropped all patches.
  270. - dropped system-config-audit.
  271. - added python3 bindings.
  272. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
  273. - fix sca_release
  274. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
  275. - create compat32-audit-libs subpackage
  276. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
  277. - rebuild with python-2.7.2
  278. - add Patch12 (audit-1.7.18-libaudit.patch)
  279. * Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
  280. - new upstream release
  281. - rebuild with krb5-1.8.2
  282. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  283. - forgot to increment sca_release macro (why on earth is sca_release
  284. individually defined from main package's release number anyway?)
  285. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  286. - rebuilt with gcc-4.4.3-3 on ppc
  287. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  288. - rebuilt with rpm-4.8.0-3 (on ppc)
  289. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  290. - rebuild with python-2.6
  291. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  292. - rebuild with openldap-2.4.11
  293. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  294. - initial build for Vine Linux
  295. - disable krb5, prelude and selinux
  296. - add ja.po (XXX: minimal)
  297. * Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  298. - Add subject to audit daemon events (Chu Li)
  299. - Add tcp_wrappers support for auditd
  300. - Updated syscall tables for 2.6.27 kernel
  301. - Audit connect/disconnect of remote clients
  302. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  303. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  304. - Update system-config-audit to 0.4.8
  305. - Whole lot of bug fixes - see ChangeLog for details
  306. - Reimplement auditd main loop using libev
  307. - Add TCP listener to auditd to receive remote events
  308. - Fix scheduler problem (#457061)
  309. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  310. - Move ausearch-expression to main package (#453437)
  311. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  312. - Fix interpreting of keys in syscall records
  313. - Don't error on name=(null) PATH records in ausearch/report
  314. - Add key report to aureport
  315. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  316. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  317. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  318. - Fix output of keys in ausearch interpretted mode
  319. - Fix ausearch/report --start now to not be reset to midnight
  320. - audispd now has a priority boost config option
  321. - Look for laddr in avcs reported via prelude
  322. - Detect page 0 mmaps and alert via prelude
  323. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  324. - Fix overflow in audit_log_user_command, better (#438840)
  325. - ausearch was not matching path in avc records
  326. - audisp-prelude attempt to reposition index after examining each type
  327. - correct building of mls policy
  328. - Fix auparse iterating in auparse_find_field and next_field
  329. - Don't alert on USER_AVC's - they are not quite right
  330. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  331. - Fix buffer overflow in audit_log_user_command, again (#438840)
  332. - Fix memory leak in EOE code in auditd (#440075)
  333. - In auditctl, don't use new operators in legacy rule format
  334. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  335. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  336. - Fix memleak in auditd eoe code
  337. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  338. - Remove LSB headers from init scripts
  339. - Fix buffer overflow in audit_log_user_command again
  340. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  341. - Handle user space avcs in prelude plugin
  342. - Fix watched account login detection for some failed login attempts
  343. - Couple fixups in audit logging functions (Miloslav Trmac)
  344. - Add support in auditctl for virtual keys
  345. - auparse_find_field_next was not iterating correctly, fixed it
  346. - Add idmef alerts for access or execution of watched file
  347. - Fix buffer overflow in audit_log_user_command
  348. - Add basic remote logging plugin - only sends & no flow control
  349. - Update ausearch with interpret fixes from auparse
  350. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  351. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  352. - Apply auparse expression interface patch (Miloslav Trmac)
  353. - Fix potential memleak in audit event dispatcher
  354. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  355. - audisp-prelude alerts now controlled by config file
  356. - Updated syscall table for 2.6.25 kernel
  357. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  358. - Added watched account login detection for prelude plugin
  359. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  360. - Update for gcc 4.3
  361. - Cleanup descriptors in audispd before running plugin
  362. - Fix 'recent' keyword for aureport/search
  363. - Fix SE Linux policy for zos_remote plugin
  364. - Add event type for group password authentication attempts
  365. - Couple of updates to the translation tables
  366. - Add detection of failed group authentication to audisp-prelude
  367. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  368. - In ausearch/report, prefer -if to stdin
  369. - In ausearch/report, add new command line option --input-logs (#428860)
  370. - Updated audisp-prelude based on feedback from prelude-devel
  371. - Added prelude alert for promiscuous socket being opened
  372. - Added prelude alert for SE Linux policy enforcement changes
  373. - Added prelude alerts for Forbidden Login Locations and Time
  374. - Applied patch to auparse fixing error handling of searching by
  375. interpreted value (Miloslav Trmac)
  376. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  377. - Add prelude IDS plugin for IDMEF alerts
  378. - Add --user option to aulastlog command
  379. - Use desktop-file-install for system-config-audit
  380. - Avoid touching auditd.conf most of the time (#408501)
  381. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  382. - Updates for spec file review
  383. - Adjust permission on selinux policy file
  384. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  385. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  386. - Check for audit log being writable by owner in auditd
  387. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  388. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  389. - Added aulastlog utility
  390. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  391. - Allow 0600 file perms for audit logs
  392. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  393. - fchmod of log file was on wrong variable (#426934)
  394. - Allow use of errno strings for exit codes in audit rules
  395. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  396. - Don't fchmod() /dev/null to mode 0400 (#426934)
  397. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  398. - Add kernel release string to DEAMON_START events
  399. - Fix keep_logs when num_logs option disabled (#325561)
  400. - Fix auparse to handle node fields for syscall records
  401. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  402. - Add keyword week-ago to aureport & ausearch start/end times
  403. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  404. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  405. - Add event queue overflow action to audispd
  406. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  407. - Don't retry if the rt queue is full.
  408. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  409. - Add support for searching by posix regular expressions in auparse
  410. - Route DEAMON events into rt interface
  411. - If event pipe is full, try again after doing local logging
  412. - Optionally add node/machine name to records in audit daemon
  413. - Update ausearch/aureport to specify nodes to search on
  414. - Fix segfault interpretting saddr fields in avcs
  415. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  416. - Fix uninitialized variable in auparse (John Dennis)
  417. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  418. - External plugin support in place
  419. - Fix reference counting in auparse python bindings (#263961)
  420. - Moved default af_unix plugin socket to /var/run/audispd_events
  421. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  422. - Add newline to audispd string formatted events
  423. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  424. - spec file cleanups
  425. - Update to s-c-audit 0.4.3
  426. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  427. - Update Licence tags
  428. - Adding perm field should not set syscall added flag in auditctl
  429. - Fix segfault when aureport -if option is used
  430. - Fix auditctl to better check keys on rule lines
  431. - Add support for audit by TTY and other new event types
  432. - Auditd config option for group permission of audit logs
  433. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  434. - New audit event dispatcher
  435. - Update syscall tables for 2.6.23 kernel
  436. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  437. - Fix potential buffer overflow in print clone flags of auparse
  438. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  439. - Update auditctl to handle legacy kernels when putting a watch on a dir
  440. - Fix acct interpretation in auparse
  441. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  442. - Fix a double free when auditd receives SIGHUP
  443. - Move the system-config-audit menu entry to the Administration menu
  444. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  445. - Add system-config-audit (Miloslav Trmac)
  446. - Correct bug in audit_make_equivalent function (Al Viro)
  447. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  448. - Add feed interface to auparse library (John Dennis)
  449. - Apply patch to libauparse for unresolved symbols (#241178)
  450. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  451. - Change seresults to seresult in libauparse (John Dennis)
  452. - Add unit32_t definition to swig (#244210)
  453. - Add support for directory auditing
  454. - Update acct field to be escaped
  455. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  456. - Change buffer size to prevent truncation of DAEMON events with large labels
  457. - Fix memory leaks in auparse (John Dennis)
  458. - Update syscall tables for 2.6.21 kernel
  459. - Update capp & lspp rules
  460. - New python bindings for libauparse (John Dennis)
  461. * Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  462. - New event dispatcher (James Antill)
  463. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  464. - Apply patch correcting python libs permissions (Philipp Hahn)
  465. - Fix auditd segfault on reload
  466. - Fix bug in auparse library for file pointers and descriptors
  467. - Extract subject information out of daemon events for ausearch
  468. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  469. - Remove requires kernel-headers for python-libs
  470. - Apply patch to prevent segfaults on auditd reload
  471. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  472. - Updated autrace to monitor *at syscalls
  473. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  474. - Finish reworking auditd config parser
  475. - In auparse, interpret open, fcntl, and clone flags
  476. - In auparse, when interpreting execve record types, run args through unencode
  477. - Add support for OBJ_PID message type
  478. - Event dispatcher updates
  479. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  480. - rebuild
  481. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  482. - NEW audit dispatcher program & plugin framework
  483. - Correct hidden variables in libauparse
  484. - Added NISPOM sample rules
  485. - Verify accessibility of files passed in auparse_init
  486. - Fix bug in parser library interpreting socketcalls
  487. - Add support for stdio FILE pointer in auparse_init
  488. - Adjust init script to allow anyone to status auditd (#230626)
  489. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  490. - Add man pages
  491. - Reduce text relocations in parser library
  492. - Add -n option to auditd for no fork
  493. - Add exec option to space_left, admin_space_left, disk_full,
  494. and disk_error - eg EXEC /usr/local/script
  495. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  496. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  497. - Finished search options for audit parsing library
  498. - Fix ausearch -se to work correctly
  499. - Fix auditd init script for /usr on netdev (#228528)
  500. - Parse avc seperms better when there are more than one
  501. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  502. - New report about authentication attempts
  503. - Updates for python 2.5
  504. - update autrace to have resource usage mode
  505. - update auditctl to support immutable config
  506. - added audit_log_user_command function to libaudit api
  507. - interpret capabilities
  508. - added audit event parsing library
  509. - updates for 2.6.20 kernel
  510. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  511. - Make more adjustments for python 2.5
  512. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  513. - Fix a couple parsing problems (#217952)
  514. - Add tgkill to S390* syscall tables (#218484)
  515. - Fix error messages in ausearch/aureport
  516. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  517. - rebuild against python 2.5
  518. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  519. - Fix timestamp for libaudit.conf (#218053)
  520. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  521. - Fix minor parsing problem and add new msg types
  522. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  523. - ausearch & aureport implement uid/gid caching
  524. - In ausearch & aureport, extract addr when hostname is unknown
  525. - In ausearch & aureport, test audit log presence O_RDONLY
  526. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  527. - Added --add & --delete option to aureport
  528. - Update res parsing in config change events
  529. - Increase the size on audit daemon buffers
  530. - Parse avc_path records in ausearch/aureport
  531. - ausearch has new output mode, raw, for extracting events
  532. - ausearch/aureport can now read stdin
  533. - Rework AVC processing in ausearch/aureport
  534. - Added long options to ausearch and aureport
  535. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  536. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  537. - Fix some defines in libaudit.h
  538. - Some auditd config strings were not initialized in aureport (#211443)
  539. - Updated man pages
  540. - Add Netlabel event types to libaudit
  541. - Update aureports to current audit event types
  542. - Update autrace a little
  543. - Deprecated all the old audit_rule functions from public API
  544. - Drop auparse library for the moment
  545. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  546. - Add dist tag and bump version (#208532)
  547. - Make internal auditd buffers bigger for context info
  548. - Correct address resolving of hostname in logging functions
  549. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  550. - Only =, != operators for arch & inode fields in auditctl (#206427)
  551. - Updated audit message type table
  552. - Remove watches from aureport since FS_WATCH is deprecated
  553. - Add audit_log_avc back temporarily (#208152)