isl-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. Summary: Integer point manipulation library
  2. Name: isl
  3. Version: 0.14.1
  4. License: MIT
  5. Group: System Environment/Libraries
  6. URL: http://isl.gforge.inria.fr/
  7. %global libmajor 13
  8. %global libversion %{libmajor}.1.1
  9. # Please set buildid below when building a private version of this rpm to
  10. # differentiate it from the stock rpm.
  11. #
  12. # % global buildid .local
  13. Release: 1%{?_dist_release}
  14. BuildRequires: gmp-devel
  15. BuildRequires: pkgconfig
  16. Source0: http://isl.gforge.inria.fr/isl-%{version}.tar.xz
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: Takemikaduchi
  21. %description
  22. isl is a library for manipulating sets and relations of integer points
  23. bounded by linear constraints. Supported operations on sets include
  24. intersection, union, set difference, emptiness check, convex hull,
  25. (integer) affine hull, integer projection, computing the lexicographic
  26. minimum using parametric integer programming, coalescing and parametric
  27. vertex enumeration. It also includes an ILP solver based on generalized
  28. basis reduction, transitive closures on maps (which may encode infinite
  29. graphs), dependence analysis and bounds on piecewise step-polynomials.
  30. %package devel
  31. Summary: Development for building integer point manipulation library
  32. Requires: isl == %{version}-%{release}
  33. Requires: gmp-devel
  34. Group: Development/Libraries
  35. %description devel
  36. isl is a library for manipulating sets and relations of integer points
  37. bounded by linear constraints. Supported operations on sets include
  38. intersection, union, set difference, emptiness check, convex hull,
  39. (integer) affine hull, integer projection, computing the lexicographic
  40. minimum using parametric integer programming, coalescing and parametric
  41. vertex enumeration. It also includes an ILP solver based on generalized
  42. basis reduction, transitive closures on maps (which may encode infinite
  43. graphs), dependence analysis and bounds on piecewise step-polynomials.
  44. %prep
  45. %setup -q
  46. %build
  47. %configure
  48. make %{?_smp_mflags} V=1
  49. %install
  50. %make_install INSTALL="install -p"
  51. rm -f %{buildroot}/%{_libdir}/libisl.a
  52. rm -f %{buildroot}/%{_libdir}/libisl.la
  53. mkdir -p %{buildroot}/%{_datadir}
  54. %global gdbprettydir %{_datadir}/gdb/auto-load/%{_libdir}
  55. mkdir -p %{buildroot}/%{gdbprettydir}
  56. mv %{buildroot}/%{_libdir}/*-gdb.py* %{buildroot}/%{gdbprettydir}
  57. %check
  58. make check
  59. %post -p /sbin/ldconfig
  60. %postun -p /sbin/ldconfig
  61. %files
  62. %{_libdir}/libisl.so.%{libmajor}
  63. %{_libdir}/libisl.so.%{libversion}
  64. %{gdbprettydir}/*
  65. %doc AUTHORS ChangeLog LICENSE README
  66. %files devel
  67. %{_includedir}/*
  68. %{_libdir}/libisl.so
  69. %{_libdir}/pkgconfig/isl.pc
  70. %doc doc/manual.pdf
  71. %changelog
  72. * Sat Jun 25 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  73. - initial build for Vine Linux
  74. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14-4
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  76. * Mon Jan 5 2015 David Howells <dhowells@redhat.com> - 0.14-3
  77. - Initial packaging.