jasper1-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: jasper1
  3. Summary: implementation of the JPEG-2000 standard, Part 1
  4. Version: 1.900.1
  5. Release: 12%{?_dist_release}
  6. Group: Applications/Graphics
  7. License: Modified BSD (see LICENSE)
  8. URL: http://www.ece.uvic.ca/~mdadams/jasper/
  9. Source: jasper-%{version}.zip
  10. Patch1: jasper-1.701.0-GL.patch
  11. # autoconf/automake bits of patch1
  12. Patch2: jasper-1.701.0-GL-ac.patch
  13. # CVE-2007-2721 (bug #240397)
  14. # borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=413041;msg=88
  15. Patch3: patch-libjasper-stepsizes-overflow.diff
  16. # borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469786
  17. Patch4: jpc_dec.c.patch
  18. # OpenBSD hardening patches addressing couple of possible integer overflows
  19. # during the memory allocations
  20. # https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3520
  21. Patch5: jasper-1.900.1-CVE-2008-3520.patch
  22. # https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3522
  23. Patch6: jasper-1.900.1-CVE-2008-3522.patch
  24. # add pkg-config support
  25. Patch7: jasper-pkgconfig.patch
  26. Patch8: jasper-1.900.1-CVE-2011-4516-CVE-2011-4517-CERT-VU-887409.patch
  27. Patch9: jasper-CVE-2014-9029.patch
  28. Patch10: jasper-CVE-2014-8137.patch
  29. Patch11: jasper-CVE-2014-8138.patch
  30. # Issues found by static analysis of code
  31. Patch110: jasper-1.900.1-Coverity-BAD_SIZEOF.patch
  32. Patch111: jasper-1.900.1-Coverity-CHECKED_RETURN.patch
  33. Patch112: jasper-1.900.1-Coverity-FORWARD_NULL.patch
  34. Patch113: jasper-1.900.1-Coverity-NULL_RETURNS.patch
  35. Patch114: jasper-1.900.1-Coverity-RESOURCE_LEAK.patch
  36. Patch115: jasper-1.900.1-Coverity-UNREACHABLE.patch
  37. Patch116: jasper-1.900.1-Coverity-UNUSED_VALUE.patch
  38. # from debian
  39. Patch1000: 09-CVE-2016-1577.patch
  40. Patch1001: 10-CVE-2016-2089.patch
  41. Patch1002: 11-CVE-2016-2116.patch
  42. BuildRoot: %{_tmppath}/jasper-%{version}-root
  43. BuildRequires: autoconf automake libtool
  44. BuildRequires: freeglut-devel
  45. BuildRequires: libGLU-devel
  46. BuildRequires: libjpeg-devel
  47. BuildRequires: pkgconfig
  48. Requires: jasper-libs = %{version}-%{release}
  49. Vendor: Project Vine
  50. Distribution: Vine Linux
  51. %description
  52. JasPer is a collection of software (i.e., a library and application
  53. programs) for the coding and manipulation of images. This software
  54. can handle image data in a variety of formats. One such format
  55. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  56. %package libs
  57. Summary: Runtime libraries for jasper
  58. Group: System Environment/Libraries
  59. %description libs
  60. This package contains runtime libraries for JasPer.
  61. # compat32
  62. %package -n compat32-jasper1-libs
  63. Summary: Runtime libraries for jasper
  64. Group: System Environment/Libraries
  65. %description -n compat32-jasper1-libs
  66. This package contains runtime libraries for JasPer.
  67. %prep
  68. %setup -q -n jasper-%{version}
  69. %patch1 -p1 -b .GL
  70. %patch2 -p1 -b .GL-ac
  71. %patch3 -p1 -b .CVE-2007-2721
  72. %patch4 -p1 -b .jpc_dec_assertion
  73. %patch5 -p1 -b .CVE-2008-3520
  74. %patch6 -p1 -b .CVE-2008-3522
  75. %patch7 -p1 -b .pkgconfig
  76. %patch8 -p1 -b .CVE-2011-4516-4517
  77. %patch9 -p1 -b .CVE-2014-9029
  78. %patch10 -p1 -b .CVE-2014-8137-variant2
  79. %patch11 -p1 -b .CVE-2014-8138
  80. %patch110 -p1 -b .BAD_SIZEOF
  81. %patch111 -p1 -b .CHECKED_RETURN
  82. %patch112 -p1 -b .FORWARD_NULL
  83. %patch113 -p1 -b .NULL_RETURNS
  84. %patch114 -p1 -b .RESOURCE_LEAK
  85. %patch115 -p1 -b .UNREACHABLE
  86. %patch116 -p1 -b .UNUSED_VALUE
  87. %patch1000 -p1 -b .CVE-2016-1577
  88. %patch1001 -p1 -b .CVE-2016-2089
  89. %patch1002 -p1 -b .CVE-2016-2116
  90. autoreconf --verbose --force --install
  91. %build
  92. CFLAGS="%{optflags} -fno-strict-overflow" \
  93. %configure --enable-shared --disable-static
  94. make %{?_smp_mflags}
  95. %install
  96. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  97. make install DESTDIR=$RPM_BUILD_ROOT
  98. # remove .la
  99. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  100. %clean
  101. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  102. %post libs -p /sbin/ldconfig
  103. %postun libs -p /sbin/ldconfig
  104. %post -n compat32-jasper1-libs -p /sbin/ldconfig
  105. %postun -n compat32-jasper1-libs -p /sbin/ldconfig
  106. %files libs
  107. %defattr(-,root,root)
  108. %{_libdir}/libjasper*.so.*
  109. # compat32
  110. %if %{build_compat32}
  111. %files -n compat32-jasper1-libs
  112. %defattr(-,root,root)
  113. %{_libdir}/libjasper*.so.*
  114. %endif
  115. %changelog
  116. * Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-12
  117. - created a new package for compatibility only.
  118. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
  119. - added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
  120. * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
  121. - imported all patches from RawHide.
  122. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
  123. - rebuild with libpng-1.6.12
  124. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  125. - rebuilt with current VineSeed
  126. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  127. - added compat32 subpackage for x86_64 arch support.
  128. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  129. - splited out runtime library to sub package
  130. - enable opengl again, add BuildRequires: freeglut-devel
  131. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  132. - remove .la
  133. - add --disable-static to configure option
  134. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  135. - added Patch0 from VinePlus/4.0
  136. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  137. - add patch100 for fix CVE-2007-2721
  138. - add Vendor/Distributin Tag
  139. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  140. - remove BuildPrereq: freeglut-devel and Requires freeglut
  141. - add --disable-opengl to configure option
  142. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  143. - add BuildPreReq: unzip (used in the %%pre section)
  144. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  145. - new upstream release
  146. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  147. - new upstream release
  148. - changed Group to System Environment/Libraries
  149. - added --mandir=%{_mandir}
  150. - added %post and %postun section
  151. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  152. - added --libdir=%{_libdir} configure option
  153. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  154. - build with freeglut
  155. - change BuildPrereq and Requires
  156. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  157. - new upstream version (jasper-1.701.0)
  158. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  159. - rebuild for VineSeedPlus
  160. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  161. - source upgrade
  162. - change spec to build for VineLinux
  163. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  164. - spec file created