jline-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. # Copyright (c) 2000-2005, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. Name: jline
  31. Summary: Java library for reading and editing user input in console applications
  32. Version: 1.0
  33. Release: 2%{?_dist_release}
  34. License: BSD
  35. URL: http://jline.sf.net/
  36. Group: Development/Libraries
  37. Source0: http://download.sourceforge.net/sourceforge/jline/jline-%{version}.zip
  38. Source1: CatalogManager.properties
  39. Source2: jline-build.xml
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  41. BuildArch: noarch
  42. BuildRequires: jpackage-utils >= 1.7
  43. Requires: bash
  44. # for /bin/stty
  45. Requires: coreutils
  46. Requires: jpackage-utils
  47. %description
  48. JLine is a java library for reading and editing user input in console
  49. applications. It features tab-completion, command history, password
  50. masking, customizable keybindings, and pass-through handlers to use to
  51. chain to other console applications.
  52. %prep
  53. %setup -q -n %{name}-%{version}
  54. %build
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. # jars
  58. install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
  59. install -m 644 %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/
  60. (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do \
  61. ln -sf ${jar} ${jar/-%{version}/}; done)
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %files
  65. %defattr(0644,root,root,0755)
  66. %doc LICENSE.txt
  67. %{_javadir}/%{name}.jar
  68. %{_javadir}/%{name}-%{version}.jar
  69. %changelog
  70. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0-2
  71. - merge VinePlus/6 pakcage
  72. * Tue May 29 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-1
  73. - updated to 1.0
  74. * Wed Sep 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.94-1
  75. - Initial build for VineLinux
  76. * Mon Mar 8 2010 Peter Lemenkov <lemenkov@gmail.com> - 0:0.9.94-0.6
  77. - Added missing Requires: jpackage-utils (%%{_javadir} and %%{_javadocdir})
  78. * Tue Jan 12 2010 Alexander Kurtakov <akurtako@redhat.com> 0:0.9.94-0.5
  79. - Fix BRs.
  80. - Drop gcj_support.
  81. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.9.94-0.4
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  83. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.9.94-0.3
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  85. * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:9.94-0.2
  86. - drop repotag
  87. * Mon Mar 24 2008 Matt Wringe <mwringe@redhat.com> - 0:9.94-0jpp.1
  88. - Update to 0.9.94 (BZ #436204)
  89. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:0.9.9-2jpp.1
  90. - Autorebuild for GCC 4.3
  91. * Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:0.9.9-1jpp.1
  92. - Add option to build with ant.
  93. - Fix various rpmlint issues
  94. - Specify proper license
  95. * Thu May 04 2006 Alexander Kurtakov <akurtkov at gmail.com> - 0:0.9.9-1jpp
  96. - Upgrade to 0.9.9
  97. * Thu May 04 2006 Ralph Apel <r.apel at r-apel.de> - 0:0.9.5-1jpp
  98. - Upgrade to 0.9.5
  99. - First JPP-1.7 release
  100. * Mon Apr 25 2005 Fernando Nasser <fnasser@redhat.com> - 0:0.9.1-1jpp
  101. - Upgrade to 0.9.1
  102. - Disable attempt to include external jars
  103. * Mon Apr 25 2005 Fernando Nasser <fnasser@redhat.com> - 0:0.8.1-3jpp
  104. - Changes to use locally installed DTDs
  105. - Do not try and access sun site for linking javadoc
  106. * Mon Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:0.8.1-2jpp
  107. - Rebuild with ant-1.6.2
  108. * Mon Jan 26 2004 David Walluck <david@anti-microsoft.org> 0:0.8.1-1jpp
  109. - release