lyx-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338
  1. %define pkg_name lyx
  2. %define pkg_version 2.3.0
  3. %define pkg_release 1%{?_dist_release}
  4. %define _fontdir %{_datadir}/fonts/%{name}
  5. %define texmf %{_datadir}/texmf
  6. %define build_texmf %{buildroot}%{texmf}
  7. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
  8. Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
  9. Summary(ja): LaTeX 形式で保存できるワードプロセッサ
  10. Name: %{pkg_name}
  11. Version: %{pkg_version}
  12. Release: %{pkg_release}
  13. License: GPLv2 or GPLv3
  14. Group: Applications/Editors
  15. URL: http://www.lyx.org/
  16. Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
  17. Source1: lyxrc.dist
  18. Source10: lyx.desktop
  19. ## upstreamable patches
  20. # submitted, but upstream rejected it. we currently agree to disagree.
  21. # Patch50: lyx-2.0.6-xdg_open.patch
  22. Patch50: lyx-2.3.0-xdg_open.patch
  23. ## vine
  24. # reverted checkLatex to lyx-1.6.5
  25. Patch100: lyx-2.3.0-configurepy-vine.patch
  26. BuildRequires: enchant-devel
  27. BuildRequires: hunspell-devel
  28. BuildRequires: libboost-devel
  29. BuildRequires: libboost-filesystem
  30. BuildRequires: libboost-signals
  31. BuildRequires: libboost-regex
  32. BuildRequires: desktop-file-utils
  33. BuildRequires: gettext
  34. BuildRequires: python
  35. BuildRequires: xorg-x11-devel
  36. BuildRequires: qt5-qtbase-devel
  37. BuildRequires: qt5-qtsvg-devel
  38. BuildRequires: libpng-devel
  39. BuildRequires: glib2-devel
  40. BuildRequires: zlib-devel
  41. BuildRequires: bc
  42. Requires(post): texlive-common
  43. Requires(postun): texlive-common
  44. Requires: ghostscript
  45. Requires: python
  46. Requires: %{name}-fonts = %{version}-%{release}
  47. Requires: xdg-utils
  48. Requires: rcs
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. Vendor: Project Vine
  51. Distribution: Vine Linux
  52. %description
  53. LyX is a modern approach to writing documents which breaks with the
  54. obsolete "typewriter paradigm" of most other document preparation
  55. systems.
  56. It is designed for people who want professional quality output
  57. with a minimum of time and effort, without becoming specialists in
  58. typesetting.
  59. The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
  60. That is, the author focuses on content, not on the details of formatting.
  61. This allows for greater productivity, and leaves the final typesetting
  62. to the backends (like LaTeX) that are specifically designed for the task.
  63. With LyX, the author can concentrate on the contents of his writing,
  64. and let the computer take care of the rest.
  65. This is LyX built with the Qt frontend.
  66. %description -l ja
  67. LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
  68. 特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
  69. してあります。
  70. %package fonts
  71. Summary: Lyx/MathML fonts
  72. Group: User Interface/X
  73. # The actual license says "The author of these fonts, Basil K. Malyshev, has
  74. # kindly granted permission to use and modify these fonts."
  75. # One of the font files (wasy10) is separately licensed GPL+.
  76. License: Copyright only and GPL+
  77. Obsoletes: latex-xft-fonts
  78. BuildArch: noarch
  79. %description fonts
  80. A collection of Math symbol fonts for %{name}.
  81. %prep
  82. %setup -q
  83. %patch50 -b .xdg_open
  84. %patch100 -b .vine
  85. %build
  86. %{configure} \
  87. --disable-dependency-tracking \
  88. --disable-rpath \
  89. --enable-build-type=release \
  90. --disable-debug \
  91. --enable-optimization="%{optflags}" \
  92. --without-included-boost \
  93. --disable-stdlib-debug \
  94. --with-enchant \
  95. --with-hunspell \
  96. --enable-qt5 \
  97. ;
  98. %{__make} %{?_smp_mflags}
  99. %install
  100. %{__rm} -rf ${RPM_BUILD_ROOT}
  101. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  102. # misc/extras
  103. %{__install} -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
  104. # Set up the lyx-specific class files where TeX can see them
  105. %{__mkdir_p} %{build_texmf}/tex/latex
  106. %{__mv} %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
  107. # desktop & icon
  108. desktop-file-install --vendor="vine" \
  109. --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
  110. %__install -p -D -m644 lib/images/lyx.png \
  111. %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
  112. %{__rm} -f ${RPM_BUILD_ROOT}%{_datadir}/applications/lyx.desktop
  113. # ghost'd files
  114. touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
  115. touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
  116. # fonts
  117. %{__install} -m 0755 -d %{buildroot}%{_fontdir}
  118. %{__mv} %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
  119. %{__rm} -rf %{buildroot}%{_datadir}/lyx/fonts
  120. %find_lang %{name}
  121. %check
  122. # tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
  123. %{__make} -k check || :
  124. %clean
  125. %{__rm} -rf ${RPM_BUILD_ROOT}
  126. %post
  127. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  128. %postun
  129. if [ $1 -eq 0 ] ; then
  130. %{exec_texhash} >& /dev/null
  131. update-desktop-database -q &> /dev/null
  132. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  133. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  134. fi
  135. %posttrans
  136. %{exec_texhash} >& /dev/null
  137. update-desktop-database -q &> /dev/null
  138. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  139. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  140. %post fonts
  141. %{__font_install_post} %{_fontdir}
  142. %postun fonts
  143. %{__font_install_postun} %{_fontdir}
  144. %files -f %{name}.lang
  145. %defattr(-,root,root,-)
  146. %doc ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
  147. %{_bindir}/*
  148. %{_datadir}/lyx/
  149. %{texmf}/tex/latex/lyx/
  150. %{_datadir}/applications/*.desktop
  151. %{_datadir}/icons/hicolor/*/*/*
  152. %{_mandir}/man*/*
  153. %config(noreplace) %{_datadir}/lyx/lyxrc.dist
  154. %ghost %{_datadir}/lyx/lyxrc.defaults
  155. %ghost %{_datadir}/lyx/*.lst
  156. %ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
  157. %files fonts
  158. %defattr(-,root,root,-)
  159. %dir %{_fontdir}/
  160. %{_fontdir}/*.ttf
  161. %changelog
  162. * Fri Jun 08 2018 Toshiaki Ara <ara_t@384.jp> 2.3.0-1
  163. - update to 2.3.0
  164. - update Patch50 and Patch100
  165. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
  166. - new upstream release
  167. - update Patch50 (lyx-2.2.3-xdg_open.patch)
  168. - add BuildRequires: bc
  169. - use qt5 instead of qt4
  170. - add --enable-qt5 option
  171. - add BuildRequires: qt5-qtbase-devel, qt5-qtsvg-devel
  172. - drop BuildRequires: qt4-devel
  173. - delete unused options
  174. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
  175. - update to 2.0.6
  176. - update Patch50 (lyx-2.0.6-xdg_open.patch)
  177. * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
  178. - rebuild with hunspell-devel
  179. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
  180. - new upstream release
  181. - added subpackage "lyx-fonts"
  182. - added Obsoletes: latex-xft-fonts
  183. * Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
  184. - applied lyx-2.0.1-configurepy-vine.patch
  185. - reverted checkLatex to lyx-1.6.5
  186. * Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
  187. - new upstream release
  188. * Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  189. - new upstream release
  190. - dropped BuildRequires: aspell-devel
  191. - added BuildRequires:
  192. - libboost-regex
  193. - enchant-devel
  194. - hunspell-devel
  195. * Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
  196. - new upstream release
  197. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
  198. - new upstream release
  199. - TeX Live 2009
  200. - dropped Requires: xdvik, dvipdfmx
  201. * Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
  202. - new upstream release
  203. - updated Patch0: lyx-1.6.5-xdg_open.patch
  204. * Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
  205. - new upstream release
  206. - dropped old source files
  207. - change License: GPLv2+
  208. - added lyx.desktop
  209. - added BuildRequires:
  210. - aspell-devel
  211. - desktop-file-utils
  212. - gettext
  213. - python
  214. - qt4-devel
  215. - zlib-devel
  216. - libboost-devel
  217. - libboost-filesystem
  218. - libboost-signals
  219. - libpng-devel
  220. - glib2-devel
  221. - added Requires:
  222. - ghostscript
  223. - dvipdfmx
  224. - xdvik
  225. - qt4
  226. - xdg-utils
  227. - optimized some configure options
  228. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
  229. - applied new versioning policy, spec in utf-8
  230. * Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
  231. - updated to 1.4.4 with the most recent CJK patch
  232. - updated Patch1
  233. * Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
  234. - base spec file : Vine Linux BTS #219
  235. * Mon Nov 6 2006 M.H
  236. - new upstream release
  237. - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
  238. * Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
  239. - changed Group to Applications/Editors
  240. * Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
  241. - rebuild with qt-3.3.5
  242. * Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
  243. - new upstream version
  244. - change frontend, xforms -> qt
  245. - require tetex, qt, latex-xft-fonts
  246. - change applnk file
  247. - change Group
  248. * Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
  249. - new upstream version
  250. - add mime-info
  251. - minor change in spec file
  252. * Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  253. - 1.0.3_jp-4
  254. - added BuildPrereq:
  255. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  256. - 1.0.3_jp-3
  257. - minor change in spec file
  258. - build for Vine Linux 2.1
  259. * Wed Jan 5 2000 Jun Nishii <jun@vinelinux.org>
  260. - change group
  261. * Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
  262. - updated to lyx-1.0.3
  263. - rebuild for Vine Linux 2.0
  264. * Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
  265. - merged Japanese Documents
  266. * Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
  267. - first build