meson-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
  2. %global libname mesonbuild
  3. Name: meson
  4. Version: 0.44.0
  5. Release: 1%{?_dist_release}
  6. Group: Development/Tools
  7. Summary: High productivity build system
  8. License: ASL 2.0
  9. URL: http://mesonbuild.com/
  10. Source0: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
  11. BuildArch: noarch
  12. Obsoletes: %{name}-gui < 0.31.0-3
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: tomop
  16. BuildRequires: python3-devel
  17. BuildRequires: python3-setuptools
  18. BuildRequires: python-rpm-macros
  19. BuildRequires: python3-rpm-macros
  20. BuildRequires: ninja
  21. # Various languages
  22. BuildRequires: gcc
  23. BuildRequires: libasan
  24. BuildRequires: gcc-c++
  25. BuildRequires: gcc-objc
  26. BuildRequires: gcc-objc++
  27. BuildRequires: rust
  28. # Various libs support
  29. BuildRequires: libboost-devel
  30. BuildRequires: vala
  31. BuildRequires: flex
  32. BuildRequires: bison
  33. BuildRequires: gettext
  34. BuildRequires: git-core
  35. #BuildRequires: pkgconfig(glib-2.0)
  36. #BuildRequires: pkgconfig(gobject-introspection-1.0)
  37. #BuildRequires: itstool
  38. BuildRequires: zlib-devel
  39. BuildRequires: llvm-devel
  40. BuildRequires: cups-devel
  41. Requires: ninja
  42. %description
  43. Meson is a build system designed to optimize programmer
  44. productivity. It aims to do this by providing simple, out-of-the-box
  45. support for modern software development tools and practices, such as
  46. unit tests, coverage reports, Valgrind, CCache and the like.
  47. %prep
  48. %autosetup -p1
  49. find -type f -name '*.py' -executable -exec sed -i -e '1s|.*|#!%{__python3}|' {} ';'
  50. # Remove MPI tests for now because it is complicated to run
  51. rm -rf "test cases/frameworks/17 mpi"
  52. %build
  53. %py3_build
  54. #python3 setup.py build
  55. %install
  56. %py3_install
  57. #python3 setup.py install --root %{buildroot}
  58. install -Dpm0644 data/macros.%{name} %{buildroot}%{rpmmacrodir}/macros.%{name}
  59. %check
  60. export MESON_PRINT_TEST_OUTPUT=1
  61. #python3 ./run_tests.py ||:
  62. %files
  63. %license COPYING
  64. %{_bindir}/%{name}
  65. %{_bindir}/%{name}conf
  66. %{_bindir}/%{name}introspect
  67. %{_bindir}/%{name}test
  68. %{_bindir}/wraptool
  69. %{python3_sitelib}/%{libname}/
  70. %{python3_sitelib}/%{name}-*.egg-info/
  71. %{_mandir}/man1/%{name}.1*
  72. %{_mandir}/man1/%{name}conf.1*
  73. %{_mandir}/man1/%{name}introspect.1*
  74. %{_mandir}/man1/%{name}test.1*
  75. %{_mandir}/man1/wraptool.1*
  76. %{rpmmacrodir}/macros.*
  77. %changelog
  78. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.44.0-1
  79. - updated to 0.44.0.
  80. * Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.42.0-1
  81. - initial build for Vine Linux.
  82. * Fri Aug 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.42.0-1
  83. - Update to 0.42.0
  84. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41.2-2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  86. * Wed Jul 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.2-1
  87. - Update to 0.41.2
  88. * Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 0.41.1-3
  89. - Backport various gtk-doc fixes from upstream
  90. * Thu Jul 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.1-2
  91. - Strip trailing slash from pkg-config files
  92. * Mon Jun 19 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.1-1
  93. - Update to 0.41.1
  94. * Tue Jun 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.0-1
  95. - Update to 0.41.0
  96. * Wed May 31 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-2
  97. - Don't run ldc tests
  98. * Fri Apr 28 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-1
  99. - Update to 0.40.1
  100. * Sun Apr 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.0-1
  101. - Update to 0.40.0
  102. * Thu Apr 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-2
  103. - Exclude ldc for module builds
  104. * Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-1
  105. - Update to 0.39.1
  106. * Mon Mar 06 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.39.0-1
  107. - Update to 0.39.0
  108. * Tue Feb 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.1-1
  109. - Update to 0.38.1
  110. * Sun Jan 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.0-1
  111. - Update to 0.38.0
  112. * Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.1-2
  113. - Rebuild for Python 3.6
  114. * Tue Dec 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.1-1
  115. - Update to 0.37.1
  116. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.0-2
  117. - Rebuild for Python 3.6
  118. * Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
  119. - Update to 0.37.0
  120. * Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
  121. - Backport more RPM macro fixes (FPC ticket #655)
  122. * Tue Dec 13 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-3
  123. - Backport fixes to RPM macros
  124. * Sat Dec 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-2
  125. - Print test output during build
  126. * Mon Nov 14 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-1
  127. - Update to 0.36.0
  128. * Tue Oct 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.1-1
  129. - Update to 0.35.1 (RHBZ #1385986)
  130. * Tue Oct 11 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-3
  131. - Backport couple of fixes
  132. * Wed Oct 05 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-2
  133. - Apply patch to fix FTBFS
  134. * Mon Oct 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-1
  135. - Update to 0.35.0
  136. * Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-2
  137. - Run D test suite
  138. * Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-1
  139. - Update to 0.34.0
  140. * Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-2
  141. - Obsoletes fix.
  142. * Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-1
  143. - 0.33.0
  144. - GUI dropped upstream.
  145. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31.0-2
  146. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  147. * Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.31.0-1
  148. - Update to 0.31.0
  149. * Sun Mar 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0-1
  150. - Update to 0.30.0
  151. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  153. * Sun Jan 24 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.29.0-1
  154. - Update to 0.29.0
  155. * Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 0.28.0-2
  156. - Rebuilt for Boost 1.60
  157. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.28.0-1
  158. - 0.28.0
  159. * Wed Nov 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.27.0-1
  160. - 0.27.0
  161. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
  162. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  163. * Fri Oct 30 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-2
  164. - Fix rpm macros for using optflags
  165. * Sun Sep 13 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-1
  166. - 0.26.0
  167. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.25.0-4
  168. - Rebuilt for Boost 1.59
  169. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-3
  170. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  171. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.25.0-2
  172. - rebuild for Boost 1.58
  173. * Sun Jul 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.0-1
  174. - 0.25.0
  175. * Sat Jul 11 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-3
  176. - Update URLs
  177. - drop unneded hacks in install section
  178. - enable print test output for tests
  179. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-2
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  181. * Mon May 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-1
  182. - Update to 0.24.0
  183. * Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
  184. - Update to latest git
  185. * Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
  186. - Add patch to accept .S files
  187. * Wed Apr 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-2
  188. - Add python3 to Requires (Thanks to Ilya Kyznetsov)
  189. * Tue Mar 31 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-1
  190. - 0.23.0
  191. * Sat Mar 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150328git3b49b71
  192. - Update to latest git
  193. * Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150325git18550fe
  194. - Update to latest git
  195. - Include mesonintrospect
  196. * Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150322git78d31ca
  197. - Fix filelists for mesongui (python-bytecode-without-source)
  198. * Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-8.20150322git78d31ca
  199. - Enable C# tests
  200. * Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
  201. - update to latest git
  202. - fix tests on arm
  203. * Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
  204. - update to latest git
  205. * Mon Mar 16 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150316gitfa2c659
  206. - update to latest git
  207. * Tue Mar 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150310gitf9f51b1
  208. - today's git snapshot with support for cool GNOME features
  209. - re-enable wxGTK3 tests, package fixed in rawhide
  210. * Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-6.git7581895
  211. - split gui to subpkg
  212. - update to latest snapshot
  213. - enable tests
  214. * Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-5.gitc6dbf98
  215. - Fix packaging style
  216. - Make package noarch
  217. * Mon Feb 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-4.git.c6dbf98
  218. - Use development version
  219. * Sat Feb 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-3
  220. - Add ninja-build to requires
  221. * Thu Jan 22 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-2
  222. - fix shebang in python files
  223. * Wed Jan 21 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-1
  224. - Initial package