mod_python-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277
  1. %define contentdir /var/www
  2. %define httpd apache2
  3. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  4. Summary: An embedded Python interpreter for the Apache HTTP Server
  5. Summary(ja): Apacheサーバの組み込みPython言語インタプリタ
  6. Name: mod_python
  7. Version: 3.3.1
  8. Release: 3%{?_dist_release}
  9. URL: http://www.modpython.org/
  10. Source: http://www.apache.org/dist/httpd/modpython/%{name}-%{version}.tgz
  11. Source1: python.conf.vine
  12. Patch1: mod_python-3.1.3-ldflags.patch
  13. Patch2: mod_python-3.1.4-cflags.patch
  14. Patch3: mod_python-3.3.1-buckets.patch
  15. License: Apache License Version 2.0
  16. Group: System Environment/Daemons
  17. BuildRequires: python, python-devel
  18. BuildRequires: %{httpd}-devel >= 2.0.40-6
  19. #Requires: %{httpd}-mmn = %(cat %{_includedir}/%{httpd}/.mmn || echo missing)
  20. Requires: %{httpd} >= 2.0.40
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. Mod_python is a module that embeds the Python language interpreter within
  26. the server, allowing Apache handlers to be written in Python.
  27. Mod_python brings together the versatility of Python and the power of
  28. the Apache Web server for a considerable boost in flexibility and
  29. performance over the traditional CGI approach.
  30. %prep
  31. %setup -q
  32. %patch1 -p1 -b .ldflags
  33. %patch2 -p1 -b .cflags
  34. %patch3 -p1 -b .buckets
  35. %build
  36. %configure --with-apxs=/usr/bin/apxs --with-max-locks=4
  37. make %{?_smp_mflags} APXS_CFLAGS="-Wc,-fno-strict-aliasing"
  38. %install
  39. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  40. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules
  41. make install DESTDIR=$RPM_BUILD_ROOT
  42. # Install the config file
  43. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d
  44. install -m 644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/python.conf
  45. # Install the manual.
  46. mkdir -p $RPM_BUILD_ROOT%{contentdir}/manual/mod/mod_python
  47. cp -a doc-html/* $RPM_BUILD_ROOT%{contentdir}/manual/mod/mod_python/
  48. %clean
  49. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  50. %files
  51. %defattr(-,root,root)
  52. %doc README NEWS CREDITS LICENSE NOTICE
  53. %{contentdir}/manual/mod/mod_python
  54. %{_libdir}/%{httpd}/modules/mod_python.so
  55. %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/*.conf
  56. %{python_sitearch}/mod_python*
  57. %changelog
  58. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.3.1-3
  59. - rebuild with python-2.6
  60. * Sun Mar 29 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.3.1-2
  61. - add Patch3 to fix build failure (from RH bugzilla #465246)
  62. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.3.1-1vl5
  63. - initial build for Vine Linux
  64. - applied vine versioning policy, spec in utf-8
  65. - use /usr/bin/apxs instead of /usr/sbin/apxs
  66. - modified python.conf
  67. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.3.1-7
  68. - Autorebuild for GCC 4.3
  69. * Fri Jan 4 2008 Joe Orton <jorton@redhat.com> 3.3.1-6
  70. - fix rebuild failure due to new egg-info directory
  71. * Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 3.3.1-5
  72. - rebuild for fixed 32-bit APR
  73. * Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 3.3.1-4
  74. - fix License
  75. * Mon Feb 19 2007 Jeremy Katz <katzj@redhat.com> - 3.3.1-3
  76. - don't use legacy python-abi requires syntax
  77. * Fri Feb 16 2007 Joe Orton <jorton@redhat.com> 3.3.1-2
  78. - update to 3.3.1
  79. - fix BuildRoot, Summary, drop BR for autoconf
  80. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 3.2.10-4
  81. - rebuild against python 2.5
  82. * Tue Nov 21 2006 Joe Orton <jorton@redhat.com> 3.2.10-3
  83. - update to 3.2.10
  84. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
  85. - rebuild
  86. * Mon Feb 27 2006 Joe Orton <jorton@redhat.com> 3.2.8-3
  87. - remove use of apr_sockaddr_port_get
  88. * Mon Feb 27 2006 Joe Orton <jorton@redhat.com> 3.2.8-2
  89. - update to 3.2.8
  90. * Mon Feb 13 2006 Joe Orton <jorton@redhat.com> 3.1.4-4
  91. - fix configure syntax error with bash 3.1 (#180731)
  92. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.4-3.2.1
  93. - bump again for double-long bug on ppc(64)
  94. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.1.4-3.2
  95. - rebuilt for new gcc4.1 snapshot and glibc changes
  96. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  97. - rebuilt
  98. * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 3.1.4-3
  99. - rebuild for httpd 2.2
  100. - build with -fno-strict-aliasing
  101. - don't use deprecated APR_STATUS_IS_SUCCESS() macro
  102. * Fri Mar 4 2005 Joe Orton <jorton@redhat.com> 3.1.4-2
  103. - rebuild
  104. * Thu Feb 10 2005 Joe Orton <jorton@redhat.com> 3.1.4-1
  105. - update to 3.1.4
  106. * Tue Feb 1 2005 Joe Orton <jorton@redhat.com> 3.1.3-8
  107. - link against shared libpython (#129019)
  108. - add python.conf comment on using PSP (#121212)
  109. * Thu Nov 18 2004 Joe Orton <jorton@redhat.com> 3.1.3-7
  110. - require python-abi
  111. * Thu Nov 18 2004 Joe Orton <jorton@redhat.com> 3.1.3-6
  112. - rebuild for Python 2.4
  113. * Tue Oct 12 2004 Joe Orton <jorton@redhat.com> 3.1.3-5
  114. - include LICENSE and NOTICE
  115. * Tue Oct 12 2004 Joe Orton <jorton@redhat.com> 3.1.3-4
  116. - use a maximum of four semaphores by default
  117. * Tue Jul 13 2004 Nils Philippsen <nphilipp@redhat.com>
  118. - set default-handler for manual files to fix #127622
  119. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  120. - rebuilt
  121. * Mon Mar 8 2004 Mihai Ibanescu <misa@redhat.com> 3.1.3-0.1
  122. - upgrade to 3.1.3
  123. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  124. - rebuilt
  125. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  126. - rebuilt
  127. * Tue Feb 3 2004 Gary Benson <gbenson@redhat.com> 3.0.4-1
  128. - upgrade to 3.0.4 (fixes CVE CAN-2003-0973)
  129. * Fri Nov 7 2003 Joe Orton <jorton@redhat.com> 3.0.3-4
  130. - rebuild for python 2.3.2
  131. * Thu Jul 3 2003 Gary Benson <gbenson@redhat.com> 3.0.3-3
  132. - fix license (#98245)
  133. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 3.0.3-2
  134. - rebuilt
  135. * Tue May 13 2003 Gary Benson <gbenson@redhat.com> 3.0.3-1
  136. - upgrade to 3.0.3.
  137. * Thu Feb 20 2003 Gary Benson <gbenson@redhat.com> 3.0.1-3
  138. - call PyOS_AfterFork() after forking (#84610)
  139. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 3.0.1-2
  140. - rebuilt
  141. * Mon Dec 9 2002 Gary Benson <gbenson@redhat.com> 3.0.1-1
  142. - upgrade to 3.0.1.
  143. * Mon Nov 18 2002 Gary Benson <gbenson@redhat.com> 3.0.0-12
  144. - upgrade to beta4.
  145. * Wed Nov 6 2002 Gary Benson <gbenson@redhat.com> 3.0.0-11
  146. - install libraries in lib64 when pertinent.
  147. * Fri Sep 13 2002 Gary Benson <gbenson@redhat.com>
  148. - add a filter example to /etc/httpd/conf.d/python.conf
  149. * Wed Sep 11 2002 Gary Benson <gbenson@redhat.com>
  150. - undisable filters (#73825)
  151. - fix filter lookup breakage
  152. * Mon Sep 2 2002 Joe Orton <jorton@redhat.com> 3.0.0-10
  153. - require httpd-mmn for module ABI compatibility
  154. * Tue Aug 28 2002 Gary Benson <gbenson@redhat.com> 3.0.0-9
  155. - remove empty files from the generated manual
  156. * Fri Aug 23 2002 Gary Benson <gbenson@redhat.com> 3.0.0-8
  157. - add built manual to snapshot tarball and install it (#69361)
  158. - add some examples to /etc/httpd/conf.d/python.conf (#71316)
  159. * Mon Aug 12 2002 Gary Benson <gbenson@redhat.com> 3.0.0-7
  160. - rebuild against httpd-2.0.40
  161. * Mon Jul 22 2002 Gary Benson <gbenson@redhat.com> 3.0.0-6
  162. - upgrade to latest CVS
  163. * Tue Jul 9 2002 Gary Benson <gbenson@redhat.com> 3.0.0-5
  164. - bring input filter API in line with 2.0.36 (#66566)
  165. * Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 3.0.0-4
  166. - upgrade to latest CVS
  167. * Fri Jun 21 2002 Gary Benson <gbenson@redhat.com>
  168. - move /etc/httpd2 back to /etc/httpd
  169. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.0.0-3
  170. - automated rebuild
  171. * Mon Jun 10 2002 Gary Benson <gbenson@redhat.com> 3.0.0-2
  172. - drop the CVS date from the release
  173. * Mon Jun 10 2002 Gary Benson <gbenson@redhat.com> 3.0.0-1.20020610
  174. - upgrade to latest CVS
  175. * Mon May 27 2002 Gary Benson <gbenson@redhat.com> 3.0.0-1.20020527
  176. - upgrade to latest CVS and change paths for httpd-2.0
  177. - make it build with 2.0.36
  178. - add the config file.
  179. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.8-2
  180. - rebuild in new environment
  181. * Mon Apr 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.8-1
  182. - update for RHSA-2002:070
  183. * Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.6-5
  184. - add patch for cleanups (#57232)
  185. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.6-4
  186. - rebuild with python 1.5
  187. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  188. - automated rebuild
  189. * Fri Jan 04 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  190. - change for python 2.2
  191. * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com>
  192. - update to 2.7.6
  193. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  194. - update to 2.7.5
  195. - add URL
  196. - move docs so that they live under %{contentdir}
  197. * Thu May 31 2001 Nalin Dahyabhai <nalin@redhat.com>
  198. - update to 2.7.3
  199. * Tue Jan 16 2001 Cristian Gafton <gafton@redhat.com>
  200. - fix module compilation paths
  201. - build first package for RHN