module-init-tools-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554
  1. Summary: Kernel module management utilities.
  2. Summary(ja): カーネルモジュール管理ユーティリティ
  3. Name: module-init-tools
  4. Version: 3.16
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Kernel
  8. Source: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.gz
  9. Source1: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.gz.sign
  10. #Source2: modprobe-dist.conf
  11. Source3: weak-modules
  12. Source4: depmod-dist.conf
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: zlib-devel, docbook-utils
  15. BuildRequires: zlib-static
  16. BuildRequires: glibc-static
  17. Exclusiveos: Linux
  18. Requires(post): chkconfig, coreutils
  19. Obsoletes: modutils-devel, modutils
  20. Provides: modutils = %{version}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: daisuke
  24. %description
  25. The module-init-tools package includes various programs needed for automatic
  26. loading and unloading of modules under 2.6 and later kernels, as well
  27. as other module management programs. Device drivers and filesystems
  28. are two examples of loaded and unloaded modules.
  29. %description -l ja
  30. module-init-tools パッケージには,バージョン 2.6 以上の kernel モジュールを
  31. 自動的にロード/アンロードする為の様々なプログラムや,モジュール管理の
  32. 為のプログラムなどが収められています.モジュールとしては,デバイスドライバ,
  33. ファイルシステム,その他が挙げられます.
  34. %prep
  35. %setup -q
  36. %build
  37. export CC=gcc
  38. export CFLAGS="$RPM_OPT_FLAGS -DCONFIG_NO_BACKWARDS_COMPAT=1"
  39. %configure --enable-zlib
  40. make
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. %makeinstall sbindir=$RPM_BUILD_ROOT/sbin
  44. install -m 755 generate-modprobe.conf \
  45. $RPM_BUILD_ROOT/sbin
  46. mkdir -p $RPM_BUILD_ROOT/etc/modprobe.d
  47. mkdir -p $RPM_BUILD_ROOT/lib/modprobe.d
  48. #install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/modprobe.d/modprobe-dist.conf
  49. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT/sbin/weak-modules
  50. mkdir -p $RPM_BUILD_ROOT/etc/depmod.d
  51. install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/depmod.d/depmod-dist.conf
  52. mv $RPM_BUILD_ROOT/%{_bindir}/lsmod $RPM_BUILD_ROOT/sbin
  53. touch $RPM_BUILD_ROOT/etc/modprobe.d/modprobe.conf
  54. touch $RPM_BUILD_ROOT/etc/modprobe.d/local.conf
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %pre
  58. if [ -e /etc/modprobe.conf ] && [ ! -e /etc/modprobe.d/local.conf ]
  59. then
  60. mv /etc/modprobe.conf /etc/modprobe.d/local.conf
  61. fi
  62. %files
  63. %defattr(-,root,root)
  64. /etc/modprobe.d
  65. /lib/modprobe.d
  66. /etc/depmod.d
  67. /sbin/*
  68. %{_mandir}/*/*
  69. %ghost %config(noreplace) %verify(not md5 size mtime) /etc/modprobe.d/modprobe.conf
  70. %ghost %config(noreplace) %verify(not md5 size mtime) /etc/modprobe.d/local.conf
  71. %changelog
  72. * Sat Jan 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.16-1
  73. - update to 3.16
  74. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-2
  75. - add BR: glibc-static
  76. - add V/D/P tags
  77. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
  78. - new upstream release
  79. * Tue May 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-4
  80. - remove kernel 2.4 compatibility from %%post
  81. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-3
  82. - move /etc/modprobe.conf to /etc/modprobe.d/modprobe.conf
  83. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-2
  84. - rename /etc/modprobe.d/{depmod,modprobe}.conf.dist to
  85. {depmod,modprobe}-dist.conf
  86. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-1
  87. - new upstream release
  88. - add BR: zlib-static
  89. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6-1
  90. - new upstream release
  91. - rename to module-init-tools
  92. - Provides: modutils, Obsoletes: modules, modutils-devel
  93. - drop modutils compatibility support
  94. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.2-1vl5
  95. - applied new versioning policy, spec in utf-8
  96. * Mon Oct 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl4
  97. - add Patch102 to build with gcc4
  98. - enable combined-rmmod for insmod.static (initramfs needs rmmod)
  99. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl3
  100. - update modprobe.conf.dist
  101. - load mmc_block when sdhci is loaded
  102. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl2
  103. - enable %%build_small
  104. - add modutils-devel subpackage for internal use.
  105. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl1
  106. - update module-init-tools-3.2.2
  107. - use module-init-tools version for package version
  108. - update modprobe.conf.dist, move to /etc/modprobe.d
  109. - remove "include" statement from /etc/modprobe.conf if found.
  110. * Thu May 6 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.27-0vl1
  111. - new upstream release
  112. - modutils-2.4.27
  113. - module-init-tools-3.0
  114. - import fedora fixes
  115. * Wed May 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-16
  116. - fix sound restoring on module load when done via OSS compat
  117. * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 2.4.26-15
  118. - don't buildreq autoconf-2.13 (#116770)
  119. - sound-slot-0/snd-card-0 hacking-around
  120. * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-14
  121. - modinfo: use new modinfo if passed <foo>.ko
  122. * Tue Mar 23 2004 Steve Dickson <SteveD@RedHat.com>
  123. - Added the mounting of /proc/fs/nfsd to modprobe.conf.dist
  124. so it gets mounted when nfsd is loaded.
  125. * Tue Mar 16 2004 Steve Dickson <SteveD@RedHat.com>
  126. - /var/lib/nfs/rpc_pipefs not /var/lib/rpc_pipes should be
  127. mounted when sunrpc is loaded.
  128. * Fri Mar 12 2004 Steve Dickson <SteveD@RedHat.com>
  129. - umount rpc_pipefs when sunrpc is unloaded
  130. * Thu Mar 11 2004 Bill Nottingham <notting@redhat.com> 2.4.26-9
  131. - add nfsv4 aliases to modprobe.conf.dist
  132. - clean out upstreamed aliases in modprobe.conf.dist
  133. - mount rpc_pipefs when sunrpc is loaded
  134. * Fri Mar 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-7
  135. - blacklist eth1394 (#117383)
  136. * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 2.4.26-6
  137. - update module-init-tools to 3.0pre10
  138. - fix modinfo (#116305)
  139. - always include /etc/modprobe.conf.dist (don't require the line in modprobe.conf)
  140. - ship a static modprobe.conf.dist, don't generate it at build time
  141. - clean up modprobe.conf.dist a little (#113772, #113768)
  142. * Wed Feb 11 2004 Bill Nottingham <notting@redhat.com>
  143. - don't use trampolines in insmod, working around #106005
  144. * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-3
  145. - fix irda (#114268), bluetooth (#114019) and alsa aliases
  146. * Wed Jan 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.26-2vl1
  147. - syncd with fedora
  148. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.26-0vl1
  149. - new upstream release
  150. * Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.25-0vl1
  151. - new upstream release
  152. * Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.22-0vl3
  153. - enable build with dietlibc also on ppc and alpha
  154. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl2
  155. - enable zlib
  156. - remove pre-defined "above"s. it's not needed for Vine Linux.
  157. * Sun Dec 8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl1
  158. - new upstream release
  159. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.20-0vl1
  160. - new upstream release
  161. * Thu Jul 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.16-1vl2
  162. - BuildPreReq: dietlibc for ix86 only
  163. * Tue Jul 09 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.16-1vl1
  164. - new upstream release
  165. * Sun May 05 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.14-1vl2
  166. - rebuild with diet.
  167. - merged with Skipjack.
  168. * Mon Apr 1 2002 Bill Nottingham <notting@redhat.com> 2.4.14-2
  169. - fix support for symbols that contain _R (<streeter@redhat.com>)
  170. * Thu Mar 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.14-1vl1
  171. - source update
  172. * Sat Mar 2 2002 Bill Nottingham <notting@redhat.com> 2.4.14-1
  173. - update to 2.4.14
  174. - take out genksyms.old, no more buildprereq for gperf
  175. * Thu Feb 28 2002 Bill Nottingham <notting@redhat.com> 2.4.13-7/8
  176. - rebuild against diet
  177. - reenable rmmod in the library version, shrink it too
  178. * Wed Feb 27 2002 Bill Nottingham <notting@redhat.com> 2.4.13-5
  179. - rebuild in earlier environments
  180. * Fri Feb 22 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.13-4vl1
  181. - modified for Vine
  182. - merged devel-package with parent package
  183. * Sun Feb 10 2002 Bill Nottingham <notting@redhat.com> 2.4.13-4
  184. - various space shavings in -devel
  185. * Fri Feb 8 2002 Bill Nottingham <notting@redhat.com> 2.4.13-3
  186. - bump rev
  187. - buildprereq gperf
  188. * Mon Feb 4 2002 Bill Nottingham <notting@redhat.com> 2.4.13-1
  189. - update to 2.4.13
  190. - fix GPL symbol export
  191. * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 2.4.12-9
  192. - shrink insmod.static
  193. * Thu Jan 24 2002 Bill Nottingham <notting@redhat.com> 2.4.12-8
  194. - fix installation of extra libraries (#58427)
  195. * Thu Jan 17 2002 Bill Nottingham <notting@redhat.com> 2.4.12-7
  196. - hack to allow depmod of 64bit kernels on 32bit PPC
  197. * Tue Jan 15 2002 Bill Nottingham <notting@redhat.com> 2.4.12-6
  198. - more ppc64 fixes
  199. * Thu Jan 10 2002 Bill Nottingham <notting@redhat.com> 2.4.12-5
  200. - fix build on combined 32/64 targets (ppc/sparc)
  201. * Tue Dec 11 2001 Matt Wilson <msw@redhat.com>
  202. - added a -devel subpackage that contains libraries that apps can use
  203. to implement insmod and rmmod
  204. * Tue Dec 4 2001 Bill Nottingham <notting@redhat.com>
  205. - get rid of some obsolete patches, other tweaks
  206. * Thu Nov 29 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  207. - update to 2.4.12
  208. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  209. - update to 2.4.11
  210. * Tue Oct 2 2001 Bill Nottingham <notting@redhat.com>
  211. - update to 2.4.10
  212. - deprecate -i, -m arguments to depmod
  213. * Tue Sep 25 2001 Bill Nottingham <notting@redhat.com>
  214. - update to 2.4.9
  215. * Wed Aug 29 2001 Bill Nottingham <notting@redhat.com>
  216. - replace modutils-2.4.6-error patch with version that was integrated
  217. upstream
  218. * Sat Aug 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  219. - disable char-major-4 for s390/s390x
  220. * Mon Jul 8 2001 Bill Nottingham <notting@redhat.com>
  221. - remove /etc/cron.d/kmod
  222. * Fri Jul 6 2001 Bill Nottingham <notting@redhat.com>
  223. - update to 2.4.6
  224. - alias binfmt-0000 off (#9709)
  225. - turn off 'modules.conf is more recent than modules.dep' message (#14276,
  226. others)
  227. - return nonzero from depmod if there are errors (#40935)
  228. - fix manpage typo (#33123)
  229. * Thu Jul 05 2001 Karsten Hopp <karsten@redhat.de>
  230. - new S390 patch from IBM
  231. * Tue Jun 26 2001 Elliot Lee <sopwith@redhat.com> 2.4.5-3
  232. - Add modutils-2.4.5-stblocal.patch from Jakub. See the e-mail message
  233. inside the patch file for details.
  234. - Use smp_mflags macro
  235. * Thu Jun 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  236. - add s390/s390x support
  237. * Tue Apr 24 2001 Bill Nottingham <notting@redhat.com>
  238. - update to 2.4.5
  239. * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
  240. - add default post/preun for binfmt_misc
  241. * Mon Feb 19 2001 Bill Nottingham <notting@redhat.com>
  242. - change ipv6 alias to 'alias net-pf-10 off'
  243. * Tue Feb 13 2001 Bill Nottingham <notting@redhat.com>
  244. - add 'net-pf-10 ipv6' alias (#25405)
  245. * Sun Jan 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  246. - change "#ifdef s390" -> "#if defined(__s390__) || defined(__s390x__)"
  247. * Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
  248. - update to 2.4.2
  249. - ship a genksyms.old
  250. * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
  251. - fix ppp aliases
  252. * Tue Jan 9 2001 Bill Nottingham <notting@redhat.com>
  253. - oops, I blew away other people's changes. Fix that.
  254. - only have tty-ldisc-11 in the aliases once
  255. * Mon Jan 8 2001 Bill Nottingham <notting@redhat.com>
  256. - update to 2.4.0
  257. - tweak irda aliases
  258. - remove vixie-cron dependency (it's not *required*)
  259. - add missing %build (where did that go?)
  260. * Sun Jan 7 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  261. - 2.4.0
  262. - Get rid of obsolete char-major-60==ircom-tty patch
  263. (moved to 161)
  264. * Sat Jan 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  265. - add "ctc{0,1,2} -> ctc" alias for s390
  266. * Sat Dec 23 2000 Bill Nottingham <notting@redhat.com>
  267. - add missing comma in alias list
  268. - add irda aliases
  269. * Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
  270. - add char-major-108 ppp_async alias
  271. * Mon Dec 11 2000 Bill Nottingham <notting@redhat.com>
  272. - fix ide-probe aliases (now ide-probe-mod)
  273. * Wed Nov 22 2000 Matt Wilson <msw@redhat.com>
  274. - 2.3.21, fixes more security problems.
  275. * Thu Nov 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  276. - 2.3.20, fixes security holes
  277. * Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  278. - 2.3.19
  279. - add IrDA devices to alias patch
  280. - update source URL
  281. * Thu Oct 26 2000 Bill Nottingham <notting@redhat.com>
  282. - fix ia64 module loading
  283. * Mon Oct 2 2000 Bill Nottingham <notting@redhat.com>
  284. - stupid ia64 tricks
  285. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  286. - upgrade to 2.3.17.
  287. - sparc64 ELF hacks.
  288. * Mon Aug 21 2000 Michael K. Johnson <johnsonm@redhat.com>
  289. - Use %{_mandir} for removing kerneld-related man pages.
  290. * Wed Aug 9 2000 Jakub Jelinek <jakub@redhat.com>
  291. - fix build on SPARC
  292. * Tue Aug 8 2000 Jakub Jelinek <jakub@redhat.com>
  293. - update to 2.3.14
  294. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  295. - update to 2.3.13
  296. - turn psaux off again
  297. - remove sound patch; it's obsolete
  298. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  299. - rebuild to cope with glibc locale binary incompatibility
  300. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  301. - 2.3.12
  302. - fix up ia64
  303. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  304. - automatic rebuild
  305. * Sat Jul 1 2000 Florian La Roche <laroche@redhat.com>
  306. - add aliases for cipcb[0-3]
  307. * Wed Jun 14 2000 Matt Wilson <msw@redhat.com>
  308. - fix build on combined 32/64 bit sparc
  309. * Thu Jun 1 2000 Bill Nottingham <notting@redhat.com>
  310. - modules.confiscation
  311. * Wed May 17 2000 Bill Nottingham <notting@redhat.com>
  312. - add ia64 patch from Intel
  313. * Wed May 17 2000 Jakub Jelinek <jakub@redhat.com>
  314. - fix build with glibc 2.2
  315. * Tue May 09 2000 Doug Ledford <dledford@redhat.com>
  316. - Correct %description to reflect that we don't build kerneld by default
  317. * Fri Apr 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  318. - 2.3.11
  319. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  320. - fix net-pf-* aliases for ipx, appletalk
  321. * Fri Mar 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  322. - 2.3.10
  323. * Thu Feb 17 2000 Matt Wilson <msw@redhat.com>
  324. - added alias for agpgart
  325. * Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
  326. - hardcode psaux alias to off everywhere
  327. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  328. - add a symlink from conf.modules.5 to modules.conf.5
  329. * Fri Jan 29 2000 Bill Nottingham <notting@redhat.com>
  330. - fix breakage *correctly*
  331. * Sat Jan 22 2000 Bill Nottingham <notting@redhat.com>
  332. - fix breakage of our own cause w.r.t sound modules
  333. * Thu Jan 06 2000 Jakub Jelinek <jakub@redhat.com>
  334. - update to 2.3.9.
  335. - port RH patches from 2.1.121 to 2.3.9 where needed.
  336. - disable warning about conf.modules for now, in 7.0
  337. we should move to modules.conf.
  338. * Wed Oct 13 1999 Jakub Jelinek <jakub@redhat.com>
  339. - hardcode psaux alias on sparc to off.
  340. * Tue Oct 05 1999 Bill Nottingham <notting@redhat.com>
  341. - hardcode parport aliases....
  342. * Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
  343. - rebuild against new glibc in the sparc tree
  344. * Wed Sep 15 1999 Jakub Jelinek <jakub@redhat.com>
  345. - rewrite sparckludge so that separate *64 binaries
  346. are not needed anymore.
  347. * Sat Sep 11 1999 Cristian Gafton <gafton@redhat.com>
  348. - apply the last patch in the %prep section (doh!)
  349. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  350. - add support for the ppp compression modules by default
  351. * Tue Apr 13 1999 Michael K. Johnson <johnsonm@redhat.com>
  352. - add cron.d file to run rmmod -as
  353. * Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
  354. - take out kerneld
  355. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  356. - add patch to make all raid personalities recognized
  357. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  358. - auto rebuild in the new build environment (release 7)
  359. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  360. - obsoletes modules
  361. - get rid of the /lib/modules/preferred hack
  362. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  363. - added support for /lib/modules/foo/pcmcia
  364. - make kerneld initscript not start by default
  365. * Tue Feb 23 1999 Matt Wilson <msw@redhat.com>
  366. - added sparc64 support from UltraPenguin
  367. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  368. - call libtoolize to allow it to compile on the arm
  369. * Wed Dec 23 1998 Jeff Johnson <jbj@redhat.com>
  370. - search /lib/modules/preferred before defaults but after specified paths.
  371. * Tue Nov 17 1998 Cristian Gafton <gafton@redhat.com>
  372. - upgraded to version 2.1.121
  373. * Thu Nov 05 1998 Erik Troan <ewt@redhat.com>
  374. - added -m, -i options
  375. * Thu Oct 01 1998 Michael K. Johnson <johnsonm@redhat.com>
  376. - fix syntax error I introduced when enhancing initscript
  377. * Wed Sep 30 1998 Michael K. Johnson <johnsonm@redhat.com>
  378. - enhance initscript
  379. * Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
  380. - recompile statically linked binary for 5.2/sparc
  381. * Tue Jul 28 1998 Jeff Johnson <jbj@redhat.com>
  382. - pick up ultrapenguin patches (not applied for now).
  383. - pre-generate keyword.c so gperf doesn't have to be present (not applied).
  384. - util/sys_cm.c: fix create_module syscall (signed return on sparc too)
  385. * Wed Jul 15 1998 Jeff Johnson <jbj@redhat.com>
  386. - correct %postun typos
  387. * Fri May 01 1998 Erik Troan <ewt@redhat.com>
  388. - added /lib/modules/preferred to search path
  389. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  390. - translations modified for de, fr, tr
  391. * Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
  392. - updated to 2.1.85
  393. - actually make use of the BuildRoot
  394. * Fri Apr 3 1998 Jakub Jelinek <jj@ultra.linux.cz>
  395. - Fix sparc64, add modinfo64 on sparc.
  396. * Wed Mar 23 1998 Jakub Jelinek <jj@ultra.linux.cz>
  397. - Handle EM_SPARCV9, kludge to support both 32bit and 64bit kernels
  398. from the same package on sparc/sparc64.
  399. * Fri Nov 7 1997 Michael Fulbright
  400. - removed warning message when conf.modules exists and is a empty
  401. * Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
  402. - patched to honor -k in options
  403. - added modprobe.1
  404. - added init script
  405. * Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
  406. - removed bogus strip of lsmod (which is a script)
  407. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  408. - updated to 2.1.55
  409. - builds in a buildroot
  410. * Mon Aug 25 1997 Erik Troan <ewt@redhat.com>
  411. - added insmod.static
  412. * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
  413. - built on Intel
  414. - combined rmmod and insmod