monodevelop-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437
  1. Summary: A Full-Featured IDE for Mono and Gtk#
  2. Summary(ja): Gtk# 版 Mono 統合開発環境
  3. Name: monodevelop
  4. Version: 5.9
  5. Release: 1%{?_dist_release}
  6. License: LGPLv2.1 and MIT
  7. Group: Applications/Development
  8. URL: http://www.monodevelop.org/
  9. Source0: http://download.mono-project.com/sources/%{name}/%{name}-%{version}.0.431.tar.bz2
  10. Patch0: downgrade_to_mvc3.patch
  11. # Vine patch(es)
  12. Patch70: monodevelop-5.9-exec.patch
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gconf-sharp2-devel
  16. BuildRequires: gnome-sharp2-devel
  17. BuildRequires: gnome-vfs-sharp2-devel
  18. BuildRequires: gtk-sharp2-devel
  19. BuildRequires: gtksourceview-sharp2-devel
  20. BuildRequires: libgnomeui-devel
  21. BuildRequires: mono-addins-devel
  22. BuildRequires: mono-data
  23. BuildRequires: mono-devel
  24. BuildRequires: mono-mvc-devel
  25. BuildRequires: mono-nuget-devel
  26. BuildRequires: mono-wcf-devel
  27. BuildRequires: monodoc
  28. BuildRequires: nunit-devel
  29. BuildRequires: intltool perl-XML-Parser shared-mime-info
  30. BuildRequires: dos2unix shared-mime-info desktop-file-utils
  31. BuildRequires: git
  32. # Mono.Cecil.dll requires rsync after it's build
  33. BuildRequires: rsync
  34. Requires: mono-basic
  35. Requires: mono-web
  36. Requires: nunit
  37. Requires: xsp
  38. Requires: mono-devel
  39. Requires: mono-tools
  40. Requires: git
  41. Requires: pkgconfig
  42. Requires(post,postun): shared-mime-info
  43. %description
  44. MonoDevelop is a full-featured integrated development
  45. environment (IDE) for Mono and Gtk# primarily designed
  46. for C-Sharp and other .NET languages. It allows to quickly
  47. create desktop and ASP.NET Web applications. Support
  48. for Visual Studio file formats eases porting to Linux.
  49. %description -l ja
  50. MonoDevelop は主として C# やその他の .NET 言語向けの、mono 及び Gtk# の
  51. すべての機能を取り込んだ統合 IDE 環境です.デスクトップアプリケーション及び
  52. ASP.NET ウェブアプリケーションを迅速に作成することができます.Visual Studio
  53. 形式のファイルをサポートしており、Linux へのポーティングを簡易にします.
  54. %package devel
  55. Summary: Development files for MonoDevelop
  56. Summary(ja): MonoDevelop の開発用ファイル
  57. Group: Development/Libraries
  58. Requires: monodevelop = %{version}-%{release}
  59. %description devel
  60. This package contains development files for the IDE and plugins.
  61. %prep
  62. %setup -q
  63. %patch0 -p1
  64. %patch70 -p1
  65. %build
  66. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  67. %configure \
  68. --libdir=%{_prefix}/lib \
  69. --disable-update-mimedb \
  70. --disable-update-desktopdb
  71. #./configure \
  72. # --prefix=%{_prefix} \
  73. # --enable-subversion \
  74. # --enable-monoextensions \
  75. # --enable-aspnet \
  76. # --disable-update-mimedb \
  77. # --disable-update-desktopdb
  78. make
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  82. make install DESTDIR=$RPM_BUILD_ROOT \
  83. GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_prefix}/lib"
  84. mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
  85. mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
  86. cp -a %{_prefix}/lib/mono/nuget/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/
  87. cp -a %{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/
  88. ln -s %{_prefix}/lib/mono/nunit/nunit.core.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
  89. ln -s %{_prefix}/lib/mono/nunit/nunit.core.interfaces.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
  90. ln -s %{_prefix}/lib/mono/nunit/nunit.framework.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
  91. ln -s %{_prefix}/lib/mono/nunit/nunit.util.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
  92. rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/locale
  93. %find_lang %{name}
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %post
  97. touch --no-create %{_datadir}/icons/hicolor || :
  98. %postun
  99. if [ $1 -eq 0 ] ; then
  100. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  101. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  102. update-desktop-database -q &> /dev/null
  103. update-mime-database %{_datadir}/mime &> /dev/null
  104. fi
  105. %posttrans
  106. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  107. update-desktop-database -q &> /dev/null
  108. update-mime-database %{_datadir}/mime &> /dev/null
  109. %files -f %{name}.lang
  110. %defattr(-,root,root)
  111. %doc AUTHORS ChangeLog COPYING README
  112. %{_prefix}/bin/*
  113. %{_prefix}/lib/monodevelop
  114. %{_datadir}/applications/monodevelop.desktop
  115. %{_datadir}/mime/packages/monodevelop.xml
  116. %{_datadir}/icons/hicolor/*/apps/monodevelop.png
  117. %{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
  118. %{_mandir}/man1/mdtool.1.gz
  119. %{_mandir}/man1/monodevelop.1.gz
  120. %files devel
  121. %defattr(-,root,root)
  122. %{_datadir}/pkgconfig/monodevelop.pc
  123. %{_datadir}/pkgconfig/monodevelop-core-addins.pc
  124. %changelog
  125. * Tue May 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.9-1
  126. - new upstream release
  127. - added Patch0 from OpenSUSE
  128. - added Patch70 for launching monodevelop
  129. - split pkgconfig file into devel subpackage
  130. * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-2
  131. - rebuilt with mono-2.10.1-3
  132. * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
  133. - updated monodevelop to 2.4.2
  134. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  135. - rebuild with mono-addins-0.5
  136. * Thu Jun 17 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-1
  137. - updated monodevelop to 2.4
  138. - changed source url
  139. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.2-1
  140. - updated monodevelop to 2.2.2
  141. * Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
  142. - updated monodevelop to 2.2
  143. - changed licencse to LGPL2.1
  144. * Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
  145. - added description in japanease
  146. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
  147. - rebuilt with latest rpm to update mono-dependencies
  148. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
  149. - changed Group to Applications/Development
  150. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  151. - updated monodevelop to 2.0
  152. * Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
  153. - updated monodevelop to 1.9.1
  154. - rebuilt with mono-2.0.1
  155. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
  156. - initial build for VineSeed
  157. - applied vine versioning policy
  158. - added japanese summary
  159. - spec in utf-8
  160. * Wed Apr 9 2008 wberrier@suse.de
  161. - Remove vte-sharp2 from build requires. It's not needed,
  162. and that package doesn't exist anymore.
  163. * Wed Mar 26 2008 wberrier@suse.de
  164. - Update to 1.0
  165. - Bug fixes:
  166. - MD Crashes when you drag a menu inside its own submenu
  167. (bnc#363865)
  168. - Monodevelop and stetic destroy forms (bnc#362596)
  169. - Problem with subclassing any container widget (bnc#361650)
  170. - Version Control doesn't behave propertly (bnc#363858)
  171. - Comment and uncomment function (bnc#325469)
  172. - Create Package fails on projects with translations (bnc#362567)
  173. - Exception with null arguments or nonexistant paths when
  174. compiling/cleaning C project (bnc#361045)
  175. - MonoDevelop crashes when creating/opening C++ Console Project
  176. (bnc#359567)
  177. - Build Output autohide button missing (bnc#368436)
  178. - Have to hit esc twice to close the file/new file dialog
  179. (bnc#358361)
  180. - Changes in 0.19 (1.0 RC1)
  181. - Will use 2.0 runtime as default
  182. - Icons have been tango-ified
  183. - More than 85 bugs fixed
  184. * Mon Jan 14 2008 wberrier@suse.de
  185. - Fixed .desktop file to adhear to standards
  186. - Fix naming of Slovenian translation
  187. - Update to 0.18
  188. - packaging split (database, boo, and java in separate packages)
  189. - Improved Dock Manager
  190. - Circa 75 bugfixes
  191. - Update to 0.17
  192. - Deployment of ASP.NET projects
  193. - Support for VS 2005 Web Application projects
  194. - ASP.NET Codebehind Generation Improvements
  195. - Generation of Satellite Assemblies
  196. - Makefile generation improvements
  197. - Various other IDE enhancements
  198. - Circa 90 bugfixes
  199. * Wed Oct 10 2007 wberrier@suse.de
  200. - Don't use fdupes afterall (fails build)
  201. * Tue Oct 9 2007 wberrier@suse.de
  202. - Update to 0.16
  203. - C/C++ Support
  204. - New Database Add-in
  205. - Text editor improvements
  206. - On-the-fly error underlining
  207. - Auto-generation of XML comment tags
  208. - New ASP.NET features
  209. - Multiple GTK# versions
  210. - ChangeLog add-in
  211. - More than 100 bugs fixed
  212. * Mon Sep 24 2007 wberrier@suse.de
  213. - monodevelop-fix_kde_crash_r86138.patch: fix #309204
  214. * Fri Aug 3 2007 maw@suse.de
  215. - Use %%fdupes.
  216. * Fri Aug 3 2007 wberrier@suse.de
  217. - Remove upstream monodevelop-rename_ja_JP.patch
  218. - Update to 0.15
  219. - Configurable keybindings
  220. - Output pad pinning
  221. - Makefile integration
  222. - Standard header support for source files
  223. - Localization add-in preview
  224. - Text editor improvements
  225. - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
  226. - Assembly signing
  227. - Message log for internal messages
  228. - More than 60 bugs fixed
  229. * Thu Jun 14 2007 wberrier@novell.com
  230. - Put ja_JP locale files in valid location
  231. (monodevelop-rename_ja_JP.patch)
  232. - Update to 0.14
  233. - Improved Toolbox and Properties pad
  234. - Subversion add-in updates
  235. - auth prompts
  236. - supports newer versions of subversion
  237. - New refactory operations:
  238. - rename
  239. - implement interface
  240. - encapsulate field
  241. - Search by filename or classname in Open Solution File Dialog
  242. - New class and member selector when browsing source
  243. - Improved smart indenting for C#
  244. - Project export/conversion
  245. - Packaging features: automatic bundling of an app
  246. - Desktop integration: automatically generate shell wrappers,
  247. .desktop and .pc files
  248. - Improved New Project dialog
  249. - New Navigation Toolbar
  250. - Gtk# Designer updates:
  251. - better widget defaults
  252. - supports internal and custom widgets
  253. - images assigned to widgets are automatically added to project
  254. - Can add file to project while creating them
  255. - Improved VS2005 support and VS integration
  256. - VB.Net support utilizes new vbnc compiler
  257. - Close to 100 bugs fixed
  258. * Wed May 16 2007 wberrier@novell.com
  259. - Remove gtkhtml2-devel from BuildRequires (not needed, allows
  260. building on sle10)
  261. * Tue Apr 24 2007 wberrier@novell.com
  262. - Depend on version of boo found at build time
  263. * Fri Apr 13 2007 wberrier@novell.com
  264. - add %%debug_package so debug packages get created
  265. * Wed Apr 11 2007 wberrier@novell.com
  266. - Add mono dep/req for older distros
  267. * Thu Apr 5 2007 wberrier@suse.de
  268. - Update to 0.13.1:
  269. - Bugfix release to fix some asp.net compilation issues
  270. - Adapt for buildservice
  271. - Clean up unnecessary BuildRequires
  272. * Thu Mar 1 2007 wberrier@suse.de
  273. - Update to 0.13:
  274. - More than 70 bugs fixed
  275. - Revamped VersionControl addin
  276. - New task view features (TODO type lists)
  277. - Code completion improvements and fixes
  278. - Native support for VisualStudio 2005 Project files
  279. - Custom commands in projects
  280. - Makefile integration
  281. - New Generic Project Type
  282. - New Deployment infrastruction
  283. - Automatic project reloading when changes in files detected
  284. while the project is open
  285. - Gtk# designer improvements (Undo/Redo support)
  286. - Context sensitive help for classes when F1 is pressed
  287. - Support for Win32Icon and Win32Resource options in C# projects
  288. - New Layout toolbar which includes a combobox for fast layout
  289. switching
  290. - Support for files outside of a project directory
  291. - Editor wrap mode selector
  292. - File viewer selector (possible to have multiple viewers for
  293. a filetype)
  294. - Improvements in ASP.NET support:
  295. - added a new option that can be used to disable compilation-time
  296. CodeBehind verification for different configurations
  297. - Several important stability fixes in AspNetEdit
  298. - Improvements to toolbox, now includes default items with icons
  299. - New Go to Type dialog, for easily jumping to a class defined
  300. in a project
  301. * Mon Jan 22 2007 ro@suse.de
  302. - drop requires for gnome-filesystem
  303. * Wed Jan 3 2007 wberrier@suse.de
  304. - handle mime files properly
  305. - spec file fixes from Andreas Hanke to fix bnc #225812
  306. * Thu Oct 19 2006 ro@suse.de
  307. - added mono-devel to buildrequires
  308. * Tue Sep 5 2006 wberrier@suse.de
  309. - Update to 0.12
  310. - Better code completion support, supports C# 2.0
  311. - Class information is shown using the syntax of the current
  312. language
  313. - New "Open With" Menu
  314. - stetic menu designer
  315. - autotools project support
  316. - additional addin management features
  317. - Support for multiple text file encodings
  318. - ASP.NET Support
  319. - Lots of bug fixes and better stability
  320. * Wed Aug 30 2006 wberrier@suse.de
  321. - Add mono-nunit to BuildRequires
  322. * Mon Jul 31 2006 wberrier@suse.de
  323. - Update to 0.11
  324. - Lots of new features and fixes, too many to list here. One big
  325. addition is the stetic gui designer integration
  326. - 2.4.0 -> 2.8.0 hack now unnecessary
  327. * Sun Mar 26 2006 ro@suse.de
  328. - removed ifarch from noarch package
  329. * Fri Mar 24 2006 wberrier@suse.de
  330. - Require mono-basic so that vbnet templates will compile
  331. * Wed Mar 15 2006 wberrier@suse.de
  332. - Update references for gtk# 2.4 to 2.8 in template files
  333. * * Otherwise all the gtk#2 template projects will fail to compile **
  334. * Mon Mar 13 2006 wberrier@suse.de
  335. - Remove mime.cache and quote update_desktop args
  336. * Fri Feb 17 2006 gekker@suse.de
  337. - fixup desktop file for UI team
  338. * Wed Feb 1 2006 aj@suse.de
  339. - Fix Requires and BuildRequires to build again.
  340. * Wed Jan 25 2006 mls@suse.de
  341. - converted neededforbuild to BuildRequires
  342. * Fri Jan 13 2006 gekker@suse.de
  343. - Fixup nfb and Requires for new gtk-sharp2 packaging
  344. * Mon Jan 9 2006 gekker@suse.de
  345. - Fix to build against new mono version 1.1.13
  346. * Mon Dec 12 2005 wberrier@suse.de
  347. - Convert to noarch package, and clean up build deps
  348. * Tue Nov 29 2005 wberrier@suse.de
  349. - Update to 0.9 (which obsoletes the version control patch)
  350. * Fri Nov 18 2005 wberrier@suse.de
  351. - Patch VersionControl AddIn to compile with mcs 1.1.10
  352. * Mon Nov 7 2005 sbrabec@suse.cz
  353. - Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
  354. * Tue Oct 25 2005 ro@suse.de
  355. - remove mono-debugger from nfb for the moment
  356. * Thu Oct 20 2005 ro@suse.de
  357. - rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
  358. * Thu Oct 13 2005 wberrier@suse.de
  359. - Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
  360. * Thu Sep 22 2005 ro@suse.de
  361. - remove libgdiplus-devel from nfb (dropped)
  362. * Tue Sep 13 2005 gekker@suse.de
  363. - Disable boo support so monodevelop will run (113802)
  364. * Sun Sep 4 2005 aj@suse.de
  365. - Update check-build.sh.
  366. * Tue Aug 30 2005 ro@suse.de
  367. - do not require mono-debugger on ppc (can not build there)
  368. * Fri Aug 26 2005 ro@suse.de
  369. - nfb: monodoc -> monodoc-core
  370. * Thu Aug 18 2005 gekker@suse.de
  371. - Fix desktop category for menus.
  372. * Tue Aug 16 2005 aj@suse.de
  373. - Add check-build script.
  374. * Tue Aug 9 2005 gekker@suse.de
  375. - Fix requirements
  376. - Remove files that conflict with shared-mime-info
  377. - Verify that bugs #71734 and #71735 are fixed
  378. * Sun Aug 7 2005 ro@suse.de
  379. - rename nfb and deps for gtksourceview-sharp and gecko-sharp
  380. * Thu Aug 4 2005 gekker@suse.de
  381. - Update to version 0.7
  382. - Remove upstreamed patches
  383. * Wed May 18 2005 gekker@suse.de
  384. - fix to build with mono-1.1.7
  385. * Tue Mar 1 2005 gekker@suse.de
  386. - fix requires (66770).
  387. * Tue Feb 15 2005 ro@suse.de
  388. - fix build on x86_64
  389. * Tue Feb 8 2005 gekker@suse.de
  390. - Add patches to fix namespacing issues.
  391. - Add suse_update_desktop_config
  392. * Mon Dec 13 2004 clahey@suse.de
  393. - New package.