opensource-cobol-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. %define pkg_name opensource-cobol
  2. %define pkg_version 1.5.1J
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: An open-source COBOL compiler
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPLv2
  9. Group: Development/Languages
  10. URL: https://www.osscons.jp/
  11. Source0: %{name}-%{version}-utf8.tar.gz
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. %if %{?_dist_release} == "vl6"
  14. BuildRequires: db4-devel
  15. %else
  16. BuildRequires: libdb-devel
  17. %endif
  18. BuildRequires: gmp-devel
  19. BuildRequires: ncurses-devel
  20. BuildRequires: texinfo
  21. BuildRequires: texlive-common
  22. %if %{?_dist_release} == "vl6"
  23. BuildRequires: texlive-collection-texinfo
  24. %else
  25. BuildRequires: texlive-collection-plainextra
  26. BuildRequires: texlive-collection-fontsrecommended
  27. %endif
  28. Requires: ncurses-devel
  29. %if %{?_dist_release} == "vl6"
  30. Requires: db4-devel
  31. %else
  32. Requires: libdb-devel
  33. %endif
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: ara_t
  37. %description
  38. "opensource COBOL" is open-source COBOL compiler,
  39. an extension of the Japan-specific features.
  40. "opensource COBOL" translates COBOL program to C code
  41. and compiles it using GCC or CL.
  42. It was forked from OpenCOBOL in 2012.
  43. See also OpenCOBOL project.
  44. http://www.opencobol.org/
  45. http://sourceforge.net/projects/open-cobol/
  46. %description -l ja
  47. opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
  48. COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
  49. コンパイルします。
  50. opensource COBOLは、オープンCOBOLソリューション部会によって
  51. OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
  52. メンテナンスを加えたものです。
  53. %prep
  54. %{__rm} -rf ${RPM_BUILD_ROOT}
  55. %setup -q -n %{name}-%{version}-utf8
  56. %build
  57. # %if %{?_dist_release} >= "vl7"
  58. # export CFLAGS="%{optflags} -std=gnu89"
  59. # %endif
  60. %{configure} \
  61. --enable-utf8 \
  62. --disable-static
  63. %{__make} %{?_smp_mflags}
  64. %{__make} pdf html
  65. %check
  66. %{__make} check
  67. %install
  68. %{make_install}
  69. %{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
  70. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  71. %clean
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %post
  74. %{_syssbindir}/install-info %{_infodir}/open-cobol.info.gz \
  75. %{_infodir}/dir 2>/dev/null
  76. %{_syssbindir}/ldconfig
  77. %preun
  78. if [ $1 = 0 ]; then
  79. %{_syssbindir}/install-info --delete %{_infodir}/open-cobol.info.gz \
  80. %{_infodir}/dir 2>/dev/null
  81. fi
  82. %postun -p %{_syssbindir}/ldconfig
  83. %files
  84. %defattr(-,root,root)
  85. %doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
  86. %doc texi/open-cobol.pdf
  87. %doc texi/open-cobol.html/
  88. %{_bindir}/
  89. %{_includedir}/libcob.h
  90. %{_includedir}/libcob
  91. %{_libdir}/libcob.so*
  92. %{_datadir}/locale/
  93. %{_datadir}/%{name}-%{version}
  94. %{_infodir}/*.info.gz
  95. %changelog
  96. * Mon Dec 12 2016 Toshiaki Ara <ara_t@384.jp> 1.5.1J-1
  97. - new upstream release
  98. * Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-3
  99. - change Group to Development/Languages
  100. * Fri Jul 29 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-2
  101. - change Requires: ncurses to ncurses-devel
  102. - change Requires: db4/libdb to db4-devel/libdb-devel
  103. - add export CFLAGS="%{optflags} -std=gnu89" for VineSeed (gcc-5)
  104. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-1
  105. - update to 1.5.0J
  106. - delete BuildRequires: texlive-collection-lang*
  107. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
  108. - rebuild under texlive 2016 pretest
  109. - add BuildRequires
  110. * Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
  111. - new package