rhythmbox-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 3.3.1
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/${name}/3.3/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk3-devel
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: gstreamer1-plugins-base-devel
  20. BuildRequires: json-glib-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libgnome-keyring-devel >= 2.30.0
  23. BuildRequires: libgpod-devel
  24. BuildRequires: eudev-libgudev1-devel
  25. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  26. BuildRequires: libnotify-devel
  27. BuildRequires: libsoup-devel
  28. BuildRequires: pygobject3-devel
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: WebKit3-gtk-devel
  31. BuildRequires: libpeas-devel
  32. BuildRequires: libsecret-devel
  33. BuildRequires: clutter-gtk-devel
  34. BuildRequires: clutter-gst-devel
  35. BuildRequires: libmx-devel
  36. BuildRequires: check-devel
  37. BuildRequires: libmtp-devel
  38. BuildRequires: libtdb-devel
  39. BuildRequires: grilo-devel
  40. BuildRequires: libdmapsharing-devel
  41. BuildRequires: lirc-devel
  42. BuildRequires: gnome-doc-utils >= 0.3.2
  43. BuildRequires: yelp-tools
  44. Requires: brasero
  45. Requires: libgnome-keyring
  46. %if %{enable_DLNA_UPnP}
  47. Requires: python-Coherence
  48. %endif
  49. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  50. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  51. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  52. # # respectively.
  53. # Requires: self-build-gstreamer-plugins-ffmpeg
  54. # Requires: self-build-gstreamer-plugins-ugly
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. %description
  58. Rhythmbox is an integrated music management application based on the powerful
  59. GStreamer media framework. It has a number of features, including an easy to
  60. use music browser, searching and sorting, comprehensive audio format support
  61. through GStreamer, Internet Radio support, playlists and more.
  62. Rhythmbox is extensible through a plugin system.
  63. %description -l ja
  64. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  65. 統合音楽管理アプリケーションです。
  66. 見やすいユーザインターフェースを備え、検索や整列ができ、
  67. GStreamer により数多くの音声フォーマットをサポート、
  68. インターネットラジオをサポート、プレイリスト管理などの
  69. 数多くの特徴を持ちます。
  70. %package devel
  71. Summary: Development tools for rhythmbox applications.
  72. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: pkgconfig
  76. Requires: libxml2-devel
  77. Requires: glib2-devel
  78. Requires: gtk3-devel
  79. Requires: libsoup-devel
  80. Requires: totem-pl-parser-devel
  81. Requires: gstreamer1-devel
  82. %description devel
  83. Header files and libraries for building a extension library for the rhythmbox.
  84. %description devel -l ja
  85. %prep
  86. %setup -q
  87. tar xjf %{SOURCE101}
  88. %build
  89. autoreconf -if
  90. intltoolize --force --copy
  91. %configure --with-ipod \
  92. --with-mtp \
  93. --enable-lirc \
  94. --disable-python \
  95. --disable-vala \
  96. --disable-browser-plugin \
  97. --disable-static \
  98. --enable-browser-plugin \
  99. --without-hal
  100. %__make %{?_smp_mflags}
  101. %install
  102. %__rm -rf $RPM_BUILD_ROOT
  103. %__make install DESTDIR=$RPM_BUILD_ROOT
  104. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  105. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  106. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  107. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  108. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  109. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  111. ## Don't package DLNA/UPnP plugin
  112. %if !%{enable_DLNA_UPnP}
  113. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  114. %endif
  115. %find_lang %{name} --all-name --with-gnome
  116. # Don't package api docs
  117. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  118. # And don't package vala
  119. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  120. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  121. # remove sample plugins
  122. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  123. %clean
  124. %__rm -rf $RPM_BUILD_ROOT
  125. %post
  126. /sbin/ldconfig
  127. update-desktop-database -q
  128. touch --no-create %{_datadir}/icons/hicolor
  129. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  130. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  131. fi
  132. %postun
  133. /sbin/ldconfig
  134. update-desktop-database -q
  135. touch --no-create %{_datadir}/icons/hicolor
  136. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  137. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  138. fi
  139. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  140. %posttrans
  141. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  142. %files -f %{name}.lang
  143. %defattr(-, root, root)
  144. %doc AUTHORS COPYING ChangeLog README NEWS
  145. %{_bindir}/*
  146. %{_libdir}/girepository-1.0/*.typelib
  147. %{_libdir}/lib*.so.*
  148. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  149. %{_libdir}/rhythmbox/plugins
  150. %{_datadir}/appdata/rhythmbox.appdata.xml
  151. %{_datadir}/applications/rhythmbox.desktop
  152. %{_datadir}/applications/rhythmbox-device.desktop
  153. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  154. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  155. %{_datadir}/icons/*
  156. %{_datadir}/rhythmbox
  157. %{_mandir}/man1/*
  158. %{_libexecdir}/rhythmbox-metadata
  159. %files devel
  160. %defattr(-, root, root)
  161. %{_includedir}/%{name}/*
  162. %{_libdir}/*.so
  163. %{_libdir}/pkgconfig/*.pc
  164. %{_datadir}/gir-1.0/*.gir
  165. %changelog
  166. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
  167. - new upstream release
  168. - add BuildRequires: libsecret-devel, lirc-devel
  169. - remove Patch0 (rhythmbox-3.0-disable-python3.patch)
  170. * Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.1-2
  171. - rebuilt with libimobiledevice 1.2.0 and libplist 1.12
  172. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  173. - new upstream release
  174. * Sat Apr 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
  175. - new upstream release
  176. * Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
  177. - rebuild with new libimobiledevice
  178. * Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  179. - new upstream release
  180. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  181. - new upstream release
  182. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
  183. - rebuild with VineSeed environment
  184. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  185. - new upstream release
  186. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  187. - new upstream release
  188. - add Patch0 (rhythmbox-3.0-disable-python3.patch)
  189. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
  190. - new upstream release
  191. - add BuildRequies: yelp-tools
  192. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  193. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  194. - rebuild with libimobiledevice-1.1.5
  195. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  196. - new upstream release
  197. - add BuildRequires: grilo-devel, libdmapsharing-devel
  198. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  199. - new upstream release
  200. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  201. - new upstream release
  202. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  203. - new upstream release
  204. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  205. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  206. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  207. - rebuild with cogl-0.8.0
  208. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  209. - rebuild with libnotify-0.7
  210. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  211. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  212. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  213. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  214. - add Source101 (rhythmbox-png.tar.bz2)
  215. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  216. - add BuildRequires: json-glib-devel
  217. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  218. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  219. - new upstream release
  220. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  221. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  222. - new upstream release
  223. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  224. - rebuild with brasero-2.32.0
  225. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  226. - rebuild with rpm-4.8.1 for pkg-config file
  227. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  228. - new upstream release
  229. - fix %files (add rhythmbox-device.desktop)
  230. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  231. - new upstream release
  232. - change BuildRequires: gnome-media-devel instead of gnome-media
  233. - add devel package
  234. - drop Patch0
  235. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  236. - new upstream release
  237. - drop Patch1, Patch2, Patch3
  238. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  239. - change Requires: nautilus-cd-burner -> brasero
  240. - change BuildRequires: hal-devel -> libgudev1-devel
  241. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  242. - change Requires: gnome-keyring -> libgnome-keyring
  243. - add configure option (--without-hal)
  244. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  245. - rebuilt with new environment
  246. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  247. - new upstream release
  248. - dropped upstreamed/obsolete patches
  249. - added patches applied Fedora development
  250. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  251. - new upstream release
  252. - added configure options:
  253. --disable-vala
  254. --disable-browser-plugin
  255. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  256. - added Japanese description
  257. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  258. - new upstream release
  259. - dropped rb-disable-power-plugin-by-default.patch
  260. - added BuildRequires:
  261. - libSM-devel
  262. - gnome-media
  263. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  264. - rebuild with libgpod-0.7.2
  265. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  266. - new upstream release
  267. - corrected License tag
  268. - dropped rhythmbox-0.11.6-libmtp.patch
  269. - added BuildRequires:
  270. - sqlite3-devel
  271. - libffi-devel
  272. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  273. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  274. - applied rhythmbox-0.11.6-libmtp.patch
  275. - added Requires:
  276. - libgpod
  277. - libnotify
  278. - libsexy
  279. - lirc
  280. - libmtp
  281. - libgnomeui
  282. - nautilus-cd-burner
  283. - gstreamer-python
  284. - gnome-vfs2
  285. - gnome-themes
  286. - gnome-keyring
  287. - python-Coherence, if enable_DLNA_UPnP = 1
  288. - added BuildRequires:
  289. - libnotify-devel
  290. - libsexy-devel
  291. - lirc
  292. - libmtp-devel
  293. - gnome-vfs2-devel, instead of gnome-vfs2
  294. - gnome-keyring-devel
  295. - dropped --with-internal-libsexy in configure options
  296. - added in configure options:
  297. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  298. - added %%preun to remove the schema
  299. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  300. - new upstream release
  301. - changed to --with-metadata-helper in configure options
  302. - added BuildRequires:
  303. - gstreamer-python
  304. - intltool >= 0.35.0
  305. - popt-devel
  306. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  307. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  308. - rebuilt with python-2.5.2
  309. - applied new versioning policy
  310. - spec in utf-8
  311. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  312. - rebuilt with libgpod-0.6.0
  313. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  314. - new upstream release
  315. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  316. - new upstream release
  317. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  318. - rebuilt with new toolchain and libgpod-0.4.2
  319. - add BuildRequires: dbus-glib-devel
  320. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  321. - new upstream release
  322. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  323. - rebuilt for VineSeed
  324. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  325. - new upstream release
  326. - added --enable-python option to %%configure
  327. - added Requires: gnome-python
  328. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  329. - new upstream release
  330. - built with libsoup 2.2.99
  331. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  332. - added --with-cd-burner to configure
  333. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  334. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  335. - add BuildRequires:
  336. - gnome-doc-utils >= 0.3.2
  337. - python-devel
  338. - pygtk2-devel
  339. - check >= 0.8.2
  340. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  341. - rebuild with gnutls-1.4.1
  342. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  343. - new upstream release
  344. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  345. - new upstream release
  346. - run scrollkeeper-update at %post and %postun
  347. - added BuildRequires: libnotify-devel
  348. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  349. - new upstream release (dropped patch0)
  350. - added --without-metadata-helper at configure
  351. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  352. - Initial build for Vine Linux based on FC pacakge
  353. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  354. - add patch from James "Doc" Livingston to stop a hang
  355. for new users (bug 183883)
  356. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  357. - bump again for double-long bug on ppc(64)
  358. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  359. - rebuilt for new gcc4.1 snapshot and glibc changes
  360. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  361. - Update to 0.9.3.1
  362. - Use gstreamer (0.10)
  363. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  364. - Remove hack for 173869, as its no longer needed.
  365. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  366. - 0.9.3
  367. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  368. - Newer CVS snapshot
  369. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  370. - Update to latest CVS
  371. - Add hack to workaround bug #173869
  372. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  373. - Rebuild, now that gstreamer08-plugins has been fixed
  374. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  375. - bonobo multilib issue (bug 156982)
  376. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  377. - rebuild with ipod support
  378. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  379. - rebuilt again
  380. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  381. - rebuilt
  382. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  383. - rebuild
  384. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  385. - rebuild for new dbus
  386. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  387. - Update to 0.9.2
  388. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  389. - Update to 0.9.1
  390. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  391. - Add configure flags --with-bonobo --with-dbus
  392. - BR nautilus-cd-burner-devel
  393. - New upstream CVS snapshot for testing
  394. - Drop IDL file and ui .xml
  395. - Add dbus service file
  396. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  397. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  398. * Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  399. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  400. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  401. cell renderer for playback icon (no longer necessary) and
  402. changes the rating renderer to work with non-b&w icons
  403. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  404. - Rebuild for GCC4
  405. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  406. - New upstream version
  407. - Remove librb-nautilus-context-menu.so, killed upstream
  408. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  409. - PreReq desktop-file-utils >= 0.9
  410. * Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  411. - New upstream version
  412. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  413. - Fix postun to use correct syntax, thanks Nils Philippsen
  414. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  415. - New upstream version
  416. - Call update-desktop-database in post and postun
  417. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  418. - New upstream version
  419. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  420. - rebuilt
  421. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  422. - New upstream version
  423. - Remove backported patches
  424. - Gratuitiously bump various BuildRequires versions
  425. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  426. - Remove code to unregister GConf schema for now (Closes: #122532)
  427. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  428. - Apply tiny patch from 0.8 arch to fix GConf key used
  429. for initial sorting
  430. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  431. - Apply patch from 0.8 arch tree to fix a number of memleaks
  432. * Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  433. - Update to 0.8.3: fixes showstopper bug with internet radio
  434. * Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  435. - Update to 0.8.2
  436. - Fix Source url
  437. - Add smp_mflags
  438. - Bump BuildRequires on gstreamer to 0.8.1
  439. * Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  440. - Uninstall GConf schemas on removal
  441. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  442. - Update to 0.8.1
  443. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  444. - Update to 0.8.0
  445. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  446. - Update to 0.7.2
  447. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  448. - Remove BuildRequires on autoconf and libvorbis-devel
  449. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  450. - New major version - I know we are past major version slush, but
  451. this should have been done two weeks ago along with the GNOME 2.6
  452. upload. As upstream author as well, I believe this version is
  453. good enough for FC2.
  454. - Remove --disable-mp3
  455. - Remove id3, flac variables
  456. - Remove GStreamer major version patch
  457. - Fix typo in description
  458. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  459. - rebuild for new gstreamer
  460. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  461. - update to 0.6.8
  462. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  463. - rebuilt
  464. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  465. - update to 0.6.7
  466. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  467. - rebuilt
  468. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  469. - New upstream version
  470. - Don't re-run the autotools; upstream incorporates newer versions.
  471. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  472. - new version
  473. - remove smp_flags
  474. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  475. - remove the initial iradio channels as they all are mp3 based.
  476. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  477. - Fix category from Development/Libraries to Applications/Multimedia.
  478. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  479. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  480. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  481. - Removed unnecessary date expansion define.
  482. - Updated description, including mp3 reference removal.
  483. - Added libid3tag and flac optional support for convenient rebuild.
  484. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  485. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  486. - new version
  487. - use %{_sysconfdir} instead of /etc
  488. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  489. - rebuilt
  490. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  491. - gave up on other archs for the Beta
  492. - new version
  493. - remove werror and add missing files
  494. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  495. - update to newer cvs snap
  496. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  497. - update to cvs snap
  498. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  499. - use %%(lang)
  500. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  501. - fix post to actually install the schema
  502. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  503. - Added gconf file
  504. - Added i18n directory
  505. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  506. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  507. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  508. - removed bonobo dependency
  509. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  510. - created new spec file