pspp-vl.spec 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. %define pkg_name pspp
  2. %define pkg_version 1.0.1
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A program for statistical analysis of sampled data
  5. Summary(ja): データ統計解析用プログラム
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv3 or later
  10. Group: Applications/Edutainment
  11. URL: http://www.gnu.org/software/pspp/
  12. Source0: http://public.p-knowledge.co.jp/gnu-mirror/pspp/pspp-%{version}.tar.gz
  13. Buildroot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: texinfo
  15. BuildRequires: readline-devel
  16. BuildRequires: gtk3-devel gtksourceview3-devel
  17. BuildRequires: gsl-devel
  18. BuildRequires: plotutils-devel
  19. Requires: gtk3 gtksourceview3
  20. Requires: gsl
  21. Requires: plotutils
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. PSPP is a program for statistical analysis of sampled data.
  26. It is a free replacement for the proprietary program SPSS.
  27. PSPP supports t-tests, ANOVA, GLM, factor analysis, non-parametric tests,
  28. and other statistical features. PSPP produces statistical reports
  29. in plain text, PDF, PostScript, CSV, HTML, SVG, and OpenDocument formats.
  30. PSPP has both text-based and graphical user interfaces.
  31. The PSPP user interface has been translated into a number of languages.
  32. %description -l ja
  33. %{description}
  34. %prep
  35. %{__rm} -rf ${RPM_BUILD_ROOT}
  36. %setup -q
  37. %build
  38. %{configure} \
  39. --disable-static \
  40. --docdir=%{_docdir}/%{name}-%{version}
  41. %{__make} %{?_smp_mflags}
  42. %check
  43. %{__make} check
  44. %install
  45. %{make_install}
  46. %{__rm} ${RPM_BUILD_ROOT}%{_libdir}/pspp/*.la
  47. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  48. %{__cp} AUTHORS COPYING ChangeLog NEWS ONEWS README THANKS TODO \
  49. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  50. # modify desktop file
  51. %{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
  52. ${RPM_BUILD_ROOT}%{_datadir}/applications/pspp.desktop
  53. %clean
  54. %{__rm} -rf ${RPM_BUILD_ROOT}
  55. %post
  56. for doc in pspp pspp-dev; do
  57. file=%{_infodir}/${doc}.info.gz
  58. if [ -e ${file} ]; then
  59. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  60. fi
  61. done
  62. %{_syssbindir}/ldconfig
  63. %preun
  64. if [ $1 = 0 ]; then
  65. for doc in pspp pspp-dev; do
  66. file=%{_infodir}/${doc}.info.gz
  67. if [ -e ${file} ]; then
  68. /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
  69. fi
  70. done
  71. fi
  72. %postun -p %{_syssbindir}/ldconfig
  73. %files
  74. %defattr(-,root,root)
  75. %{_bindir}/
  76. %{_libdir}/pspp/
  77. %{_datadir}/appdata/
  78. %{_datadir}/applications/
  79. %{_datadir}/icons/
  80. %{_datadir}/locale/
  81. %{_datadir}/pspp
  82. %{_infodir}/
  83. %{_mandir}/man1/
  84. %{_docdir}/
  85. %changelog
  86. * Sun Oct 15 2017 Toshiaki Ara <ara_t@384.jp> 1.0.1-1
  87. - new package