yaml-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. %define pkg_name yaml
  2. %define pkg_version 0.9.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Support for parsing and rendering YAML documents
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: transformers-compat-0.6.2.tar.gz
  13. Source12: transformers-compat.cabal
  14. Source13: unliftio-core-0.1.1.0.tar.gz
  15. Source14: unliftio-core.cabal
  16. Source15: vector-algorithms-0.7.0.1.tar.gz
  17. Source16: vector-algorithms.cabal
  18. Source17: exceptions-0.10.0.tar.gz
  19. Source18: exceptions.cabal
  20. Source19: mono-traversable-1.0.8.1.tar.gz
  21. Source20: mono-traversable.cabal
  22. Source21: resourcet-1.2.1.tar.gz
  23. Source22: resourcet.cabal
  24. Source23: conduit-1.3.0.3.tar.gz
  25. Source24: conduit.cabal
  26. Source25: yaml-0.9.0.tar.gz
  27. Source26: yaml.cabal
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildRequires: ghc haskell-platform
  30. BuildRequires: libffi-devel gmp-devel zlib-devel
  31. BuildRequires: libghc-dlist
  32. BuildRequires: libghc-old-locale
  33. BuildRequires: libghc-aeson
  34. BuildRequires: libghc-semigroups
  35. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  36. Requires: ghc haskell-platform
  37. Requires: haskell-platform-dep
  38. Requires: libghc-dlist
  39. Requires: libghc-old-locale
  40. Requires: libghc-aeson
  41. Requires: libghc-semigroups
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. Packager: ara_t
  45. %description
  46. This package includes the full libyaml C library version 0.1.5
  47. by Kirill Simonov in the package so you don't need to worry
  48. about any non-Haskell dependencies.
  49. The package is broken down into two primary modules.
  50. "Data.Yaml" provides a high-level interface based around the JSON datatypes
  51. provided by the @aeson@ package.
  52. "Text.Libyaml" provides a lower-level, streaming interface.
  53. For most users, "Data.Yaml" is recommended.
  54. #'
  55. %prep
  56. %{__rm} -rf ${RPM_BUILD_ROOT}
  57. %build
  58. %ghc_pkg_init
  59. for pkg in `sed '$d' %{SOURCE0}`; do
  60. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  61. pushd ${pkg}
  62. %ghc_fix_dependencies ${pkg}
  63. %cabal_configure2 %{name} ${pkg}
  64. %cabal_build
  65. %cabal_haddock
  66. %cabal_copy_resister %{name}_${pkg}
  67. popd
  68. done
  69. # build yaml
  70. for pkg in `tail -n 1 %{SOURCE0}`; do
  71. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  72. pushd ${pkg}
  73. %ghc_fix_dependencies ${pkg}
  74. %cabal_configure2 %{name}/${pkg} \
  75. -f -no-exe
  76. %cabal_build
  77. %cabal_haddock
  78. %cabal_copy_resister %{pkg_name}-%{version}
  79. popd
  80. done
  81. %install
  82. # copy documents
  83. pushd %{_builddir}/%{pkg_name}-%{version}
  84. %{__cp} ChangeLog.md README.md \
  85. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
  86. popd
  87. %clean
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %post
  90. %ghc_pkg_recache
  91. %postun
  92. %ghc_pkg_recache
  93. %files
  94. %defattr(-, root, root)
  95. %{_bindir}/
  96. %{_libdir}/ghc-%{ghc_version}/
  97. %{_libdir}/ghc-lib/
  98. %{_docdir}/%{name}/
  99. %changelog
  100. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.9.0-1
  101. - update to 0.9.0
  102. - build using ghc-8.4.3
  103. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.8.30-1
  104. - update to 0.8.30
  105. - rebuild using ghc-8.4.2
  106. - rewrite using macro
  107. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.8.25.1-1
  108. - update to 0.8.25.1
  109. - build using ghc-8.2.2
  110. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-2
  111. - build using ghc-8.0.2
  112. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-1
  113. - update to 0.8.21.2
  114. - build using ghc-8.0.1
  115. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-3
  116. - rebuilt
  117. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-2
  118. - correct SPEC file
  119. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-1
  120. - new package