netatalk-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467
  1. %bcond_with systemd
  2. %bcond_with tracker
  3. %global tracker_api 3.0
  4. ################################################# BASIC PACKAGE INFORMATION
  5. Summary: AFP fileserver for Macintosh clients
  6. Summary(ja): Macintoshクライアント向けのAFPファイルサーバー
  7. Name: netatalk
  8. Version: 3.2.0
  9. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  10. Group: servers
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: shaolin, tomop
  14. License: GPLv2+
  15. URL: http://netatalk.sourceforge.net/
  16. %define altver %(echo %{version} | tr . -)
  17. Source0: https://github.com/Netatalk/Netatalk/releases/download/netatalk-%{altver}/netatalk-%{version}.tar.xz
  18. Source1: netatalk.pam-system-auth
  19. Source2: netatalk.conf
  20. Patch1: netatalk-systemd-execstartpre.patch
  21. ############################################################## REQUIREMENTS
  22. BuildRequires: cracklib openssl-devel pam quota libtool automake
  23. BuildRequires: autoconf libdb-devel pam-devel libgcrypt-devel
  24. BuildRequires: avahi-devel libacl-devel openldap-devel
  25. BuildRequires: dbus-devel dbus-glib-devel glib2-devel
  26. BuildRequires: libevent-devel libtdb-devel libmariadb-devel
  27. %if %{with tracker}
  28. BuildRequires: tracker-devel
  29. %endif
  30. Requires: dbus-python3
  31. Requires: dconf
  32. %if %{with systemd}
  33. BuildRequires: systemd
  34. %{?systemd_requires}
  35. %else
  36. Requires(post): /sbin/chkconfig
  37. Requires(preun): /sbin/chkconfig
  38. Requires(preun): /sbin/service
  39. Requires(postun): /sbin/service
  40. %endif
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  42. %description
  43. Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
  44. system running Netatalk is capable of serving many Macintosh clients
  45. simultaneously as an AppleShare file server (AFP).
  46. %description -l ja
  47.  Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
  48. Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
  49. アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
  50. 可能です。
  51. %package devel
  52. Summary: Headers for Netatalk development
  53. Summary(ja): Netatalk開発用ヘッダファイル
  54. Group: programming
  55. %description devel
  56. This package contains the header files for Netatalk.
  57. %debug_package
  58. %prep
  59. %setup -q
  60. %autopatch -p1
  61. autoreconf -fiv
  62. rm -frv libevent/
  63. ln -s ./NEWS ChangeLog
  64. # Avoid re-running the autotools
  65. touch -r aclocal.m4 configure configure.ac macros/gssapi-check.m4
  66. # fix permissions
  67. find include \( -name '*.h' -a -executable \) -exec chmod -x {} \;
  68. # Don't call systemctl daemon-reload during the build
  69. sed -i 's\-systemctl daemon-reload\\g' distrib/initscripts/Makefile.in
  70. %build
  71. %configure \
  72. --disable-silent-rules \
  73. --disable-static \
  74. --enable-shared \
  75. --localstatedir=%{_localstatedir}/lib \
  76. --with-pkgconfdir=%{_sysconfdir}/netatalk \
  77. --with-cracklib \
  78. --with-pam \
  79. --with-shadow \
  80. --with-uams-path=%{_libdir}/netatalk \
  81. --enable-shared \
  82. --enable-krbV-uam \
  83. --enable-overwrite \
  84. --with-gnu-ld \
  85. %if %{with systemd}
  86. --with-lockfile=/run/lock/netatalk/netatalk \
  87. --with-init-style=redhat-systemd \
  88. --with-init-dir=%{_unitdir} \
  89. %else
  90. --with-init-style=redhat-sysv \
  91. %endif
  92. --with-libgcrypt \
  93. --without-libevent \
  94. --without-tdb \
  95. --with-pam-confdir=%{_sysconfdir}/pam.d \
  96. --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d \
  97. -with-spotlight \
  98. %if %{with tracker}
  99. --with-tracker-pkgconfig-version=%{tracker_api}
  100. %endif
  101. make %{?_smp_mflags} all
  102. %install
  103. ### INSTALL (USING "make install") ###
  104. rm -rf ${RPM_BUILD_ROOT}
  105. make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
  106. # install our tmpfiles config
  107. install -Dpm644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/netatalk.conf
  108. # install example config files in doc
  109. mkdir -p config.example
  110. cp -fp config/afp.conf config.example
  111. cp -fp config/extmap.conf config.example
  112. mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
  113. cp -fp %{SOURCE1} config.example
  114. # XXX bad hack until this file is updated in glibc-headers:
  115. rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
  116. # Clean up .a and .la files
  117. find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
  118. find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
  119. # Fix python shebang
  120. sed -i 's\^#!/usr/bin/env python$\#!%{__python3}\' %{buildroot}/usr/bin/afpstats
  121. %clean
  122. rm -rf ${RPM_BUILD_ROOT}
  123. %post
  124. if [ -e /var/netatalk/afp_signature.conf -a ! -e /var/lib/netatalk/afp_signature.conf ]; then
  125. mv -f /var/netatalk/afp_signature.conf /var/lib/netatalk/
  126. fi
  127. if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/lib/netatalk/afp_signature.conf ]; then
  128. mv -f /etc/netatalk/afp_signature.conf /var/lib/netatalk/
  129. fi
  130. if [ -e /var/netatalk/afp_voluuid.conf -a ! -e /var/lib/netatalk/afp_voluuid.conf ]; then
  131. mv -f /var/netatalk/afp_voluuid.conf /var/lib/netatalk/
  132. fi
  133. if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/lib/netatalk/afp_voluuid.conf ]; then
  134. mv -f /etc/netatalk/afp_voluuid.conf /var/lib/netatalk/
  135. fi
  136. %if %{with systemd}
  137. %systemd_post %{name}.service
  138. %else
  139. /sbin/chkconfig --add netatalk
  140. %endif
  141. %preun
  142. %if %{with systemd}
  143. %systemd_preun %{name}.service
  144. %else
  145. if [ "$1" = "0" -o -x /bin/systemctl ] ; then
  146. # check for existence due to renaming initscript
  147. if [ -x %{_initrddir}/netatalk ] ; then
  148. /sbin/service netatalk stop > /dev/null 2>&1
  149. /sbin/chkconfig --del netatalk
  150. fi
  151. fi
  152. %endif
  153. %postun
  154. %if %{with systemd}
  155. %systemd_postun_with_restart %{name}.service
  156. %else
  157. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  158. /sbin/service netatalk condrestart > /dev/null 2>&1 || :
  159. fi
  160. %endif
  161. %files
  162. %defattr(-,root,root)
  163. %license COPYING COPYRIGHT
  164. %doc README.md NEWS
  165. %doc config.example
  166. %if %{with systemd}
  167. %{_unitdir}/netatalk.service
  168. %{_tmpfilesdir}/netatalk.conf
  169. %else
  170. %attr(755,root,root) %{_initrddir}/netatalk
  171. %endif
  172. %dir %{_sysconfdir}/netatalk
  173. %config(noreplace) %{_sysconfdir}/netatalk/afp.conf
  174. %config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
  175. %config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
  176. %config(noreplace) %{_sysconfdir}/pam.d/netatalk
  177. %config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
  178. %{_sbindir}/*
  179. %{_bindir}/*
  180. %exclude %{_bindir}/netatalk-config
  181. %{_mandir}/man*/*
  182. %exclude %{_mandir}/man*/netatalk-config*
  183. %{_datadir}/netatalk
  184. %{_libdir}/*.so
  185. %{_libdir}/*.so.*
  186. %dir %{_libdir}/netatalk
  187. %{_libdir}/netatalk/*.so
  188. %{_localstatedir}/lib/netatalk
  189. %files devel
  190. %defattr(-,root,root)
  191. %license COPYING COPYRIGHT
  192. %dir %{_includedir}/atalk
  193. %attr(0644,root,root) %{_includedir}/atalk/*
  194. %{_datadir}/aclocal/netatalk.m4
  195. %{_bindir}/netatalk-config
  196. %{_mandir}/man*/netatalk-config.1*
  197. %changelog
  198. * Mon Jun 03 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.2.0-1
  199. - new upstream release.
  200. * Fri Oct 06 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.18-1
  201. - new upstream release.
  202. * Sun Sep 17 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.17-1
  203. - new upstream release.
  204. * Tue Sep 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.16-1
  205. - new upstream release.
  206. * Sat Apr 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.15-1
  207. - new upstream release.
  208. * Wed Jan 11 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.14-1
  209. - new upstream release.
  210. * Fri Nov 11 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.13-3
  211. - rebuilt with openldap-2.6.3.
  212. * Thu Nov 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.13-2
  213. - imported Patch4 and 6 from rawhide.
  214. * Thu Nov 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.13-1
  215. - new upstream release.
  216. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-5
  217. - rebuilt with openssl-3.0.0.
  218. * Tue Mar 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-4
  219. - disabled tracker.
  220. * Sat Mar 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-3
  221. - rebuilt with current environment.
  222. - cleaned up BR.
  223. * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-2
  224. - rebuilt with libevent-2.1.11.
  225. - added systemd support (disabled as default).
  226. * Mon Jan 07 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-1
  227. - new upstream release.
  228. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-2
  229. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  230. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-1
  231. - new upstream release.
  232. * Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.9-1
  233. - new upstream release.
  234. - dropped Patch1: fixed in upstream.
  235. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
  236. - added Patch1.
  237. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
  238. - new upstream release.
  239. * Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
  240. - new upstream release.
  241. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
  242. - rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
  243. * Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
  244. - new upstream release.
  245. - added build option 'force_uidgid'.
  246. * Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
  247. - new upstream release
  248. - fix configure options; add missing BRs
  249. * Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
  250. - now back from the upstream confusion (and one more or two...)
  251. new upstream release 2.2.0 at the official site
  252. * Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
  253. - fix Patch10 to follow HAT-san's strong and confident objection
  254. (no need to set ATALK_NAME explicitly in netatalk.conf)
  255. * Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
  256. - new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
  257. - add Source100 to add one missing header file in the tarball
  258. - revise Patch10
  259. - explicitly specify --disable-ddp for the first time
  260. * Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
  261. - new upstream release
  262. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  263. - rebuild with openssl-1.0.0c
  264. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  265. - fix Patch10 & update description - upon HAT-san's suggestions
  266. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  267. - new upstream release
  268. - update Vine patch
  269. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  270. - new upstream release
  271. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  272. - new upstream release
  273. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  274. - rebuilt both for VineSeed / VinePlus-4.0
  275. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  276. - updated to the cjk-6 patch
  277. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  278. - Patch14 updated for db46
  279. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  280. - remove openslp dependency
  281. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  282. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  283. - TODO: remember to revise this fix after VineSeed changes default locale
  284. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  285. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  286. - revise description (thanks HAT-san for pointing this out)
  287. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  288. (without this, uams_* modules won't get .so suffix)
  289. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  290. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  291. (Patch10 now includes all the modifications and more fixes)
  292. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  293. - add patch13 and patch14 for db-4.3.
  294. - move files in %%_libexecdir to %%libdir.
  295. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  296. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  297. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  298. - security fix: added Patch10 (CAN-2004-0974)
  299. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  300. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  301. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  302. - updated to 2.0 with cjk patch
  303. (see the above Patch section for details)
  304. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  305. - merge the patch repairing bug for System 7.5.5
  306. - (patch6 netatalk-1.5.3.oldsys.patch)
  307. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  308. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  309. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  310. - euc and kana patch originally by
  311. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  312. - applied to netatalk-1.5.2 by me
  313. - README.vine
  314. - omit VERSION from doc, omit perl from require
  315. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  316. - this package is removed because the release number duplicated
  317. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  318. - move acleandir.rc to the doc directory, remove executable flag.
  319. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  320. - updated to new upstream release
  321. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  322. - added Japanese Summary for devel and corrected Group
  323. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  324. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  325. (say atd.pid doesn't have anything to do with netatalk!!)
  326. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  327. - updated to new upstream release
  328. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  329. - install man pages into %%{_mandir}
  330. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  331. - let pre script exit 0
  332. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  333. - spec cleanup
  334. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  335. - restart atalk daemons in the %%post section
  336. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  337. - v1.5.1.1-0vl1
  338. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  339. - v1.5.0-0vl1
  340. - release 1.5.0 for sourceforge
  341. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  342. - v1.5pre6-1rh7
  343. - pre-release 6 for sourceforge
  344. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  345. - v1.5pre5-1
  346. - pre-release 5 for sourceforge
  347. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  348. - v1.5pre5-0
  349. - pre-release 5 for sourceforge (prebuild)
  350. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  351. - v1.5pre4-1
  352. - pre-release 4 for sourceforge
  353. - modified/split mandrake spec for redhat 7 build
  354. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  355. - v1.5pre3-1mdk
  356. - pre-release 3 for sourceforge
  357. - moved away from 1.4.99 ...
  358. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  359. - v1.4.99-0.20001108mdk
  360. - pre-release 2 for sourceforge
  361. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  362. - v1.4.99-0.20000927mdk
  363. - pre-release 1 for sourceforge