rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 2.98
  8. Release: 2%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/rhythmbox/2.98/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk3-devel
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  20. BuildRequires: json-glib-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libgnome-keyring-devel >= 2.30.0
  23. BuildRequires: libgpod-devel
  24. BuildRequires: libgudev1-devel
  25. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  26. BuildRequires: libnotify-devel
  27. BuildRequires: libsoup-devel
  28. BuildRequires: pygobject3-devel
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: WebKit3-gtk-devel
  31. BuildRequires: libpeas-devel
  32. BuildRequires: clutter-gtk-devel
  33. BuildRequires: clutter-gst-devel
  34. BuildRequires: libmx-devel
  35. BuildRequires: check-devel
  36. BuildRequires: libmtp-devel
  37. BuildRequires: libtdb-devel
  38. BuildRequires: grilo-devel
  39. BuildRequires: libdmapsharing-devel
  40. BuildRequires: lirc
  41. BuildRequires: gnome-doc-utils >= 0.3.2
  42. Requires: libgpod
  43. Requires: libnotify
  44. Requires: lirc
  45. Requires: libmtp
  46. Requires: brasero
  47. Requires: gnome-themes
  48. Requires: libgnome-keyring
  49. %if %{enable_DLNA_UPnP}
  50. Requires: python-Coherence
  51. %endif
  52. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  53. Requires: scrollkeeper
  54. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  55. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  56. # # respectively.
  57. # Requires: self-build-gstreamer-plugins-ffmpeg
  58. # Requires: self-build-gstreamer-plugins-ugly
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. %description
  62. Rhythmbox is an integrated music management application based on the powerful
  63. GStreamer media framework. It has a number of features, including an easy to
  64. use music browser, searching and sorting, comprehensive audio format support
  65. through GStreamer, Internet Radio support, playlists and more.
  66. Rhythmbox is extensible through a plugin system.
  67. %description -l ja
  68. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  69. 統合音楽管理アプリケーションです。
  70. 見やすいユーザインターフェースを備え、検索や整列ができ、
  71. GStreamer により数多くの音声フォーマットをサポート、
  72. インターネットラジオをサポート、プレイリスト管理などの
  73. 数多くの特徴を持ちます。
  74. %package devel
  75. Summary: Development tools for rhythmbox applications.
  76. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: pkgconfig
  80. Requires: libxml2-devel
  81. Requires: glib2-devel
  82. Requires: gtk3-devel
  83. Requires: libsoup-devel
  84. Requires: totem-pl-parser-devel
  85. Requires: gstreamer-devel
  86. %description devel
  87. Header files and libraries for building a extension library for the rhythmbox.
  88. %description devel -l ja
  89. %prep
  90. %setup -q
  91. tar xjf %{SOURCE101}
  92. %build
  93. # work around a gstreamer bug
  94. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  95. libtoolize --force --copy
  96. autoreconf
  97. %configure --with-ipod \
  98. --with-mtp \
  99. --with-mdns=avahi \
  100. --enable-lirc \
  101. --enable-python \
  102. --disable-vala \
  103. --disable-browser-plugin \
  104. --disable-static \
  105. --disable-scrollkeeper \
  106. --enable-browser-plugin \
  107. --without-hal
  108. %__make %{?_smp_mflags}
  109. %install
  110. %__rm -rf $RPM_BUILD_ROOT
  111. %__make install DESTDIR=$RPM_BUILD_ROOT
  112. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  113. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  114. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  115. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  116. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  117. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  118. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  119. ## Don't package DLNA/UPnP plugin
  120. %if !%{enable_DLNA_UPnP}
  121. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  122. %endif
  123. %find_lang %{name} --all-name --with-gnome
  124. # Don't package api docs
  125. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  126. # Don't package scrollkeeper catalogs
  127. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  128. # And don't package vala
  129. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  130. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  131. # remove sample plugins
  132. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  133. %clean
  134. %__rm -rf $RPM_BUILD_ROOT
  135. %post
  136. /sbin/ldconfig
  137. update-desktop-database -q
  138. scrollkeeper-update -q
  139. touch --no-create %{_datadir}/icons/hicolor
  140. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  141. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  142. fi
  143. %postun
  144. /sbin/ldconfig
  145. update-desktop-database -q
  146. scrollkeeper-update -q
  147. touch --no-create %{_datadir}/icons/hicolor
  148. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  149. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  150. fi
  151. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  152. %posttrans
  153. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  154. %files -f %{name}.lang
  155. %defattr(-, root, root)
  156. %doc AUTHORS COPYING ChangeLog README NEWS
  157. %{_bindir}/*
  158. %{_libdir}/girepository-1.0/*.typelib
  159. %{_libdir}/lib*.so.*
  160. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  161. %{_libdir}/rhythmbox/plugins
  162. %{_datadir}/applications/rhythmbox.desktop
  163. %{_datadir}/applications/rhythmbox-device.desktop
  164. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  165. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  166. %{_datadir}/icons/*
  167. %{_datadir}/rhythmbox
  168. %{_mandir}/man1/*
  169. %{_libexecdir}/rhythmbox-metadata
  170. %files devel
  171. %defattr(-, root, root)
  172. %{_includedir}/%{name}/*
  173. %{_libdir}/*.so
  174. %{_libdir}/pkgconfig/*.pc
  175. %{_datadir}/gir-1.0/*.gir
  176. %changelog
  177. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  178. - rebuild with libimobiledevice-1.1.5
  179. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  180. - new upstream release
  181. - add BuildRequires: grilo-devel, libdmapsharing-devel
  182. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  183. - new upstream release
  184. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  185. - new upstream release
  186. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  187. - new upstream release
  188. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  189. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  190. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  191. - rebuild with cogl-0.8.0
  192. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  193. - rebuild with libnotify-0.7
  194. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  195. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  196. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  197. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  198. - add Source101 (rhythmbox-png.tar.bz2)
  199. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  200. - add BuildRequires: json-glib-devel
  201. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  202. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  203. - new upstream release
  204. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  205. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  206. - new upstream release
  207. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  208. - rebuild with brasero-2.32.0
  209. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  210. - rebuild with rpm-4.8.1 for pkg-config file
  211. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  212. - new upstream release
  213. - fix %files (add rhythmbox-device.desktop)
  214. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  215. - new upstream release
  216. - change BuildRequires: gnome-media-devel instead of gnome-media
  217. - add devel package
  218. - drop Patch0
  219. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  220. - new upstream release
  221. - drop Patch1, Patch2, Patch3
  222. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  223. - change Requires: nautilus-cd-burner -> brasero
  224. - change BuildRequires: hal-devel -> libgudev1-devel
  225. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  226. - change Requires: gnome-keyring -> libgnome-keyring
  227. - add configure option (--without-hal)
  228. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  229. - rebuilt with new environment
  230. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  231. - new upstream release
  232. - dropped upstreamed/obsolete patches
  233. - added patches applied Fedora development
  234. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  235. - new upstream release
  236. - added configure options:
  237. --disable-vala
  238. --disable-browser-plugin
  239. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  240. - added Japanese description
  241. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  242. - new upstream release
  243. - dropped rb-disable-power-plugin-by-default.patch
  244. - added BuildRequires:
  245. - libSM-devel
  246. - gnome-media
  247. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  248. - rebuild with libgpod-0.7.2
  249. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  250. - new upstream release
  251. - corrected License tag
  252. - dropped rhythmbox-0.11.6-libmtp.patch
  253. - added BuildRequires:
  254. - sqlite3-devel
  255. - libffi-devel
  256. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  257. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  258. - applied rhythmbox-0.11.6-libmtp.patch
  259. - added Requires:
  260. - libgpod
  261. - libnotify
  262. - libsexy
  263. - lirc
  264. - libmtp
  265. - libgnomeui
  266. - nautilus-cd-burner
  267. - gstreamer-python
  268. - gnome-vfs2
  269. - gnome-themes
  270. - gnome-keyring
  271. - python-Coherence, if enable_DLNA_UPnP = 1
  272. - added BuildRequires:
  273. - libnotify-devel
  274. - libsexy-devel
  275. - lirc
  276. - libmtp-devel
  277. - gnome-vfs2-devel, instead of gnome-vfs2
  278. - gnome-keyring-devel
  279. - dropped --with-internal-libsexy in configure options
  280. - added in configure options:
  281. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  282. - added %%preun to remove the schema
  283. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  284. - new upstream release
  285. - changed to --with-metadata-helper in configure options
  286. - added BuildRequires:
  287. - gstreamer-python
  288. - intltool >= 0.35.0
  289. - popt-devel
  290. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  291. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  292. - rebuilt with python-2.5.2
  293. - applied new versioning policy
  294. - spec in utf-8
  295. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  296. - rebuilt with libgpod-0.6.0
  297. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  298. - new upstream release
  299. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  300. - new upstream release
  301. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  302. - rebuilt with new toolchain and libgpod-0.4.2
  303. - add BuildRequires: dbus-glib-devel
  304. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  305. - new upstream release
  306. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  307. - rebuilt for VineSeed
  308. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  309. - new upstream release
  310. - added --enable-python option to %%configure
  311. - added Requires: gnome-python
  312. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  313. - new upstream release
  314. - built with libsoup 2.2.99
  315. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  316. - added --with-cd-burner to configure
  317. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  318. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  319. - add BuildRequires:
  320. - gnome-doc-utils >= 0.3.2
  321. - python-devel
  322. - pygtk2-devel
  323. - check >= 0.8.2
  324. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  325. - rebuild with gnutls-1.4.1
  326. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  327. - new upstream release
  328. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  329. - new upstream release
  330. - run scrollkeeper-update at %post and %postun
  331. - added BuildRequires: libnotify-devel
  332. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  333. - new upstream release (dropped patch0)
  334. - added --without-metadata-helper at configure
  335. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  336. - Initial build for Vine Linux based on FC pacakge
  337. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  338. - add patch from James "Doc" Livingston to stop a hang
  339. for new users (bug 183883)
  340. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  341. - bump again for double-long bug on ppc(64)
  342. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  343. - rebuilt for new gcc4.1 snapshot and glibc changes
  344. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  345. - Update to 0.9.3.1
  346. - Use gstreamer (0.10)
  347. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  348. - Remove hack for 173869, as its no longer needed.
  349. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  350. - 0.9.3
  351. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  352. - Newer CVS snapshot
  353. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  354. - Update to latest CVS
  355. - Add hack to workaround bug #173869
  356. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  357. - Rebuild, now that gstreamer08-plugins has been fixed
  358. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  359. - bonobo multilib issue (bug 156982)
  360. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  361. - rebuild with ipod support
  362. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  363. - rebuilt again
  364. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  365. - rebuilt
  366. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  367. - rebuild
  368. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  369. - rebuild for new dbus
  370. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  371. - Update to 0.9.2
  372. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  373. - Update to 0.9.1
  374. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  375. - Add configure flags --with-bonobo --with-dbus
  376. - BR nautilus-cd-burner-devel
  377. - New upstream CVS snapshot for testing
  378. - Drop IDL file and ui .xml
  379. - Add dbus service file
  380. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  381. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  382. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  383. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  384. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  385. cell renderer for playback icon (no longer necessary) and
  386. changes the rating renderer to work with non-b&w icons
  387. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  388. - Rebuild for GCC4
  389. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  390. - New upstream version
  391. - Remove librb-nautilus-context-menu.so, killed upstream
  392. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  393. - PreReq desktop-file-utils >= 0.9
  394. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  395. - New upstream version
  396. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  397. - Fix postun to use correct syntax, thanks Nils Philippsen
  398. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  399. - New upstream version
  400. - Call update-desktop-database in post and postun
  401. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  402. - New upstream version
  403. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  404. - rebuilt
  405. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  406. - New upstream version
  407. - Remove backported patches
  408. - Gratuitiously bump various BuildRequires versions
  409. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  410. - Remove code to unregister GConf schema for now (Closes: #122532)
  411. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  412. - Apply tiny patch from 0.8 arch to fix GConf key used
  413. for initial sorting
  414. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  415. - Apply patch from 0.8 arch tree to fix a number of memleaks
  416. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  417. - Update to 0.8.3: fixes showstopper bug with internet radio
  418. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  419. - Update to 0.8.2
  420. - Fix Source url
  421. - Add smp_mflags
  422. - Bump BuildRequires on gstreamer to 0.8.1
  423. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  424. - Uninstall GConf schemas on removal
  425. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  426. - Update to 0.8.1
  427. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  428. - Update to 0.8.0
  429. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  430. - Update to 0.7.2
  431. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  432. - Remove BuildRequires on autoconf and libvorbis-devel
  433. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  434. - New major version - I know we are past major version slush, but
  435. this should have been done two weeks ago along with the GNOME 2.6
  436. upload. As upstream author as well, I believe this version is
  437. good enough for FC2.
  438. - Remove --disable-mp3
  439. - Remove id3, flac variables
  440. - Remove GStreamer major version patch
  441. - Fix typo in description
  442. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  443. - rebuild for new gstreamer
  444. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  445. - update to 0.6.8
  446. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  447. - rebuilt
  448. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  449. - update to 0.6.7
  450. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  451. - rebuilt
  452. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  453. - New upstream version
  454. - Don't re-run the autotools; upstream incorporates newer versions.
  455. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  456. - new version
  457. - remove smp_flags
  458. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  459. - remove the initial iradio channels as they all are mp3 based.
  460. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  461. - Fix category from Development/Libraries to Applications/Multimedia.
  462. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  463. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  464. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  465. - Removed unnecessary date expansion define.
  466. - Updated description, including mp3 reference removal.
  467. - Added libid3tag and flac optional support for convenient rebuild.
  468. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  469. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  470. - new version
  471. - use %{_sysconfdir} instead of /etc
  472. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  473. - rebuilt
  474. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  475. - gave up on other archs for the Beta
  476. - new version
  477. - remove werror and add missing files
  478. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  479. - update to newer cvs snap
  480. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  481. - update to cvs snap
  482. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  483. - use %%(lang)
  484. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  485. - fix post to actually install the schema
  486. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  487. - Added gconf file
  488. - Added i18n directory
  489. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  490. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  491. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  492. - removed bonobo dependency
  493. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  494. - created new spec file