clutter-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. %define clutter_version 1.18.4
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.18/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: atk-devel
  21. BuildRequires: pkgconfig
  22. BuildRequires: pango-devel
  23. BuildRequires: libXdamage-devel
  24. BuildRequires: libXcomposite-devel
  25. BuildRequires: libXi-devel
  26. BuildRequires: gettext
  27. BuildRequires: gtk-doc
  28. BuildRequires: gobject-introspection-devel >= 0.9.5
  29. BuildRequires: json-glib-devel
  30. BuildRequires: cogl-devel >= 1.18.0
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Takemikaduchi
  34. %description
  35. Clutter is an open source software library for creating fast,
  36. visually rich graphical user interfaces. The most obvious example
  37. of potential usage is in media center type applications.
  38. We hope however it can be used for a lot more.
  39. %description -l ja
  40. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  41. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  42. しかしながら、我々はいろいろな分野で使用されることを願っています。
  43. %package devel
  44. Summary: Clutter development environment
  45. Summary(ja): Clutterの開発環境
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  49. Requires: mesa-libGL-devel
  50. Requires: gobject-introspection-devel
  51. Requires: json-glib-devel
  52. Requires: libXcomposite-devel
  53. Requires: libXi-devel
  54. %description devel
  55. Header files and libraries for building a extension library for the
  56. clutter
  57. %package docs
  58. Summary: Documentation for %{name}
  59. Summary(ja): %{name}用のドキュメント
  60. Group: Documentation
  61. Provides: %{name}-doc = %{version}-%{release}
  62. BuildArch: noarch
  63. Requires: %{name} = %{version}-%{release}
  64. %description docs
  65. Clutter is an open source software library for creating fast,
  66. visually rich graphical user interfaces. The most obvious example
  67. of potential usage is in media center type applications.
  68. We hope however it can be used for a lot more.
  69. This package contains documentation for clutter.
  70. %prep
  71. %setup -q
  72. %patch0 -p1 -b .dso
  73. %build
  74. #%configure --enable-gtk-doc \
  75. # --enable-introspection=yes \
  76. # --disable-silent-rules \
  77. # --enable-xinput \
  78. # --disable-static
  79. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  80. %configure $CONFIGFLAGS \
  81. --enable-introspection=yes \
  82. --disable-silent-rules \
  83. --enable-xinput \
  84. --disable-static
  85. # clutter git ships with some magic to put the git log in shipped tarballs
  86. # which gets listed in files; don't blow up if it's missing
  87. if ! test -f ChangeLog; then
  88. echo "Created from snapshot" > ChangeLog
  89. fi
  90. )
  91. make V=0
  92. %install
  93. rm -rf $RPM_BUILD_ROOT
  94. #make DESTDIR=$RPM_BUILD_ROOT install
  95. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  97. %find_lang %{name}-1.0
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %files -f %{name}-1.0.lang
  103. %defattr(-,root,root,-)
  104. %doc AUTHORS COPYING NEWS README
  105. %{_libdir}/*.so.*
  106. %{_libdir}/girepository-1.0/*.typelib
  107. %files devel
  108. %defattr(-, root, root)
  109. %doc ChangeLog
  110. %{_includedir}/clutter-1.0
  111. %{_libdir}/*.so
  112. %{_libdir}/pkgconfig/*.pc
  113. %{_datadir}/gir-1.0/*.gir
  114. %files docs
  115. %defattr(-, root, root)
  116. %{_datadir}/gtk-doc/html/clutter
  117. %{_datadir}/gtk-doc/html/cally
  118. %changelog
  119. * Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
  120. - new upstream release
  121. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  122. - new upstream release
  123. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  124. - new upstream release
  125. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
  126. - new upstream release
  127. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  128. - new upstream release
  129. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  130. - new upstream release
  131. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  132. - new upstream release
  133. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  134. - new upstream release
  135. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  136. - new upstream release
  137. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  138. - new upstream release
  139. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  140. - new upstream release
  141. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  142. - new upstream release
  143. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  144. - new upstream release
  145. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  146. - new upstream release
  147. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  148. - new upstream release
  149. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  150. - new upstream release
  151. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  152. - new upstream release
  153. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  154. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  155. - new upstream release
  156. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  157. - new upstream release
  158. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  159. - new upstream release
  160. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  161. - new upstream release
  162. - add BuildRequires: cogl-devel
  163. - add "BuildArch: noarch" to doc sub package
  164. - add Patch0 (clutter-fixdso.patch)
  165. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  166. - new upstream release
  167. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  168. - new upstream release
  169. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  170. - new upstream release
  171. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  172. - new upstream release
  173. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  174. - new upstream release
  175. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  176. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  177. - drop Patch0
  178. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  179. - new upstream release
  180. - drop Patch1
  181. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  182. - new upstream release
  183. - add BuildRequires: json-glib-devel
  184. - delete Requires: gir-repository
  185. - delete BuildRequires: gir-repository-devel
  186. - add Requires: json-glib-devel (devel package)
  187. - add Patch0, Patch1
  188. - fix %build
  189. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  190. - rebuild with rpm-4.8.1 for pkg-config file
  191. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  192. - new upstream release
  193. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  194. - new upstream release
  195. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  196. - new upstream release
  197. - add configure option (--enable-xinput)
  198. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  199. - new upstream release
  200. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  201. - new upstream release
  202. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  203. - new upstream release
  204. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  205. - new upstream release
  206. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  207. - new upstream release
  208. - build for Vine Linux
  209. - add Summary(ja)
  210. - fix BuildRoot
  211. - remove Obsolete and Provides
  212. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  213. - Update to 1.0.6
  214. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  215. - Update to 1.0.4, update gobject-introspection requirement
  216. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  217. - Update to 1.0.2
  218. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  219. - Move ChangeLog to -devel to save some space
  220. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  221. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  222. onto the live cd
  223. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  224. - Update to 1.0.0
  225. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  226. - fix bz #507389
  227. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  228. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  229. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  230. - Update to 0.9.8
  231. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  232. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  233. introspection support to clutter (#512260)
  234. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  235. - Update to 0.9.6
  236. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  237. - Update to 0.9.4
  238. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  239. - Update to 0.9.2
  240. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  241. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  242. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  243. - Remove noarch from doc subpackage
  244. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  245. - Added gtk-doc for cogl
  246. - Created doc subpackage
  247. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  248. - Update to 0.8.6
  249. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  250. - Update to 0.8.2
  251. - Removed clutter-0.8.0-clutter-fixed.patch
  252. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  253. - Update to 0.8.0
  254. - Added clutter-0.8.0-clutter-fixed.patch
  255. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  256. - Update to 0.6.4
  257. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  258. - Update to 0.6.2
  259. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  260. - Update to 0.6.0
  261. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  262. - Autorebuild for GCC 4.3
  263. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  264. - Update to 0.4.2
  265. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  266. - Update to 0.4.1
  267. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  268. - Update to 0.3.1
  269. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  270. - Update to 0.2.3
  271. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  272. - Changed buildrequires and requires
  273. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  274. - Fix .spec
  275. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  276. - Fix .spec
  277. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  278. - Initial RPM release