augeas-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. Name: augeas
  2. Version: 1.14.0
  3. Release: 1%{?_dist_release}
  4. Summary: A library for changing configuration files
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: LGPLv2+
  9. URL: http://augeas.net/
  10. # mkdir augeas-x.xx.x
  11. # pushd augeas-x.xx.x/
  12. # git clone --recursive https://github.com/hercules-team/augeas.git .
  13. # ./autogen.sh
  14. # make distclean
  15. # popd
  16. # tar --exclude=".*" -cvf - augeas-x.xx.x | gzip -9 > augeas-x.xx.x.tar.gz
  17. Source0: https://github.com/hercules-team/augeas/archive/refs/tags/release-%{version}.tar.gz#/augeas-%{version}.tar.gz
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  19. BuildRequires: bison flex readline-devel libxml2-devel
  20. Requires: %{name}-libs = %{version}-%{release}
  21. %description
  22. A library for programmatically editing configuration files. Augeas parses
  23. configuration files into a tree structure, which it exposes through its
  24. public API. Changes made through the API are written back to the initially
  25. read files.
  26. The transformation works very hard to preserve comments and formatting
  27. details. It is controlled by ``lens'' definitions that describe the file
  28. format and the transformation into a tree.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Group: programming
  32. Requires: %{name}-libs = %{version}-%{release}
  33. Requires: pkgconfig
  34. %description devel
  35. The %{name}-devel package contains libraries and header files for
  36. developing applications that use %{name}.
  37. %package libs
  38. Summary: Libraries for %{name}
  39. Group: system
  40. %description libs
  41. The libraries for %{name}.
  42. Augeas is a library for programmatically editing configuration files. It parses
  43. configuration files into a tree structure, which it exposes through its
  44. public API. Changes made through the API are written back to the initially
  45. read files.
  46. %package vim
  47. Summary: The macro an syntax files of Augeas for vim.
  48. Group: programming
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: vim-common
  51. %description vim
  52. This package contains macro an syntax files of Augeas for vim.
  53. %debug_package
  54. %prep
  55. %setup -q
  56. sed -i -e '/is_selinux_enabled/a typedef char *security_context_t;' \
  57. gnulib/lib/se-selinux.in.h
  58. %build
  59. %configure --disable-static --without-selinux
  60. make %{?_smp_mflags}
  61. %check
  62. # Disable test-preserve.sh SELinux testing. This fails when run under mock due
  63. # to differing SELinux labelling.
  64. export SKIP_TEST_PRESERVE_SELINUX=1
  65. make %{?_smp_mflags} check || {
  66. echo '===== tests/test-suite.log ====='
  67. cat tests/test-suite.log
  68. exit 1
  69. }
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
  73. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  74. # The tests/ subdirectory contains lenses used only for testing, and
  75. # so it shouldn't be packaged.
  76. rm -r $RPM_BUILD_ROOT%{_datadir}/augeas/lenses/dist/tests
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %files
  80. %defattr(-,root,root,-)
  81. %{_bindir}/augmatch
  82. %{_bindir}/augtool
  83. %{_bindir}/augparse
  84. %{_bindir}/augprint
  85. %{_bindir}/fadot
  86. %dir %{_datadir}/bash-completion
  87. %dir %{_datadir}/bash-completion/completions
  88. %{_datadir}/bash-completion/completions/*
  89. %doc %{_mandir}/man1/*
  90. %files libs
  91. %defattr(-,root,root,-)
  92. # %{_datadir}/augeas and %{_datadir}/augeas/lenses are owned
  93. # by filesystem.
  94. %{_datadir}/augeas/lenses/dist
  95. %{_libdir}/*.so.*
  96. %doc AUTHORS HACKING* INSTALL NEWS README*
  97. %license COPYING
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %{_includedir}/*
  101. %{_libdir}/*.so
  102. %{_libdir}/pkgconfig/augeas.pc
  103. %files vim
  104. %defattr(-,root,root,-)
  105. %{_datadir}/vim/vimfiles/syntax/augeas.vim
  106. %{_datadir}/vim/vimfiles/ftdetect/augeas.vim
  107. %changelog
  108. * Thu Dec 08 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.14.0-1
  109. - new upstream release.
  110. * Mon Oct 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.13.0-1
  111. - new upstream release.
  112. * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-4
  113. - rebuilt with current environment.
  114. - dropped ldconfig scriptlets.
  115. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-3
  116. - rebuilt with current environment.
  117. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-2
  118. - rebuilt with current environment.
  119. * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-1
  120. - new upstream release.
  121. * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.11.0-1
  122. - new upstream release.
  123. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.0-1
  124. - new upstream release.
  125. * Sun Jul 17 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.5.0-1
  126. - new upstream release.
  127. * Thu Nov 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4.0-3
  128. - initial build for Vine Linux.
  129. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  131. * Tue Jun 02 2015 Dominic Cleal <dcleal@redhat.com> - 1.4.0-1
  132. - Update to 1.4.0
  133. * Sat Nov 08 2014 Dominic Cleal <dcleal@redhat.com> - 1.3.0-1
  134. - Update to 1.3.0; remove all patches
  135. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-4
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  137. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  139. * Mon Mar 31 2014 Dominic Cleal <dcleal@redhat.com> - 1.2.0-2
  140. - Add patch for Krb5, parse braces in values (RHBZ#1079444)
  141. * Wed Feb 12 2014 Dominic Cleal <dcleal@redhat.com> - 1.2.0-1
  142. - Update to 1.2.0, add check section
  143. - Update source URL to download.augeas.net (RHBZ#996032)
  144. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  146. * Wed Jun 19 2013 David Lutterkort <lutter@redhat.com> - 1.1.0-1
  147. - Update to 1.1.0; remove all patches
  148. * Tue Jun 18 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-4
  149. - Fix /etc/sysconfig/network (RHBZ#904222).
  150. * Wed Jun 5 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-3
  151. - Don't package lenses in tests/ subdirectory.
  152. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  154. * Fri Jan 4 2013 David Lutterkort <lutter@redhat.com> - 1.0.0-1
  155. - New version; remove all patches
  156. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-4
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  158. * Tue Jan 10 2012 David Lutterkort <lutter@redhat.com> - 0.10.0-3
  159. - Add patches for bugs 247 and 248 (JSON lens)
  160. * Sat Dec 3 2011 Richard W.M. Jones <rjones@redhat.com> - 0.10.0-2
  161. - Add patch to resolve missing libxml2 requirement in augeas.pc.
  162. * Fri Dec 2 2011 David Lutterkort <lutter@redhat.com> - 0.10.0-1
  163. - New version
  164. * Mon Jul 25 2011 David Lutterkort <lutter@redhat.com> - 0.9.0-1
  165. - New version; removed patch pathx-whitespace-ea010d8
  166. * Tue May 3 2011 David Lutterkort <lutter@redhat.com> - 0.8.1-2
  167. - Add patch pathx-whitespace-ea010d8.patch to fix BZ 700608
  168. * Fri Apr 15 2011 David Lutterkort <lutter@redhat.com> - 0.8.1-1
  169. - New version
  170. * Wed Feb 23 2011 David Lutterkort <lutter@redhat.com> - 0.8.0-1
  171. - New version
  172. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-2
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  174. * Mon Nov 22 2010 Matthew Booth <mbooth@redhat.com> - 0.7.4-1
  175. - Update to version 0.7.4
  176. * Thu Nov 18 2010 Richard W.M. Jones <rjones@redhat.com> - 0.7.3-2
  177. - Upstream patch proposed to fix GCC optimization bug (RHBZ#651992).
  178. * Fri Aug 6 2010 David Lutterkort <lutter@redhat.com> - 0.7.3-1
  179. - Remove upstream patches
  180. * Tue Jun 29 2010 David Lutterkort <lutter@redhat.com> - 0.7.2-2
  181. - Patches based on upstream fix for BZ 600141
  182. * Tue Jun 22 2010 David Lutterkort <lutter@redhat.com> - 0.7.2-1
  183. - Fix ownership of /usr/share/augeas. BZ 569393
  184. * Wed Apr 21 2010 David Lutterkort <lutter@redhat.com> - 0.7.1-1
  185. - New version
  186. * Thu Jan 14 2010 David Lutterkort <lutter@redhat.com> - 0.7.0-1
  187. - Remove patch vim-ftdetect-syntax.patch. It's upstream
  188. * Tue Dec 15 2009 David Lutterkort <lutter@redhat.com> - 0.6.0-2
  189. - Fix ftdetect file for vim
  190. * Mon Nov 30 2009 David Lutterkort <lutter@redhat.com> - 0.6.0-1
  191. - Install vim syntax files
  192. * Mon Sep 14 2009 David Lutterkort <lutter@redhat.com> - 0.5.3-1
  193. - Remove separate xorg.aug, included in upstream source
  194. * Tue Aug 25 2009 Matthew Booth <mbooth@redhat.com> - 0.5.2-3
  195. - Include new xorg lens from upstream
  196. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  198. * Mon Jul 13 2009 David Lutterkort <lutter@redhat.com> - 0.5.2-1
  199. - New version
  200. * Fri Jun 5 2009 David Lutterkort <lutter@redhat.com> - 0.5.1-1
  201. - Install fadot
  202. * Fri Mar 27 2009 David Lutterkort <lutter@redhat.com> - 0.5.0-2
  203. - fadot isn't being installed just yet
  204. * Tue Mar 24 2009 David Lutterkort <lutter@redhat.com> - 0.5.0-1
  205. - New program /usr/bin/fadot
  206. * Mon Mar 9 2009 David Lutterkort <lutter@redhat.com> - 0.4.2-1
  207. - New version
  208. * Fri Feb 27 2009 David Lutterkort <lutter@redhat.com> - 0.4.1-1
  209. - New version
  210. * Fri Feb 6 2009 David Lutterkort <lutter@redhat.com> - 0.4.0-1
  211. - New version
  212. * Mon Jan 26 2009 David Lutterkort <lutter@redhat.com> - 0.3.6-1
  213. - New version
  214. * Tue Dec 23 2008 David Lutterkort <lutter@redhat.com> - 0.3.5-1
  215. - New version
  216. * Mon Feb 25 2008 David Lutterkort <dlutter@redhat.com> - 0.0.4-1
  217. - Initial specfile