ModemManager-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. #define ppp_version 2.4.7
  4. %define glib2_version 2.40
  5. Name: ModemManager
  6. Summary: Mobile broadband modem management service
  7. Summary(ja): Mobile broadband modem management service
  8. Version: 1.4.12
  9. Release: 2%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. #
  14. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  15. # tarball built with:
  16. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  17. # make distcheck
  18. #
  19. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  20. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  21. Patch0: buildsys-hates-openpty.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel >= %{glib2_version}
  24. BuildRequires: eudev-libgudev1-devel
  25. BuildRequires: automake autoconf intltool libtool
  26. BuildRequires: gobject-introspection-devel
  27. BuildRequires: polkit-devel
  28. BuildRequires: gtk-doc
  29. # for xsltproc
  30. BuildRequires: libxslt
  31. Requires: dbus-glib
  32. %description
  33. The ModemManager service manages WWAN modems and provides a consistent API for
  34. interacting with these devices to client applications.
  35. %package devel
  36. Summary: Development tools for %{name}
  37. Summary(ja): %{name} の開発環境
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. %description devel
  42. Header files and libraries for building a extension library for the %{name}.
  43. %package glib
  44. Summary: Libraries for adding ModemManager support to applications that use glib.
  45. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  46. Group: System Environment/Libraries
  47. Requires: glib2 >= %{glib2_version}
  48. %description glib
  49. This package contains the libraries that make it easier to use some ModemManager
  50. functionality from applications that use glib.
  51. %package glib-devel
  52. Summary: Development tools for %{name}-glib
  53. Summary(ja): %{name}-glib の開発環境
  54. Group: Development/Libraries
  55. Requires: %{name}-glib = %{version}-%{release}
  56. Requires: %{name}-devel = %{version}-%{release}
  57. Requires: glib2-devel
  58. Requires: pkgconfig
  59. %description glib-devel
  60. Header files and libraries for building a extension library for the %{name}-glib.
  61. %prep
  62. %setup -q
  63. %patch0 -p1 -b .pty
  64. %build
  65. autoreconf -if
  66. intltoolize --force
  67. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  68. %configure \
  69. --disable-static \
  70. --enable-gtk-doc=yes \
  71. --enable-vala=no \
  72. --enable-more-warnings=yes \
  73. --with-udev-base-dir=/lib/udev \
  74. --without-mbim \
  75. --without-qmi \
  76. --with-dist-version=%{version}-%{release}
  77. make %{?_smp_mflags}
  78. %check
  79. make check
  80. %install
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  83. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  84. %find_lang %{name}
  85. %post
  86. /sbin/ldconfig
  87. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  88. %postun
  89. /sbin/ldconfig
  90. if [ $1 -eq 0 ]; then
  91. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  92. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  93. fi
  94. %posttrans
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  96. %post glib -p /sbin/ldconfig
  97. %postun glib -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(-,root, root,-)
  100. %doc COPYING README
  101. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  102. %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
  103. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  104. %attr(0755,root,root) %{_sbindir}/ModemManager
  105. %attr(0755,root,root) %{_bindir}/mmcli
  106. %dir %{_libdir}/%{name}
  107. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  108. /lib/udev/rules.d/*
  109. %{_datadir}/dbus-1/interfaces/*.xml
  110. %{_datadir}/icons/hicolor/22x22/apps/*.png
  111. %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
  112. %{_mandir}/man8/*
  113. %files devel
  114. %defattr(-,root,root,-)
  115. %{_includedir}/ModemManager/*.h
  116. %dir %{_datadir}/gtk-doc/html/%{name}
  117. %{_datadir}/gir-1.0/ModemManager-1.0.gir
  118. %{_datadir}/gtk-doc/html/%{name}/*
  119. %{_libdir}/pkgconfig/%{name}.pc
  120. %files glib
  121. %defattr(-,root,root,-)
  122. %{_libdir}/libmm-glib.so.*
  123. %files glib-devel
  124. %defattr(-,root,root,-)
  125. %{_libdir}/libmm-glib.so
  126. %dir %{_includedir}/libmm-glib
  127. %{_includedir}/libmm-glib/*.h
  128. %{_libdir}/pkgconfig/mm-glib.pc
  129. %dir %{_datadir}/gtk-doc/html/libmm-glib
  130. %{_datadir}/gtk-doc/html/libmm-glib/*
  131. %changelog
  132. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
  133. - fix spec file
  134. * Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
  135. - new upstream release
  136. - add BuildRequires: gobject-introspection-devel, polkit-devel
  137. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
  138. - new upstream release
  139. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
  140. - new upstream release
  141. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  142. - new upstream release
  143. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  144. - new upstream release
  145. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  146. - new upstream release
  147. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  148. - moved ModemManager-glib to System Environment/Libraries Group
  149. - removed BR: ppp, ppp-devel and dbus-glib-devel
  150. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  151. - new upstream release
  152. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  153. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  154. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  155. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  156. - new upstream release
  157. - update Patch0
  158. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  159. - update to 0.7.991 snapshot
  160. - fix spec file based on FC package
  161. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  162. - Update to 0.7.991 snapshot
  163. - Fix SMS validity parsing
  164. - Allow registration changes to 'searching' without disconnecting
  165. - Fix reading SMS messages from some QMI-based devices
  166. - Increase connection timeout for Novatel E362
  167. - Fix PIN retries checking when unlocking Ericsson devices
  168. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  169. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  170. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  171. - new upstream release
  172. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  173. - new upstream release
  174. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  175. - delete Patch20
  176. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  177. - update Patch20 (ModemManager-0.4-git20110428.patch)
  178. - delete Patch21,22
  179. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  180. - update to 0.4
  181. - add Patch20 (ModemManager-0.4-git20100720.patch)
  182. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  183. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  184. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  185. - initial build for Vine Linux
  186. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  187. - core: ignore some failures on disconnect (rh #578280)
  188. - core: add support for platform serial devices
  189. - gsm: better Blackberry DUN support
  190. - gsm: periodically poll access technology
  191. - cdma: prevent crash on modem removal (rh #571921)
  192. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  193. - novatel: better signal strength reporting on CDMA cards
  194. - novatel: add access technology and mode preference support on GSM cards
  195. - zte: fix mode preference retrieval
  196. - longcheer: add support for Zoom modems (4595, 4596, etc)
  197. - longcheer: add access technology and mode preference support
  198. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  199. - Silence %%post
  200. - Update scripts
  201. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  202. - gsm: fix parsing Blackberry supported character sets response
  203. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  204. - mbm: fix retrieval of current allowed mode
  205. - gsm: fix initialization issues with some devices (like Blackberries)
  206. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  207. - core: fix detection of some generic devices (rh #579247)
  208. - core: fix detection regression of some Huawei devices in 0.3-5
  209. - cdma: periodically poll registration state and signal quality
  210. - cdma: really fix registration detection on various devices (rh #569067)
  211. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  212. - core: fix PPC/SPARC/etc builds
  213. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  214. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  215. - cdma: handle signal quality requests while connected for more devices
  216. - cdma: handle serving system requests while connected for more devices
  217. - gsm: determine current access technology earlier
  218. - huawei: work around automatic registration issues on some devices
  219. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  220. - core: ensure enabled modems are disabled when MM stops
  221. - core: better capability detection for Blackberry devices (rh #573510)
  222. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  223. - gsm: don't block modem when it requires PIN2
  224. - option: fix access technology updates
  225. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  226. - mbm: add device IDs for C3607w
  227. - mbm: fail earlier during connection failures
  228. - mbm: fix username/password authentication when checked by the network
  229. - hso: implement asynchronous signal quality updates
  230. - option: implement asynchronous signal quality updates
  231. - novatel: correctly handle CDMA signal quality
  232. - core: basic PolicyKit support
  233. - core: fix direct GSM registration information requests
  234. - core: general GSM PIN/PUK unlock fixes
  235. - core: poll GSM registration state internally for quicker status updates
  236. - core: implement GSM 2G/3G preference
  237. - core: implement GSM roaming allowed/disallowed preference
  238. - core: emit signals on access technology changes
  239. - core: better handling of disconnections
  240. - core: fix simple CDMA status requests
  241. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  242. - core: startup speed improvements
  243. - core: GSM PIN checking improvements
  244. - huawei: fix EVDO-only connections on various devices (rh #553199)
  245. - longcheer: add support for more devices
  246. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  247. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  248. - core: fix crashes when devices are unplugged during operation (rh #553953)
  249. - cdma: prefer primary port for status/registration queries
  250. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  251. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  252. - gsm: fix Nokia N80 network scan parsing
  253. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  254. - core: fix apparent hangs by limiting retried serial writes
  255. - gsm: ensure modem state is reset when disabled
  256. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  257. - sierra: fix CDMA registration detection in some cases (rh #547513)
  258. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  259. - sierra: ensure CDMA device is powered up when trying to use it
  260. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  261. - zte: handle unsolicited messages better during probing
  262. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  263. - cdma: fix signal strength reporting on some devices
  264. - cdma: better registration state detection when dialing (ex Sierra 5275)
  265. - option: always use the correct tty for dialing commands
  266. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  267. - core: fix reconnect after manual disconnect (rh #541314)
  268. - core: fix various segfaults during registration
  269. - core: fix probing of various modems on big-endian architectures (ie PPC)
  270. - core: implement modem states to avoid duplicate operations
  271. - hso: fix authentication for Icera-based devices like iCON 505
  272. - zte: use correct port for new devices
  273. - nozomi: fix detection
  274. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  275. - Update to latest git
  276. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  277. - cdma: wait for network registration before trying to connect
  278. - gsm: add cell access technology reporting
  279. - gsm: allow longer-running network scans
  280. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  281. - nokia: don't power down phones on disconnect
  282. - hso: fix disconnection/disable
  283. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  284. - Fixes for Motorola and Ericsson devices
  285. - Fixes for CDMA "serving-system" command parsing
  286. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  287. - Fix a typo in one of the udev rules files
  288. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  289. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  290. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  291. - Fix source repo location
  292. - Fix directory ownership
  293. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  294. - Initial version