123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131 |
- #
- # - NetAddr::IP -
- # This spec file was automatically generated by cpan2rpm [ver: 2.028]
- # The following arguments were used:
- # NetAddr::IP
- # For more information on cpan2rpm please visit: http://perl.arix.com/
- #
- %define pkgname NetAddr-IP
- %define filelist %{pkgname}-%{version}-filelist
- %define NVR %{pkgname}-%{version}-%{release}
- %define maketest 1
- Name: perl-NetAddr-IP
- Summary: NetAddr-IP - Manages IPv4 and IPv6 addresses and subnets
- Version: 4.042
- Release: 1%{?_dist_release}
- License: Artistic
- Group: Development/Libraries
- Url: http://www.cpan.org
- BuildRoot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
- Prefix: %(echo %{_prefix})
- Source: http://search.cpan.org//CPAN/authors/id/M/MI/MIKER/NetAddr-IP-4.042.tar.gz
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: tomop
- %description
- This module provides an object-oriented abstraction on top of IP
- addresses or IP subnets, that allows for easy manipulations.
- Version 4.xx of NetAdder::IP will will work older
- versions of Perl and does B<not> use Math::BigInt as in previous versions.
- The internal representation of all IP objects is in 128 bit IPv6 notation.
- IPv4 and IPv6 objects may be freely mixed.
- #
- # This package was generated automatically with the cpan2rpm
- # utility. To get this software or for more information
- # please visit: http://perl.arix.com/
- #
- %prep
- %setup -q -n %{pkgname}-%{version}
- chmod -R u+w %{_builddir}/%{pkgname}-%{version}
- %build
- grep -rsl '^#!.*perl' . |
- grep -v '.bak$' |xargs --no-run-if-empty \
- %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
- CFLAGS="$RPM_OPT_FLAGS"
- %{__perl} Makefile.PL INSTALLDIRS="vendor" `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
- %{__make}
- %if %maketest
- %{__make} test
- %endif
- %install
- [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
- %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
- cmd=/usr/share/spec-helper/compress_files
- [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
- [ -x $cmd ] && $cmd
- # SuSE Linux
- if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
- then
- %{__mkdir_p} %{buildroot}/var/adm/perl-modules
- %{__cat} `find %{buildroot} -name "perllocal.pod"` \
- | %{__sed} -e s+%{buildroot}++g \
- > %{buildroot}/var/adm/perl-modules/%{name}
- fi
- # remove special files
- find %{buildroot} -name "perllocal.pod" \
- -o -name ".packlist" \
- -o -name "*.bs" \
- |xargs -i rm -f {}
- # no empty directories
- find %{buildroot}%{_prefix} \
- -type d -depth \
- -exec rmdir {} \; 2>/dev/null
- %{__perl} -MFile::Find -le '
- find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
- print "%doc TODO Lite Changes docs README";
- for my $x (sort @dirs, @files) {
- push @ret, $x unless indirs($x);
- }
- print join "\n", sort @ret;
- sub wanted {
- return if /auto$/;
- local $_ = $File::Find::name;
- my $f = $_; s|^\Q%{buildroot}\E||;
- return unless length;
- return $files[@files] = $_ if -f $f;
- $d = $_;
- /\Q$d\E/ && return for reverse sort @INC;
- $d =~ /\Q$_\E/ && return
- for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
- $dirs[@dirs] = $_;
- }
- sub indirs {
- my $x = shift;
- $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
- }
- ' > %filelist
- [ -z %filelist ] && {
- echo "ERROR: empty %files listing"
- exit -1
- }
- %clean
- [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
- %files -f %filelist
- %defattr(-,root,root)
- %changelog
- * Thu Apr 07 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.042-1
- - Initial build.
|