1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798 |
- %define pkg_name haddock-library
- %define pkg_version 1.6.0
- %define pkg_release 1%{?_dist_release}
- Summary: Haskell libraries: %{pkg_name}
- Name: libghc-%{pkg_name}
- Version: %{pkg_version}
- Release: %{pkg_release}
- License: BSD3
- Group: Applications/Text
- URL: http://hackage.haskell.org
- Source0: packages
- Source11: haddock-library-1.6.0.tar.gz
- Source12: haddock-library.cabal
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: ghc haskell-platform
- BuildRequires: libffi-devel gmp-devel zlib-devel
- BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
- Requires: ghc haskell-platform
- Requires: haskell-platform-dep
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: ara_t
- %description
- Haskell libraries: %{pkg_name}-%{version}
- %prep
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %build
- %ghc_pkg_init
- cd %{_builddir}
- for pkg in `cat %{SOURCE0}`; do
- %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
- pushd ${pkg}
- %ghc_fix_dependencies ${pkg}
- %cabal_configure1 ${pkg}
- %cabal_build
- %cabal_haddock
- %cabal_copy_resister ${pkg}
- popd
- done
- %install
- # move conf files to correct site
- pushd ${RPM_BUILD_ROOT}/%{_libdir}/ghc-%{ghc_version}/package.conf.d
- %{__mv} %{pkg_name}-%{version}.conf/* .
- for conf in *-%{pkg_name}-%{version}-*; do
- %{__mv} ${conf} `echo ${conf} | sed -e "s/[0-9.]\+-//"`.conf
- done
- %{__rm} -rf %{pkg_name}-%{version}.conf
- popd
- # copy documents
- pushd %{_builddir}/%{pkg_name}-%{version}
- %{__cp} CHANGES.md \
- ${RPM_BUILD_ROOT}%{_docdir}/%{pkg_name}-%{version}
- popd
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %post
- %ghc_pkg_recache
- %postun
- %ghc_pkg_recache
- %files
- %defattr(-, root, root)
- %{_libdir}/ghc-%{ghc_version}/
- %{_libdir}/ghc-lib/
- %{_datadir}/
- %changelog
- * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 1.6.0-1
- - update to 1.6.0
- - build using ghc-8.4.3
- * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.5.0.1-1
- - new package
|