libghc-old-locale-vl.spec 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. %define pkg_name old-locale
  2. %define pkg_version 1.0.0.7
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: Haskell libraries: %{pkg_name}
  5. Name: libghc-%{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: old-locale-1.0.0.7.tar.gz
  13. Source12: old-locale.cabal
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: ghc haskell-platform
  16. BuildRequires: libffi-devel gmp-devel zlib-devel
  17. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  18. Requires: ghc haskell-platform
  19. Requires: haskell-platform-dep
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: ara_t
  23. %description
  24. Haskell libraries: %{pkg_name}-%{version}
  25. %prep
  26. %{__rm} -rf ${RPM_BUILD_ROOT}
  27. %build
  28. %ghc_pkg_init
  29. cd %{_builddir}
  30. for pkg in `cat %{SOURCE0}`; do
  31. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  32. pushd ${pkg}
  33. %ghc_fix_dependencies ${pkg}
  34. %cabal_configure2 %{name} ${pkg}
  35. %cabal_build
  36. %cabal_haddock
  37. %cabal_copy_resister %{name}_${pkg}
  38. popd
  39. done
  40. %install
  41. # copy documents
  42. pushd %{_builddir}/%{pkg_name}-%{version}
  43. %{__cp} changelog.md \
  44. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
  45. popd
  46. %clean
  47. %{__rm} -rf ${RPM_BUILD_ROOT}
  48. %post
  49. %ghc_pkg_recache
  50. %postun
  51. %ghc_pkg_recache
  52. %files
  53. %defattr(-, root, root)
  54. %{_libdir}/ghc-%{ghc_version}/
  55. %{_libdir}/ghc-lib/
  56. %{_datadir}/
  57. %changelog
  58. * Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0.7-2
  59. - build using ghc-8.4.3
  60. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0.7-1
  61. - new package