libdb-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define __soversion_major 5
  3. %define __soversion %{__soversion_major}.3
  4. %bcond_with java
  5. Summary: The Berkeley DB database library for C
  6. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  7. Name: libdb
  8. Version: 5.3.28
  9. Release: 8%{?_dist_release}
  10. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  11. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  12. # For mt19937db.c
  13. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  14. Patch0: libdb-multiarch.patch
  15. # db-1.85 upstream patches
  16. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  17. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  18. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  19. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  20. # other patches
  21. Patch20: db-1.85-errno.patch
  22. Patch22: db-4.6.21-1.85-compat.patch
  23. Patch24: db-4.5.20-jni-include-dir.patch
  24. # License clarification patch
  25. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  26. Patch25: 007-mt19937db.c_license.patch
  27. URL: http://www.oracle.com/database/berkeley-db/
  28. License: BSD and LGPLv2 and Sleepycat
  29. Group: System Environment/Libraries
  30. BuildRequires: perl libtool
  31. BuildRequires: tcl >= 8.5.2-3
  32. %if %{with java}
  33. BuildRequires: java-devel >= 1:1.6.0
  34. %endif
  35. #BuildRequires: chrpath
  36. #Conflicts: filesystem < 3
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. Packager: tomop
  40. %description
  41. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  42. provides embedded database support for both traditional and
  43. client/server applications. The Berkeley DB includes B+tree, Extended
  44. Linear Hashing, Fixed and Variable-length record access methods,
  45. transactions, locking, logging, shared memory caching, and database
  46. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  47. used by many applications, including Python and Perl, so this should
  48. be installed on all systems.
  49. %package utils
  50. Summary: Command line tools for managing Berkeley DB databases
  51. Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
  52. Group: Applications/Databases
  53. Requires: %{name}%{?_isa} = %{version}-%{release}
  54. Obsoletes: db4-utils
  55. Provides: db4-utils
  56. %description utils
  57. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  58. provides embedded database support for both traditional and
  59. client/server applications. Berkeley DB includes B+tree, Extended
  60. Linear Hashing, Fixed and Variable-length record access methods,
  61. transactions, locking, logging, shared memory caching, and database
  62. recovery. DB supports C, C++, Java and Perl APIs.
  63. %package devel
  64. Summary: C development files for the Berkeley DB library
  65. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  66. Group: Development/Libraries
  67. Requires: %{name}%{?_isa} = %{version}-%{release}
  68. Obsoletes: db4-devel
  69. Provides: db4-devel
  70. %description devel
  71. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  72. provides embedded database support for both traditional and
  73. client/server applications. This package contains the header files
  74. and libraries for building programs which use the Berkeley DB.
  75. %package devel-doc
  76. Summary: C development documentation files for the Berkeley DB library
  77. Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
  78. Group: Documentation
  79. Requires: %{name} = %{version}-%{release}
  80. Requires: %{name}-devel = %{version}-%{release}
  81. BuildArch: noarch
  82. %description devel-doc
  83. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  84. provides embedded database support for both traditional and
  85. client/server applications. This package contains the documentation
  86. for building programs which use the Berkeley DB.
  87. %package devel-static
  88. Summary: Berkeley DB static libraries
  89. Summary(ja): Berkeley DB 静的ライブラリ
  90. Group: Development/Libraries
  91. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  92. %description devel-static
  93. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  94. provides embedded database support for both traditional and
  95. client/server applications. This package contains static libraries
  96. needed for applications that require static linking of
  97. Berkeley DB.
  98. %package cxx
  99. Summary: The Berkeley DB database library for C++
  100. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  101. Group: System Environment/Libraries
  102. Requires: %{name}%{?_isa} = %{version}-%{release}
  103. %description cxx
  104. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  105. provides embedded database support for both traditional and
  106. client/server applications. The Berkeley DB includes B+tree, Extended
  107. Linear Hashing, Fixed and Variable-length record access methods,
  108. transactions, locking, logging, shared memory caching, and database
  109. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  110. used by many applications, including Python and Perl, so this should
  111. be installed on all systems.
  112. %package cxx-devel
  113. Summary: C++ development files for the Berkeley DB library
  114. Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
  115. Group: Development/Libraries
  116. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  117. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  118. %description cxx-devel
  119. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  120. provides embedded database support for both traditional and
  121. client/server applications. This package contains the header files,
  122. libraries, and documentation for building programs which use the
  123. Berkeley DB in C++.
  124. %package tcl
  125. Summary: The Berkeley DB library for tcl
  126. Summary(ja): tcl 用 Berkeley DB データベースライブラリ
  127. Group: System Environment/Libraries
  128. Requires: %{name}%{?_isa} = %{version}-%{release}
  129. %description tcl
  130. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  131. provides embedded database support for both traditional and
  132. client/server applications. This package contains the libraries
  133. for building programs which use the Berkeley DB in Tcl.
  134. %package tcl-devel
  135. Summary: Development files for using the Berkeley DB with tcl
  136. Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
  137. Group: Development/Libraries
  138. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  139. %description tcl-devel
  140. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  141. provides embedded database support for both traditional and
  142. client/server applications. This package contains the libraries
  143. for building programs which use the Berkeley DB in Tcl.
  144. %package sql
  145. Summary: The Berkeley DB library for SQL
  146. Summary(ja): SQL 用 Berkeley DB データベースライブラリ
  147. Group: System Environment/Libraries
  148. Requires: %{name}%{?_isa} = %{version}-%{release}
  149. %description sql
  150. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  151. provides embedded database support for both traditional and
  152. client/server applications. This package contains the libraries
  153. for building programs which use the Berkeley DB in SQL.
  154. %package sql-devel
  155. Summary: Development files for using the Berkeley DB with sql
  156. Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
  157. Group: Development/Libraries
  158. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  159. %description sql-devel
  160. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  161. provides embedded database support for both traditional and
  162. client/server applications. This package contains the libraries
  163. for building programs which use the Berkeley DB in SQL.
  164. %if %{with java}
  165. %package java
  166. Summary: The Berkeley DB library for Java
  167. Summary(ja): Java 用 Berkeley DB データベースライブラリ
  168. Group: System Environment/Libraries
  169. Requires: %{name}%{?_isa} = %{version}-%{release}
  170. %description java
  171. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  172. provides embedded database support for both traditional and
  173. client/server applications. This package contains the libraries
  174. for building programs which use the Berkeley DB in Java.
  175. %package java-devel
  176. Summary: Development files for using the Berkeley DB with Java
  177. Summary(ja): Java で Berkeley DB を利用するための開発ファイル
  178. Group: Development/Libraries
  179. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  180. %description java-devel
  181. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  182. provides embedded database support for both traditional and
  183. client/server applications. This package contains the libraries
  184. for building programs which use the Berkeley DB in Java.
  185. %endif
  186. # compat32
  187. %package -n compat32-%{name}
  188. Summary: The Berkeley DB database library for C
  189. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  190. Group: System Environment/Libraries
  191. Requires: libdb = %{version}-%{release}
  192. %description -n compat32-%{name}
  193. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  194. provides embedded database support for both traditional and
  195. client/server applications. The Berkeley DB includes B+tree, Extended
  196. Linear Hashing, Fixed and Variable-length record access methods,
  197. transactions, locking, logging, shared memory caching, and database
  198. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  199. used by many applications, including Python and Perl, so this should
  200. be installed on all systems.
  201. %package -n compat32-%{name}-cxx
  202. Summary: The Berkeley DB database library for C++
  203. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  204. Group: System Environment/Libraries
  205. Requires: %{name}-cxx = %{version}-%{release}
  206. Requires: compat32-%{name} = %{version}-%{release}
  207. %description -n compat32-%{name}-cxx
  208. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  209. provides embedded database support for both traditional and
  210. client/server applications. The Berkeley DB includes B+tree, Extended
  211. Linear Hashing, Fixed and Variable-length record access methods,
  212. transactions, locking, logging, shared memory caching, and database
  213. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  214. used by many applications, including Python and Perl, so this should
  215. be installed on all systems.
  216. %package -n compat32-%{name}-devel
  217. Summary: C development files for the Berkeley DB library
  218. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  219. Group: Development/Libraries
  220. Requires: compat32-%{name} = %{version}-%{release}
  221. Requires: %{name}-devel = %{version}-%{release}
  222. Obsoletes: compat32-db4-devel
  223. Provides: compat32-db4-devel
  224. %description -n compat32-%{name}-devel
  225. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  226. provides embedded database support for both traditional and
  227. client/server applications. This package contains the header files,
  228. libraries, and documentation for building programs which use the
  229. Berkeley DB.
  230. %prep
  231. %setup -q -n db-%{version} -a 1
  232. cp %{SOURCE2} .
  233. %patch0 -p1 -b .multiarch
  234. pushd db.1.85/PORT/linux
  235. %patch10 -p0 -b .1.1
  236. popd
  237. pushd db.1.85
  238. %patch11 -p0 -b .1.2
  239. %patch12 -p0 -b .1.3
  240. %patch13 -p0 -b .1.4
  241. %patch20 -p1 -b .errno
  242. popd
  243. %patch22 -p1 -b .185compat
  244. %patch24 -p1 -b .4.5.20.jni
  245. %patch25 -p1 -b .licensefix
  246. cd dist
  247. ./s_config
  248. cd ..
  249. %build
  250. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  251. CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  252. export CFLAGS
  253. # Build the old db-185 libraries.
  254. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  255. test -d dist/dist-tls || mkdir dist/dist-tls
  256. # Static link db_dump185 with old db-185 libraries.
  257. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  258. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  259. # Update config files to understand aarch64
  260. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  261. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  262. #done
  263. pushd dist/dist-tls
  264. %define _configure ../configure
  265. %configure -C \
  266. --enable-compat185 \
  267. --enable-dump185 \
  268. --enable-shared \
  269. --enable-static \
  270. --enable-tcl \
  271. --with-tcl=%{_libdir} \
  272. --enable-cxx \
  273. --enable-sql \
  274. --enable-test \
  275. --disable-rpath \
  276. --with-tcl=%{_libdir}/tcl8.5 \
  277. %if %{with java}
  278. --enable-java
  279. %endif
  280. # Remove libtool predep_objects and postdep_objects wonkiness so that
  281. # building without -nostdlib doesn't include them twice. Because we
  282. # already link with g++, weird stuff happens if you don't let the
  283. # compiler handle this.
  284. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  285. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  286. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  287. make %{?_smp_mflags}
  288. %if %{with java}
  289. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  290. LDBJ=./.libs/libdb_java-%{__soversion}.la
  291. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  292. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  293. fi
  294. %endif
  295. popd
  296. %install
  297. rm -rf ${RPM_BUILD_ROOT}
  298. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  299. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  300. %makeinstall STRIP=/bin/true -C dist/dist-tls
  301. # XXX Nuke non-versioned archives and symlinks
  302. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  303. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  304. # Move the header files to a subdirectory, in case we're deploying on a
  305. # system with multiple versions of DB installed.
  306. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  307. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  308. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  309. for i in db.h db_cxx.h db_185.h; do
  310. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  311. done
  312. %if %{with java}
  313. # Move java jar file to the correct place
  314. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  315. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  316. %endif
  317. # Eliminate installed doco
  318. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  319. # XXX Avoid Permission denied. strip when building as non-root.
  320. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  321. # remove unneeded .la files (#225675)
  322. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  323. # remove RPATHs
  324. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  325. # unify documentation and examples, remove stuff we don't need
  326. rm -rf docs/csharp
  327. rm -rf examples/csharp
  328. rm -rf docs/installation
  329. mv examples docs
  330. %clean
  331. rm -rf ${RPM_BUILD_ROOT}
  332. %post -p /sbin/ldconfig
  333. %postun -p /sbin/ldconfig
  334. %post cxx -p /sbin/ldconfig
  335. %postun cxx -p /sbin/ldconfig
  336. %post sql -p /sbin/ldconfig
  337. %postun sql -p /sbin/ldconfig
  338. %post tcl -p /sbin/ldconfig
  339. %postun tcl -p /sbin/ldconfig
  340. %if %{with java}
  341. %post java -p /sbin/ldconfig
  342. %postun java -p /sbin/ldconfig
  343. %endif
  344. %if %{build_compat32}
  345. %post -n compat32-%{name} -p /sbin/ldconfig
  346. %postun -n compat32-%{name} -p /sbin/ldconfig
  347. %post -n compat32-%{name}-cxx -p /sbin/ldconfig
  348. %postun -n compat32-%{name}-cxx -p /sbin/ldconfig
  349. %endif
  350. %files
  351. %defattr(-,root,root,-)
  352. %doc LICENSE README lgpl-2.1.txt
  353. %{_libdir}/libdb-%{__soversion}.so
  354. %{_libdir}/libdb-%{__soversion_major}.so
  355. %files devel
  356. %defattr(-,root,root,-)
  357. %{_libdir}/libdb.so
  358. %dir %{_includedir}/%{name}
  359. %{_includedir}/%{name}/db.h
  360. %{_includedir}/%{name}/db_185.h
  361. %{_includedir}/db.h
  362. %{_includedir}/db_185.h
  363. %files devel-doc
  364. %defattr(-,root,root,-)
  365. %doc docs/*
  366. %files devel-static
  367. %defattr(-,root,root,-)
  368. %{_libdir}/libdb-%{__soversion}.a
  369. %{_libdir}/libdb_cxx-%{__soversion}.a
  370. %{_libdir}/libdb_tcl-%{__soversion}.a
  371. %{_libdir}/libdb_sql-%{__soversion}.a
  372. %if %{with java}
  373. %{_libdir}/libdb_java-%{__soversion}.a
  374. %endif
  375. %files utils
  376. %defattr(-,root,root,-)
  377. %{_bindir}/db*_archive
  378. %{_bindir}/db*_checkpoint
  379. %{_bindir}/db*_deadlock
  380. %{_bindir}/db*_dump*
  381. %{_bindir}/db*_hotbackup
  382. %{_bindir}/db*_load
  383. %{_bindir}/db*_printlog
  384. %{_bindir}/db*_recover
  385. %{_bindir}/db*_replicate
  386. %{_bindir}/db*_stat
  387. %{_bindir}/db*_upgrade
  388. %{_bindir}/db*_verify
  389. %{_bindir}/db*_tuner
  390. %files cxx
  391. %defattr(-,root,root,-)
  392. %{_libdir}/libdb_cxx-%{__soversion}.so
  393. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  394. %files cxx-devel
  395. %defattr(-,root,root,-)
  396. %{_includedir}/%{name}/db_cxx.h
  397. %{_includedir}/db_cxx.h
  398. %{_libdir}/libdb_cxx.so
  399. %files tcl
  400. %defattr(-,root,root,-)
  401. %{_libdir}/libdb_tcl-%{__soversion}.so
  402. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  403. %files tcl-devel
  404. %defattr(-,root,root,-)
  405. %{_libdir}/libdb_tcl.so
  406. %files sql
  407. %defattr(-,root,root,-)
  408. %{_libdir}/libdb_sql-%{__soversion}.so
  409. %{_libdir}/libdb_sql-%{__soversion_major}.so
  410. %files sql-devel
  411. %defattr(-,root,root,-)
  412. %{_bindir}/dbsql
  413. %{_libdir}/libdb_sql.so
  414. %{_includedir}/%{name}/dbsql.h
  415. %if %{with java}
  416. %files java
  417. %defattr(-,root,root,-)
  418. %{_libdir}/libdb_java-%{__soversion_major}*.so
  419. %{_datadir}/java/*.jar
  420. %files java-devel
  421. %defattr(-,root,root,-)
  422. %{_libdir}/libdb_java.so
  423. %endif
  424. %if %{build_compat32}
  425. %files -n compat32-%{name}
  426. %defattr(-,root,root)
  427. %{_libdir}/libdb-%{__soversion}.so
  428. %{_libdir}/libdb-%{__soversion_major}.so
  429. %files -n compat32-%{name}-cxx
  430. %defattr(-,root,root)
  431. %{_libdir}/libdb_cxx-%{__soversion}.so
  432. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  433. %files -n compat32-%{name}-devel
  434. %defattr(-,root,root)
  435. %{_libdir}/libdb.so
  436. %endif
  437. %changelog
  438. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
  439. - added compat32 subpackages
  440. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
  441. - updated Summary and Group
  442. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  443. - added "Provides: db4-{utils,devel}".
  444. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  445. - initial build for Vine Linux.
  446. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  447. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  448. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  449. - Fix configure macro usage for better aarch64 build fix
  450. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  451. - Updated config files to allow build on aarch64 (#1022970)
  452. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  453. - Added Sleepycat to the license list (#1013841)
  454. - Updated to 5.3.28 (#1013233)
  455. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  456. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  457. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  458. - add copy of lgpl-2.1.txt
  459. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  460. - Fix missing debuginfo issue for utils subpackage
  461. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  462. - add license clarification fix
  463. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  464. - Added sqlite compability CFLAGS (#788496)
  465. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  466. - Cleaning the specfile - removed gcc-java dependecy other way
  467. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  468. - Removed dependency on obsolete gcc-java package (#927742)
  469. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  470. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  471. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  472. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  473. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  474. - fix license tag
  475. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  476. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  477. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  478. - Specify tag for libtool (fixes FTBFS # 838334 )
  479. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  480. - update to 5.3.21
  481. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  482. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  483. - move C++ header files to cxx-devel
  484. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  485. - fix -devel packages dependencies yet more (#832225)
  486. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  487. - package -devel packages correctly
  488. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  489. - fix multiarch conflict in libdb-devel (#812901)
  490. - remove unneeded dos2unix BR
  491. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  492. - update to 5.3.15
  493. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  494. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  495. - Resolves rhbz#794472
  496. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  497. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  498. - add filesystem guard
  499. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  500. - install everything in /usr
  501. https://fedoraproject.org/wiki/Features/UsrMove
  502. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  503. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  504. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  505. - update to 5.2.36,
  506. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  507. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  508. - move development documentation to devel-doc subpackage (#705386)
  509. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  510. - update to 5.2.28
  511. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  512. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  513. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  514. - update to 5.1.25
  515. * Wed Sep 29 2010 jkeating - 5.1.19-2
  516. - Rebuilt for gcc bug 634757
  517. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  518. - update to 5.1.19
  519. - rename -devel-static to -static subpackage (#617800)
  520. - build java on all arches
  521. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  522. - update to 5.0.26
  523. - drop BR: ed
  524. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  525. - add Requires: libdb-cxx to libdb-devel
  526. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  527. - initial build
  528. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  529. - remove C# documentation
  530. - disable/remove rpath
  531. - fix description
  532. - tighten dependencies
  533. - run ldconfig for cxx and sql subpackages
  534. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  535. - enable sql
  536. - package 5.0.21