imlib-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. # Note that this is NOT a relocatable package
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: Image loading and rendering library for X11R6
  4. Summary(ja): 画像の読み込み/レンダリング用のライブラリ
  5. Name: imlib
  6. Version: 1.9.15
  7. Release: 3%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. Source0: ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
  11. Patch0: imlib-1.9.14-suse-alt-bound.patch
  12. Patch1: imlib-1.9.13-sec2.patch
  13. Patch2: imlib-1.9.14-configure-x86_64.patch
  14. Patch3: imlib-1.9.15-libpng15.patch
  15. Obsoletes: Imlib
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libpng-devel >= 2:1.2.5
  18. BuildRequires: gtk+-devel >= 1.2.1
  19. BuildRequires: libtiff-devel
  20. BuildRequires: libjpeg-devel
  21. BuildRequires: libungif-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libXt-devel
  24. Requires: libpng
  25. Requires: libtiff
  26. Requires: libjpeg
  27. Requires: zlib
  28. Requires: netpbm-progs
  29. Requires: libungif
  30. %description
  31. Imlib is an advanced replacement library for libraries like libXpm that
  32. provides many more features with much greater flexability and
  33. speed.
  34. %package -n compat32-%{name}
  35. Summary: Image loading and rendering library for X11R6
  36. Summary(ja): 画像の読み込み/レンダリング用のライブラリ
  37. Group: System Environment/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description -n compat32-%{name}
  40. Imlib is an advanced replacement library for libraries like libXpm that
  41. provides many more features with much greater flexability and
  42. speed.
  43. %package devel
  44. Summary: Imlib headers, static libraries and documentation
  45. Summary(ja): Imlib のヘッダファイルおよび静的ライブラリ、ドキュメント
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: libungif-devel libjpeg-devel
  49. Requires: libtiff-devel libpng-devel zlib-devel
  50. Obsoletes: Imlib
  51. %description devel
  52. Headers, static libraries and documentation for Imlib.
  53. %package cfgeditor
  54. Summary: Imlib configuration editor
  55. Summary(ja): Imlib 設定エディタ
  56. Group: User Interface/Desktops
  57. Requires: %{name} = %{version}
  58. #Requires: gtk+ >= 1.2.1
  59. %description cfgeditor
  60. The imlib_config program allows you to control the way imlib uses
  61. color and handles gamma correction/etc.
  62. %prep
  63. %setup -q
  64. #patch0 -p1 -b .bmp-buffer-overflow
  65. %patch1 -p1 -b .can-2004-1025_1026
  66. %patch2 -p1 -b .x86_64
  67. %patch3 -p0 -b .libpng
  68. %build
  69. %define __libtoolize /bin/true
  70. %configure --disable-static
  71. if [ "$SMP" != "" ]; then
  72. (make "MAKE=make -k -j $SMP"; exit 0)
  73. make
  74. else
  75. make
  76. fi
  77. %install
  78. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  81. ##%find_lang %{name}
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %post -n compat32-%{name} -p /sbin/ldconfig
  85. %postun -n compat32-%{name} -p /sbin/ldconfig
  86. %clean
  87. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  88. ##%files -f %{name}.lang
  89. %files
  90. %defattr(-,root,root)
  91. %doc README AUTHORS ChangeLog NEWS
  92. %config %{_sysconfdir}/*
  93. %{_libdir}/lib*.so.*
  94. %{_libdir}/libimlib-*.so
  95. %files cfgeditor
  96. %defattr(-,root,root)
  97. %{_bindir}/imlib_config
  98. %{_mandir}/man1/imlib_config*
  99. %files devel
  100. %defattr(-,root,root)
  101. %doc doc/*.gif doc/*.html
  102. %{_bindir}/imlib-config
  103. %{_libdir}/libImlib.so
  104. %{_libdir}/libgdk_imlib.so
  105. %{_libdir}/pkgconfig/*
  106. %{_includedir}/*
  107. %{_datadir}/aclocal/*
  108. %{_mandir}/man1/imlib-config*
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root)
  112. %{_libdir}/lib*.so.*
  113. %{_libdir}/libimlib-*.so
  114. %endif
  115. %changelog
  116. * Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.15-4
  117. - add BuildRequires: libSM-devel, libXt-devel
  118. - add Patch3 (imlib-1.9.15-libpng15.patch) from fedora
  119. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.9.15-3
  120. - rebuilt with rpm-4.8.1 for pkg-config
  121. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.15-2
  122. - spec in utf-8
  123. * Tue Jul 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.15-1
  124. - updated to 1.9.15 (dropped Patch0)
  125. - applied to new versioning policy
  126. * Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.9.14-0vl10
  127. - added compat32-imlib package for x86_64 architecture support
  128. * Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 1.9.14-0vl9
  129. - added imlib-1.9.14-configure-x86_64.patch
  130. - disable %%find_lang macro
  131. - rebuilt for x86_64 architecture
  132. * Sat May 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.14-0vl8
  133. - added Requires: lib*-devel to devel package
  134. - added %{_libdir}/pkgconfig/*.pc files to devel package
  135. - removed gtk+ dependancy on main package
  136. * Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.14-0vl7
  137. - rebuild for VineSeed
  138. * Mon Jan 31 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.9.14-0vl6.1
  139. - Added a security patch for CAN-2004-1025 and CAN-2004-1026.
  140. - Patch1: imlib-1.9.13-sec2.patch
  141. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138516
  142. * Fri Sep 17 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.9.14-0vl6
  143. - Updated Patch0: http://bugzilla.gnome.org/show_bug.cgi?id=151034#c8
  144. * Wed Sep 1 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.9.14-0vl5
  145. - Added a security patch for buffer overflow in bmp handling (Patch0).
  146. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.9.14-0vl4
  147. - rebuild
  148. * Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.9.14-0vl2
  149. - rebuild with libpng12-devel
  150. - add BuildPrereq
  151. * Sat Mar 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.14-0vl1
  152. - updated to new upstream release
  153. - Patch0 removed (merged into upstream source)
  154. * Sat Jul 14 2001 <sagami@vinelinux.org>
  155. - 1.9.10-0vl2: fix to build against new libtool
  156. * Tue May 8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.10-0vl1
  157. - New upstream release.
  158. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.9-0vl1
  159. - New upstream release.
  160. - use rpmmacros.
  161. * Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
  162. - 1.9.8.1-2vl2
  163. - requires netpbm-progs instead of libgr-progs
  164. * Sun Jul 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  165. - change to use libtoolize
  166. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  167. - change group
  168. - added Japanese summary
  169. * Wed Jan 5 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
  170. - added setlocale patch
  171. * Mon Jan 11 1999 Carsten Haitzler <raster@redhat.com>
  172. - up to 1.9.0
  173. * Wed Sep 23 1998 Carsten Haitzler <raster@redhat.com>
  174. - up to 1.8.1
  175. * Tue Sep 22 1998 Cristian Gafton <gafton@redhat.com>
  176. - yet another build for today (%defattr and %attr in the files lists)
  177. - devel docs are back on the spec file
  178. * Tue Sep 22 1998 Carsten Haitzler <raster@redhat.com>
  179. - Added minor patch for ps saving code.
  180. * Mon Sep 21 1998 Cristian Gafton <gafton@redhat.com>
  181. - updated to version 1.8
  182. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  183. - take out imlib_config from devel package
  184. * Wed Sep 9 1998 Michael Fulbright <msf@redhat.com>
  185. - upgraded to 1.7
  186. - changed name so it will persist if user later install devel imlib
  187. - added subpackage for imlib_config
  188. * Fri Apr 3 1998 Michael K. Johnson <johnsonm@redhat.com>
  189. - fixed typo
  190. * Fri Mar 13 1998 Marc Ewing <marc@redhat.com>
  191. - Added -k, Obsoletes
  192. - Integrate into CVS source tree