libotf-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. ## -*- coding: utf-8-unix -*-
  2. Name: libotf
  3. Version: 0.9.13
  4. Release: 2%{?_dist_release}
  5. Summary: A Library for handling OpenType Font
  6. Summary(ja): OpenType フォントを扱うライブラリ
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.m17n.org/libotf/
  10. Source0: http://www.m17n.org/%{name}/%{name}-%{version}.tar.gz
  11. Patch0: libotf-0.9.13-freetype2.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gcc chrpath freetype2-devel libXaw-devel
  14. BuildRequires: autoconf
  15. Requires: freetype2
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. The library "libotf" provides the following facilites.
  20. Read Open Type Layout Tables from OTF file. Currently these tables are
  21. supported; head, name, cmap, GDEF, GSUB, and GPOS. Convert a Unicode
  22. character sequence to a glyph code sequence by using the above tables.
  23. The combination of libotf and the FreeType library (Ver.2) realizes
  24. CTL (complex text layout) by OpenType fonts. This library is currently
  25. used by the m17n library. It seems that the probject Free Type Layout
  26. provides the similar (or better) facility as this library, but
  27. currently they have not yet released their library. So, we have
  28. developed this one.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}, pkgconfig
  33. %description devel
  34. The %{name}-devel package contains libraries and header files for
  35. developing applications that use %{name}.
  36. %prep
  37. %setup -q
  38. %patch0 -p1
  39. %build
  40. autoreconf -if
  41. %configure --disable-static
  42. %__make %{?_smp_mflags}
  43. %install
  44. %__rm -rf $RPM_BUILD_ROOT
  45. %__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  46. find $RPM_BUILD_ROOT -name '*.la' -exec %__rm -f {} ';'
  47. for file in $RPM_BUILD_ROOT/usr/bin/*; do chrpath -d $file || true; done
  48. (cd example && %__make clean && %__rm -rf .deps && rm Makefile)
  49. %__rm $RPM_BUILD_ROOT/usr/bin/libotf-config
  50. %clean
  51. %__rm -rf $RPM_BUILD_ROOT
  52. %post -p /sbin/ldconfig
  53. %postun -p /sbin/ldconfig
  54. %files
  55. %defattr(-,root,root,-)
  56. %doc AUTHORS COPYING README NEWS
  57. %{_libdir}/*.so.*
  58. %{_bindir}/otfdump
  59. %{_bindir}/otflist
  60. %{_bindir}/otftobdf
  61. %{_bindir}/otfview
  62. %files devel
  63. %defattr(-,root,root,-)
  64. %doc example
  65. %{_includedir}/*
  66. %{_libdir}/*.so
  67. %{_libdir}/pkgconfig/*
  68. %changelog
  69. * Sat Jul 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.13-2
  70. - rebuild with libpng-1.6.12
  71. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.13-1
  72. - update to 0.9.13
  73. - add Patch0 (libotf-0.9.13-freetype2.patch)
  74. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.12-1
  75. - new upstream release
  76. * Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1
  77. - built based on Fedora development
  78. - s/freetype/freetype2/ in Requires, BuildRequires tags
  79. * Sat Oct 24 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-3
  80. - Add BR libXaw-devel (BR 530586)
  81. * Fri Oct 9 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-2
  82. - Remove libotf-config (just just pkg-config instead)
  83. - Remove example/Makefile to fix multilib conflict
  84. * Tue Aug 25 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-1
  85. - Update to 0.9.9
  86. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-3
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  88. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  90. * Fri Aug 8 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.8-1
  91. - Update to 0.9.8
  92. * Mon Apr 14 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-4
  93. - Remove .deps from example
  94. * Fri Mar 28 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-3
  95. - Change to LGPLv2+
  96. - Add examples
  97. * Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-2
  98. - Cleanup suggestions from panemade at gmail dot com
  99. * Tue Mar 25 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-1
  100. - Initial