viewnior-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. # We don't build with Gnome support by default to avoid a GConf dependency.
  2. # If you would like to set the Gnome background image with Viewnior, rebuild
  3. # the srpm with:
  4. # rpmbuild --rebuild viewnior-*-src.rpm --with gnome
  5. # or use bcond_without to change the default
  6. #%bcond_with gnome
  7. Name: viewnior
  8. Version: 1.4
  9. Release: 1%{?_dist_release}
  10. Summary: Elegant image viewer
  11. Summary(ja): エレガントな画像ビューア
  12. Group: Applications/Graphics
  13. License: GPLv3+
  14. URL: http://xsisqox.github.com/Viewnior
  15. Source0: http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
  16. Patch0: viewnior-0.7-dsofix.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: exiv2-devel
  19. BuildRequires: gdk-pixbuf2-devel >= 2.4.0
  20. BuildRequires: glib2-devel >= 2.24
  21. BuildRequires: gtk2-devel >= 2.20
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: intltool >= 0.35.0
  25. BuildRequires: perl-XML-Parser
  26. BuildRequires: shared-mime-info >= 0.20
  27. #%if %{with gnome}
  28. #BuildRequires: GConf2-devel
  29. #%endif
  30. %description
  31. Viewnior is an image viewer program. Created to be simple, fast and elegant.
  32. It's minimalistic interface provides more screen space for your images. Among
  33. its features are:
  34. * Fullscreen & Slideshow
  35. * Rotate, flip, save, delete images
  36. * Animation support
  37. * Browse only selected images
  38. * Navigation window
  39. * Simple interface
  40. * Configurable mouse actions
  41. %prep
  42. %setup -q
  43. %patch0 -p1 -b .dsofix
  44. # fix spurious executable perms
  45. chmod 0644 AUTHORS ChangeLog COPYING NEWS README TODO src/*
  46. %build
  47. %configure --enable-static=no \
  48. #%if %{with gnome}
  49. # --enable-wallpaper
  50. #%endif
  51. make %{?_smp_mflags} V=1
  52. %install
  53. rm -rf %{buildroot}
  54. make install DESTDIR=%{buildroot} INSTALL='install -p'
  55. %find_lang %{name}
  56. desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
  57. %clean
  58. rm -rf %{buildroot}
  59. %post
  60. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  61. update-desktop-database &> /dev/null || :
  62. %postun
  63. if [ $1 -eq 0 ] ; then
  64. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  65. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  66. fi
  67. update-desktop-database &> /dev/null || :
  68. %posttrans
  69. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  70. %files -f %{name}.lang
  71. %defattr(-,root,root,-)
  72. %doc AUTHORS ChangeLog COPYING NEWS README TODO
  73. %{_bindir}/%{name}
  74. %{_datadir}/applications/%{name}.desktop
  75. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  76. %{_datadir}/%{name}/
  77. %{_mandir}/man?/
  78. %changelog
  79. * Sat Mar 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4-1
  80. - new upstream release
  81. - added BuildRequires: exiv2-devel
  82. * Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3-1
  83. - new upstream release
  84. - dropt patch1
  85. * Sat Feb 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2-1
  86. - new upstream release
  87. - added patch1 to fix typo
  88. - added configure option: --enable-static=no
  89. * Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
  90. - initial build for VineSeed
  91. * Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
  92. - Update to 1.0
  93. * Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
  94. - Add patch to fix DSO linking (#565018)
  95. - Switch to %%bcond macro
  96. * Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
  97. - Update to 0.7
  98. * Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
  99. - Spec file cleanups from review.
  100. * Sat Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
  101. - Initial package