avogadro-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  3. %define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
  4. Name: avogadro
  5. Summary: An advanced molecular editor for chemical purposes
  6. Version: 1.1.1
  7. Release: 2%{?_dist_release}
  8. Group: Applications/Editors
  9. License: GPLv2
  10. URL: http://avogadro.openmolecules.net/
  11. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. Patch0: avogadro-1.0.3-mkspecs-dir.patch
  13. BuildRequires: cmake >= 2.6.0
  14. BuildRequires: qt4-devel >= 4.5.1
  15. BuildRequires: qt4-tools
  16. BuildRequires: eigen2-devel >= 2.0.3
  17. BuildRequires: openbabel-devel >= 2.2.2
  18. BuildRequires: libboost-devel >= 1.35
  19. BuildRequires: libboost-python >= 1.35
  20. BuildRequires: glew-devel >= 1.5.0
  21. BuildRequires: desktop-file-utils
  22. BuildRequires: docbook-utils
  23. BuildRequires: sip-devel >= 4.11
  24. BuildRequires: numpy
  25. Requires: %{name}-libs = %{version}-%{release}
  26. %description
  27. An advanced molecular editor designed for
  28. cross-platform use in computational chemistry,
  29. molecular modeling, bioinformatics, materials science,
  30. and related areas, which offers flexible rendering and
  31. a powerful plugin architecture.
  32. %package libs
  33. Summary: Shared libraries for Avogadro
  34. Summary(ja): Avogadro の共用ライブラリ
  35. Group: System Environment/Libraries
  36. Requires: sip
  37. %description libs
  38. This package contains the shared libraries for the
  39. molecular editor Avogadro.
  40. %package devel
  41. Summary: Development files for Avogadro
  42. Summary(ja): Avogadro の開発用ファイル
  43. Group: Development/Libraries
  44. Requires: %{name}-libs = %{version}-%{release}
  45. Requires: qt4-devel = %{_qt4_version}
  46. Requires: eigen2-devel >= 2.0.3
  47. Requires: glew-devel >= 1.5.0
  48. Requires: pkgconfig
  49. %description devel
  50. This package contains files to develop applications using
  51. Avogadros libraries.
  52. %prep
  53. %setup -q
  54. %patch0 -p1 -b .mkspecs-dir
  55. %build
  56. mkdir -p %{_target_platform}
  57. pushd %{_target_platform}
  58. %cmake -Wno-dev \
  59. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  60. -DBIN_INSTALL_DIR:PATH=bin \
  61. -DLIB_INSTALL_DIR:PATH=%{_lib} \
  62. -DENABLE_GLSL:BOOL=ON \
  63. -DENABLE_PYTHON:BOOL=ON \
  64. -DENABLE_RPATH:BOOL=OFF \
  65. -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
  66. %{?ENABLE_TESTS} ..
  67. popd
  68. make %{?_smp_mflags} -C %{_target_platform}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  72. %check
  73. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
  74. # all of these currently require an active X session, so will fail
  75. # in mock
  76. %{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
  77. %post libs -p /sbin/ldconfig
  78. %postun libs -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root,-)
  81. %doc AUTHORS ChangeLog COPYING
  82. %{_bindir}/avogadro
  83. %{_bindir}/avopkg
  84. # TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
  85. %{_datadir}/avogadro/
  86. %{_datadir}/pixmaps/avogadro-icon.png
  87. %{_datadir}/applications/avogadro.desktop
  88. %{_mandir}/man1/avogadro.1*
  89. %{_mandir}/man1/avopkg.1*
  90. %files devel
  91. %defattr(-,root,root,-)
  92. %{_includedir}/avogadro/
  93. %{_libdir}/libavogadro.so
  94. %{_libdir}/libavogadro_OpenQube.so
  95. %{_libdir}/avogadro/*.cmake
  96. %{_libdir}/avogadro/cmake/
  97. %{_libdir}/pkgconfig/avogadro.pc
  98. %{_qt4_prefix}/mkspecs/features/avogadro.prf
  99. %files libs
  100. %defattr(-,root,root,-)
  101. %{python_sitearch}/Avogadro.so
  102. %{_datadir}/libavogadro/
  103. %{_libdir}/libavogadro.so.*
  104. %{_libdir}/libavogadro_OpenQube.so.*
  105. %dir %{_libdir}/avogadro/
  106. %{_libdir}/avogadro/colors/
  107. %{_libdir}/avogadro/extensions/
  108. %{_libdir}/avogadro/engines/
  109. %{_libdir}/avogadro/tools/
  110. %changelog
  111. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-2
  112. - rebuild with glew-1.13.0
  113. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
  114. - update to 1.1.1
  115. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
  116. - update to 1.0.3
  117. - remove old patches
  118. - add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
  119. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
  120. - rebuild with qt4-4.8.5
  121. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
  122. - rebuild with qt4-4.8.3
  123. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
  124. - rebuild with qt4-4.8.2
  125. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
  126. - rebuild with python-2.7.2
  127. * Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
  128. - rebuild with qt4-4.8.0 and glew-1.7.0
  129. * Wed Mar 9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
  130. - rebuilt with qt4-4.7.2
  131. - BR: qt4-tools instead of qt4-designer
  132. * Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
  133. - added BR: libboost-python
  134. - added R: glew-devel, eigen2-devel to devel package
  135. * Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
  136. - rebuilt with qt4-4.7.1
  137. - added Patch0 and 1 from Fedora
  138. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
  139. - rebuilt with libboost-1.45.0
  140. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  141. - Initial build for Vine Linux
  142. * Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
  143. - Rebuild for Boost soname bump
  144. - Update to match current guidelines
  145. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
  146. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  147. * Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
  148. - avogadro-1.0.1
  149. - -devel: move cmake-related files here
  150. - -devel: Req: qt4-devel
  151. - %%files: track lib sonames
  152. - %%check section
  153. * Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
  154. - reenable plugin builds and libs subpackage
  155. - fix their build with sip 4.10
  156. * Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
  157. - disable plugin builds and libs subpackage
  158. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
  159. - rebuild (sip)
  160. * Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
  161. - rebuild (for qt-4.6.0-rc1, f13+)
  162. * Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
  163. - -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
  164. - Requires: %%{name}-libs ...
  165. * Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
  166. - update to new upstream release
  167. * Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
  168. - rebuild (eigen2)
  169. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
  170. - fix typo in file list
  171. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
  172. - update to new upstream release
  173. - enable python and glsl support again
  174. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  176. * Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
  177. - new upstream release to fix issue with qt 4.5.0 and earlier
  178. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
  179. - remove remaining python parts
  180. - fix files section finally
  181. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
  182. - disable python and glsl for now
  183. - fix files section
  184. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
  185. - update to new release
  186. * Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
  187. - update to new release
  188. * Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
  189. - update to new release
  190. * Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
  191. - get desktop file properly installed
  192. * Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
  193. - update to new release
  194. * Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
  195. - update to new release
  196. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  198. * Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
  199. - update to new release
  200. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
  201. - add handbook to docs
  202. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
  203. - add build requirements and fix group names
  204. * Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
  205. - fix typos
  206. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
  207. - reorganize spec file
  208. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
  209. - rename shared library package and structure spec file
  210. * Sun Aug 3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
  211. - initial pacakging release based on PackMan release