dblatex-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: dblatex
  3. Version: 0.3.2
  4. Release: 4%{?_dist_release}
  5. Summary: DocBook to LaTeX/ConTeXt Publishing
  6. BuildArch: noarch
  7. Group: Applications/Publishing
  8. License: GPLv2+
  9. URL: http://dblatex.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  11. #Source1: http://docbook.sourceforge.net/release/xsl/current/COPYING
  12. Source1: COPYING-docbook-xsl
  13. Patch0: dblatex-0.2.7-external-which.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  15. BuildRequires: python-devel
  16. BuildRequires: python-which
  17. BuildRequires: libxslt docbook-dtds ImageMagick
  18. ## Need epstopdf, fig2dev
  19. BuildRequires: texlive-collection-fontutils
  20. BuildRequires: transfig
  21. BuildRequires: texlive-vtlpkg >= 2013
  22. ##BuildRequires: tex(latex)
  23. ##BuildRequires: tex(xetex)
  24. BuildRequires: texlive >= 2013
  25. ## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
  26. ## overpic.sty, subfigure.sty, titlesec.sty
  27. BuildRequires: texlive-collection-latexextra
  28. ## stmaryrd.sty
  29. BuildRequires: texlive-collection-mathextra
  30. BuildRequires: texlive-collection-htmlxml
  31. Requires: libxslt docbook-dtds ImageMagick
  32. ##Requires: tex(xetex)
  33. Requires: texlive >= 2013
  34. Requires: texlive-collection-latexextra
  35. Requires: transfig
  36. BuildRequires: texlive-collection-mathextra
  37. ##Requires: passivetex
  38. Requires: texlive-collection-htmlxml
  39. ## $ rpm -qf --qf "%{name}\n" $(kpsewhich $(grep "usepackage" $(rpm -ql dblatex | grep sty) | sed -e "s,.*{,," -e "s,}.*$,.sty,")) | sort | uniq
  40. Requires: texlive-collection-langcjk texlive-collection-bibtexextra
  41. %description
  42. dblatex is a program that transforms your SGML/XMLDocBook
  43. documents to DVI, PostScript or PDF by translating them
  44. into pure LaTeX as a first process. MathML 2.0 markups
  45. are supported, too. It started as a clone of DB2LaTeX.
  46. Authors:
  47. --------
  48. Benoît Guillon <marsgui at users dot sourceforge dot net>
  49. Andreas Hoenen <andreas dot hoenen at arcor dot de>
  50. %prep
  51. %setup -q
  52. %patch0 -p1 -b .external-which
  53. %__rm -rf lib/contrib
  54. %build
  55. %{__python} setup.py build
  56. %install
  57. %__rm -rf $RPM_BUILD_ROOT
  58. #%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  59. %{__python} setup.py install --root $RPM_BUILD_ROOT
  60. # these are already in tetex-latex:
  61. for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
  62. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
  63. done
  64. %__mkdir_p $RPM_BUILD_ROOT%{_tl_texmfvine}/tex/latex/dblatex
  65. for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
  66. %__mv $file $RPM_BUILD_ROOT%{_tl_texmfvine}/tex/latex/dblatex/`basename $file` || exit 1;
  67. done
  68. ## also move .xetex files
  69. for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
  70. %__mv $file $RPM_BUILD_ROOT%{_tl_texmfvine}/tex/latex/dblatex/`basename $file` || exit 1;
  71. done
  72. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
  73. %__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
  74. # shipped in %%docs
  75. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
  76. %__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
  77. touch -r xsl/mathml2/README README-xsltml
  78. %__cp -p %{SOURCE1} COPYING-docbook-xsl
  79. %clean
  80. %__rm -rf $RPM_BUILD_ROOT
  81. %post
  82. %_tl_touch_run texhash
  83. exit 0
  84. %postun
  85. if [ "$1" = 0 ]; then
  86. %_tl_touch_run texhash
  87. fi
  88. exit 0
  89. %posttrans
  90. %{_tl_exec_texhash}
  91. exit 0
  92. %files
  93. %defattr(-,root,root,-)
  94. %{_mandir}/man1/dblatex.1*
  95. %doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
  96. %{python_sitelib}/dbtexmf/
  97. %{python_sitelib}/dblatex-*.egg-info
  98. %{_bindir}/dblatex
  99. %{_datadir}/dblatex/
  100. %{_tl_texmfvine}/tex/latex/dblatex/
  101. %dir %{_sysconfdir}/dblatex
  102. %changelog
  103. * Thu Aug 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-4
  104. - added BuildRequires: texlive-vtlpkg
  105. * Fri Dec 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-3
  106. - added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]
  107. * Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-2
  108. - rebuild with Python 2.7.2
  109. * Fri Jan 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
  110. - new upstream release
  111. * Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
  112. - initial build
  113. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  115. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
  116. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  117. * Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
  118. - Update to 0.3
  119. - Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
  120. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  122. * Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
  123. - remove dblatex-0.2.9-xetex.patch
  124. * Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
  125. - Update to 0.2.10
  126. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  128. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
  129. - Rebuild for Python 2.6
  130. * Fri Jul 4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
  131. - BR: texlive-xetex -> tex(xetex) for F-10 and later
  132. * Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
  133. - Update to latest upstream (0.2.9) (#448953)
  134. - Remove some redundant Requires and BuildRequires (passivetex pulls
  135. in the tetex/tex requires, python dep added automatically)
  136. - For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
  137. scripts to install extra new files.
  138. - Add patch from dblatex mailing list for better handling of a missing
  139. xetex.
  140. - Conditionally add .egg-info file only if F9+ to allow for unified
  141. spec file
  142. * Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
  143. - don't install in docbook directory, it is a link to a versioned
  144. directory and may break upon docbook update (#425251,#389231)
  145. * Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
  146. - Update to 0.2.8
  147. * Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
  148. - convert spec to utf8
  149. - change to gplv2+
  150. * Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
  151. - Add copyright info
  152. * Mon Nov 5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
  153. - Req tetex-fonts for texhash
  154. - Fix post, postun
  155. * Sun Nov 4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
  156. - Add texhash
  157. * Sun Nov 4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
  158. - Fix xsl link
  159. * Sat Nov 3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
  160. - Various fixes from pertusus@free.fr:
  161. - rm iconv stuff
  162. - simplify docs installation
  163. * Fri Nov 2 2007 <ndbecker2@gmail.com> - 0.2.7-11
  164. - Various minor fixes
  165. * Thu Nov 1 2007 <ndbecker2@gmail.com> - 0.2.7-10
  166. - Add some reqs and brs
  167. - rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
  168. * Sat Oct 27 2007 <ndbecker2@gmail.com> - 0.2.7-9
  169. - link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
  170. - rmdir /usr/share/dblatex/latex/{misc,specs,style}
  171. - own /etc/dblatex
  172. - change $(...) -> `...`
  173. - Preserve timestamps on iconv
  174. * Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
  175. - mv all .sty files to datadir/texmf/tex/latex/dblatex
  176. - Add Conflicts tetex-tex4ht
  177. - mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
  178. * Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
  179. - rm redundant latex files
  180. * Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
  181. - Fixed encodings in docs directory
  182. - Install docs at correct location
  183. * Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
  184. - Revert back to GPLv2
  185. - untabify
  186. * Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
  187. - Fix source URL
  188. - Install all docs
  189. - Tabify
  190. * Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
  191. - Add BR tetex-latex
  192. * Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
  193. - Add BR tetex, ImageMagick
  194. * Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
  195. - Add BR libxslt
  196. * Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
  197. - Add BR python-devel
  198. * Fri Sep 7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
  199. - Initial