gdb-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 7.5
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. BuildRequires: python-devel
  13. BuildRequires: zlib-devel
  14. Requires: install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Takemikaduchi
  18. %description
  19. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  20. and other languages, by executing them in a controlled fashion and
  21. printing their data.
  22. %description -l ja
  23. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  24. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  25. %prep
  26. %setup -q
  27. %build
  28. export CFLAGS="$RPM_OPT_FLAGS"
  29. rm -fr dejagnu tcl expect
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --sysconfdir=%{_sysconfdir} \
  33. --mandir=%{_mandir} \
  34. --infodir=%{_infodir} \
  35. %{_target_platform}
  36. make
  37. make info
  38. cp gdb/NEWS .
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  42. # install the gcore script in /usr/bin
  43. install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
  44. # The above is broken, do this for now:
  45. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  46. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  47. # These are part of binutils
  48. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  49. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  51. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  52. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  53. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
  54. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  55. rm -rf $RPM_BUILD_ROOT%{_includedir}
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  63. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
  64. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  65. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  66. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  67. %preun
  68. if [ $1 = 0 ]; then
  69. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  73. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  74. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  75. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  76. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  77. fi
  78. %files
  79. %defattr(-,root,root)
  80. %doc COPYING COPYING.LIB README NEWS
  81. %{_bindir}/*
  82. %{_mandir}/*/*
  83. %{_datadir}/gdb/syscalls
  84. %{_datadir}/gdb/python/gdb
  85. %{_infodir}/annotate.info*
  86. %{_infodir}/gdb.info*
  87. %{_infodir}/gdbint.info*
  88. %{_infodir}/stabs.info*
  89. %exclude %{_infodir}/dir
  90. %ifarch %{ix86} x86_64
  91. %{_libdir}/libinproctrace.so
  92. %endif
  93. ## don't include the files in include, they are part of binutils
  94. #%{_includedir}/*
  95. #%{_infodir}/bfd.info*
  96. #%{_infodir}/configure.info*
  97. #%{_infodir}/standard.info*
  98. #%{_libdir}/*
  99. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  100. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  101. %changelog
  102. * Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
  103. - new upstream release
  104. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
  105. - new upstream release
  106. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
  107. - new upstream release
  108. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  109. - add BuildRequires: python-devel, zlib-devel
  110. - fix %%files
  111. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  112. - updated gdb to 7.2
  113. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  114. - updated gdb to 7.0.1
  115. - rebuilt with new environment
  116. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  117. - applied new versioning policy, spec in utf-8
  118. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  119. - rebuild with expat-2.0.1
  120. - add BuildRequires: expat-devel
  121. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  122. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  123. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  124. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  125. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  126. - new upstream release
  127. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  128. - new upstream release
  129. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  130. - new upstream release
  131. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  132. - Oops, spec was written in Shift-JIS. Fixed.
  133. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  134. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  135. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  136. - added mainframe patch from developerworks
  137. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  138. - Add changelogs to the previous patch
  139. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  140. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  141. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  142. - 5.2.1
  143. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  144. - compile on mainframe
  145. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  146. - Rebuild
  147. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  148. - Rebuild
  149. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  150. - 5.2
  151. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  152. - 5.1.92. Hopefully identical to 5.2 final
  153. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  154. - 5.1.91. 5.2 expected in a week
  155. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  156. - Update to current
  157. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  158. - Update to current
  159. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  160. - Update to current
  161. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  162. - Update to current
  163. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  164. - Update to current 5.2 branch
  165. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  166. - 5.1.1
  167. - add URL
  168. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  169. - automated rebuild
  170. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  171. - Fix some thread+fpu problems
  172. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  173. - 5.1
  174. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  175. - 5.0.94. Almost there....
  176. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  177. - Add patch from jakub@redhat.com to improve handling of DWARF
  178. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  179. - 5.0.93
  180. - handle missing info pages in post/pre scripts
  181. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  182. - 5.0.92
  183. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  184. - New snapshot
  185. - Use the 5.0.91 versioning from the snapshot
  186. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  187. - New snapshot
  188. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  189. - New snapshot
  190. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  191. - New snapshot
  192. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  193. - Don't buildrequire compat-glibc (#51690)
  194. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  195. - New snapshot, from the stable branch eventually leading to gdb 5.1
  196. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  197. - s/Copyright/License/
  198. - Add texinfo to BuildRequires
  199. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  200. - New snapshot
  201. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  202. - New snapshot
  203. - Add ncurses-devel to buildprereq
  204. - Remove perl from buildprereq, as gdb changed the way
  205. version strings are generated
  206. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  207. - New snapshot
  208. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  209. - New snapshot - this had thread fixes for curing #39070
  210. - New way of specifying version
  211. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  212. - New tarball
  213. - Kevin's patch is now part of gdb
  214. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  215. - Add patch from kevinb@redhat.com to fix floating point + thread
  216. problem (#24310)
  217. - remove old workarounds
  218. - new snapshot
  219. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  220. - New snapshot
  221. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  222. - on ia64, there are no old headers :)
  223. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  224. - build with old headers, new compiler
  225. * Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  226. - new snapshot
  227. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  228. - new snapshot which should fix some more IA64 problems (#29151)
  229. - remove IA64 patch, it's now integrated
  230. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  231. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  232. - use perl instead of patch for fixing the version string
  233. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  234. - don't use kgcc anymore
  235. - mark it as our own version
  236. - new snapshot
  237. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  238. - Link with ncurses 5.x even though we're using kgcc.
  239. No need to drag in requirements on ncurses4 (Bug #24445)
  240. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  241. - new snapshot
  242. * Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  243. - new snapshot
  244. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  245. - new snapshot
  246. - new alpha patch - it now compiles everywhere. Finally.
  247. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  248. - new snapshot
  249. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  250. - new CVS snapshot
  251. - disable the patches
  252. - don't use %%configure, as it confuses the autoconf script
  253. - enable SPARC, disable Alpha
  254. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  255. - added patch from GDB team for C++ symbol handling
  256. * Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  257. - upgrade to CVS snapshot
  258. - excludearch SPARC, build on IA61
  259. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  260. - rebuild
  261. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  262. - automatic rebuild
  263. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  264. - rebuild
  265. * Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  266. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  267. and %%{_tmppath}
  268. - the install scripts for info are broken(they don't care about
  269. you specify in the installstep), work around that.
  270. - don't build for IA64
  271. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  272. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  273. - added the NEWS file to the %%doc files
  274. - don't delete files which doesn't get installed (readline, texinfo)
  275. - let build system handle stripping and gzipping
  276. - don't delete libmmalloc
  277. - apply patch from jakub@redhat.com to make it build on SPARC
  278. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  279. - rebuilt against new ncurses
  280. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  281. - rebuild for sparc baud rates > 38400.
  282. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  283. - fix core file handling on i386 with glibc 2.1.3 headers
  284. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  285. - fix reading registers from core on sparc.
  286. - hack around build problems on i386 with glibc 2.1.3 headers
  287. * Thu Oct 7 1999 Jim Kingdon
  288. - List files to install in /usr/info specifically (so we don't pick up
  289. things like info.info from GDB snapshots).
  290. * Thu Oct 7 1999 Jim Kingdon
  291. - Update GDB to 19991004 snapshot. This eliminates the need for the
  292. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  293. * Mon Aug 23 1999 Jim Kingdon
  294. - Omit readline manpage.
  295. * Tue Aug 7 1999 Jim Kingdon
  296. - Remove H.J. Lu's patches (they had been commented out).
  297. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  298. from code fusion CD-ROM).
  299. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  300. - merge H.J. Lu's patches into 4.18.
  301. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  302. - updated the kern22 patch with stuff from davem
  303. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  304. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  305. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  306. - auto rebuild in the new build environment (release 3)
  307. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  308. - Sparc fiddles for Red Hat 6.0.