lftp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350
  1. %define name lftp
  2. %define version 4.4.0
  3. %define release 1%{?_dist_release}
  4. Summary: The lftp command line ftp/http client
  5. Summary(ja): lftp - コマンドライン ftp/http クライアント
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. License: GPL3
  10. Group: Applications/Internet
  11. # Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.bz2
  12. Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.xz
  13. # Source10: lftp-3.0.9-0vl1-ja.po
  14. # Source10: lftp-3.7.4-ja.po
  15. URL: http://lftp.yar.ru/
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel
  18. BuildRequires: expat-devel
  19. Packager: iwamoto
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. LFTP is a shell-like command line ftp client. It is
  24. reliable: can retry operations and does reget automatically.
  25. It can do several transfers simultaneously in background.
  26. You can start a transfer in background and continue browsing
  27. the ftp site or another one. This all is done in one process.
  28. Background jobs will be completed in nohup mode if you exit
  29. or close modem connection. Lftp has reput, mirror, reverse
  30. mirror among its features. Since version 2.0 it also supports
  31. http protocol.
  32. %description -l ja
  33. LFTP は、shell ライクなコマンドライン ftp クライアントです。
  34. リトライ機能の実装や自動的な再取得を行うため信頼性が高いです。
  35. バックグラウンドで複数の転送を同時に行うことができます。
  36. バックグラウンドでの転送を開始し、その ftp サイトや別の ftp
  37. サイトを閲覧し続けることができます。これらは全て 1 つのプロセス
  38. で実行されます。
  39. もし、モデムの接続が exit や close された場合、バックグラウンド
  40. ジョブは、nohup モードで終了します。lftp の特徴は、reput やミラー、
  41. 逆ミラーなどです。バージョン 2.0 以降では、HTTP もサポートしています。
  42. %package scripts
  43. Summary: Scripts for lftp
  44. Summary(ja): lftp のユーティリティスクリプト
  45. Group: Applications/Internet
  46. Requires: lftp = %{version}-%{release}
  47. Requires: perl(DBD::SQLite)
  48. BuildArch: noarch
  49. %description scripts
  50. Utility scripts for use with lftp.
  51. %description scripts -l ja
  52. lftp のユーティリティスクリプトです。
  53. %prep
  54. %setup -q
  55. # cp po/ja.po po/ja.po.orig
  56. # msgmerge -v %{SOURCE10} po/ja.po.orig -o po/ja.po
  57. %build
  58. if pkg-config openssl ; then
  59. CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
  60. LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
  61. fi
  62. LDFLAGS="-L`pwd`/src/.libs $LDFLAGS"; export LDFLAGS
  63. %configure --with-modules --disable-static --with-openssl
  64. export tagname=CC
  65. make %{?_smp_mflags}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. %makeinstall sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.la
  70. chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/*
  71. chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.so
  72. # Remove files from $RPM_BUILD_ROOT that we aren't shipping.
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.a
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  75. %find_lang %{name}
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %files -f %{name}.lang
  79. %defattr(-,root,root)
  80. %doc README README.modules FAQ THANKS COPYING
  81. %doc TODO lftp.lsm NEWS INSTALL FEATURES
  82. %config(noreplace) %{_sysconfdir}/lftp.conf
  83. %{_bindir}/*
  84. %{_mandir}/*/*
  85. # %{_datadir}/lftp
  86. %{_libdir}/*.so*
  87. %dir %{_libdir}/lftp
  88. %dir %{_libdir}/lftp/%{version}
  89. %{_libdir}/lftp/%{version}/cmd-*.so
  90. %{_libdir}/lftp/%{version}/liblftp-network.so
  91. # %{_libdir}/lftp/%{version}/liblftp-getdate.so
  92. %{_libdir}/lftp/%{version}/liblftp-pty.so
  93. %{_libdir}/lftp/%{version}/proto-*.so
  94. %files scripts
  95. %defattr(-,root,root,-)
  96. %{_datadir}/lftp
  97. %changelog
  98. * Sun Sep 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.4.0-1
  99. - new upstream release
  100. - use upstream ja.po instead of old local ja.po (source10)
  101. * Sat Jun 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.7-1
  102. - new upstream release
  103. - built with openssl 1.0.1
  104. * Mon May 2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.3-1
  105. - new upstream release
  106. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-3
  107. - rebuilt with openssl 1.0.0c
  108. * Wed Jan 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-2
  109. - separated scripts to script package
  110. * Mon Jan 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-1
  111. - new upstream release
  112. - change source tarball format (bz2 -> xz)
  113. * Sat Aug 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.9-1
  114. - new upstream release with security fix (CVE-2010-2251)
  115. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.5-1
  116. - new upstream release
  117. - update ja.po file (Thanks to Tadashi Jokagi <elf@elf.no-ip.org>)
  118. - update %files section to fit new release
  119. * Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.15-1
  120. - new upstream release
  121. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.14-1
  122. - new upstream release
  123. * Wed May 06 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.13-1
  124. - new upstream release
  125. * Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.11-1
  126. - new upstream release
  127. * Wed Mar 04 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.9-1vl5
  128. - new upstream release
  129. * Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.8-1vl5
  130. - new upstream release
  131. - fix License tag
  132. * Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.7-1vl5
  133. - new upstream release
  134. * Mon Dec 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.6-1vl5
  135. - new upstream release
  136. * Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.4-1vl5
  137. - new upstream release
  138. - del liblftp-getdate.so from files list (upstream change)
  139. * Sat Jul 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.3-1vl5
  140. - new upstream release
  141. - spec in UTF8
  142. * Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-2vl5
  143. - add BuildPrereq expat-devel
  144. * Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-1vl5
  145. - new upstream release
  146. - new versioning policy
  147. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.0-0vl1
  148. - new upstream release
  149. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.6.1-0vl2
  150. - rebuild with expat-2.0.1
  151. * Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.6.1-0vl1
  152. - new upstream release
  153. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.15-0vl1
  154. - new upstream release
  155. * Tue Aug 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.13-0vl1
  156. - new upstream release
  157. * Mon Jul 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.12-0vl1
  158. - new upstream release
  159. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-0vl1
  160. - new upstream release
  161. - rebuilt with new toolchain and openssl-0.9.8
  162. * Sat Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.9-0vl1
  163. - new upstream release
  164. * Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.5.6-0vl3
  165. - fix configure option to use openssl
  166. * Sun Oct 29 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.5.6-0vl2
  167. - rebuild with gnutls-1.4.1
  168. * Fri Oct 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.6-0vl1
  169. - new upstream release
  170. * Mon Aug 21 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.5.4-0vl1
  171. - new upstream release
  172. * Fri Jul 07 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.7-0vl2
  173. - changed Group to Applications/Internet
  174. * Fri Jun 09 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.4.7-0vl1
  175. - new upstream release
  176. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.4.2-0vl2
  177. - rebuild with readline-5.1
  178. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.2-0vl1
  179. - new upstream release
  180. * Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 3.0.9-0vl1
  181. - new upstream release
  182. - update ja.po ( Source10 )
  183. - add Japanese description
  184. - lftp.conf: noreplace
  185. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-0vl1
  186. - new upstream release
  187. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.5-0vl1
  188. - new upstream release
  189. * Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.3-0vl1
  190. - new upstream release
  191. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl2
  192. - update ja.po (more work needed...)
  193. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl1
  194. - new upstream release
  195. * Sun Apr 4 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 3.0.0-0vl1
  196. - new upstream release
  197. * Mon Mar 1 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 2.6.12-0vl1
  198. - new upstream release
  199. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.11-0vl1
  200. - new upstream release
  201. * Thu Dec 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.10-0vl1
  202. - new upstream release
  203. * Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.7-0vl1
  204. - new upstream release
  205. * Tue Jun 10 2003 Jun NISHII <jun@vinelinux.org> 2.6.5-2vl1
  206. - synced with RawHide 2.6.5-2
  207. * Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.6.3-4vl1
  208. - synced with RawHide 2.6.3-4
  209. * Wed Jan 23 2002 Jun Nishii <jun@vinelinux.org> 2.4.8-0vl1
  210. - ver.up
  211. - fix COPYRIGHT(GPL->GPL2)
  212. * Tue Sep 25 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  213. - 2.4.4
  214. - major version update
  215. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  216. - 2.3.10-0vl5
  217. - rebuilt with openssl-0.9.6b
  218. * Thu May 24 2001 <sagami@vinelinux.org>
  219. - 2.3.10-0vl4: fix so as not to own %%{_bindir} itself
  220. * Thu May 24 2001 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.10-0vl3
  221. - remove configurei's --with-modules option.
  222. * Sat May 19 2001 <takei@vinelinux.org> 2.3.10-0vl2
  223. - fixed spec bug( sevaral lftp modules lack)
  224. * Fri May 11 2001 <sagami@vinelinux.org>
  225. - 2.3.10-0vl1: use more macros
  226. * Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl2
  227. - enable ssl
  228. * Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl1
  229. - 2.3.7-0vl1
  230. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  231. - 2.3.3-0vl4
  232. - rebuilt with readline-4
  233. * Thu Oct 12 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl3
  234. - add lftpget
  235. * Mon Oct 9 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl1
  236. - upstream merge ja.po
  237. - %doc /usr/man -> %{_mandir}
  238. - several .spec file's bug fixed.
  239. * Sun Oct 1 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.0-0vl5
  240. - fixed ja.po
  241. * Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  242. - 2.2.6-1vl0
  243. - remove noroot.patch
  244. * Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  245. - 2.2.2-1vl3
  246. - added Japanese message catalog file
  247. * Thu Jul 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  248. - 2.2.2-1vl2
  249. - cleaned up noroot.patch
  250. - added %build tag (why forgotten?)
  251. - added Japanese Summary
  252. - modified %files section to handle compressed man pages
  253. * Thu May 4 2000 Kazuhisa TAKEI <takei@vinelinux.org>
  254. - change spec file for Vine Linux
  255. * Sat Oct 02 1999 Alexander Lukyanov <lav@yars.free.net>
  256. - 2.1.1 release
  257. - removed ChangeLog from doc.
  258. * Mon Sep 27 1999 Alexander Lukyanov <lav@yars.free.net>
  259. - 2.1.0 release
  260. * Tue Sep 14 1999 Alexander Lukyanov <lav@yars.free.net>
  261. - add lftpget
  262. * Tue Jul 27 1999 Adrian Likins <alikins@redhat.com>
  263. -initial release