ming-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201
  1. Name: ming
  2. Summary: Ming - an SWF output library
  3. Summary(ja): SWF 出力ライブラリ
  4. Version: 0.4.3
  5. Release: 2%{?_dist_release}
  6. License: LGPL
  7. Group: System Environment/Libraries
  8. URL: http://sourceforge.net/projects/ming/
  9. Source: %{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Requires: freetype2 zlib libungif libpng
  12. BuildRequires: freetype2-devel zlib-devel libungif-devel libpng-devel
  13. BuildRequires: swig
  14. %description
  15. Ming is a library for generating Macromedia Flash files (.swf), written in C,
  16. and includes useful utilities for working with .swf files.
  17. It has wrappers that allow it to be used in C++, PHP, Python, Ruby, and Perl.
  18. See http://www.libming.net/FrontPage
  19. %package devel
  20. Summary: A SWF output library
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}
  23. Requires: freetype2-devel zlib-devel libungif-devel libpng-devel
  24. %description devel
  25. The ming-devel package includes the static libraries,
  26. header files, and developer docs for the ming package.
  27. Install ming-devel if you want to develop programs which
  28. will use ming.
  29. %package python
  30. Summary: Ming Python wrapper
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}
  33. BuildRequires: python-devel
  34. %description python
  35. %{summary}
  36. %package tcl
  37. Summary: Ming Tcl wrapper
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}
  40. %description tcl
  41. %{summary}
  42. %package perl
  43. Summary: Ming Perl wrapper
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}
  46. %description perl
  47. %{summary}
  48. %package php
  49. Summary: Ming PHP wrapper
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}
  52. BuildRequires: php5-devel
  53. %description php
  54. %{summary}
  55. %prep
  56. %setup -q
  57. %build
  58. %configure \
  59. --enable-python \
  60. --enable-tcl \
  61. --enable-php \
  62. --enable-perl \
  63. --with-pic \
  64. ;
  65. make %{?_smp_mflags}
  66. %install
  67. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  68. make install \
  69. DESTDIR=$RPM_BUILD_ROOT \
  70. pkgconfigdir=%{_libdir}/pkgconfig \
  71. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  72. ;
  73. chmod 755 $RPM_BUILD_ROOT%{perl_sitearch}/auto/SWF/*.so
  74. make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man1
  75. make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man3
  76. %post -p /sbin/ldconfig
  77. %post python -p /sbin/ldconfig
  78. %post tcl -p /sbin/ldconfig
  79. %post perl -p /sbin/ldconfig
  80. %post php -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %postun python -p /sbin/ldconfig
  83. %postun tcl -p /sbin/ldconfig
  84. %postun perl -p /sbin/ldconfig
  85. %postun php -p /sbin/ldconfig
  86. %clean
  87. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  88. %files
  89. %defattr(-,root,root)
  90. %doc README AUTHORS COPYING ChangeLog
  91. %{_libdir}/libming*.so.*
  92. %{_bindir}/*
  93. %{_mandir}/man1/*
  94. %files devel
  95. %defattr(-, root, root)
  96. %{_includedir}/*
  97. %{_libdir}/libming.so
  98. %{_libdir}/pkgconfig
  99. %{_mandir}/man3/*
  100. %exclude %{_libdir}/*.a
  101. %exclude %{_libdir}/*.la
  102. %files python
  103. %defattr(-, root, root)
  104. %{python_sitearch}/*.so
  105. %{python_sitearch}/*.py*
  106. %{python_sitearch}/mingc-%{version}-py%{pyver}.egg-info
  107. %files tcl
  108. %defattr(-, root, root)
  109. %{_libdir}/%{name}/tcl/*.so
  110. %exclude %{_libdir}/%{name}/tcl/*.a
  111. %exclude %{_libdir}/%{name}/tcl/*.la
  112. %files perl
  113. %defattr(-, root, root)
  114. %{_libdir}/perl5/*
  115. %files php
  116. %defattr(-, root, root)
  117. %{_libdir}/php5/*
  118. %changelog
  119. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-2
  120. - rebuilt with rpm-4.8.1 for pkg-config
  121. * Tue Feb 16 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-1
  122. - updated ming to 0.4.3
  123. - added %{name}-python, -tcl, -perl, -php sub packages
  124. - added BR: swig python-devel php-devel
  125. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.2-1vl5
  126. - updated ming to 0.4.2
  127. - added tags: BuildRequires Requires
  128. - added sub package: ming-devel
  129. - added script at %%clean
  130. - applied new versioning policy, spec in utf-8
  131. * Wed Sep 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl3
  132. - fixed args type of addString function (Patch1)
  133. - added Japanese Summary
  134. * Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl2
  135. - removed Vendor: tag
  136. - fixed post and postun section
  137. * Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl1
  138. - rebuild for Vine Linux
  139. - based on TLD 10, but removed Serial:
  140. * Thu Apr 24 2003 Noriyuki Suzuki <noriyuki@turbolinux.co.jp>
  141. - modified spec file for x86_64.
  142. * Thu Feb 28 2002 Kiichiro NAKA <knaka@turbolinux.co.jp>
  143. - I have gotten SRPM from http://rpms.arvin.dk/ming/source/
  144. * Tue Aug 21 2001 Troels Arvin <troels@arvin.dk>
  145. [0.2a-2.arvin]
  146. - Add Hansuck Jo's listmp3.c patch.
  147. - Build and include some of the utils.
  148. * Mon Aug 20 2001 Troels Arvin <troels@arvin.dk>
  149. [0.2a-1.arvin]
  150. - Uses new source version.
  151. * Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
  152. [0.1.1-3.arvin]
  153. - Added distribution to release-tag.
  154. * Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
  155. [0.1.1-2.arvin]
  156. - Fixed a permission problem for the documentation
  157. area.
  158. * Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
  159. [0.1.1-1.arvin]
  160. - Rebuilt with new source version.
  161. * Mon Mar 19 2001 Troels Arvin <troels@arvin.dk>
  162. [0.1.0-1.arvin]
  163. - Rebuilt with new source version. Patches shouldn't be need
  164. any more.
  165. * Mon Jan 29 2001 Troels Arvin <troels@arvin.dk>
  166. [0.0.9c-1.arvin]
  167. - First Ming RPM package. Currently, the RPM doesn't include
  168. anyting but the shared library and the C-oriented include
  169. file. None of the wrappers for other languages are handled by this
  170. RPM, currently. Also, none of the utilities are included in the
  171. package yet.