xl2tpd-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378
  1. %define src_dir_name xl2tpd-%{version}
  2. Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
  3. Name: xl2tpd
  4. Version: 1.3.10.1
  5. Release: 1%{?_dist_release}
  6. # No version specified.
  7. License: GPL+
  8. Url: http://www.xelerance.com/software/xl2tpd/
  9. Group: System Environment/Daemons
  10. Source0: https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz#/xl2tpd-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. Requires: ppp
  13. BuildRequires: libpcap-devel
  14. BuildRequires: openssl-devel
  15. Requires(post): /sbin/chkconfig
  16. Requires(preun): /sbin/chkconfig
  17. Requires(preun): /sbin/service
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: tomop
  21. %description
  22. xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
  23. L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user
  24. sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP
  25. servers. Another important application is Virtual Private Networks where
  26. the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec,
  27. RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and
  28. Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec
  29. implementations such as Openswan.
  30. Example configuration files for such a setup are included in this RPM.
  31. xl2tpd works by opening a pseudo-tty for communicating with pppd.
  32. It runs completely in userspace.
  33. xl2tpd supports IPsec SA Reference tracking to enable overlapping internak
  34. NAT'ed IP's by different clients (eg all clients connecting from their
  35. linksys internal IP 192.168.1.101) as well as multiple clients behind
  36. the same NAT router.
  37. xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher,
  38. or via a patch in contrib for 2.4.x kernels.
  39. Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
  40. It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
  41. %prep
  42. %setup -q -n %{src_dir_name}
  43. %build
  44. make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
  45. %install
  46. rm -rf %{buildroot}
  47. make DESTDIR=%{buildroot} PREFIX=%{_prefix} install
  48. install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf
  49. install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd
  50. install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets
  51. install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
  52. install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd
  53. install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
  54. %clean
  55. rm -rf %{buildroot}
  56. %post
  57. /sbin/chkconfig --add xl2tpd
  58. %preun
  59. if [ $1 -eq 0 ]; then
  60. /sbin/service xl2tpd stop > /dev/null 2>&1
  61. /sbin/chkconfig --del xl2tpd
  62. fi
  63. %postun
  64. if [ $1 -ge 1 ]; then
  65. /sbin/service xl2tpd condrestart 2>&1 >/dev/null
  66. fi
  67. %files
  68. %defattr(-,root,root)
  69. %doc BUGS CHANGES CREDITS LICENSE README* TODO
  70. %doc doc/README.patents examples/chapsecrets.sample
  71. %{_sbindir}/xl2tpd
  72. %{_sbindir}/xl2tpd-control
  73. %{_bindir}/pfc
  74. %{_mandir}/*/*
  75. %dir %{_sysconfdir}/xl2tpd
  76. %config(noreplace) %{_sysconfdir}/xl2tpd/*
  77. %config(noreplace) %{_sysconfdir}/ppp/*
  78. %attr(0755,root,root) %{_initrddir}/xl2tpd
  79. %dir %{_localstatedir}/run/xl2tpd
  80. %ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control
  81. %changelog
  82. * Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.10.1-1
  83. - new upstream release.
  84. * Tue Mar 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.9-1
  85. - new upstream release.
  86. * Wed Apr 2 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
  87. - new upstream release.
  88. * Sun Jan 05 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
  89. - new upstream release.
  90. * Sat Sep 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  91. - new upstream release.
  92. * Fri Sep 16 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
  93. - new upstream release.
  94. * Fri Apr 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.8-2
  95. - built for Vine Linux.
  96. * Wed Feb 23 2011 Paul Wouters <paul@xelerance.com> - 1.2.8-1
  97. - Updated to 1.2.8
  98. - Add ghosting for l2tp pipe (bz#656725)
  99. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-3
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  101. * Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-2
  102. - fix md5 of init script in sources
  103. * Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-1
  104. - Updated to 1.2.7
  105. - Added more DEBUG build options to the make command
  106. - Minor cleanups
  107. * Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-2
  108. - Bump for EVR
  109. * Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-1
  110. - Upgraded to 1.2.5. (fixes interop with two Windows machines behind same NAT)
  111. - Fix mix space/tab in spec file
  112. - Added missing keyword Default-Stop
  113. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-4
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  115. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-3
  116. - Bump version for tagging mistake
  117. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-2
  118. -Fix initscript for https://bugzilla.redhat.com/show_bug.cgi?id=247100
  119. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-1
  120. - Upgraded to 1.2.4
  121. - Merged spec file with upstream
  122. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  124. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.2.0-1
  125. - Updated to new upstream release
  126. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.12-3
  127. - fix license tag
  128. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.12-2
  129. - Autorebuild for GCC 4.3
  130. * Fri Oct 26 2007 Paul Wouters <paul@xelerance.com> 1.1.12-1
  131. - Upgraded to new release upstream
  132. - Removed l2tpd to xl2tpd migration in post
  133. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.1.11-3
  134. - Rebuild for selinux ppc32 issue.
  135. * Sat Jul 28 2007 Paul Wouters <paul@xelerance.com> 1.1.11-2
  136. - Upgraded to 1.1.11
  137. - Include new split README.*
  138. * Mon Mar 19 2007 Paul Wouters <paul@xelerance.com> 1.1.09-1
  139. - Upgraded to 1.1.09
  140. * Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-2
  141. - Bump for EVR
  142. * Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1
  143. - Upgraded to 1.1.08
  144. - This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM
  145. * Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2
  146. - Fixed version usage in source macro
  147. * Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-1
  148. - Upgraded to 1.1.07
  149. - Added /var/run/xl2tpd to the spec file so this pacakge
  150. owns /var/run/xl2tpd
  151. * Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5
  152. - Changed space/tab replacing method
  153. * Wed Dec 6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4
  154. - Added -p to keep original timestamps
  155. - Added temporary hack to change space/tab in init file.
  156. - Added /sbin/service dependancy
  157. * Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3
  158. - Added Requires(post) / Requires(preun)
  159. - changed init file to create /var/run/xl2tpd fixed a tab/space
  160. - changed control file to be within /var/run/xl2tpd/
  161. * Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2
  162. - Changed Mr. Karlsen's name to not be a utf8 problem
  163. - Fixed Obosoletes/Provides to be more specific wrt l2tpd.
  164. - Added dist tag which accidentally got deleted.
  165. * Mon Dec 4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1
  166. - Rebased spec file on Fedora Extras copy, but using xl2tpd as package name
  167. * Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030
  168. - Pulled up sourceforget.net CVS fixes.
  169. - various debugging added, but debugging should not be on by default.
  170. - async/sync conversion routines must be ready for possibility that the read
  171. will block due to routing loops.
  172. - refactor control socket handling.
  173. - move all logic about pty usage to pty.c. Try ptmx first, if it fails try
  174. legacy ptys
  175. - rename log() to l2tp_log(), as "log" is a math function.
  176. - if we aren't deamonized, then log to stderr.
  177. - added install: and DESTDIR support.
  178. * Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13
  179. - Removed suse/mandrake specifics. Comply for Fedora Extras guidelines
  180. * Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl
  181. - Added log() patch by Paul Wouters so that l2tpd compiles on FC4.
  182. * Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl>
  183. - l2tpd.org has been hijacked. Project moved back to SourceForge:
  184. http://l2tpd.sourceforge.net
  185. * Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl>
  186. - Small Makefile fixes. Explicitly use gcc instead of cc.
  187. Network services library was not linked on Solaris due to typo.
  188. * Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl
  189. - Choosing between SysV or BSD style ptys is now configurable through
  190. a compile-time boolean "unix98pty".
  191. * Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl>
  192. - Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys.
  193. Requires the N_HDLC kernel module.
  194. * Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl>
  195. - Updated the README.
  196. * Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
  197. - Patch by Marald Klein and Roger Luethi. Fixes writing PID file.
  198. (http://l2tpd.graffl.net/msg01790.html)
  199. Long overdue. Rereleasing 10jdl.
  200. * Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
  201. - [SECURITY FIX] Added fix from Debian because of a bss-based
  202. buffer overflow.
  203. (http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html)
  204. - Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration
  205. directories /etc/{freeswan,openswan,strongswan}. Install our
  206. configuration files to /etc/ipsec.d and create symbolic links in
  207. those directories.
  208. * Wed Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl>
  209. - Removed 'leftnexthop=' lines. Not relevant for recent versions
  210. of FreeS/WAN and derivates.
  211. * Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-9jdl
  212. - Added "noccp" because of too much MPPE/CCP messages sometimes.
  213. * Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl>
  214. - Added patch in order to prevent StopCCN messages.
  215. * Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl>
  216. - MTU/MRU 1410 seems to be the lowest possible for MSL2TP.
  217. For Windows 2000/XP it doesn't seem to matter.
  218. - Typo in l2tpd.conf (192.168.128/25).
  219. * Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-8jdl
  220. - Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal
  221. value but some apps had problems with the default value.
  222. * Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl>
  223. - Added workaround for the missing hostname bug in the MSL2TP client
  224. ('Specify your hostname', error 629: "You have been disconnected
  225. from the computer you are dialing").
  226. * Sun Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-7jdl
  227. - Added the "listen-addr" global parameter for l2tpd.conf. By
  228. default, the daemon listens on *all* interfaces. Use
  229. "listen-addr" if you want it to bind to one specific
  230. IP address (interface), for security reasons. (See also:
  231. http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning)
  232. - Explained in l2tpd.conf that two different IP addresses should be
  233. used for 'listen-addr' and 'local ip'.
  234. - Modified init script. Upgrades should work better now. You
  235. still need to start/chkconfig l2tpd manually.
  236. - Renamed the example Openswan .conf files to better reflect
  237. the situation. There are two variants using different portselectors.
  238. Previously I thought Windows 2000/XP used portselector 17/0
  239. and the rest used 17/1701. But with the release of an updated
  240. IPsec client by Microsoft, it turns out that 17/0 must have
  241. been a mistake: the updated client now also uses 17/1701.
  242. * Thu Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-6jdl
  243. - Changed sample chap-secrets to be valid only for specific
  244. IP addresses.
  245. * Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de>
  246. - Adjustments for SuSE8.x (thanks, Bernhard!)
  247. - Added sample chap-secrets.
  248. * Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl
  249. - Replaced Dominique's patch by Damion de Soto's, which does not
  250. depend on the N_HDLC kernel module.
  251. * Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl
  252. - Seperate example config files for Win9x (MSL2TP) and Win2K/XP
  253. due to left/rightprotoport differences.
  254. Fixing preun for Red Hat.
  255. * Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
  256. - Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/
  257. Error fixed: source6 was used for both PSK and CERT.
  258. * Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
  259. - Added Dominique Cressatti's pty patch in another attempt to
  260. prevent the Windows 2000 Professional "loopback detected" error.
  261. Seems to work!
  262. * Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl
  263. - Added 'connect-delay' to PPP parameters in an attempt to
  264. prevent the Windows 2000 Professional "loopback detected" error.
  265. Didn't seem to work.
  266. * Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
  267. - Did not build on Red Hat 8.0. Solved by adding comments(?!).
  268. Bug detected in spec file: chkconfig --list l2tpd does not work
  269. on Red Hat 8.0. Not important enough to look into yet.
  270. * Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
  271. - Tested on Red Hat, required some changes. No gprintf. Used different
  272. pty patch, otherwise wouldn't run. Added buildroot sanity check.
  273. * Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl>
  274. - Specfile adapted from Mandrake Cooker. The original RPM can be
  275. retrieved through:
  276. http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd
  277. - Config path changed from /etc/l2tp/ to /etc/l2tpd/
  278. (Seems more logical and rp-l2tp already uses /etc/l2tp/).
  279. - Do not run at boot or install. The original RPM uses a config file
  280. which is completely commented out, but it still starts l2tpd on all
  281. interfaces. Could be a security risk. This RPM does not start l2tpd,
  282. the sysadmin has to edit the config file and start l2tpd explicitly.
  283. - Renamed patches to start with l2tpd-
  284. - Added dependencies for pppd, glibc-devel.
  285. - Use %%{name} as much as possible.
  286. - l2tp-secrets contains passwords, thus should not be world readable.
  287. - Removed dependency on rpm-helper.
  288. * Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk
  289. - from Per 0yvind Karlsen <peroyvind@delonic.no> :
  290. - PreReq and Requires
  291. - Fix preun_service
  292. * Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk
  293. - Move l2tpd from /usr/bin to /usr/sbin
  294. - Added SysV initscript
  295. - Patch0
  296. - Patch1
  297. * Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk
  298. - Initial release